Subject: Re: [Json] JSON Content Rules -05

From: Daniel Parker <[email-masked]>
Date: Fri, 18 Mar 2016 10:29:52 -0400

Regarding JCR - 05

http://www.ietf.org/id/draft-newton-json-content-rules-05.txt

Is there anything about the JCR grammar that requires the colon character
to be used as a prefix to a value rule, as opposed to simply being a
name-rule separator in an object rule?

For example, to my eye, the example

{

"Image" {
         width, height, "Title" :string,
         "Thumbnail" { width, height, "Url" :uri },
         "IDs" [ *:integer ]
       }
}

width "Width" : 0..1280
height "Height" : 0..1024

would look more "JSON like" written as

{

"Image" {
         width, height, "Title" :string,
         "Thumbnail" : { width, height, "Url" :uri },
         "IDs" [ *integer ]
       }
}

width "Width" : 0..1280
height "Height" : 0..1024

and similarly

the_bradys [ parents, children ]
    children ( :"Greg", :"Marsha", :"Bobby", :"Jan" )

       parents ( :"Mike", :"Carol" )

would look more "JSON like" written as

the_bradys [ parents, children ]
      children ("Greg", "Marsha", "Bobby", "Jan" )
       parents ( "Mike", "Carol" ).

Thanks,
Daniel

---

From: Andrew Newton <[email-masked]>
Date: Fri, 18 Mar 2016 10:50:10 -0400

Daniel,

Actually we realized that too. The -06 version, which should be out
soon, has an updated ABNF to allow the colon before object and array
rule definitions.

However, it is still needed for value rules so a parser can tell the
difference between a value rule and a rule name.

-andy

On Fri, Mar 18, 2016 at 10:29 AM, Daniel Parker <[email-masked]> wrote:
> Is there anything about the JCR grammar that requires the colon character to
> be used as a prefix to a value rule, as opposed to simply being a name-rule
> separator in an object rule?
>
> _______________________________________________
> json mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/json
>

---

From: Daniel Parker <[email-masked]>
Date: Fri, 18 Mar 2016 12:09:17 -0400

Hi Andy,

Thanks for the response, looking forward to -06.

Regarding distinguishing value rules and name rules, value rules starting
with a quote or a number are straightforward to distinguish, and couldn't
 "integer", "true", "boolean", etc be treated as names of built in rules,
so not necessary to distinguish?

In any case, thank you very much for the work you've put into this
specification, it's very much appreciated.

Best regards,
Daniel

---

From: Andrew Newton <[email-masked]>
Date: Fri, 18 Mar 2016 12:51:25 -0400

Daniel,

I like your suggestion. We'll look into it.

-andy

On Fri, Mar 18, 2016 at 12:09 PM, Daniel Parker <[email-masked]> wrote:
> "integer", "true", "boolean", etc be treated as names of built in rules, so
> not necessary to distinguish?
>