Subject: [Json] [Editorial Errata Reported] RFC8259 (5318)

From: RFC Errata System <[email-masked]>
Date: Wed, 4 Apr 2018 10:25:15 -0700 (PDT)

The following errata report has been submitted for RFC8259,
"The JavaScript Object Notation (JSON) Data Interchange Format".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata/eid5318

--------------------------------------
Type: Editorial
Reported by: Joakim Erdfelt <[email-masked]>

Section: 7

Original Text
-------------
      string = quotation-mark *char quotation-mark

      char = unescaped /
          escape (
              %x22 /          ; "    quotation mark  U+0022
              %x5C /          ; \    reverse solidus U+005C
              %x2F /          ; /    solidus         U+002F
              %x62 /          ; b    backspace       U+0008
              %x66 /          ; f    form feed       U+000C
              %x6E /          ; n    line feed       U+000A
              %x72 /          ; r    carriage return U+000D
              %x74 /          ; t    tab             U+0009
              %x75 4HEXDIG )  ; uXXXX                U+XXXX

      escape = %x5C              ; \

      quotation-mark = %x22      ; "

      unescaped = %x20-21 / %x23-5B / %x5D-10FFFF

Corrected Text
--------------
      string = quotation-mark *char quotation-mark

      char = unescaped /
          escape (
              %x22 /          ; "    quotation mark  U+0022
              %x5C /          ; \    reverse solidus U+005C
              %x2F /          ; /    solidus         U+002F
              %x62 /          ; b    backspace       U+0008
              %x66 /          ; f    form feed       U+000C
              %x6E /          ; n    line feed       U+000A
              %x72 /          ; r    carriage return U+000D
              %x74 /          ; t    tab             U+0009
              %x75 4HEXDIG )  ; uXXXX                U+XXXX

      escape = %x5C              ; \

      quotation-mark = %x22      ; "

      unescaped = %x20-21 / %x23-2E / %x30-5B / %x5D-10FFFF

Notes
-----
The solidus U+002F is listed as being escaped above, but is not excluded in the 'unescaped' sequence.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC8259 (draft-ietf-jsonbis-rfc7159bis-04)
--------------------------------------
Title               : The JavaScript Object Notation (JSON) Data Interchange Format
Publication Date    : December 2017
Author(s)           : T. Bray, Ed.
Category            : INTERNET STANDARD
Source              : Javascript Object Notation Update
Area                : Applications and Real-Time
Stream              : IETF
Verifying Party     : IESG

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 4 Apr 2018 19:49:51 +0200

> The solidus U+002F is listed as being escaped above, but is not excluded in the 'unescaped' sequence.

This is exactly as it should be — escaping the slash is optional, as it is unnecessary (and is generally not done outside the inclusion of JavaScript in HTML script elements, where it is needed to provide data transparency for strings containing “</script>”).

Grüße, Carsten

---

From: "Matthew A. Miller" <[email-masked]>
Date: Mon, 9 Apr 2018 09:31:54 -0600

RFC Editor,

Please reject this erratum.  As Carsten stated, the solidus character is
valid in a string unescaped as well as escaped.

- m&m

Matthew A. Miller

On 18/04/04 11:49, Carsten Bormann wrote:
> _______________________________________________
> json mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/json
>