Subject: [Json] Implementation report for JSON Extended Numeric Data

From: Anders Rundgren <[email-masked]>
Date: Fri, 18 May 2018 10:05:54 +0200

https://github.com/cyberphone/I-JSON-Number-System#existing-solutions

Adaptive Notation was a novelty to me although RFC 7493 may indeed be interpreted as RECOMMENDING this scheme.

Anders

---

From: Joe Hildebrand <[email-masked]>
Date: Sat, 19 May 2018 19:29:48 -0600

I think I see where you’re going.  If you take the idea of tags from CBOR, choose a funny separator, and add an IANA first-come-first-serve registry, you’d have:

[“decimal###3.22", “bigNumber###1e999”, “date###2018-05-20T01:27:03.028Z”]

> On May 18, 2018, at 2:05 AM, Anders Rundgren <[email-masked]> wrote:
> 
> _______________________________________________
> json mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/json

---

From: Anders Rundgren <[email-masked]>
Date: Sun, 20 May 2018 03:42:19 +0200

On 2018-05-20 03:29, Joe Hildebrand wrote:
> I think I see where you’re going.  If you take the idea of 
> tags from CBOR, choose a funny separator, and add an IANA 
> first-come-first-serve registry, you’d have:
> 

The intention was only to describe the current situation regarding representation of numbers in JSON that does not fit into IEEE-754 double precision.

This posting is maybe clearer: https://www.ietf.org/mail-archive/web/json/current/msg04318.html

I'm not advocating some kind additional type system; name mapping have proved to be fully sufficient in practice.

Anders