Subject: [Json] [Technical Errata Reported] RFC8259 (5355)

From: RFC Errata System <[email-masked]>
Date: Wed, 9 May 2018 23:46:19 -0700 (PDT)

The following errata report has been submitted for RFC8259,
"The JavaScript Object Notation (JSON) Data Interchange Format".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata/eid5355

--------------------------------------
Type: Technical
Reported by: Anders Rundgren <[email-masked]>

Section: 6

Original Text
-------------
Note that when such software is used, numbers that are integers and
are in the range [-(2**53)+1, (2**53)-1] are interoperable in the
sense that implementations will agree exactly on their numeric
values.

Corrected Text
--------------
Note that when such software is used, numbers that are integers and
are in the range [-(2**53), (2**53)] are interoperable in the
sense that implementations will agree exactly on their numeric
values.

Notes
-----
The limit is presumably derived from ECMAScript which says:

"The value of Number.MAX_SAFE_INTEGER is the largest integer n such that n and n + 1 are both exactly representable as a Number value"

However, Number.MAX_SAFE_INTEGER is 9007199254740991 ((2*53)-1) making n+1 (2**53) the largest exactly representable Number value

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC8259 (draft-ietf-jsonbis-rfc7159bis-04)
--------------------------------------
Title               : The JavaScript Object Notation (JSON) Data Interchange Format
Publication Date    : December 2017
Author(s)           : T. Bray, Ed.
Category            : INTERNET STANDARD
Source              : Javascript Object Notation Update
Area                : Applications and Real-Time
Stream              : IETF
Verifying Party     : IESG

---

From: "Matthew A. Miller" <[email-masked]>
Date: Fri, 11 May 2018 12:42:21 -0600

Similarly to errata 5354[1], I think this also ought to be rejected.

- m&m

Matthew A. Miller
[1] Thread starting with <
https://mailarchive.ietf.org/arch/msg/json/ldojFA4eUi78AyON5L8QjzG2-vU >