Subject: [Json] [IANA #1147224] WebSocket Subprotocol Name registration

From: Amanda Baber <[email-masked]>
Date: Tue, 17 Sep 2019 04:50:55 +0000

Hi all,

IANA has received a request to register "json" in the WebSocket Subprotocol Name registry at

https://www.iana.org/assignments/websocket/websocket.xml#subprotocol-name

Barry Leiba and Alexey Melnikov suggested asking this mailing list for opinions on this request.

This is all of the information that was provided:

===

Type of Assignment:
WebSocket Subprotocol ID: `json`, Common Name: `JavaScript Object Notation`

Description:
A lightweight messaging protocol for structured data using simple data types. Defined in http://www.ecma-international.org/publications/files/ECMA-ST/ECMA-404.pdf

===

We currently have only the requester's name as an entry for the registry's "Reference" field. 

We're also asking the CBOR mailing list to comment on a request to register "cbor."

thanks,
Amanda

---

From: Julian Reschke <[email-masked]>
Date: Tue, 17 Sep 2019 07:01:35 +0200

> We're also asking the CBOR mailing list to comment on a request to register "cbor."

That looks insufficient to me. The definition of a payload format isn't
a protocol definition, as required by
<https://tools.ietf.org/html/rfc6455#section-11.5>:

>    Subprotocol Definition
>       A reference to the document in which the subprotocol being used
>       with the WebSocket Protocol is defined.

Best regards, Julian

---

From: "Amanda Baber via RT" <[email-masked]>
Date: Wed, 25 Sep 2019 23:30:34 +0000

Hi Julian, all,

We received a suggestion from the ADs that we specifically ask about the utility of websocket subprotocol IDs for JSON (and CBOR, the subject of the other request we received). Are there issues there? 

thanks,

Amanda Baber
Lead IANA Services Specialist

On Tue Sep 17 05:02:33 2019, [email-masked] wrote:
> > A lightweight messaging protocol for structured data using simple
> > data types. Defined in http://www.ecma-
> > international.org/publications/files/ECMA-ST/ECMA-404.pdf
> >
> > ===
> >

---

From: "Matthew A. Miller" <[email-masked]>
Date: Wed, 25 Sep 2019 17:59:31 -0600

In my opinion, a generic "json" WebSocket subprotocol does not make
sense.  JSON is too generic a content format for a client and server to
adequately understand what the WebSocket session would be used for.

If there were a specification that made it clearer what the intent is,
my opinion might change.

- m&m

Matthew A. Miller
On 19/09/25 17:30, Amanda Baber via RT wrote:
> _______________________________________________
> json mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/json
>

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 26 Sep 2019 10:06:49 +1000

+1

> On 26 Sep 2019, at 9:59 am, Matthew A. Miller <[email-masked]> wrote:
> 

--
Mark Nottingham   https://www.mnot.net/

---

From: Martin J. Dürst <[email-masked]>
Date: Thu, 26 Sep 2019 05:05:24 +0000

On 2019/09/26 09:06, Mark Nottingham wrote:
>> sense.

Fully agreed.

>> JSON is too generic a content format for a client and server to

Yes indeed. Same for CBOR.

>> If there were a specification that made it clearer what the intent is,

Yes. As a very short summary, it would have to say what kinds of JSON 
data the server sends, what kind of JSON data the client sends, in what 
order, and what the meaning of each of these messages is.

Silly example: The IANA protocol registry access WebSocket subprotocol:

Client sends ... (details to be worked out), indicating the IANA 
protocol registry data that is requested.

Server sends: ... (details to be worked out), actual protocol registry data.

Of course this example doesn't make much sense, as a very similar thing 
can be done much more easily over HTTP(S) directly.

Regards,   Martin.