Subject: Re: [Json] draft-goessner-dispatch-jsonpath-00.txt

From: Daniel P <[email-masked]>
Date: Tue, 14 Jul 2020 05:06:48 -0400

Just FYI, there is an alternative effort to propose a JSONPath
standardization based on a consensus of JSONPath implementations, see
https://cburgmer.github.io/json-path-comparison/ for the comparisons.
They're currently putting together a Proposal A,
https://github.com/cburgmer/json-path-comparison/tree/master/proposals/Proposal_A,
including an ABNF grammar and test suite, and have invited comments.

Best regards,
Daniel

Il 14/07/2020 07:31, Tim Bray ha scritto:
> During my time at AWS I worked very heavily with JSONPath and lamented
> a useful referenceable spec. I would be happy to invest cycles into
> this work. There currently isn't a JSON working group but I suppose it
> wouldn't be too hard to reconstitute it for this purpose.

+1

Mario

>
> On Mon, Jul 13, 2020 at 10:14 PM Carsten Bormann <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>     (Reply-To set to [email-masked] <mailto:[email-masked]>)
>
>     I would like to initiate discussion for
>     draft-goessner-dispatch-jsonpath:
>
>     https://www.ietf.org/id/draft-goessner-dispatch-jsonpath-00.html
>
>     It says:
>
>     > This document picks up the popular JSONPath specification dated
>     > 2007-02-21 and provides a more normative definition for it.
>     > It is intended as a submission to the IETF DISPATCH WG, in order to
>     > find the right way to complete standardization of this
>     specification.
>     > In its current state, it is a strawman document showing what
>     needs to
>     > be covered.
>
>     (For some reason the abstract landed in the Contributing note;
>     typical Internet-Draft deadline day botch.)
>
>     This is a widely implemented specification that has been around
>     for more than a decade; now may be a good opportunity to finally
>     go ahead and turn it into a proper Internet standards document.
>     The immediate cause for writing this up now is that some IoT
>     discovery work (some of which happens in W3C) can make good use of
>     JSONPath.  Clearly, we already have JSON Pointer (RFC 6901) for a
>     more limited set of applications; the specification would do good
>     in defining how these two fit together.
>
>     There is no active WG that immediately fits this work.
>
>     Eventually CDDL may pick JSONPath up in the form of a predicate
>     operator; this might make the CBOR WG the right group (which
>     probably would then go ahead and write up another specification
>     that makes JSONPath useful for querying CBOR instances that go
>     beyond the JSON generic data model).
>
>     Reopening the JSON WG may be another approach, as may be creating
>     a short-lived targeted WG.
>
>     Please discuss!
>
>     Grüße, Carsten
>
>
>
>     > Begin forwarded message:
>     >
>     > From: [email-masked] <mailto:[email-masked]>
>     > Subject: New Version Notification for
>     draft-goessner-dispatch-jsonpath-00.txt
>     > Date: 2020-07-13 at 22:08:50 CEST
>     > To: "Stefan Gössner" <[email-masked]
>     <mailto:[email-masked]>>, "Stefan Gossner"
>     <[email-masked]
>     <mailto:[email-masked]>>, "Carsten Bormann"
>     <[email-masked] <mailto:[email-masked]>>
>     >
>     >
>     > A new version of I-D, draft-goessner-dispatch-jsonpath-00.txt
>     > has been successfully submitted by Carsten Bormann and posted to the
>     > IETF repository.
>     >
>     > Name:         draft-goessner-dispatch-jsonpath
>     > Revision:     00
>     > Title:                JSONPath -- XPath for JSON
>     > Document date:        2020-07-12
>     > Group:                Individual Submission
>     > Pages:                14
>     > URL:
>     https://www.ietf.org/internet-drafts/draft-goessner-dispatch-jsonpath-00.txt
>     > Status:
>     https://datatracker.ietf.org/doc/draft-goessner-dispatch-jsonpath/
>     > Htmlized:
>     https://tools.ietf.org/html/draft-goessner-dispatch-jsonpath-00
>     > Htmlized:
>     https://datatracker.ietf.org/doc/html/draft-goessner-dispatch-jsonpath
>     >
>     >
>     > Abstract:
>     >   insert abstract here
>     >
>     >
>     >
>     >
>     > Please note that it may take a couple of minutes from the time
>     of submission
>     > until the htmlized version and diff are available at
>     tools.ietf.org <http://tools.ietf.org>.
>     >
>     > The IETF Secretariat
>     >
>     >
>
>     _______________________________________________
>     json mailing list
>     [email-masked] <mailto:[email-masked]>
>     https://www.ietf.org/mailman/listinfo/json
>
>
> _______________________________________________
> json mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/json

-- 
Dr. Mario Loffredo
Systems and Technological Development Unit
Institute of Informatics and Telematics (IIT)
National Research Council (CNR)
via G. Moruzzi 1, I-56124 PISA, Italy
Phone: +39.0503153497
Mobile: +39.3462122240
Web: http://www.iit.cnr.it/mario.loffredo

[Json] draft-goessner-dispatch-jsonpath-00.txt  Carsten Bormann
Re: [Json] draft-goessner-dispatch-jsonpath-00.txt  Tim Bray
Re: [Json] draft-goessner-dispatch-jsonpath-00.txt  Mario Loffredo

>
> I would like to initiate discussion for draft-goessner-dispatch-jsonpath:
>
> https://www.ietf.org/id/draft-goessner-dispatch-jsonpath-00.html
>
> It says:
>
> > This document picks up the popular JSONPath specification dated
> > 2007-02-21 and provides a more normative definition for it.
> > It is intended as a submission to the IETF DISPATCH WG, in order to
> > find the right way to complete standardization of this specification.
> > In its current state, it is a strawman document showing what needs to
> > be covered.
>
> (For some reason the abstract landed in the Contributing note; typical Internet-Draft deadline day botch.)
>
> This is a widely implemented specification that has been around for more than a decade; now may be a good opportunity to finally go ahead and turn it into a proper Internet standards document.  The immediate cause for writing this up now is that some IoT discovery work (some of which happens in W3C) can make good use of JSONPath.  Clearly, we already have JSON Pointer (RFC 6901) for a more limited set of applications; the specification would do good in defining how these two fit together.
>
> There is no active WG that immediately fits this work.
>
> Eventually CDDL may pick JSONPath up in the form of a predicate operator; this might make the CBOR WG the right group (which probably would then go ahead and write up another specification that makes JSONPath useful for querying CBOR instances that go beyond the JSON generic data model).
>
> Reopening the JSON WG may be another approach, as may be creating a short-lived targeted WG.
>
> Please discuss!
>
> Grüße, Carsten
>
>
>
> > Begin forwarded message:
> >
> > From: [email-masked]
> > Subject: New Version Notification for draft-goessner-dispatch-jsonpath-00.txt
> > Date: 2020-07-13 at 22:08:50 CEST
> > To: "Stefan Gössner" <[email-masked]>, "Stefan Gossner" <[email-masked]>, "Carsten Bormann" <[email-masked]>
> >
> >
> > A new version of I-D, draft-goessner-dispatch-jsonpath-00.txt
> > has been successfully submitted by Carsten Bormann and posted to the
> > IETF repository.
> >
> > Name:         draft-goessner-dispatch-jsonpath
> > Revision:     00
> > Title:                JSONPath -- XPath for JSON
> > Document date:        2020-07-12
> > Group:                Individual Submission
> > Pages:                14
> > URL:            https://www.ietf.org/internet-drafts/draft-goessner-dispatch-jsonpath-00.txt
> > Status:         https://datatracker.ietf.org/doc/draft-goessner-dispatch-jsonpath/
> > Htmlized:       https://tools.ietf.org/html/draft-goessner-dispatch-jsonpath-00
> > Htmlized:       https://datatracker.ietf.org/doc/html/draft-goessner-dispatch-jsonpath
> >
> >
> > Abstract:
> >   insert abstract here
> >
> >
> >
> >
> > Please note that it may take a couple of minutes from the time of submission
> > until the htmlized version and diff are available at tools.ietf.org.
> >
> > The IETF Secretariat
> >
> >
>
>
>
>
>
> ---------- Forwarded message ----------
> From: Tim Bray <[email-masked]>
> To: [email-masked]
> Cc: [email-masked], JSON WG <[email-masked]>
> Bcc:
> Date: Mon, 13 Jul 2020 22:31:49 -0700
> Subject: Re: [Json] draft-goessner-dispatch-jsonpath-00.txt
> During my time at AWS I worked very heavily with JSONPath and lamented a useful referenceable spec. I would be happy to invest cycles into this work. There currently isn't a JSON working group but I suppose it wouldn't be too hard to reconstitute it for this purpose.
>
> On Mon, Jul 13, 2020 at 10:14 PM Carsten Bormann <[email-masked]> wrote:
>>
>> (Reply-To set to [email-masked])
>>
>> I would like to initiate discussion for draft-goessner-dispatch-jsonpath:
>>
>> https://www.ietf.org/id/draft-goessner-dispatch-jsonpath-00.html
>>
>> It says:
>>
>> > This document picks up the popular JSONPath specification dated
>> > 2007-02-21 and provides a more normative definition for it.
>> > It is intended as a submission to the IETF DISPATCH WG, in order to
>> > find the right way to complete standardization of this specification.
>> > In its current state, it is a strawman document showing what needs to
>> > be covered.
>>
>> (For some reason the abstract landed in the Contributing note; typical Internet-Draft deadline day botch.)
>>
>> This is a widely implemented specification that has been around for more than a decade; now may be a good opportunity to finally go ahead and turn it into a proper Internet standards document.  The immediate cause for writing this up now is that some IoT discovery work (some of which happens in W3C) can make good use of JSONPath.  Clearly, we already have JSON Pointer (RFC 6901) for a more limited set of applications; the specification would do good in defining how these two fit together.
>>
>> There is no active WG that immediately fits this work.
>>
>> Eventually CDDL may pick JSONPath up in the form of a predicate operator; this might make the CBOR WG the right group (which probably would then go ahead and write up another specification that makes JSONPath useful for querying CBOR instances that go beyond the JSON generic data model).
>>
>> Reopening the JSON WG may be another approach, as may be creating a short-lived targeted WG.
>>
>> Please discuss!
>>
>> Grüße, Carsten
>>
>>
>>
>> > Begin forwarded message:
>> >
>> > From: [email-masked]
>> > Subject: New Version Notification for draft-goessner-dispatch-jsonpath-00.txt
>> > Date: 2020-07-13 at 22:08:50 CEST
>> > To: "Stefan Gössner" <[email-masked]>, "Stefan Gossner" <[email-masked]>, "Carsten Bormann" <[email-masked]>
>> >
>> >
>> > A new version of I-D, draft-goessner-dispatch-jsonpath-00.txt
>> > has been successfully submitted by Carsten Bormann and posted to the
>> > IETF repository.
>> >
>> > Name:         draft-goessner-dispatch-jsonpath
>> > Revision:     00
>> > Title:                JSONPath -- XPath for JSON
>> > Document date:        2020-07-12
>> > Group:                Individual Submission
>> > Pages:                14
>> > URL:            https://www.ietf.org/internet-drafts/draft-goessner-dispatch-jsonpath-00.txt
>> > Status:         https://datatracker.ietf.org/doc/draft-goessner-dispatch-jsonpath/
>> > Htmlized:       https://tools.ietf.org/html/draft-goessner-dispatch-jsonpath-00
>> > Htmlized:       https://datatracker.ietf.org/doc/html/draft-goessner-dispatch-jsonpath
>> >
>> >
>> > Abstract:
>> >   insert abstract here
>> >
>> >
>> >
>> >
>> > Please note that it may take a couple of minutes from the time of submission
>> > until the htmlized version and diff are available at tools.ietf.org.
>> >
>> > The IETF Secretariat
>> >
>> >
>>
>> _______________________________________________
>> json mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/json
>
>
>
>
> ---------- Forwarded message ----------
> From: Mario Loffredo <[email-masked]>
> To: Tim Bray <[email-masked]>, [email-masked]
> Cc: [email-masked], JSON WG <[email-masked]>
> Bcc:
> Date: Tue, 14 Jul 2020 09:33:53 +0200
> Subject: Re: [Json] draft-goessner-dispatch-jsonpath-00.txt
>
>
> Il 14/07/2020 07:31, Tim Bray ha scritto:
>
> During my time at AWS I worked very heavily with JSONPath and lamented a useful referenceable spec. I would be happy to invest cycles into this work. There currently isn't a JSON working group but I suppose it wouldn't be too hard to reconstitute it for this purpose.
>
> +1
>
> Mario
>
>
> On Mon, Jul 13, 2020 at 10:14 PM Carsten Bormann <[email-masked]> wrote:
>>
>> (Reply-To set to [email-masked])
>>
>> I would like to initiate discussion for draft-goessner-dispatch-jsonpath:
>>
>> https://www.ietf.org/id/draft-goessner-dispatch-jsonpath-00.html
>>
>> It says:
>>
>> > This document picks up the popular JSONPath specification dated
>> > 2007-02-21 and provides a more normative definition for it.
>> > It is intended as a submission to the IETF DISPATCH WG, in order to
>> > find the right way to complete standardization of this specification.
>> > In its current state, it is a strawman document showing what needs to
>> > be covered.
>>
>> (For some reason the abstract landed in the Contributing note; typical Internet-Draft deadline day botch.)
>>
>> This is a widely implemented specification that has been around for more than a decade; now may be a good opportunity to finally go ahead and turn it into a proper Internet standards document.  The immediate cause for writing this up now is that some IoT discovery work (some of which happens in W3C) can make good use of JSONPath.  Clearly, we already have JSON Pointer (RFC 6901) for a more limited set of applications; the specification would do good in defining how these two fit together.
>>
>> There is no active WG that immediately fits this work.
>>
>> Eventually CDDL may pick JSONPath up in the form of a predicate operator; this might make the CBOR WG the right group (which probably would then go ahead and write up another specification that makes JSONPath useful for querying CBOR instances that go beyond the JSON generic data model).
>>
>> Reopening the JSON WG may be another approach, as may be creating a short-lived targeted WG.
>>
>> Please discuss!
>>
>> Grüße, Carsten
>>
>>
>>
>> > Begin forwarded message:
>> >
>> > From: [email-masked]
>> > Subject: New Version Notification for draft-goessner-dispatch-jsonpath-00.txt
>> > Date: 2020-07-13 at 22:08:50 CEST
>> > To: "Stefan Gössner" <[email-masked]>, "Stefan Gossner" <[email-masked]>, "Carsten Bormann" <[email-masked]>
>> >
>> >
>> > A new version of I-D, draft-goessner-dispatch-jsonpath-00.txt
>> > has been successfully submitted by Carsten Bormann and posted to the
>> > IETF repository.
>> >
>> > Name:         draft-goessner-dispatch-jsonpath
>> > Revision:     00
>> > Title:                JSONPath -- XPath for JSON
>> > Document date:        2020-07-12
>> > Group:                Individual Submission
>> > Pages:                14
>> > URL:            https://www.ietf.org/internet-drafts/draft-goessner-dispatch-jsonpath-00.txt
>> > Status:         https://datatracker.ietf.org/doc/draft-goessner-dispatch-jsonpath/
>> > Htmlized:       https://tools.ietf.org/html/draft-goessner-dispatch-jsonpath-00
>> > Htmlized:       https://datatracker.ietf.org/doc/html/draft-goessner-dispatch-jsonpath
>> >
>> >
>> > Abstract:
>> >   insert abstract here
>> >
>> >
>> >
>> >
>> > Please note that it may take a couple of minutes from the time of submission
>> > until the htmlized version and diff are available at tools.ietf.org.
>> >
>> > The IETF Secretariat
>> >
>> >
>>
>> _______________________________________________
>> json mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/json
>
>
> _______________________________________________
> json mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/json
>
> --
> Dr. Mario Loffredo
> Systems and Technological Development Unit
> Institute of Informatics and Telematics (IIT)
> National Research Council (CNR)
> via G. Moruzzi 1, I-56124 PISA, Italy
> Phone: +39.0503153497
> Mobile: +39.3462122240
> Web: http://www.iit.cnr.it/mario.loffredo
>
> _______________________________________________
> json mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/json

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 14 Jul 2020 11:15:19 +0200

Hi Daniel,

that is great confirmation that now is a good time to bring these efforts together.
Do you know the people who are driving this?  Are they aware of how they could be contributing to the IETF?  Could they be convinced to contribute to an IETF effort?  Who should talk to them about this?

Grüße, Carsten

> On 2020-07-14, at 11:06, Daniel P <[email-masked]> wrote:
>

---

From: Daniel P <[email-masked]>
Date: Tue, 14 Jul 2020 09:49:18 -0400

Hi Carsten,

I learned about this project when I was contacted by Christoph Burgmer
for help with integrating my C++ implementation into their workflow,
most languages they covered had standard package managers, but C++
not. My understanding is that their primary goal is to propose a
specification of JSONPath known as "Proposal A" that is consistent
with the consensus of implementations, and to solicit as much feedback
as possible. There's more information about that here:
https://github.com/cburgmer/json-path-comparison/blob/master/FAQ.md.

I'm not sure what they intend to do with their "Proposal A" once it's
completed. It looks pretty far advanced to me, and my quick take is
that some implementations are aligning themselves on the consensus,
thus expanding it. Perhaps it could be worked into an IETF
recommendation, but I can't speak for that. I would suggest contacting
Christoph Burgmer if you thought it useful to follow up along that
line.

Best regards,
Daniel