Subject: Re: [Json] [Asdf] Kicking off ASDF charter discussion

From: Michael Richardson <[email-masked]>
Date: Fri, 07 Aug 2020 18:25:15 -0400

{didn't open issues for this}

  } The ASDF WG will work closely with the CBOR WG, home of the CDDL
  } specification. It will also engage the still active mailing list of the
  } dormant JSON WG. Recent proposals to form an IRTF formal description
  } techniques (FDT) Research Group may lead to another collaboration
  } partner. The Thing-to-Thing Research Group (T2TRG) and its WISHI program
  } can be instrumental in engaging researchers and other SDOs in this space,
  } or instance W3C WoT, which is working on Thing Description Templates and
  } related specifications.

I can't really agree or disagree with any of this :-)
Can we split this up a bit?

1> The ASDF WG will work closely with the CBOR WG, home of the CDDL
1> specification.

While we are using CDDL to define the structure, I'm unclear what the back
and forth that ASDF will have with CBOR here.  Are there pieces in CDDL that
are missing that this model will motivate adding to CDDL?

2> It will also engage the still active mailing list of the
2> dormant JSON WG.

Is this about json-path, and/or json-schema?

3> Recent proposals to form an IRTF formal description
3> techniques (FDT) Research Group may lead to another collaboration
3> partner.

Where are these proposals occuring, and at one point will they conclude, and
is the timing of this important, critical, or optional to the process?

4> The Thing-to-Thing Research Group (T2TRG) and its WISHI program
4> can be instrumental in engaging researchers and other SDOs in this space,
4> or instance W3C WoT, which is working on Thing Description Templates and
4> related specifications.

This part seems rather aspirational.  All sorts of communications are
important and beneficial, but is there some kind of implied liason activity,
or some kind of cross-WG/RG last-call that is implied?

I don't see any effect from just deleting this paragraph from the charter :-)

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 8 Aug 2020 09:18:51 +0200

> I don't see any effect from just deleting this paragraph from the charter :-)

I completely agree.

However, relationship to other groups usually comes up in charter discussion, and this paragraph was intended to provide a landscape.  These links may be obvious to us, but maybe not to others joining the work.

But I would expect the WG to act on this landscape independent of whether it is exposed in the charter or not.

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 8 Aug 2020 09:25:15 +0200

> are missing that this model will motivate adding to CDDL?

That has already happened (the .feature feature).
I could imagine the SDF work will continue to be a fertile ground for further improving the usability of CDDL in specs of this kind.

> Is this about json-path, and/or json-schema?

Probably more about json data definition (which includes the json-schema.org proposals that have been inspiring the SDF data definition components).

> Where are these proposals occuring,

[email-masked]

> and at one point will they conclude,

Good question.

> and

Entirely optional.

> or some kind of cross-WG/RG last-call that is implied?

T2TRG is not engaging in formal liaisons.  It *is* working on getting people to talk (e.g., last week the discussion we had on Azure DTDL).  For ASDF, getting information from the various ecosystems trying to get their models expressed in SDF is vital — preferably in the form of people from these ecosystems taking part in the work, but ASDF people taking part in the communications is a good second best.

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 8 Aug 2020 09:45:33 +0200

> Probably more about json data definition (which includes the json-schema.org proposals that have been inspiring the SDF data definition components).

…and it is probably worth pointing out that, while SDF itself is notated in JSON (and thus benefits from CDDL), the data models that SDF describes cannot be limited just to the expressive gamut of JSON data.  So a JSON data definition format such as those proposed at json-schema.org can be an inspiration, but cannot on its own solve the entire problem.

Grüße, Carsten