Subject: Re: [Json] Update Standard to support ECMA-262 BigInt

From: Daniel P <[email-masked]>
Date: Fri, 30 Apr 2021 15:36:38 -0400

From: Pete Cordell <[email-masked]>

> At some point some work towards a separate RFC on higher level semantics
> for JSON string contents might take place but I'm not aware of any such
> work on the table yet.

Do you mean in the context of a schema specification? And on the
subject of schemas, is there any chance that JCR will ever become an
IETF specification? The last draft appears to have expired April 1,
2018.

Best regards,
Daniel

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 30 Apr 2021 22:53:22 +0200

On 30. Apr 2021, at 21:36, Daniel P <[email-masked]> wrote:
> Do you mean in the context of a schema specification?

CDDL (RFC 8610) can already do much of what is probably needed here.
If there is anything else to be added, CDDL has an extension point (control operators) that is rather flexible.

Grüße, Carsten