Subject: [Jsonpath] Barry Leiba's Block on charter-ietf-jsonpath-00-00: (with BLOCK)

From: Barry Leiba via Datatracker <[email-masked]>
Date: Wed, 23 Sep 2020 09:23:12 -0700

Barry Leiba has entered the following ballot position for
charter-ietf-jsonpath-00-00: Block

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/charter-ietf-jsonpath/

----------------------------------------------------------------------
BLOCK:
----------------------------------------------------------------------

I'm very supportive of forming this working group, and have just one small
issue with the "spin" on the goals in the charter proposal

     The WG will develop a standards-track JSONPath specification, with
     the primary goal of capturing the common semantics of existing
     implementations and, where there are differences, choosing
     semantics with the goal of causing the least disruption among
     JSONPath users.

I fear that this text appears to say that we primarily want to develop a
dumbed-down compromise mush, and I'm sure that's not what we really mean.  The
*primary* goal is, surely, to develop a specification for JSONPath that is
technically sound, complete, and useful.  And our resolution of differences is,
surely, going to be based on analysis of the tradeoffs and selection of the
technically best choices.

I propose this (or some similar) alternative way of saying this:

NEW
     The WG will develop a standards-track JSONPath specification that
     is technically sound and complete, based on the common semantics
     and other aspects of existing implementations.  Where there are
     differences, the working group will analyze those differences and
     make choices that rough consensus considers technically best, with
     an aim toward minimizing disruption among the different JSONPath
     implementations.
END

Does that make sense?

---

From: Glyn Normington <[email-masked]>
Date: Wed, 23 Sep 2020 17:00:36 +0000

Makes sense to me. Of course we want to avoid mush.

> On 23 Sep 2020, at 17:23, Barry Leiba via Datatracker <[email-masked]> wrote:
> 
> https://nam04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fcharter-ietf-jsonpath%2F&amp;data=02%7C01%7Cnormingtong%40vmware.com%7Cb204e686d2f04dd02c5308d85fdd0798%7Cb39138ca3cee4b4aa4d6cd83d9dd62f0%7C0%7C0%7C637364750233449682&amp;sdata=1wKhfZIaMJPtVSextS6X52RW3%2FuQ%2F4NUhpFlLmCEQOc%3D&amp;reserved=0
> 
> 
> 
> -- 
> Jsonpath mailing list
> [email-masked]
> https://nam04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fjsonpath&amp;data=02%7C01%7Cnormingtong%40vmware.com%7Cb204e686d2f04dd02c5308d85fdd0798%7Cb39138ca3cee4b4aa4d6cd83d9dd62f0%7C0%7C0%7C637364750233449682&amp;sdata=z3KdBbXmyA5CXFrOi6lIiaW8qpuS5Ico42ePu%2Bmn%2FBw%3D&amp;reserved=0

---

From: Tim Bray <[email-masked]>
Date: Wed, 23 Sep 2020 10:26:50 -0700

I'm OK with this, but for context: I've been a pretty intense JSONPath user
in recent years, and AFAIK the spec, and the implementations, are mostly
OK, so the choice between "make JSONPath good" and "don't invalidate
implementations" is unlikely to come up. If it did, my predisposition would
be to err on the side of not breaking implementations, but I don't think
that's inconsistent with Barry's text.

On Wed, Sep 23, 2020 at 9:23 AM Barry Leiba via Datatracker <
[email-masked]> wrote:

> https://www.ietf.org/mailman/listinfo/jsonpath
>

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Fri, 25 Sep 2020 20:23:58 -0700

Absent any objections to Barry's change in the next few days, I'll edit the
proposed charter in the tracker and we can move it forward to external
review as of the next IESG telechat.

Now might be a good time to put the call out for co-chair volunteers, too!

-MSK

On Wed, Sep 23, 2020 at 10:27 AM Tim Bray <[email-masked]> wrote:

> I'm OK with this, but for context: I've been a pretty intense JSONPath
> user in recent years, and AFAIK the spec, and the implementations, are
> mostly OK, so the choice between "make JSONPath good" and "don't invalidate

---

From: Tim Bray <[email-masked]>
Date: Sun, 27 Sep 2020 11:03:03 -0700

I'm interested in this and expect to be lightly employed for a while so
will volunteer to help out in whatever capacity.  I've edited & co-chaired.
I think, given that there are two drafts already, we can maybe be
optimistic about finding an editor?

On Fri, Sep 25, 2020 at 8:24 PM Murray S. Kucherawy <[email-masked]>
wrote:

> Absent any objections to Barry's change in the next few days, I'll edit
> the proposed charter in the tracker and we can move it forward to external

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Sun, 27 Sep 2020 22:22:23 -0700

On Wed, Sep 23, 2020 at 9:23 AM Barry Leiba via Datatracker <
[email-masked]> wrote:

> [...]

>      an aim toward minimizing disruption among the different JSONPath

Charter text updated.

-MSK

---

From: Glyn Normington <[email-masked]>
Date: Mon, 28 Sep 2020 16:49:19 +0000

Hi Tim

I’m willing to act as an editor since I’ve been doing that for [1]. But it would be handy for have another editor who is familiar with IETF processes, so perhaps you or Carsten could join me as an editor and the other could chair the WG? Of course, if others want to jump in, so much the better...

Regards,
Glyn

[1] https://github.com/jsonpath-standard/internet-draft

On 27 Sep 2020, at 19:03, Tim Bray <[email-masked]<mailto:[email-masked]>> wrote:

I'm interested in this and expect to be lightly employed for a while so will volunteer to help out in whatever capacity.  I've edited & co-chaired. I think, given that there are two drafts already, we can maybe be optimistic about finding an editor?

On Fri, Sep 25, 2020 at 8:24 PM Murray S. Kucherawy <[email-masked]<mailto:[email-masked]>> wrote:
Absent any objections to Barry's change in the next few days, I'll edit the proposed charter in the tracker and we can move it forward to external review as of the next IESG telechat.

-MSK

On Wed, Sep 23, 2020 at 10:27 AM Tim Bray <[email-masked]<mailto:[email-masked]>> wrote:
I'm OK with this, but for context: I've been a pretty intense JSONPath user in recent years, and AFAIK the spec, and the implementations, are mostly OK, so the choice between "make JSONPath good" and "don't invalidate implementations" is unlikely to come up. If it did, my predisposition would be to err on the side of not breaking implementations, but I don't think that's inconsistent with Barry's text.

On Wed, Sep 23, 2020 at 9:23 AM Barry Leiba via Datatracker <[email-masked]<mailto:[email-masked]>> wrote:
Barry Leiba has entered the following ballot position for
charter-ietf-jsonpath-00-00: Block

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/charter-ietf-jsonpath/<https://nam04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fcharter-ietf-jsonpath%2F&data=02%7C01%7Cnormingtong%40vmware.com%7C984511507115425a419c08d8630fa078%7Cb39138ca3cee4b4aa4d6cd83d9dd62f0%7C0%7C1%7C637368266061396613&sdata=QIF6K9R0SNT%2BtXjndRkALW2H8DfSjH8pWURJCfwLcUQ%3D&reserved=0>

NEW

Does that make sense?

--
Jsonpath mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/jsonpath<https://nam04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fjsonpath&data=02%7C01%7Cnormingtong%40vmware.com%7C984511507115425a419c08d8630fa078%7Cb39138ca3cee4b4aa4d6cd83d9dd62f0%7C0%7C1%7C637368266061406602&sdata=%2Fy1PFvYu3TlSddb4WQGr7u0CWXcDAezDaEhes%2Bvxxno%3D&reserved=0>
--
Jsonpath mailing list
[email-masked]<mailto:[email-masked]>
https://nam04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fjsonpath&amp;data=02%7C01%7Cnormingtong%40vmware.com%7C984511507115425a419c08d8630fa078%7Cb39138ca3cee4b4aa4d6cd83d9dd62f0%7C0%7C1%7C637368266061426588&amp;sdata=qXfepRr9xkkWWDm%2FwOwZASG79yXu83MY4wrfFnswUHM%3D&amp;reserved=0

---

From: Tim Bray <[email-masked]>
Date: Mon, 28 Sep 2020 10:12:15 -0700

My last few IETF workloads have been as an editor so I'd mildly prefer to
co-chair.  In principle I would co-edit, but having glanced at your I-D,
it's not obvious to me that we need a co-editor. You seem to be on top of
I-D language style and are github-competent. Frankly, there's not that much
more to it. Except for being willing to abandon ownership and go with WG
consensus. In either case, I'd be happy to help out if the editorial work
is experiencing IETF friction.

On Mon, Sep 28, 2020 at 9:49 AM Glyn Normington <[email-masked]>
wrote:

> Hi Tim
>
> I’m willing to act as an editor since I’ve been doing that for [1]. But it
> would be handy for have another editor who is familiar with IETF processes,
> so perhaps you or Carsten could join me as an editor and the other could
> chair the WG? Of course, if others want to jump in, so much the better...
>
> Regards,
> Glyn
>
> On 27 Sep 2020, at 19:03, Tim Bray <[email-masked]> wrote:
>
>>>> <https://nam04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fcharter-ietf-jsonpath%2F&data=02%7C01%7Cnormingtong%40vmware.com%7C984511507115425a419c08d8630fa078%7Cb39138ca3cee4b4aa4d6cd83d9dd62f0%7C0%7C1%7C637368266061396613&sdata=QIF6K9R0SNT%2BtXjndRkALW2H8DfSjH8pWURJCfwLcUQ%3D&reserved=0>
>>>>
>>>>
>>>>
>>>> <https://nam04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fjsonpath&data=02%7C01%7Cnormingtong%40vmware.com%7C984511507115425a419c08d8630fa078%7Cb39138ca3cee4b4aa4d6cd83d9dd62f0%7C0%7C1%7C637368266061406602&sdata=%2Fy1PFvYu3TlSddb4WQGr7u0CWXcDAezDaEhes%2Bvxxno%3D&reserved=0>
>>>>
>>> --
> Jsonpath mailing list
> [email-masked]
>

---

From: Brian Rosen <[email-masked]>
Date: Mon, 28 Sep 2020 13:21:15 -0400

I can help Glyn with IETFness.

Brian

> On Sep 28, 2020, at 1:12 PM, Tim Bray <[email-masked]> wrote:
> 
> My last few IETF workloads have been as an editor so I'd mildly prefer to co-chair.  In principle I would co-edit, but having glanced at your I-D, it's not obvious to me that we need a co-editor. You seem to be on top of I-D language style and are github-competent. Frankly, there's not that much more to it. Except for being willing to abandon ownership and go with WG consensus. In either case, I'd be happy to help out if the editorial work is experiencing IETF friction.
> 
> On Mon, Sep 28, 2020 at 9:49 AM Glyn Normington <[email-masked] <mailto:[email-masked]>> wrote:
> Hi Tim
> 
> [1] https://github.com/jsonpath-standard/internet-draft <https://github.com/jsonpath-standard/internet-draft>
> 
>> On 27 Sep 2020, at 19:03, Tim Bray <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> On Fri, Sep 25, 2020 at 8:24 PM Murray S. Kucherawy <[email-masked] <mailto:[email-masked]>> wrote:
>> On Wed, Sep 23, 2020 at 10:27 AM Tim Bray <[email-masked] <mailto:[email-masked]>> wrote:
>> On Wed, Sep 23, 2020 at 9:23 AM Barry Leiba via Datatracker <[email-masked] <mailto:[email-masked]>> wrote:
>> https://datatracker.ietf.org/doc/charter-ietf-jsonpath/ <https://nam04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fcharter-ietf-jsonpath%2F&data=02%7C01%7Cnormingtong%40vmware.com%7C984511507115425a419c08d8630fa078%7Cb39138ca3cee4b4aa4d6cd83d9dd62f0%7C0%7C1%7C637368266061396613&sdata=QIF6K9R0SNT%2BtXjndRkALW2H8DfSjH8pWURJCfwLcUQ%3D&reserved=0>
>> 
>> 
>> 
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/jsonpath <https://nam04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fjsonpath&data=02%7C01%7Cnormingtong%40vmware.com%7C984511507115425a419c08d8630fa078%7Cb39138ca3cee4b4aa4d6cd83d9dd62f0%7C0%7C1%7C637368266061406602&sdata=%2Fy1PFvYu3TlSddb4WQGr7u0CWXcDAezDaEhes%2Bvxxno%3D&reserved=0>
>> -- 
>> Jsonpath mailing list
>> [email-masked] <mailto:[email-masked]>
>> https://nam04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fjsonpath&amp;data=02%7C01%7Cnormingtong%40vmware.com%7C984511507115425a419c08d8630fa078%7Cb39138ca3cee4b4aa4d6cd83d9dd62f0%7C0%7C1%7C637368266061426588&amp;sdata=qXfepRr9xkkWWDm%2FwOwZASG79yXu83MY4wrfFnswUHM%3D&amp;reserved=0 <https://nam04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fjsonpath&amp;data=02%7C01%7Cnormingtong%40vmware.com%7C984511507115425a419c08d8630fa078%7Cb39138ca3cee4b4aa4d6cd83d9dd62f0%7C0%7C1%7C637368266061426588&amp;sdata=qXfepRr9xkkWWDm%2FwOwZASG79yXu83MY4wrfFnswUHM%3D&amp;reserved=0>
> -- 
> Jsonpath mailing list
> [email-masked]

---

From: Glyn Normington <[email-masked]>
Date: Tue, 29 Sep 2020 06:03:59 +0000

Thanks I guess I’ve been conflating the roles of chair and editor so far. I’m happy to act as editor (with anyone else who really wants to join in) and leave gauging consensus to the chair if that’s the usual split of responsibilities.

BTW, in terms of GitHub, I’m happy to hand ownership of the `jsonpath-standard` org and its repos to the Working Group. Also the Working Group can have the jsonpath-standard slack instance too, if that’s appropriate/helpful. But I guess we can discuss both those once the WG forms.

On 28 Sep 2020, at 18:21, Brian Rosen <[email-masked]<mailto:[email-masked]>> wrote:

Brian

On Sep 28, 2020, at 1:12 PM, Tim Bray <[email-masked]<mailto:[email-masked]>> wrote:

On Mon, Sep 28, 2020 at 9:49 AM Glyn Normington <[email-masked]<mailto:[email-masked]>> wrote:
Hi Tim

Regards,
Glyn

[1] https://github.com/jsonpath-standard/internet-draft<https://nam04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Fjsonpath-standard%2Finternet-draft&data=02%7C01%7Cnormingtong%40vmware.com%7C0731a1f02f5b459cdd8908d863d2eaeb%7Cb39138ca3cee4b4aa4d6cd83d9dd62f0%7C0%7C0%7C637369104843026796&sdata=nx5udPJo09VXufrHGTzUJL6TI65ihPPvBsALNT0ll1M%3D&reserved=0>

-MSK

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/charter-ietf-jsonpath/<https://nam04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fcharter-ietf-jsonpath%2F&data=02%7C01%7Cnormingtong%40vmware.com%7C0731a1f02f5b459cdd8908d863d2eaeb%7Cb39138ca3cee4b4aa4d6cd83d9dd62f0%7C0%7C0%7C637369104843036789&sdata=3pBPk9EzeO4rn7IYJ0Uxzp6wZzESs8Ev1AIWNIIUasQ%3D&reserved=0>

NEW

Does that make sense?

--
Jsonpath mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/jsonpath<https://nam04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fjsonpath&data=02%7C01%7Cnormingtong%40vmware.com%7C0731a1f02f5b459cdd8908d863d2eaeb%7Cb39138ca3cee4b4aa4d6cd83d9dd62f0%7C0%7C0%7C637369104843036789&sdata=JasY%2FfNV%2Bp%2BUJtHH%2FSFif%2Bv2eh7Fd75qxMS%2BQRWpifA%3D&reserved=0>
--
Jsonpath mailing list
[email-masked]<mailto:[email-masked]>
https://nam04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fjsonpath&amp;data=02%7C01%7Cnormingtong%40vmware.com%7C984511507115425a419c08d8630fa078%7Cb39138ca3cee4b4aa4d6cd83d9dd62f0%7C0%7C1%7C637368266061426588&amp;sdata=qXfepRr9xkkWWDm%2FwOwZASG79yXu83MY4wrfFnswUHM%3D&amp;reserved=0<https://nam04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fjsonpath&data=02%7C01%7Cnormingtong%40vmware.com%7C0731a1f02f5b459cdd8908d863d2eaeb%7Cb39138ca3cee4b4aa4d6cd83d9dd62f0%7C0%7C0%7C637369104843046781&sdata=o5BZTlCFJdUw2eaWtioO%2FgLV79dw%2BNnAnQU0kKeGr7I%3D&reserved=0>

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 29 Sep 2020 08:26:46 +0200

On 2020-09-28, at 18:49, Glyn Normington <[email-masked]> wrote:
> 
> I’m willing to act as an editor since I’ve been doing that for [1]. But it would be handy for have another editor who is familiar with IETF processes, so perhaps you or Carsten could join me as an editor and the other could chair the WG? Of course, if others want to jump in, so much the better…

As an author (editor): Sure.

As a chair (which is what Murray asked for): I’m still celebrating being free of blue-dot responsibilities since March 2020 (after having been a chair in one or the other WG since March 2000 for a total of > 24 chair-years).

Grüße, Carsten