Subject: [Jsonpath] ABNF syntax checks - help wanted

From: Glyn Normington <[email-masked]>
Date: Wed, 24 Mar 2021 10:19:04 +0000

I raised a couple of issues about ABNF syntax checking the draft.

https://github.com/ietf-wg-jsonpath/draft-ietf-jsonpath-jsonpath/issues/81 
points out that the syntax currently appears to be broken.

https://github.com/ietf-wg-jsonpath/draft-ietf-jsonpath-jsonpath/issues/82 
is to add a syntax check to CI so we can attempt to keep it clean.

If anyone wants to take a crack at either or both of these, that would 
be helpful.

Regards,

Glyn

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 24 Mar 2021 11:21:42 +0100

On 2021-03-24, at 11:19, Glyn Normington <[email-masked]> wrote:
> 
> 
> https://github.com/ietf-wg-jsonpath/draft-ietf-jsonpath-jsonpath/issues/81 points out that the syntax currently appears to be broken.

Well, the script appears to be broken.

I get (Shell command failed with code 1 and no output)
when running xmlstarlet manually.

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 24 Mar 2021 11:25:42 +0100

> Well, the script appears to be broken.

Fixed in main.

Grüße, Carsten