Subject: [Jsonpath] PR 46 merged and plans for IETF 110

From: Glyn Normington <[email-masked]>
Date: Wed, 3 Mar 2021 05:14:52 +0000

Apologies, but I had forgotten my blocking review of 
https://github.com/ietf-wg-jsonpath/draft-ietf-jsonpath-jsonpath/pull/46, 
but have now merged it.

What's the plan for IETF 110? Will there be a PR to discuss, will we be 
discussing Stefan's excellent analysis, or what?

Thanks,

Glyn

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 3 Mar 2021 07:37:21 +0100

The next step should be to split Stefan’s issue into topics, and see where we are on each topic.
I would expect some are mostly done by #46 already, some need more tweaks, and some need real work.
I’d prefer to discuss actual (if embryonic) PRs on the latter ones as well.

Grüße, Carsten

> On 3. Mar 2021, at 06:14, Glyn Normington <[email-masked]> wrote:
> 
> Apologies, but I had forgotten my blocking review of https://github.com/ietf-wg-jsonpath/draft-ietf-jsonpath-jsonpath/pull/46, but have now merged it.
> 
> What's the plan for IETF 110? Will there be a PR to discuss, will we be discussing Stefan's excellent analysis, or what?
> 
> Thanks,
> 
> Glyn
> 
> -- 
> Jsonpath mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/jsonpath

---

From: Glyn Normington <[email-masked]>
Date: Wed, 3 Mar 2021 08:00:44 +0000

+1 to (embrionic) PRs.

---

From: Greg Dennis <[email-masked]>
Date: Wed, 3 Mar 2021 08:01:33 +0000 (UTC)

I would request that if some fit into the issues I've already made (there are a few), those issues be continued.
Greg
 
  On Wed, 3 Mar 2021 at 7:37 pm, Carsten Bormann<[email-masked]> wrote:   The next step should be to split Stefan’s issue into topics, and see where we are on each topic.
I would expect some are mostly done by #46 already, some need more tweaks, and some need real work.
I’d prefer to discuss actual (if embryonic) PRs on the latter ones as well.

Grüße, Carsten

---

From: Glyn Normington <[email-masked]>
Date: Wed, 3 Mar 2021 13:20:47 +0000

After discussion with Carsten, I aim to submit the current state of our 
draft on Sunday 7 March so we have an updated draft to reference in our 
meeting.

If anyone would like to update it before then, please get your skates 
on. :-)

On 03/03/2021 08:01, Greg Dennis wrote:
> I would request that if some fit into the issues I've already made 
> (there are a few), those issues be continued.
>
> Greg
>
>     On Wed, 3 Mar 2021 at 7:37 pm, Carsten Bormann
>     <[email-masked]> wrote:
>     > On 3. Mar 2021, at 06:14, Glyn Normington
>     <[email-masked]
>     <mailto:[email-masked]>> wrote:
>     >
>     <https://github.com/ietf-wg-jsonpath/draft-ietf-jsonpath-jsonpath/pull/46,
>     >but have now merged it.
>     >
>     > What's the plan for IETF 110? Will there be a PR to discuss,
>     will we be discussing Stefan's excellent analysis, or what?
>     >
>     > Thanks,
>     >
>     > Glyn
>     >
>     > --
>     > Jsonpath mailing list
>     > [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/jsonpath>
>
>
>     -- 
>     Jsonpath mailing list
>     [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/jsonpath>
>

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 3 Mar 2021 18:59:13 +0100

> I would request that if some fit into the issues I've already made (there are a few), those issues be continued.

Good idea, but we really have to clean up those issues.

We have a few labels, but not enough.

I created a new label, “controversial” (I know, that will be controversial :-), and have started putting labels on things, according to the https://en.wikipedia.org/wiki/Wikipedia:Be_bold principle.  

Please go ahead and completely revise this (I just applied "the best way on the internet to get a question answered still is to put out a wrong answer" :-).

Grüße, Carsten

---

From: Stefan Gössner <[email-masked]>
Date: Wed, 3 Mar 2021 19:49:43 +0100

A lot has been achieved in the last days ... great. The set of terms in 
the current draft seems to be more consistent and less redundant now, 
thanks to Carsten.

I second Greg's proposal to continue already existing issues.

In indirect response to Daniel's posts "@ and the current element" with 
interesting aspects and links,  I would like to start a first issue. 
This probably needs more time to reach a solution based on a common 
consensus.
--
sg

Am 03.03.2021 um 14:20 schrieb Glyn Normington:
>
> After discussion with Carsten, I aim to submit the current state of 
> our draft on Sunday 7 March so we have an updated draft to reference 
> in our meeting.
>
> <http://www.avg.com/email-signature?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=emailclient> 
> 	Virenfrei. www.avg.com 
> <http://www.avg.com/email-signature?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=emailclient> 
>
>
> <#DAB4FAD8-2DD7-40BB-A1B8-4E2AA1F9FDF2>
>