Subject: [Jsonpath] The "union" term

From: Greg Dennis <[email-masked]>
Date: Mon, 8 Mar 2021 04:45:47 +0000 (UTC)

I've brought this up before, either on slack before IETF was involved or in a GitHub issue somewhere, but I'm not sure what the term "union" is intended to represent.
Appraising this word either from mathematical and from data structures points of view doesn't seem to apply here.
A math sense would imply a set theory operation, but we're not working with set unions, which are the distinct combination of all elements within two or more sets.
A data structures sense would mean that were attempting to store two mutually exclusive pieces of data in the same memory space, and interpreting the bits in that memory as needed when appropriate.  This isn't right either.
What is the intent behind the use of this word, e.g. in "union-element"?
Greg

---

From: Greg Dennis <[email-masked]>
Date: Mon, 8 Mar 2021 18:43:49 +0000 (UTC)

I really hate my autocorrect.
”Appraising this word either from mathematical and from data structures points of view doesn't seem to apply here.”
should be
Applying this word either from mathematical or data structures points of view doesn't seem to apply here.

  On Mon, 8 Mar 2021 at 5:46 pm, Greg Dennis<gregsdennis=[email-masked]> wrote:   I've brought this up before, either on slack before IETF was involved or in a GitHub issue somewhere, but I'm not sure what the term "union" is intended to represent.
Appraising this word either from mathematical and from data structures points of view doesn't seem to apply here.
A math sense would imply a set theory operation, but we're not working with set unions, which are the distinct combination of all elements within two or more sets.
A data structures sense would mean that were attempting to store two mutually exclusive pieces of data in the same memory space, and interpreting the bits in that memory as needed when appropriate.  This isn't right either.
What is the intent behind the use of this word, e.g. in "union-element"?
Greg-- 
Jsonpath mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/jsonpath