Subject: [Jsonpath] merging PRs

From: Greg Dennis <[email-masked]>
Date: Wed, 12 May 2021 10:54:10 +0000 (UTC)

I may have asked this before, but I can't find it in the archives.
What's the policy on merging PRs?
- Approver merges vs Submitter merges?- Do we need to be sure we leave PRs open for a set time before they're mergeable?  In the JSON Schema repo we try to leave PRs open for at least two weeks.- Other policies?
This should probably be documented somewhere if it's not already.
Greg

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 12 May 2021 15:17:45 +0200

> What's the policy on merging PRs?

That is entirely to be decided by the editors.
(Of course, it doesn’t hurt if we also agree on the policy.)

Here is my personal opinion of what would be best:

> - Approver merges vs Submitter merges?

Editor merges.

> - Do we need to be sure we leave PRs open for a set time before they're mergeable?  In the JSON Schema repo we try to leave PRs open for at least two weeks.

It is not clear what is the best time to start here.  Submission of the PR sure isn’t that, because it can take a long time before it is worth wider review.
I think that if we need consensus calls, these should be on the mailing list.
Editorial stuff should simply be disposed of by the editors.
There is some space in between — things we don’t need consensus calls with multi-week response periods for, but that do merit some discussion on the mailing list.

> - Other policies?

https://en.wikipedia.org/wiki/Wikipedia:Be_bold

Remember that the repo is a tool for the editors to move the draft forward.
Obviously (and written up in RFC 2418), they need to respect the decisions of the WG in doing that.
But the decisions happen on the mailing list, so no *real* damage can be done on the repo. (That said, the editors will want to make the state mostly move forward, not so much backward.)

Grüße, Carsten