Subject: [Jsonpath] Next meeting at IETF 112 and agenda

From: James <[email-masked]>
Date: Thu, 28 Oct 2021 18:51:30 +0200

Folks,
IETF 112 is a few weeks away with our next meeting being held on Wednesday, 10th of November from 12:00 to 14:00 UTC. If you haven’t already registered, you can do so here:

https://registration.ietf.org/112/ <https://registration.ietf.org/112/>

We have only a few items on our agenda for this session:

https://datatracker.ietf.org/doc/agenda-112-jsonpath/ <https://datatracker.ietf.org/doc/agenda-112-jsonpath/>

If there’s any other subjects or issues you’d like to be part of it please email myself or Tim and we can include it.

- J

---

From: Tim Bray <[email-masked]>
Date: Thu, 28 Oct 2021 10:45:00 -0700

You'll note that on the draft agenda, there's an item labeled "Draf Status
- Tim".

I went and took an end-to-end pass through the current draft, asking myself
the question "How much work is left to finish this and send it off to the
IESG?"  There's quite a bit, but less than I thought.  To help us talk
about this, I offer this annotated table-of-contents, outlining what I
think the draft status is section-by-section.

Feel free to disagree or amplify, either right here, by raising issues over
on GitHub, or during our Nov 10 meeting.
=======================================
Options for each section:

OK - Ready, more or less
ED - Technically OK, needs editorial work
TECH - Open technical issue(s)
BAD - Needs rewrite

Contributing

[BAD] - IETF style

1.  Introduction

[ED] - Lose 1st para, polish

1.1.  Terminology

[OK] - May need to revisit if we change any of our terms

1.2.  Inspired by XPath

[BAD] Just lose it.  Put one sentence crediting XPath in the intro

1.3.  Overview of JSONPath Expressions

[ED] - lose XPath stuff, not sure about language about conversion to
bracket notation, that's internal to a processor, right?

2.  JSONPath Examples

[OK] - May need to revisit if we change stuff

3.  JSONPath Syntax and Semantics
3.1.  Overview

[ED] - "no further errors…" language needs a little more expansion

3.2.  Processing Model

[OK]

3.3.  Syntax

[OK]

3.4.  Semantics

[OK]

3.5.  Selectors

[ED] - why is the ABNF up in 3.3 while the descriptions are here.

3.5.1.  Root Selector

[ED] the "Semantics" section is confusing, I think we already said what it
does

3.5.2.  Dot Selector

[ED]

Should we have an example in each of these 3.5.*
Maybe a note about the dangers here, e.g. if you have something like {
"a.b": 23 } you can't use dot notation

3.5.3.  Dot Wild Card Selector

[OK]

3.5.4.  Index Selector

[OK]

3.5.5.  Index Wild Card Selector

[OK]

3.5.6.  Array Slice Selector

[ED] - Seems unnecessarily long, and the language about its history adds no
value?

3.5.7.  Descendant Selector

[ED] XML history adds no value?

3.5.8.  Union Selector
3.5.8.1.  Syntax

[ED] - sloppy informal language

3.5.8.2.  Semantics

[ED] in this place "Semantics" gets its own Table of Contents entry, but
not in the other selectors

3.5.9.  Filter Selector

3.5.9.1.  Syntax

[TECH] This one seems to have all our open issues in it!!

3.5.9.2.  Semantics

[OK] - modulo some changes if we revise 3.5.9.1

4.  Expression Language

[TECH] more open issues here.

5.  IANA Considerations

[TECH] I suggest application/jsonpath

6.  Security Considerations

[TECH] Having nothing here is unacceptable. Work item.

7.  References
7.1.  Normative References
7.2.  Informative References

[OK] I guess?

On Thu, Oct 28, 2021 at 9:51 AM James <[email-masked]> wrote:

> Folks,
> IETF 112 is a few weeks away with our next meeting being held on
> Wednesday, 10th of November from 12:00 to 14:00 UTC. If you haven’t already
> registered, you can do so here:
>
> https://registration.ietf.org/112/
>
> https://datatracker.ietf.org/doc/agenda-112-jsonpath/
>
> If there’s any other subjects or issues you’d like to be part of it please
> email myself or Tim and we can include it.
>
> - J
> --
> Jsonpath mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/jsonpath
>

---

From: Stefan Gössner <[email-masked]>
Date: Sat, 30 Oct 2021 18:31:23 +0200

... just to let you know ... I will be back on the list on Monday ...
--
Stefan

Am 28.10.2021 um 19:45 schrieb Tim Bray:
> You'll note that on the draft agenda, there's an item labeled "Draf 
> Status - Tim".
>
> I went and took an end-to-end pass through the current draft, asking 
> myself the question "How much work is left to finish this and send it 
> off to the IESG?"  There's quite a bit, but less than I thought.  To 
> help us talk about this, I offer this annotated table-of-contents, 
> outlining what I think the draft status is section-by-section.
>
> Feel free to disagree or amplify, either right here, by raising issues 
> over on GitHub, or during our Nov 10 meeting.
> [ED] the "Semantics" section is confusing, I think we already said 
> what it does
>
> 3.5.2.  Dot Selector
>
> [ED]
>
> [ED] - Seems unnecessarily long, and the language about its history 
> adds no value?
>
> [ED] in this place "Semantics" gets its own Table of Contents entry, 
> but not in the other selectors
>
> 3.5.9.  Filter Selector
>
> 3.5.9.1.  Syntax
>
>     Wednesday, 10th of November from 12:00 to 14:00 UTC. If you
>     haven’t already registered, you can do so here:
>
>     If there’s any other subjects or issues you’d like to be part of
>     it please email myself or Tim and we can include it.
>
>     - J
>     -- 
>     Jsonpath mailing list
>     [email-masked]
> <http://www.avg.com/email-signature?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=emailclient> 
> 	Virenfrei. www.avg.com 
> <http://www.avg.com/email-signature?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=emailclient> 
>
>
> <#DAB4FAD8-2DD7-40BB-A1B8-4E2AA1F9FDF2>
>