Subject: [Jsonpath] Object member names in JSONPath queries ...

From: Stefan Gössner <[email-masked]>
Date: Thu, 11 Nov 2021 19:04:10 +0100

I consider it an important result of our discussion yesterday, that 
object member names can ...

1. be used explicitly in JSONPath queries only with
     - dot-selector
     - index-selector
     - descendant-selector
     - union-selector
2. be used explicitly specifically in filter-selectors with relative 
pathes only with
     - dot-selector
     - index-selector
3. not be implicitly accessed as a target in filter-selectors

Please can someone enlighten a dump mechanical engineer, what 
'projection' means in this context.

--
sg

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 11 Nov 2021 19:12:03 +0100

On 11. Nov 2021, at 19:04, Stefan Gössner <[email-masked]> wrote:
> 2. be used explicitly specifically in filter-selectors with relative pathes only with
>     - dot-selector
>     - index-selector

Why are these two lists different?

Grüße, Carsten