Subject: Re: [Jsonpath] Next meeting at IETF 112 and agenda

From: Carsten Bormann <[email-masked]>
Date: Mon, 1 Nov 2021 21:52:57 +0100

On 2021-10-28, at 19:45, Tim Bray <[email-masked]> wrote:
> 
> 1.  Introduction
> 
> [ED] - Lose 1st para, polish
> 
> 1.1.  Terminology
> 
> [OK] - May need to revisit if we change any of our terms
> 
> 1.2.  Inspired by XPath
> 
> [BAD] Just lose it.  Put one sentence crediting XPath in the intro
> 
> 1.3.  Overview of JSONPath Expressions
> 
> [ED] - lose XPath stuff, not sure about language about conversion to bracket notation, that's internal to a processor, right?

I cleaned up the introduction and moved the XPath material into an appendix, as had previously been discussed.  A short history section in the introduction points to the appendix.

Pull request at:

https://github.com/ietf-wg-jsonpath/draft-ietf-jsonpath-base/pull/129

Diff: https://u.nu/phrOT
Long form of this URL: 
https://www.ietf.org/rfcdiff?url1=https://ietf-wg-jsonpath.github.io/draft-ietf-jsonpath-base/draft-ietf-jsonpath-base.txt&url2=https://ietf-wg-jsonpath.github.io/draft-ietf-jsonpath-base/xpath-inspired/draft-ietf-jsonpath-base.txt

HTML version of document with PR:
https://ietf-wg-jsonpath.github.io/draft-ietf-jsonpath-base/xpath-inspired/draft-ietf-jsonpath-base.html#name-overview-of-jsonpath-expres

These changes are all editorial and should move us forward to having a document we can publish as soon as the technical issues are done as well.

Sorry for not quite keeping up the Schlagzahl (*) of 1 PR per day...

Grüße, Carsten

(*) Sorry, untranslatable.  
The rate of rowing strokes per unit of time in a boat.
Of course, Germans would think about intellectual work this way.
Thomas Mann wrote a page a day, even on the day where he fled Nazi Germany.

---

From: Stefan Gössner <[email-masked]>
Date: Tue, 2 Nov 2021 09:54:00 +0100

I can see two big construction sites (or merely decisions to add them 
later or leave them out):
     * functions in the expression language, `key(@)`, `length(@.arr)` 
or additions to `@` as in `@key`.
     * equality tests for structured types (deep equals)

and one not so big:

     * clean up blank space in ABNF `S` (I can do that) 
(https://github.com/ietf-wg-jsonpath/draft-ietf-jsonpath-base/issues/126)

We also need to discuss and aim for agreement regarding:

* JsonInclude 
(https://github.com/ietf-wg-jsonpath/draft-ietf-jsonpath-base/issues/124)

--
sg

Am 30.10.2021 um 18:31 schrieb Stefan Gössner:
> ... just to let you know ... I will be back on the list on Monday ...
> --
> Stefan
>
>
> Am 28.10.2021 um 19:45 schrieb Tim Bray:
>> You'll note that on the draft agenda, there's an item labeled "Draf 
>> Status - Tim".
>>
>> I went and took an end-to-end pass through the current draft, asking 
>> myself the question "How much work is left to finish this and send it 
>> off to the IESG?"  There's quite a bit, but less than I thought.  To 
>> help us talk about this, I offer this annotated table-of-contents, 
>> outlining what I think the draft status is section-by-section.
>>
>> Feel free to disagree or amplify, either right here, by raising 
>> issues over on GitHub, or during our Nov 10 meeting.
>> =======================================
>> Options for each section:
>>
>> OK - Ready, more or less
>> ED - Technically OK, needs editorial work
>> TECH - Open technical issue(s)
>> BAD - Needs rewrite
>>
>> Contributing
>>
>> [BAD] - IETF style
>>
>> 1.  Introduction
>>
>> [ED] - lose XPath stuff, not sure about language about conversion to 
>> bracket notation, that's internal to a processor, right?
>>
>> 2.  JSONPath Examples
>>
>> [OK] - May need to revisit if we change stuff
>>
>> 3.  JSONPath Syntax and Semantics
>> 3.1.  Overview
>>
>> [ED] - "no further errors…" language needs a little more expansion
>>
>> 3.2.  Processing Model
>>
>> [OK]
>>
>> 3.3.  Syntax
>>
>> [OK]
>>
>> 3.4.  Semantics
>>
>> [OK]
>>
>> 3.5.  Selectors
>>
>> [ED] - why is the ABNF up in 3.3 while the descriptions are here.
>>
>> 3.5.1.  Root Selector
>>
>> [ED] the "Semantics" section is confusing, I think we already said 
>> what it does
>>
>> 3.5.2.  Dot Selector
>>
>> [ED]
>>
>> Should we have an example in each of these 3.5.*
>> Maybe a note about the dangers here, e.g. if you have something like 
>> { "a.b": 23 } you can't use dot notation
>>
>> 3.5.3.  Dot Wild Card Selector
>>
>> [OK]
>>
>> 3.5.4.  Index Selector
>>
>> [OK]
>>
>> 3.5.5.  Index Wild Card Selector
>>
>> [OK]
>>
>> 3.5.6.  Array Slice Selector
>>
>> [ED] - Seems unnecessarily long, and the language about its history 
>> adds no value?
>>
>> 3.5.7.  Descendant Selector
>>
>> [ED] XML history adds no value?
>>
>> 3.5.8.  Union Selector
>> 3.5.8.1.  Syntax
>>
>> [ED] - sloppy informal language
>>
>> 3.5.8.2.  Semantics
>>
>> [ED] in this place "Semantics" gets its own Table of Contents entry, 
>> but not in the other selectors
>>
>> 3.5.9.  Filter Selector
>>
>> 3.5.9.1.  Syntax
>>
>> [TECH] This one seems to have all our open issues in it!!
>>
>> 3.5.9.2.  Semantics
>>
>> [OK] - modulo some changes if we revise 3.5.9.1
>>
>> 4.  Expression Language
>>
>> [TECH] more open issues here.
>>
>> 5.  IANA Considerations
>>
>> [TECH] I suggest application/jsonpath
>>
>> 6.  Security Considerations
>>
>> [TECH] Having nothing here is unacceptable. Work item.
>>
>> 7.  References
>> 7.1.  Normative References
>> 7.2.  Informative References
>>
>> [OK] I guess?
>>
>>
>> On Thu, Oct 28, 2021 at 9:51 AM James <[email-masked]> wrote:
>>
>>     Folks,
>>     IETF 112 is a few weeks away with our next meeting being held on
>>     Wednesday, 10th of November from 12:00 to 14:00 UTC. If you
>>     haven’t already registered, you can do so here:
>>
>>     https://registration.ietf.org/112/
>>
>>     We have only a few items on our agenda for this session:
>>
>>     https://datatracker.ietf.org/doc/agenda-112-jsonpath/
>>
>>     If there’s any other subjects or issues you’d like to be part of
>>     it please email myself or Tim and we can include it.
>>
>>     - J
>>     -- 
>>     Jsonpath mailing list
>>     [email-masked]
>>     https://www.ietf.org/mailman/listinfo/jsonpath
>>
>>
>> <http://www.avg.com/email-signature?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=emailclient> 
>> 	Virenfrei. www.avg.com 
>> <http://www.avg.com/email-signature?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=emailclient> 
>>
>>
>> <#DAB4FAD8-2DD7-40BB-A1B8-4E2AA1F9FDF2>
>>
>
>

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 10 Nov 2021 08:14:45 +0100

I made some slides for today; I think the chairs may be sleeping and can’t publish them in the meeting materials, so you can peek here:

http://tzi.org/~cabo/2021-11-10-jsonpath-cabo.pdf

> On 2021-11-02, at 09:54, Stefan Gössner <[email-masked]> wrote:
> 
> I can see two big construction sites (or merely decisions to add them later or leave them out):
>     * functions in the expression language, `key(@)`, `length(@.arr)` or additions to `@` as in `@key`.

I missed that part, maybe I can do some additional slides.

>     * equality tests for structured types (deep equals)

This is under #127 in my slides.

> 
> and one not so big:
> 
>     * clean up blank space in ABNF `S` (I can do that) (https://github.com/ietf-wg-jsonpath/draft-ietf-jsonpath-base/issues/126)

Which is now done (thank you!).

> * JsonInclude (https://github.com/ietf-wg-jsonpath/draft-ietf-jsonpath-base/issues/124)

My handling in the slide for #124 is a bit terse:
>>> Proposal: Not in base RFC.

Grüße, Carsten

---

From: Stefan Gössner <[email-masked]>
Date: Wed, 10 Nov 2021 09:20:02 +0100

thanks for making the slides. I will go through them. I also applaud 
your closing of issues.

My lecture will overlap with todays meeting. So I will join you 10 to 15 
minutes later.

Thanks
--
Stefan

Am 10.11.2021 um 08:14 schrieb Carsten Bormann:
>> On 2021-11-02, at 09:54, Stefan Gössner<[email-masked]>  wrote:
>>

---

From: Stefan Gössner <[email-masked]>
Date: Wed, 10 Nov 2021 10:19:32 +0100

which session software is used today ?

Am 10.11.2021 um 09:20 schrieb Stefan Gössner:
> My lecture will overlap with todays meeting. So I will join you 10 to 
> 15 minutes later.
>
> Thanks
> --
> Stefan
>
>

---

From: James <[email-masked]>
Date: Wed, 10 Nov 2021 10:22:38 +0100

We don't use external VC software - all will be done in Meetecho, which should work with any modern browser, and I believe you've used before in previous interim meetings. The link to the meeting can be found on the agenda on the icons on the right hand side:

https://datatracker.ietf.org/meeting/agenda/

- J

> On 10 Nov 2021, at 10:19, Stefan Gössner <[email-masked]> wrote:
> 
>> thanks for making the slides. I will go through them. I also applaud your closing of issues.
>> 
>> My lecture will overlap with todays meeting. So I will join you 10 to 15 minutes later.
>> 
>> Thanks
>> --
>> Stefan
>> 
>> 
>>>>     * clean up blank space in ABNF `S` (I can do that) (
>>>> https://github.com/ietf-wg-jsonpath/draft-ietf-jsonpath-base/issues/126
>>>> )
>>>> 
>>>> * JsonInclude (
>>>> https://github.com/ietf-wg-jsonpath/draft-ietf-jsonpath-base/issues/124
>>>> )
>>>> 
> JSONpath mailing list
> [email-masked]

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 10 Nov 2021 12:37:06 +0100

I made an update, and the chairs uploaded it quickly, so you can look at

https://datatracker.ietf.org/meeting/112/materials/slides-112-jsonpath-issues-01

instead of the below.

Grüße, Carsten

> On 2021-11-10, at 08:14, Carsten Bormann <[email-masked]> wrote:
>