Subject: Re: [Jsonpath] Draft minutes, consensus points, and actions from IETF 112

From: Glyn Normington <[email-masked]>
Date: Wed, 1 Dec 2021 12:29:57 +0000

I put up some PRs to try to move us forward:

* 138: Relegate XPath details to the appendix
<https://github.com/ietf-wg-jsonpath/draft-ietf-jsonpath-base/pull/138> -
this doesn't change any normative text, but puts the XPath stuff in one
place
<https://github.com/ietf-wg-jsonpath/draft-ietf-jsonpath-base/pull/138#partial-pull-merging>
* 139: Delete the "in" operator
<https://github.com/ietf-wg-jsonpath/draft-ietf-jsonpath-base/pull/139> -
this was the consensus at IETF 112
* 140: Delete expression language
<https://github.com/ietf-wg-jsonpath/draft-ietf-jsonpath-base/pull/140> -
this is to take the temperature of the WG regarding ("container" rather
than filter ) expressions

On Mon, 29 Nov 2021 at 00:08, Carsten Bormann <[email-masked]> wrote:

> I have not forgotten these action points, but I actually first created a
> pull request based on Michael McCool’s comments:
>
> https://github.com/ietf-wg-jsonpath/draft-ietf-jsonpath-base/pull/137
>
> I have structured this into multiple commits in case we can’t merge all of
> this immediately.
>
> New (somewhat) technical content:
>
> * The text is now using I-JSON (RFC 7493) to discuss integer number value
> ranges.
>   This removes some weasel wording that is likely to cause interop issues.
> * Some of the text about false/truthy is gone, some more changes will be
> needed.
> * The text about negative indexes is now less misleading.
>
> There is also a little markdown adjustment, and a lot of editorial fixes.
>
> Thanks to Michael for the review!
>
> Grüße, Carsten
>
>
> > On 2021-11-14, at 12:35, James <[email-masked]> wrote:
> >
> > All,
> >
> > The minutes for our session at IETF 112 are now uploaded to datatracker
> here:
> >
> > https://datatracker.ietf.org/doc/minutes-112-jsonpath/
> >
> > Consensus:
> >
> > * #124 - Won't be used, but can be added in future if there's real demand
> > * #127 - Won't be included in the specification, but can be part of
> extensions
> > * #119 - In boolean contexts, path converts to false if nodelist is
> empty, but does not check value(s)
> > * #117 - Normalization not part of spec, codepoint comparison should be
> used
> > * #109 - We acknowledge but won't address this issue
> > * #95 - This won't be part of spec as it's an API problem but could be
> included in future
> >
> > Outstanding action items that were captured from the meeting:
> >
> > * Draft Status - Tim to make a PR
> > * #127 - Example queries need to be written
> > * #124 - Carsten to comment that consensus is to leave it for an
> extension
> > * #123 - Discuss use cases to get consensus of undefined vs NaN on list
> > * #119 - Carsten to make further edits based on consensus
> > * #109 - Carsten to update the issue
> > * #70 - Have discussion on list with known options
> >
> > Please let me know of any omissions or errata.
> >
> > - J
>
> --
> JSONpath mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/jsonpath
>

---

From: Glyn Normington <[email-masked]>
Date: Wed, 1 Dec 2021 16:09:33 +0000

I'm leaving the approved PRs open for a day or two to ensure global
consensus.

On Wed, 1 Dec 2021 at 12:29, Glyn Normington <[email-masked]>
wrote:

>> I have structured this into multiple commits in case we can’t merge all
>> of this immediately.
>>