Subject: [Jsonpath] github discussions

From: Daniel P <[email-masked]>
Date: Fri, 18 Mar 2022 11:41:12 -0400

Just to note, it seems to me that a number of the posts under Issues
on the github site could more properly be considered questions or
ideas that do not need to be tracked, unlike real issues.

About a year ago, there was a suggestion on this list to enable the
github discussions tab on the github site, which is simply a matter of
checking this box in Settings -> General.

[x] Discussions

Discussions is the space for your community to have conversations, ask
questions and post answers without opening issues.

There was no follow up at the time. Perhaps that could be reconsidered?

Best regards,
Daniel

---

From: Tim Bray <[email-masked]>
Date: Fri, 18 Mar 2022 09:18:43 -0700

No objection here.

On Fri, Mar 18, 2022 at 8:41 AM Daniel P <[email-masked]> wrote:

> --
> JSONpath mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/jsonpath
>

---

From: Greg Dennis <[email-masked]>
Date: Fri, 18 Mar 2022 19:19:13 +0000 (UTC)

We did this on the JSON Schema repo.  User response was 50/50.  People ended up using discussions to discuss spec proposals, which could rightly be issues, and they still used issues to ask questions in issues.  The end result was to have both kinds of content in both areas.
This experience has led me to decide against enabling discussions on my personal repos.  I figured it's just easier to have everything in one place if the majority of people aren't going to be using the feature.  And there's not really a good place to document which is for what kind of discourse.
I think discussions and issues are basically the same thing except that discussions has minimal support for threads.
Something to consider.

  On Sat, 19 Mar 2022 at 5:19 am, Tim Bray<[email-masked]> wrote:   -- 
JSONpath mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/jsonpath

---

From: Glyn Normington <[email-masked]>
Date: Sat, 19 Mar 2022 13:39:48 +0000

If we enable github discussions, presumably some will happen there which
would have happened here. Since github is proprietary, I think there is a
better chance of discussions on this mailing list being available for
posterity. So I'd prefer not to enable github discussions.

On Fri, 18 Mar 2022 at 19:19, Greg Dennis <gregsdennis=
[email-masked]> wrote:

> We did this on the JSON Schema repo.  User response was 50/50.  People
> ended up using discussions to discuss spec proposals, which could rightly
> be issues, and they still used issues to ask questions in issues.  The end
> result was to have both kinds of content in both areas.
>
> This experience has led me to decide against enabling discussions on my
> personal repos.  I figured it's just easier to have everything in one place
> if the majority of people aren't going to be using the feature.  And
> there's not really a good place to document which is for what kind of
> discourse.
>
> I think discussions and issues are basically the same thing except that
> discussions has minimal support for threads.
>
> Something to consider.
>
> On Sat, 19 Mar 2022 at 5:19 am, Tim Bray
> <[email-masked]> wrote:
> --
> JSONpath mailing list
> [email-masked]

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 19 Mar 2022 14:41:54 +0100

> We did this on the JSON Schema repo.  User response was 50/50.  People ended up using discussions to discuss spec proposals, which could rightly be issues, and they still used issues to ask questio…

My gut feeling was that exactly that would be happening here as well.
As Glyn says, we already have a nice threaded discussion medium (the mailing list), so let’s stick with that.

Grüße, Carsten