
From nobody Tue Nov  8 04:05:26 2016
Return-Path: <agmalis@gmail.com>
X-Original-To: l2vpn@ietfa.amsl.com
Delivered-To: l2vpn@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id C71DE126FDC; Tue,  8 Nov 2016 04:05:24 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -2.699
X-Spam-Level: 
X-Spam-Status: No, score=-2.699 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, FREEMAIL_FROM=0.001, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_LOW=-0.7, SPF_PASS=-0.001] autolearn=ham autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (2048-bit key) header.d=gmail.com
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id aM8EY-tKan0w; Tue,  8 Nov 2016 04:05:18 -0800 (PST)
Received: from mail-yw0-x22f.google.com (mail-yw0-x22f.google.com [IPv6:2607:f8b0:4002:c05::22f]) (using TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 57276129556; Tue,  8 Nov 2016 04:05:18 -0800 (PST)
Received: by mail-yw0-x22f.google.com with SMTP id r204so172187601ywb.0; Tue, 08 Nov 2016 04:05:18 -0800 (PST)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20120113;  h=mime-version:in-reply-to:references:from:date:message-id:subject:to :cc; bh=cFyew3okzbivjHg1LIk5Vcx1kVLBXIchCO2IIRWfcV0=; b=rm6mMyinMAgc7PGFtveJiHHOwC4JCa3SMFN4/YMoZuCDbORAaZam1MwmP7Do69+YeN NyDngObRyVd0ZAXTZJP9Dk0XcZuewldiN00pVr1sPCMZw/Ra1QT2Boh+lnyxVeRWXLqd XBfE6QUVMEQUleEnkAJP8Hw2IXBdz5QiiRBQisA1l5ozBpzI5qXV1EJQ5TFJJc5BGjx3 /tIIo6e+hbmhTaqKbrVSv99DRkYeAHrLXvMu11VdpO5MkVcZZqGBIWMm6zTLluSp9AQI jgAc68Zu3IVBQVo+pYo2HoxcS4RheCtQC5S/q5u0OkxOJ4MhPD3119wA5pXAidtYlvlW hoOA==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20130820; h=x-gm-message-state:mime-version:in-reply-to:references:from:date :message-id:subject:to:cc; bh=cFyew3okzbivjHg1LIk5Vcx1kVLBXIchCO2IIRWfcV0=; b=dhrvQpa46FD/KVm/ZC/dGx8X+Ka8qhSUrwuDDbormbfWIDVeWSAyr8mI3CmlERDzAY 9oBUYS1ANTjDqQErPusCBTLszot9oMeCq0lTHKlG6XgRZxk/VEetXUhpY++Q64Sxs/fn kCNyDsOrpXF78xLwODWQbHGSx+Plp2vyw5oxSdSI4t1B/HPNKbOq7EePv2/wLg8W8owW NE5YYHdMlxRtIEGomcEkF9Iu8z/Nlya97GrsxI1OubbJtLcRuBC5Z0S10ZIs/dG+rSUL t4CrGl5PTiixaAh7MNN0Z+p2um3MtMc82lo1wYzd705RsB64l/lref4d/w4ACGQW5HxN LP3w==
X-Gm-Message-State: ABUngveUZXAGg7AEZdTU+BpxkLRZEiRbbz4YBwjVJ1PVuDPAyyL2HBtAuatktnhW0FThxz8W9PGw6kUEilN+bA==
X-Received: by 10.157.45.166 with SMTP id g35mr540844otb.223.1478606717599; Tue, 08 Nov 2016 04:05:17 -0800 (PST)
MIME-Version: 1.0
Received: by 10.182.150.42 with HTTP; Tue, 8 Nov 2016 04:04:57 -0800 (PST)
In-Reply-To: <BN3PR0201MB10732D4090F5541CBEE50A8892A70@BN3PR0201MB1073.namprd02.prod.outlook.com>
References: <BN3PR0201MB10732D4090F5541CBEE50A8892A70@BN3PR0201MB1073.namprd02.prod.outlook.com>
From: "Andrew G. Malis" <agmalis@gmail.com>
Date: Tue, 8 Nov 2016 07:04:57 -0500
Message-ID: <CAA=duU3G_RfXqGnVYRNdTKRRQtH6wc6QVXtb1Mw2skmBU2LPiA@mail.gmail.com>
Subject: Re: [Pals] Apparent inconsistency between RFC5061 and RFC4762
To: Mike Bartlett <Mike.Bartlett@metaswitch.com>
Content-Type: multipart/alternative; boundary=94eb2c04e9302a434c0540c8f4b1
Archived-At: <https://mailarchive.ietf.org/arch/msg/l2vpn/EsZgOkjDZSfRKGHvRFQPukSXis4>
Cc: "l2vpn@ietf.org" <l2vpn@ietf.org>, "pals@ietf.org" <pals@ietf.org>
X-BeenThere: l2vpn@ietf.org
X-Mailman-Version: 2.1.17
Precedence: list
List-Id: Layer 2 Virtual Private Networks <l2vpn.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/l2vpn>, <mailto:l2vpn-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/l2vpn/>
List-Post: <mailto:l2vpn@ietf.org>
List-Help: <mailto:l2vpn-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/l2vpn>, <mailto:l2vpn-request@ietf.org?subject=subscribe>
X-List-Received-Date: Tue, 08 Nov 2016 12:05:25 -0000

--94eb2c04e9302a434c0540c8f4b1
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

Mike,

Thanks for the report. I think everyone is busy on IETF prep this week (I
know I am :-) but we=E2=80=99ll remind people of your email if there aren=
=E2=80=99t any
replies in a bit. I=E2=80=99m also going to forward it to the old l2vpn lis=
t.

Cheers,
Andy


On Mon, Nov 7, 2016 at 7:01 AM, Mike Bartlett <Mike.Bartlett@metaswitch.com=
>
wrote:

> All,
>
>
>
> It seems to me that there is an inconsistency between RFC5601 (=E2=80=9CP=
seudowire
> MIB=E2=80=9D) and RFC4762 (=E2=80=9CVPLS Using LDP Signaling=E2=80=9D).  =
I would like to hear
> people=E2=80=99s views on whether this is indeed the case, or whether I h=
ave
> misunderstood.
>
>
>
> Let=E2=80=99s say I have 3 PEs =E2=80=9CPE1=E2=80=9D, =E2=80=9CPE2=E2=80=
=9D and =E2=80=9CPE3=E2=80=9D, with IP addresses 1.1.1.,
> 2.2.2.2 and 3.3.3.3 respectively.  I want to create a full-mesh VPLS
> service with the pwTable specified in RFC5601, using the Generalized PWid
> FEC (i.e. FEC type 129).  The question is =E2=80=93 how do I configure th=
e 2
> pwTable rows on PE1?
>
>
>
> According to RFC4762, section 6.1.1, the AGI is the unique name of the
> VPLS (e.g. =E2=80=9CVPLS1=E2=80=9D), and the TAII and SAII are both null.
>
>
>
>    Attachment Group Identifier (AGI), Length, Value: The unique name of
>
>    this VPLS.  The AGI identifies a type of name, and Length denotes the
>
>    length of Value, which is the name of the VPLS.  We use the term AGI
>
>    interchangeably with VPLS identifier.
>
>
>
>    Target Attachment Individual Identifier (TAII), Source Attachment
>
>    Individual Identifier (SAII): These are null because the mesh of PWs
>
>    in a VPLS terminates on MAC learning tables, rather than on
>
>    individual attachment circuits.  The use of non-null TAII and SAII is
>
>    reserved for future enhancements.
>
>
>
> This suggests that the pwTable configuration on PE1 should look like this=
:
>
>
>
> =C2=B7         pwIndex =3D 1, pwGroupAttachmentID =3D =E2=80=9CVPLS1=E2=
=80=9D, pwLocalAttachmentID
> =3D =E2=80=9C=E2=80=9D, pwRemoteAttachmentID =3D =E2=80=9C=E2=80=9D, pwPe=
erAddr =3D =E2=80=9C2.2.2.2=E2=80=9D
>
> =C2=B7         pwIndex =3D 2, pwGroupAttachmentID =3D =E2=80=9CVPLS1=E2=
=80=9D, pwLocalAttachmentID
> =3D =E2=80=9C=E2=80=9D, pwRemoteAttachmentID =3D =E2=80=9C=E2=80=9D, pwPe=
erAddr =3D =E2=80=9C3.3.3.3=E2=80=9D
>
>
>
> However, this contradicts RFC5601, specifically its definition in section
> 12 of the reverse-lookup table pwGenFecIndexMappingTable, which states th=
at
> the {AGI, SAII, TAII} triplet must be unique for a PW using the generaliz=
ed
> PWid FEC (type 129).
>
>
>
>   pwGenFecIndexMappingTable  OBJECT-TYPE
>
>      SYNTAX        SEQUENCE OF PwGenFecIndexMappingEntry
>
>      MAX-ACCESS    not-accessible
>
>      STATUS        current
>
>      DESCRIPTION
>
>           "This table enables the reverse mapping of the unique
>
>            PWid parameters [GroupAttachmentID, LocalAttachmentID,
>
>            and PeerAttachmentID] and the pwIndex.  The table is
>
>            only applicable for PW using the generalized FEC."
>
>      ::=3D { pwObjects 12 }
>
>
>
> Note that the corresponding reverse lookup table pwIndexMappingTable for
> type-128 FECs has a critical difference, in that it includes the peer IP
> Address as one of the unique PW identifiers:
>
>
>
>   pwIndexMappingTable  OBJECT-TYPE
>
>      SYNTAX        SEQUENCE OF PwIndexMappingEntry
>
>      MAX-ACCESS    not-accessible
>
>      STATUS        current
>
>      DESCRIPTION
>
>           "This table enables the reverse mapping of the unique
>
>            PWid parameters [peer IP, PW type, and PW ID] and the
>
>            pwIndex.  The table is not applicable for PWs created
>
>            manually or by using the generalized FEC."
>
>      ::=3D { pwObjects 7 }
>
>
>
> It seems to me that pwGenFecIndexMappingTable should have the peer IP
> address as a 4th =E2=80=9Cunique PWid parameter=E2=80=9D.  Otherwise, the=
se parameters
> cannot uniquely identify a PW that belongs to an RFC4762-compliant VPLS.
>
>
>
> Please let me know what you think.  My apologies if this has already been
> discussed before.
>
>
>
> Thanks,
>
>
>
> Mike Bartlett
> *mike.bartlett@metaswitch.com* <mike.bartlett@metaswitch.com>
>
>
>
> _______________________________________________
> Pals mailing list
> Pals@ietf.org
> https://www.ietf.org/mailman/listinfo/pals
>
>

--94eb2c04e9302a434c0540c8f4b1
Content-Type: text/html; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

<div dir=3D"ltr">Mike,<div><br></div><div>Thanks for the report. I think ev=
eryone is busy on IETF prep this week (I know I am :-) but we=E2=80=99ll re=
mind people of your email if there aren=E2=80=99t any replies in a bit. I=
=E2=80=99m also going to forward it to the old l2vpn list.</div><div><br></=
div><div>Cheers,</div><div>Andy</div><div><br></div></div><div class=3D"gma=
il_extra"><br><div class=3D"gmail_quote">On Mon, Nov 7, 2016 at 7:01 AM, Mi=
ke Bartlett <span dir=3D"ltr">&lt;<a href=3D"mailto:Mike.Bartlett@metaswitc=
h.com" target=3D"_blank">Mike.Bartlett@metaswitch.com</a>&gt;</span> wrote:=
<br><blockquote class=3D"gmail_quote" style=3D"margin:0 0 0 .8ex;border-lef=
t:1px #ccc solid;padding-left:1ex">





<div lang=3D"EN-GB" link=3D"#0563C1" vlink=3D"#954F72">
<div class=3D"m_6156464012854588228WordSection1">
<p class=3D"MsoNormal"><span style=3D"font-size:10.0pt;font-family:&quot;Ar=
ial&quot;,sans-serif;color:blue">All,<u></u><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:10.0pt;font-family:&quot;Ar=
ial&quot;,sans-serif;color:blue"><u></u>=C2=A0<u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:10.0pt;font-family:&quot;Ar=
ial&quot;,sans-serif;color:blue">It seems to me that there is an inconsiste=
ncy between RFC5601 (=E2=80=9CPseudowire MIB=E2=80=9D) and RFC4762 (=E2=80=
=9CVPLS Using LDP Signaling=E2=80=9D).=C2=A0 I would like to hear people=E2=
=80=99s views on
 whether this is indeed the case, or whether I have misunderstood.<u></u><u=
></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:10.0pt;font-family:&quot;Ar=
ial&quot;,sans-serif;color:blue"><u></u>=C2=A0<u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:10.0pt;font-family:&quot;Ar=
ial&quot;,sans-serif;color:blue">Let=E2=80=99s say I have 3 PEs =E2=80=9CPE=
1=E2=80=9D, =E2=80=9CPE2=E2=80=9D and =E2=80=9CPE3=E2=80=9D, with IP addres=
ses 1.1.1., 2.2.2.2 and 3.3.3.3 respectively.=C2=A0 I want to create a full=
-mesh VPLS service with the pwTable
 specified in RFC5601, using the Generalized PWid FEC (i.e. FEC type 129).=
=C2=A0 The question is =E2=80=93 how do I configure the 2 pwTable rows on P=
E1?<u></u><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:10.0pt;font-family:&quot;Ar=
ial&quot;,sans-serif;color:blue"><u></u>=C2=A0<u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:10.0pt;font-family:&quot;Ar=
ial&quot;,sans-serif;color:blue">According to RFC4762, section 6.1.1, the A=
GI is the unique name of the VPLS (e.g. =E2=80=9CVPLS1=E2=80=9D), and the T=
AII and SAII are both null.=C2=A0
<u></u><u></u></span></p>
<p class=3D"MsoNormal"><b><u><span style=3D"font-size:10.0pt;font-family:&q=
uot;Arial&quot;,sans-serif;color:blue"><u></u><span style=3D"text-decoratio=
n:none">=C2=A0</span><u></u></span></u></b></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0 Attachment Group Identifier (AGI),=
 Length, Value: The unique name of<u></u><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0 this VPLS.=C2=A0 The AGI identifie=
s a type of name, and Length denotes the<u></u><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0 length of Value, which is the name=
 of the VPLS.=C2=A0 We use the term AGI<u></u><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0 interchangeably with VPLS identifi=
er.<u></u><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black"><u></u>=C2=A0<u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0 Target Attachment Individual Ident=
ifier (TAII), Source Attachment<u></u><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0 Individual Identifier (SAII): Thes=
e are null because the mesh of PWs<u></u><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0 in a VPLS terminates on MAC learni=
ng tables, rather than on<u></u><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0 individual attachment circuits.=C2=
=A0 The use of non-null TAII and SAII is<u></u><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0 reserved for future enhancements.<=
u></u><u></u></span></p>
<p class=3D"MsoNormal"><b><u><span style=3D"font-size:10.0pt;font-family:&q=
uot;Arial&quot;,sans-serif;color:blue"><u></u><span style=3D"text-decoratio=
n:none">=C2=A0</span><u></u></span></u></b></p>
<p class=3D"MsoNormal"><span style=3D"font-size:10.0pt;font-family:&quot;Ar=
ial&quot;,sans-serif;color:blue">This suggests that the pwTable configurati=
on on PE1 should look like this:<u></u><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:10.0pt;font-family:&quot;Ar=
ial&quot;,sans-serif;color:blue"><u></u>=C2=A0<u></u></span></p>
<p class=3D"m_6156464012854588228MsoListParagraph" style=3D"margin-left:18.=
0pt">
<u></u><span style=3D"font-size:10.0pt;font-family:Symbol;color:blue"><span=
>=C2=B7<span style=3D"font:7.0pt &quot;Times New Roman&quot;">=C2=A0=C2=A0=
=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0
</span></span></span><u></u><span style=3D"font-size:10.0pt;font-family:&qu=
ot;Arial&quot;,sans-serif;color:blue">pwIndex =3D 1, pwGroupAttachmentID =
=3D =E2=80=9CVPLS1=E2=80=9D, pwLocalAttachmentID =3D =E2=80=9C=E2=80=9D, pw=
RemoteAttachmentID =3D =E2=80=9C=E2=80=9D, pwPeerAddr =3D =E2=80=9C2.2.2.2=
=E2=80=9D<u></u><u></u></span></p>
<p class=3D"m_6156464012854588228MsoListParagraph" style=3D"margin-left:18.=
0pt">
<u></u><span style=3D"font-size:10.0pt;font-family:Symbol;color:blue"><span=
>=C2=B7<span style=3D"font:7.0pt &quot;Times New Roman&quot;">=C2=A0=C2=A0=
=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0
</span></span></span><u></u><span style=3D"font-size:10.0pt;font-family:&qu=
ot;Arial&quot;,sans-serif;color:blue">pwIndex =3D 2, pwGroupAttachmentID =
=3D =E2=80=9CVPLS1=E2=80=9D, pwLocalAttachmentID =3D =E2=80=9C=E2=80=9D, pw=
RemoteAttachmentID =3D =E2=80=9C=E2=80=9D, pwPeerAddr =3D =E2=80=9C3.3.3.3=
=E2=80=9D<u></u><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:10.0pt;font-family:&quot;Ar=
ial&quot;,sans-serif;color:blue"><u></u>=C2=A0<u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:10.0pt;font-family:&quot;Ar=
ial&quot;,sans-serif;color:blue">However, this contradicts RFC5601, specifi=
cally its definition in section 12 of the reverse-lookup table pwGenFecInde=
xMappingTable, which states that the {AGI, SAII,
 TAII} triplet must be unique for a PW using the generalized PWid FEC (type=
 129).<u></u><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:10.0pt;font-family:&quot;Ar=
ial&quot;,sans-serif;color:blue"><u></u>=C2=A0<u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0pwGenFecIndexMappingTable=C2=A0 OBJ=
ECT-TYPE<u></u><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0=C2=A0=C2=A0 SYNTAX=C2=A0=C2=A0 =C2=
=A0=C2=A0=C2=A0=C2=A0=C2=A0SEQUENCE OF PwGenFecIndexMappingEntry<u></u><u><=
/u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0=C2=A0=C2=A0 MAX-ACCESS=C2=A0=C2=A0=
=C2=A0 not-accessible<u></u><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0=C2=A0=C2=A0 STATUS=C2=A0=C2=A0=C2=
=A0=C2=A0=C2=A0=C2=A0=C2=A0 current<u></u><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0=C2=A0=C2=A0 DESCRIPTION<u></u><u><=
/u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=
=A0=C2=A0 &quot;This table enables the reverse mapping of the unique<u></u>=
<u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=
=A0=C2=A0=C2=A0 PWid parameters [GroupAttachmentID, LocalAttachmentID,<u></=
u><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0=C2=A0=C2=A0 =C2=A0=C2=A0=C2=A0=C2=
=A0=C2=A0=C2=A0and PeerAttachmentID] and the pwIndex.=C2=A0 The table is<u>=
</u><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=
=A0=C2=A0=C2=A0 only applicable for PW using the generalized FEC.&quot;<u><=
/u><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0=C2=A0=C2=A0 ::=3D { pwObjects 12 }=
<u></u><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black"><u></u>=C2=A0<u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:10.0pt;font-family:&quot;Ar=
ial&quot;,sans-serif;color:blue">Note that the corresponding reverse lookup=
 table pwIndexMappingTable for type-128 FECs has a critical difference, in =
that it includes the peer IP Address as one of
 the unique PW identifiers:<u></u><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:10.0pt;font-family:&quot;Ar=
ial&quot;,sans-serif;color:blue"><u></u>=C2=A0<u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0 pwIndexMappingTable=C2=A0 OBJECT-TYPE<u>=
</u><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0=C2=A0=C2=A0 SYNTAX=C2=A0=C2=A0=C2=
=A0=C2=A0=C2=A0=C2=A0=C2=A0 SEQUENCE OF PwIndexMappingEntry<u></u><u></u></=
span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0=C2=A0=C2=A0 MAX-ACCESS=C2=A0=C2=A0=
=C2=A0 not-accessible<u></u><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0=C2=A0=C2=A0 STATUS=C2=A0=C2=A0=C2=
=A0=C2=A0=C2=A0=C2=A0=C2=A0 current<u></u><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0=C2=A0=C2=A0 DESCRIPTION<u></u><u><=
/u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=
=A0=C2=A0 &quot;This table enables the reverse mapping of the unique<u></u>=
<u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=
=A0=C2=A0=C2=A0 PWid parameters [peer IP, PW type, and PW ID] and the<u></u=
><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=
=A0=C2=A0=C2=A0 pwIndex.=C2=A0 The table is not applicable for PWs created<=
u></u><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=
=A0=C2=A0=C2=A0 manually or by using the generalized FEC.&quot;<u></u><u></=
u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0=C2=A0=C2=A0 ::=3D { pwObjects 7 }<=
u></u><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:10.0pt;font-family:&quot;Ar=
ial&quot;,sans-serif;color:blue"><u></u>=C2=A0<u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:10.0pt;font-family:&quot;Ar=
ial&quot;,sans-serif;color:blue">It seems to me that pwGenFecIndexMappingTa=
ble should have the peer IP address as a 4<sup>th</sup> =E2=80=9Cunique PWi=
d parameter=E2=80=9D.=C2=A0 Otherwise, these parameters cannot uniquely
 identify a PW that belongs to an RFC4762-compliant VPLS.<u></u><u></u></sp=
an></p>
<p class=3D"MsoNormal"><span style=3D"font-size:10.0pt;font-family:&quot;Ar=
ial&quot;,sans-serif;color:blue"><u></u>=C2=A0<u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:10.0pt;font-family:&quot;Ar=
ial&quot;,sans-serif;color:blue">Please let me know what you think.=C2=A0 M=
y apologies if this has already been discussed before.<u></u><u></u></span>=
</p>
<p class=3D"MsoNormal"><span style=3D"font-size:10.0pt;font-family:&quot;Ar=
ial&quot;,sans-serif;color:blue"><u></u>=C2=A0<u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:10.0pt;font-family:&quot;Ar=
ial&quot;,sans-serif;color:blue">Thanks,<u></u><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:10.0pt;font-family:&quot;Ar=
ial&quot;,sans-serif;color:blue"><u></u>=C2=A0<u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:10.0pt;font-family:&quot;Ar=
ial&quot;,sans-serif;color:blue">Mike Bartlett<br>
</span><span style=3D"color:blue"><a href=3D"mailto:mike.bartlett@metaswitc=
h.com" target=3D"_blank"><b><span style=3D"font-size:10.0pt;font-family:&qu=
ot;Arial&quot;,sans-serif;color:blue">mike.bartlett@metaswitch.com</span></=
b></a></span><span style=3D"font-size:10.0pt;font-family:&quot;Arial&quot;,=
sans-serif;color:blue"><u></u><u></u></span></p>
<p class=3D"MsoNormal"><u></u>=C2=A0<u></u></p>
</div>
</div>

<br>______________________________<wbr>_________________<br>
Pals mailing list<br>
<a href=3D"mailto:Pals@ietf.org">Pals@ietf.org</a><br>
<a href=3D"https://www.ietf.org/mailman/listinfo/pals" rel=3D"noreferrer" t=
arget=3D"_blank">https://www.ietf.org/mailman/<wbr>listinfo/pals</a><br>
<br></blockquote></div><br></div>

--94eb2c04e9302a434c0540c8f4b1--


From nobody Tue Nov  8 04:10:59 2016
Return-Path: <agmalis@gmail.com>
X-Original-To: l2vpn@ietfa.amsl.com
Delivered-To: l2vpn@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 2A9AB129613; Tue,  8 Nov 2016 04:10:58 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -2.699
X-Spam-Level: 
X-Spam-Status: No, score=-2.699 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, FREEMAIL_FROM=0.001, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_LOW=-0.7, SPF_PASS=-0.001] autolearn=ham autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (2048-bit key) header.d=gmail.com
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id jDTwelKaOG2r; Tue,  8 Nov 2016 04:10:55 -0800 (PST)
Received: from mail-yw0-x22e.google.com (mail-yw0-x22e.google.com [IPv6:2607:f8b0:4002:c05::22e]) (using TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id B327812985C; Tue,  8 Nov 2016 04:10:55 -0800 (PST)
Received: by mail-yw0-x22e.google.com with SMTP id l124so170196211ywb.3; Tue, 08 Nov 2016 04:10:55 -0800 (PST)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20120113;  h=mime-version:from:date:message-id:subject:to; bh=DfnE72GZoFGjJh1cIm+x+GTSBRn2vjZ52AkOU9o9YZU=; b=C1sELwDphhRBo4gR9TidS84ZBpxsVO/QKDAWrHrloWGZWBZsk9xYWFng5snxKY8TcD HaWSjqIcNp3kyeJYp2je6mOseP7NBtjgeDmj7QfTyCkMkBgCtxwLKaK9xv7w8fPGLnVQ O0L+/IVj51BPmHYK1iNccl8fTeJtAOiYJxXNKj6LgWHOCTkAVlfdufx4VZtmuUjBKiFJ a1B0REAjlZzrG4RuuIjzzX0tNxdgDI5TYF7FSGcVRGgazGTBML101j8IR+tHG3fvbRVE ukHfNUuIX3kBVoAdTxmhIzlOF5B8d1M4jfATe7jQZbljvvXE6owRoknob+5aBNkstm3J yWhA==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20130820; h=x-gm-message-state:mime-version:from:date:message-id:subject:to; bh=DfnE72GZoFGjJh1cIm+x+GTSBRn2vjZ52AkOU9o9YZU=; b=fgdj+QYuCfac3V/zlA7MltTpItUNjsQpqUuJ4Ud5Ze++foBLBW4xRxOAl4aT8HWMn8 7Lo5P8M9GSxNYQd2096BffjKMnKr3QFvmtAbTq2FJASaUWbvjWgNGz+kD6+kKMFHWAkf yQbJzolyprsId+qFUHgYkIjk/odiJMKa1a27fsVmL8F4x5v7gQOrPLQ04xxaQe9PckUE jnMdhHuCzX3uGNaQJ2NEZqiP8JJ6DwB7D/OoO0bd5mMVqi6UTYqqncypH9jX4W/ps4Hc fND8LwOL7g/Jk6ERaTrEA7LkbD8uh5+zk+c6sbskwywk4xaj9kPRs6QWc2ucEEVSIxmh loAQ==
X-Gm-Message-State: ABUngvc/H6Ezgf9AQAt52lY7yfBzWRlEuvf6irotbP0A3oMZ0qETCMRkFWofJ7Vgs1e1XNnpycza9WWRR95npQ==
X-Received: by 10.157.16.70 with SMTP id o6mr5617060oto.101.1478607054908; Tue, 08 Nov 2016 04:10:54 -0800 (PST)
MIME-Version: 1.0
Received: by 10.182.150.42 with HTTP; Tue, 8 Nov 2016 04:10:34 -0800 (PST)
From: "Andrew G. Malis" <agmalis@gmail.com>
Date: Tue, 8 Nov 2016 07:10:34 -0500
Message-ID: <CAA=duU3wDqkWz+6gKZxC3FTENdxC1HR9SVsSN17koQoPVvdJAQ@mail.gmail.com>
Subject: To the attention of PW MIB and/or VPLS configuration experts out there ...
To: "pals@ietf.org" <pals@ietf.org>, "l2vpn@ietf.org" <l2vpn@ietf.org>
Content-Type: multipart/alternative; boundary=001a11413ccc4532d80540c908c2
Archived-At: <https://mailarchive.ietf.org/arch/msg/l2vpn/eWMONzNctcHcdXuVIKVd5bUgx1c>
X-BeenThere: l2vpn@ietf.org
X-Mailman-Version: 2.1.17
Precedence: list
List-Id: Layer 2 Virtual Private Networks <l2vpn.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/l2vpn>, <mailto:l2vpn-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/l2vpn/>
List-Post: <mailto:l2vpn@ietf.org>
List-Help: <mailto:l2vpn-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/l2vpn>, <mailto:l2vpn-request@ietf.org?subject=subscribe>
X-List-Received-Date: Tue, 08 Nov 2016 12:10:58 -0000

--001a11413ccc4532d80540c908c2
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

In case you missed this email on the PALS list ...

---------- Forwarded message ----------
From: Mike Bartlett <Mike.Bartlett@metaswitch.com>
Date: Mon, Nov 7, 2016 at 7:01 AM
Subject: [Pals] Apparent inconsistency between RFC5061 and RFC4762
To: "pals@ietf.org" <pals@ietf.org>

All,



It seems to me that there is an inconsistency between RFC5601 (=E2=80=9CPse=
udowire
MIB=E2=80=9D) and RFC4762 (=E2=80=9CVPLS Using LDP Signaling=E2=80=9D).  I =
would like to hear
people=E2=80=99s views on whether this is indeed the case, or whether I hav=
e
misunderstood.



Let=E2=80=99s say I have 3 PEs =E2=80=9CPE1=E2=80=9D, =E2=80=9CPE2=E2=80=9D=
 and =E2=80=9CPE3=E2=80=9D, with IP addresses 1.1.1.,
2.2.2.2 and 3.3.3.3 respectively.  I want to create a full-mesh VPLS
service with the pwTable specified in RFC5601, using the Generalized PWid
FEC (i.e. FEC type 129).  The question is =E2=80=93 how do I configure the =
2
pwTable rows on PE1?



According to RFC4762, section 6.1.1, the AGI is the unique name of the VPLS
(e.g. =E2=80=9CVPLS1=E2=80=9D), and the TAII and SAII are both null.



   Attachment Group Identifier (AGI), Length, Value: The unique name of

   this VPLS.  The AGI identifies a type of name, and Length denotes the

   length of Value, which is the name of the VPLS.  We use the term AGI

   interchangeably with VPLS identifier.



   Target Attachment Individual Identifier (TAII), Source Attachment

   Individual Identifier (SAII): These are null because the mesh of PWs

   in a VPLS terminates on MAC learning tables, rather than on

   individual attachment circuits.  The use of non-null TAII and SAII is

   reserved for future enhancements.



This suggests that the pwTable configuration on PE1 should look like this:



=C2=B7         pwIndex =3D 1, pwGroupAttachmentID =3D =E2=80=9CVPLS1=E2=80=
=9D, pwLocalAttachmentID =3D
=E2=80=9C=E2=80=9D, pwRemoteAttachmentID =3D =E2=80=9C=E2=80=9D, pwPeerAddr=
 =3D =E2=80=9C2.2.2.2=E2=80=9D

=C2=B7         pwIndex =3D 2, pwGroupAttachmentID =3D =E2=80=9CVPLS1=E2=80=
=9D, pwLocalAttachmentID =3D
=E2=80=9C=E2=80=9D, pwRemoteAttachmentID =3D =E2=80=9C=E2=80=9D, pwPeerAddr=
 =3D =E2=80=9C3.3.3.3=E2=80=9D



However, this contradicts RFC5601, specifically its definition in section
12 of the reverse-lookup table pwGenFecIndexMappingTable, which states that
the {AGI, SAII, TAII} triplet must be unique for a PW using the generalized
PWid FEC (type 129).



  pwGenFecIndexMappingTable  OBJECT-TYPE

     SYNTAX        SEQUENCE OF PwGenFecIndexMappingEntry

     MAX-ACCESS    not-accessible

     STATUS        current

     DESCRIPTION

          "This table enables the reverse mapping of the unique

           PWid parameters [GroupAttachmentID, LocalAttachmentID,

           and PeerAttachmentID] and the pwIndex.  The table is

           only applicable for PW using the generalized FEC."

     ::=3D { pwObjects 12 }



Note that the corresponding reverse lookup table pwIndexMappingTable for
type-128 FECs has a critical difference, in that it includes the peer IP
Address as one of the unique PW identifiers:



  pwIndexMappingTable  OBJECT-TYPE

     SYNTAX        SEQUENCE OF PwIndexMappingEntry

     MAX-ACCESS    not-accessible

     STATUS        current

     DESCRIPTION

          "This table enables the reverse mapping of the unique

           PWid parameters [peer IP, PW type, and PW ID] and the

           pwIndex.  The table is not applicable for PWs created

           manually or by using the generalized FEC."

     ::=3D { pwObjects 7 }



It seems to me that pwGenFecIndexMappingTable should have the peer IP
address as a 4th =E2=80=9Cunique PWid parameter=E2=80=9D.  Otherwise, these=
 parameters
cannot uniquely identify a PW that belongs to an RFC4762-compliant VPLS.



Please let me know what you think.  My apologies if this has already been
discussed before.



Thanks,



Mike Bartlett
*mike.bartlett@metaswitch.com* <mike.bartlett@metaswitch.com>



_______________________________________________
Pals mailing list
Pals@ietf.org
https://www.ietf.org/mailman/listinfo/pals

--001a11413ccc4532d80540c908c2
Content-Type: text/html; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

<div dir=3D"ltr"><div>In case you missed this email on the PALS list ...</d=
iv><div><br></div><div class=3D"gmail_quote">---------- Forwarded message -=
---------<br>From: <b class=3D"gmail_sendername">Mike Bartlett</b> <span di=
r=3D"ltr">&lt;<a href=3D"mailto:Mike.Bartlett@metaswitch.com">Mike.Bartlett=
@metaswitch.com</a>&gt;</span><br>Date: Mon, Nov 7, 2016 at 7:01 AM<br>Subj=
ect: [Pals] Apparent inconsistency between RFC5061 and RFC4762<br>To: &quot=
;<a href=3D"mailto:pals@ietf.org">pals@ietf.org</a>&quot; &lt;<a href=3D"ma=
ilto:pals@ietf.org">pals@ietf.org</a>&gt;<br><br>





<div lang=3D"EN-GB" link=3D"#0563C1" vlink=3D"#954F72">
<div class=3D"m_4001508998765223929WordSection1">
<p class=3D"MsoNormal"><span style=3D"font-size:10.0pt;font-family:&quot;Ar=
ial&quot;,sans-serif;color:blue">All,<u></u><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:10.0pt;font-family:&quot;Ar=
ial&quot;,sans-serif;color:blue"><u></u>=C2=A0<u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:10.0pt;font-family:&quot;Ar=
ial&quot;,sans-serif;color:blue">It seems to me that there is an inconsiste=
ncy between RFC5601 (=E2=80=9CPseudowire MIB=E2=80=9D) and RFC4762 (=E2=80=
=9CVPLS Using LDP Signaling=E2=80=9D).=C2=A0 I would like to hear people=E2=
=80=99s views on
 whether this is indeed the case, or whether I have misunderstood.<u></u><u=
></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:10.0pt;font-family:&quot;Ar=
ial&quot;,sans-serif;color:blue"><u></u>=C2=A0<u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:10.0pt;font-family:&quot;Ar=
ial&quot;,sans-serif;color:blue">Let=E2=80=99s say I have 3 PEs =E2=80=9CPE=
1=E2=80=9D, =E2=80=9CPE2=E2=80=9D and =E2=80=9CPE3=E2=80=9D, with IP addres=
ses 1.1.1., 2.2.2.2 and 3.3.3.3 respectively.=C2=A0 I want to create a full=
-mesh VPLS service with the pwTable
 specified in RFC5601, using the Generalized PWid FEC (i.e. FEC type 129).=
=C2=A0 The question is =E2=80=93 how do I configure the 2 pwTable rows on P=
E1?<u></u><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:10.0pt;font-family:&quot;Ar=
ial&quot;,sans-serif;color:blue"><u></u>=C2=A0<u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:10.0pt;font-family:&quot;Ar=
ial&quot;,sans-serif;color:blue">According to RFC4762, section 6.1.1, the A=
GI is the unique name of the VPLS (e.g. =E2=80=9CVPLS1=E2=80=9D), and the T=
AII and SAII are both null.=C2=A0
<u></u><u></u></span></p>
<p class=3D"MsoNormal"><b><u><span style=3D"font-size:10.0pt;font-family:&q=
uot;Arial&quot;,sans-serif;color:blue"><u></u><span style=3D"text-decoratio=
n:none">=C2=A0</span><u></u></span></u></b></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0 Attachment Group Identifier (AGI),=
 Length, Value: The unique name of<u></u><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0 this VPLS.=C2=A0 The AGI identifie=
s a type of name, and Length denotes the<u></u><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0 length of Value, which is the name=
 of the VPLS.=C2=A0 We use the term AGI<u></u><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0 interchangeably with VPLS identifi=
er.<u></u><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black"><u></u>=C2=A0<u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0 Target Attachment Individual Ident=
ifier (TAII), Source Attachment<u></u><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0 Individual Identifier (SAII): Thes=
e are null because the mesh of PWs<u></u><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0 in a VPLS terminates on MAC learni=
ng tables, rather than on<u></u><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0 individual attachment circuits.=C2=
=A0 The use of non-null TAII and SAII is<u></u><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0 reserved for future enhancements.<=
u></u><u></u></span></p>
<p class=3D"MsoNormal"><b><u><span style=3D"font-size:10.0pt;font-family:&q=
uot;Arial&quot;,sans-serif;color:blue"><u></u><span style=3D"text-decoratio=
n:none">=C2=A0</span><u></u></span></u></b></p>
<p class=3D"MsoNormal"><span style=3D"font-size:10.0pt;font-family:&quot;Ar=
ial&quot;,sans-serif;color:blue">This suggests that the pwTable configurati=
on on PE1 should look like this:<u></u><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:10.0pt;font-family:&quot;Ar=
ial&quot;,sans-serif;color:blue"><u></u>=C2=A0<u></u></span></p>
<p class=3D"m_4001508998765223929MsoListParagraph" style=3D"margin-left:18.=
0pt">
<u></u><span style=3D"font-size:10.0pt;font-family:Symbol;color:blue"><span=
>=C2=B7<span style=3D"font:7.0pt &quot;Times New Roman&quot;">=C2=A0=C2=A0=
=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0
</span></span></span><u></u><span style=3D"font-size:10.0pt;font-family:&qu=
ot;Arial&quot;,sans-serif;color:blue">pwIndex =3D 1, pwGroupAttachmentID =
=3D =E2=80=9CVPLS1=E2=80=9D, pwLocalAttachmentID =3D =E2=80=9C=E2=80=9D, pw=
RemoteAttachmentID =3D =E2=80=9C=E2=80=9D, pwPeerAddr =3D =E2=80=9C2.2.2.2=
=E2=80=9D<u></u><u></u></span></p>
<p class=3D"m_4001508998765223929MsoListParagraph" style=3D"margin-left:18.=
0pt">
<u></u><span style=3D"font-size:10.0pt;font-family:Symbol;color:blue"><span=
>=C2=B7<span style=3D"font:7.0pt &quot;Times New Roman&quot;">=C2=A0=C2=A0=
=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0
</span></span></span><u></u><span style=3D"font-size:10.0pt;font-family:&qu=
ot;Arial&quot;,sans-serif;color:blue">pwIndex =3D 2, pwGroupAttachmentID =
=3D =E2=80=9CVPLS1=E2=80=9D, pwLocalAttachmentID =3D =E2=80=9C=E2=80=9D, pw=
RemoteAttachmentID =3D =E2=80=9C=E2=80=9D, pwPeerAddr =3D =E2=80=9C3.3.3.3=
=E2=80=9D<u></u><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:10.0pt;font-family:&quot;Ar=
ial&quot;,sans-serif;color:blue"><u></u>=C2=A0<u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:10.0pt;font-family:&quot;Ar=
ial&quot;,sans-serif;color:blue">However, this contradicts RFC5601, specifi=
cally its definition in section 12 of the reverse-lookup table pwGenFecInde=
xMappingTable, which states that the {AGI, SAII,
 TAII} triplet must be unique for a PW using the generalized PWid FEC (type=
 129).<u></u><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:10.0pt;font-family:&quot;Ar=
ial&quot;,sans-serif;color:blue"><u></u>=C2=A0<u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0pwGenFecIndexMappingTable=C2=A0 OBJ=
ECT-TYPE<u></u><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0=C2=A0=C2=A0 SYNTAX=C2=A0=C2=A0 =C2=
=A0=C2=A0=C2=A0=C2=A0=C2=A0SEQUENCE OF PwGenFecIndexMappingEntry<u></u><u><=
/u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0=C2=A0=C2=A0 MAX-ACCESS=C2=A0=C2=A0=
=C2=A0 not-accessible<u></u><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0=C2=A0=C2=A0 STATUS=C2=A0=C2=A0=C2=
=A0=C2=A0=C2=A0=C2=A0=C2=A0 current<u></u><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0=C2=A0=C2=A0 DESCRIPTION<u></u><u><=
/u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=
=A0=C2=A0 &quot;This table enables the reverse mapping of the unique<u></u>=
<u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=
=A0=C2=A0=C2=A0 PWid parameters [GroupAttachmentID, LocalAttachmentID,<u></=
u><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0=C2=A0=C2=A0 =C2=A0=C2=A0=C2=A0=C2=
=A0=C2=A0=C2=A0and PeerAttachmentID] and the pwIndex.=C2=A0 The table is<u>=
</u><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=
=A0=C2=A0=C2=A0 only applicable for PW using the generalized FEC.&quot;<u><=
/u><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0=C2=A0=C2=A0 ::=3D { pwObjects 12 }=
<u></u><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black"><u></u>=C2=A0<u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:10.0pt;font-family:&quot;Ar=
ial&quot;,sans-serif;color:blue">Note that the corresponding reverse lookup=
 table pwIndexMappingTable for type-128 FECs has a critical difference, in =
that it includes the peer IP Address as one of
 the unique PW identifiers:<u></u><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:10.0pt;font-family:&quot;Ar=
ial&quot;,sans-serif;color:blue"><u></u>=C2=A0<u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0 pwIndexMappingTable=C2=A0 OBJECT-TYPE<u>=
</u><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0=C2=A0=C2=A0 SYNTAX=C2=A0=C2=A0=C2=
=A0=C2=A0=C2=A0=C2=A0=C2=A0 SEQUENCE OF PwIndexMappingEntry<u></u><u></u></=
span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0=C2=A0=C2=A0 MAX-ACCESS=C2=A0=C2=A0=
=C2=A0 not-accessible<u></u><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0=C2=A0=C2=A0 STATUS=C2=A0=C2=A0=C2=
=A0=C2=A0=C2=A0=C2=A0=C2=A0 current<u></u><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0=C2=A0=C2=A0 DESCRIPTION<u></u><u><=
/u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=
=A0=C2=A0 &quot;This table enables the reverse mapping of the unique<u></u>=
<u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=
=A0=C2=A0=C2=A0 PWid parameters [peer IP, PW type, and PW ID] and the<u></u=
><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=
=A0=C2=A0=C2=A0 pwIndex.=C2=A0 The table is not applicable for PWs created<=
u></u><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=
=A0=C2=A0=C2=A0 manually or by using the generalized FEC.&quot;<u></u><u></=
u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:8.0pt;font-family:&quot;Cou=
rier New&quot;;color:black">=C2=A0=C2=A0=C2=A0=C2=A0 ::=3D { pwObjects 7 }<=
u></u><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:10.0pt;font-family:&quot;Ar=
ial&quot;,sans-serif;color:blue"><u></u>=C2=A0<u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:10.0pt;font-family:&quot;Ar=
ial&quot;,sans-serif;color:blue">It seems to me that pwGenFecIndexMappingTa=
ble should have the peer IP address as a 4<sup>th</sup> =E2=80=9Cunique PWi=
d parameter=E2=80=9D.=C2=A0 Otherwise, these parameters cannot uniquely
 identify a PW that belongs to an RFC4762-compliant VPLS.<u></u><u></u></sp=
an></p>
<p class=3D"MsoNormal"><span style=3D"font-size:10.0pt;font-family:&quot;Ar=
ial&quot;,sans-serif;color:blue"><u></u>=C2=A0<u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:10.0pt;font-family:&quot;Ar=
ial&quot;,sans-serif;color:blue">Please let me know what you think.=C2=A0 M=
y apologies if this has already been discussed before.<u></u><u></u></span>=
</p>
<p class=3D"MsoNormal"><span style=3D"font-size:10.0pt;font-family:&quot;Ar=
ial&quot;,sans-serif;color:blue"><u></u>=C2=A0<u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:10.0pt;font-family:&quot;Ar=
ial&quot;,sans-serif;color:blue">Thanks,<u></u><u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:10.0pt;font-family:&quot;Ar=
ial&quot;,sans-serif;color:blue"><u></u>=C2=A0<u></u></span></p>
<p class=3D"MsoNormal"><span style=3D"font-size:10.0pt;font-family:&quot;Ar=
ial&quot;,sans-serif;color:blue">Mike Bartlett<br>
</span><span style=3D"color:blue"><a href=3D"mailto:mike.bartlett@metaswitc=
h.com" target=3D"_blank"><b><span style=3D"font-size:10.0pt;font-family:&qu=
ot;Arial&quot;,sans-serif;color:blue">mike.bartlett@metaswitch.com</span></=
b></a></span><span style=3D"font-size:10.0pt;font-family:&quot;Arial&quot;,=
sans-serif;color:blue"><u></u><u></u></span></p>
<p class=3D"MsoNormal"><u></u>=C2=A0<u></u></p>
</div>
</div>

<br>______________________________<wbr>_________________<br>
Pals mailing list<br>
<a href=3D"mailto:Pals@ietf.org">Pals@ietf.org</a><br>
<a href=3D"https://www.ietf.org/mailman/listinfo/pals" rel=3D"noreferrer" t=
arget=3D"_blank">https://www.ietf.org/mailman/<wbr>listinfo/pals</a><br>
<br></div><br></div>

--001a11413ccc4532d80540c908c2--


From nobody Tue Nov  8 10:57:41 2016
Return-Path: <giles.heron@gmail.com>
X-Original-To: l2vpn@ietfa.amsl.com
Delivered-To: l2vpn@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 984B9129D91; Tue,  8 Nov 2016 10:57:36 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -2.699
X-Spam-Level: 
X-Spam-Status: No, score=-2.699 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, FREEMAIL_FROM=0.001, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_LOW=-0.7, SPF_PASS=-0.001] autolearn=ham autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (2048-bit key) header.d=gmail.com
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id EgZgnyXy726k; Tue,  8 Nov 2016 10:57:34 -0800 (PST)
Received: from mail-wm0-x235.google.com (mail-wm0-x235.google.com [IPv6:2a00:1450:400c:c09::235]) (using TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 97F6D12965E; Tue,  8 Nov 2016 10:57:33 -0800 (PST)
Received: by mail-wm0-x235.google.com with SMTP id a197so264242465wmd.0; Tue, 08 Nov 2016 10:57:33 -0800 (PST)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20120113;  h=from:message-id:mime-version:subject:date:in-reply-to:cc:to :references; bh=i6U3v5BoEa5A8qb7BMLBthr5BuEQX3hb+k17zU9/wT4=; b=wBVR20HSJ55W2/IMeCxiGSLfBZW3CN/bM4piLsIJcYE/ZfSGcjXmNj8H8BczxCuAC8 n3Uv1rpmkBu7juIkKH5mNfHM3NNtGzIOs6M9iwXqWzE9JiGNsJnlBDXs12KSZeAR76OA Sl72mGlxisr5NIxE3m7QZjVs1kCJKF1XoXjLFdXXbKfkqGiYDWKy9zqow/IcH8s3in0D QGPkqF1HZ0l7GvJmNyAynWkbRIJm6c5UmoWrBdj6gHOrdwb3wD0txCtmhPlVN9Xs5wN2 yOOyPxA3rFga2wj147TlGtN1wFwTJZwlKEiwXVJvaXm7G26I85pPvcP7PeZMu/tfonKy JWfg==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20130820; h=x-gm-message-state:from:message-id:mime-version:subject:date :in-reply-to:cc:to:references; bh=i6U3v5BoEa5A8qb7BMLBthr5BuEQX3hb+k17zU9/wT4=; b=XpPNOqZDHxqGoO1aAJnwDcgizT/3g9vxDZX3iMueprM2Nf3X194l8L+VeveGGNRJBo MgNPzWLWOv9X5cJAAjx0Uo6IVhNlb8yKKav6rmK5me6lDuB+npSNamOJ14xOKqRMnbTU U8wkMaHNXOtCGSXfVfzFwrrH3uB72x7kdhYm/Pb4jMO6YN9LzqpVZEr8Q0+hLEZ87Sts WkgRjFEKLe6wbNpydgQ/BVWkhPkeUw8Cn0CvqjcuZtBmRaMEAhn1CmZBhLQXFydiZLR4 xNmAVOezc42RAWdDDGtJAyBOWHM5Kg7FKbuJ1QPf+V6KLJLNAlyxfyPsRI70C1QF3H+b xy+g==
X-Gm-Message-State: ABUngveak/UsscZpjc0knysTOQ/9o9EalsK1Qmd4qYUvjZzFD4IKep84hFxk3ImtFMUpvQ==
X-Received: by 10.194.222.105 with SMTP id ql9mr13809441wjc.63.1478631452084;  Tue, 08 Nov 2016 10:57:32 -0800 (PST)
Received: from ams-giheron-8915.cisco.com ([173.38.220.41]) by smtp.gmail.com with ESMTPSA id g17sm38633003wjs.38.2016.11.08.10.57.30 (version=TLS1_2 cipher=ECDHE-RSA-AES128-GCM-SHA256 bits=128/128); Tue, 08 Nov 2016 10:57:31 -0800 (PST)
From: Giles Heron <giles.heron@gmail.com>
Message-Id: <3337AFD2-754D-4E22-A752-400F5D4CEA35@gmail.com>
Content-Type: multipart/alternative; boundary="Apple-Mail=_061AAA05-EB2A-4359-9DF8-8C5021EA3FF3"
Mime-Version: 1.0 (Mac OS X Mail 10.0 \(3226\))
Subject: Re: To the attention of PW MIB and/or VPLS configuration experts out there ...
Date: Tue, 8 Nov 2016 18:57:29 +0000
In-Reply-To: <CAA=duU3wDqkWz+6gKZxC3FTENdxC1HR9SVsSN17koQoPVvdJAQ@mail.gmail.com>
To: "Andrew G. Malis" <agmalis@gmail.com>
References: <CAA=duU3wDqkWz+6gKZxC3FTENdxC1HR9SVsSN17koQoPVvdJAQ@mail.gmail.com>
X-Mailer: Apple Mail (2.3226)
Archived-At: <https://mailarchive.ietf.org/arch/msg/l2vpn/dEA2b8cuRRot4C2RM0U3zwOD7p4>
Cc: "l2vpn@ietf.org" <l2vpn@ietf.org>, david.zelig@compassnetworks.com, "pals@ietf.org" <pals@ietf.org>
X-BeenThere: l2vpn@ietf.org
X-Mailman-Version: 2.1.17
Precedence: list
List-Id: Layer 2 Virtual Private Networks <l2vpn.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/l2vpn>, <mailto:l2vpn-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/l2vpn/>
List-Post: <mailto:l2vpn@ietf.org>
List-Help: <mailto:l2vpn-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/l2vpn>, <mailto:l2vpn-request@ietf.org?subject=subscribe>
X-List-Received-Date: Tue, 08 Nov 2016 18:57:36 -0000

--Apple-Mail=_061AAA05-EB2A-4359-9DF8-8C5021EA3FF3
Content-Transfer-Encoding: quoted-printable
Content-Type: text/plain;
	charset=utf-8

Looks like a bug in the MIB to me.  Tom/David were the authors so I=E2=80=99=
ll leave it to them to respond (am guessing here at David=E2=80=99s =
email), but might be worth raising an erratum.

> On 8 Nov 2016, at 12:10, Andrew G. Malis <agmalis@gmail.com> wrote:
>=20
> In case you missed this email on the PALS list ...
>=20
> ---------- Forwarded message ----------
> From: Mike Bartlett <Mike.Bartlett@metaswitch.com =
<mailto:Mike.Bartlett@metaswitch.com>>
> Date: Mon, Nov 7, 2016 at 7:01 AM
> Subject: [Pals] Apparent inconsistency between RFC5061 and RFC4762
> To: "pals@ietf.org <mailto:pals@ietf.org>" <pals@ietf.org =
<mailto:pals@ietf.org>>
>=20
> All,
>=20
> =20
>=20
> It seems to me that there is an inconsistency between RFC5601 =
(=E2=80=9CPseudowire MIB=E2=80=9D) and RFC4762 (=E2=80=9CVPLS Using LDP =
Signaling=E2=80=9D).  I would like to hear people=E2=80=99s views on =
whether this is indeed the case, or whether I have misunderstood.
>=20
> =20
>=20
> Let=E2=80=99s say I have 3 PEs =E2=80=9CPE1=E2=80=9D, =E2=80=9CPE2=E2=80=
=9D and =E2=80=9CPE3=E2=80=9D, with IP addresses 1.1.1., 2.2.2.2 and =
3.3.3.3 respectively.  I want to create a full-mesh VPLS service with =
the pwTable specified in RFC5601, using the Generalized PWid FEC (i.e. =
FEC type 129).  The question is =E2=80=93 how do I configure the 2 =
pwTable rows on PE1?
>=20
> =20
>=20
> According to RFC4762, section 6.1.1, the AGI is the unique name of the =
VPLS (e.g. =E2=80=9CVPLS1=E2=80=9D), and the TAII and SAII are both =
null.=20
>=20
> =20
>=20
>    Attachment Group Identifier (AGI), Length, Value: The unique name =
of
>=20
>    this VPLS.  The AGI identifies a type of name, and Length denotes =
the
>=20
>    length of Value, which is the name of the VPLS.  We use the term =
AGI
>=20
>    interchangeably with VPLS identifier.
>=20
> =20
>=20
>    Target Attachment Individual Identifier (TAII), Source Attachment
>=20
>    Individual Identifier (SAII): These are null because the mesh of =
PWs
>=20
>    in a VPLS terminates on MAC learning tables, rather than on
>=20
>    individual attachment circuits.  The use of non-null TAII and SAII =
is
>=20
>    reserved for future enhancements.
>=20
> =20
>=20
> This suggests that the pwTable configuration on PE1 should look like =
this:
>=20
> =20
>=20
> =C2=B7         pwIndex =3D 1, pwGroupAttachmentID =3D =E2=80=9CVPLS1=E2=80=
=9D, pwLocalAttachmentID =3D =E2=80=9C=E2=80=9D, pwRemoteAttachmentID =3D =
=E2=80=9C=E2=80=9D, pwPeerAddr =3D =E2=80=9C2.2.2.2=E2=80=9D
>=20
> =C2=B7         pwIndex =3D 2, pwGroupAttachmentID =3D =E2=80=9CVPLS1=E2=80=
=9D, pwLocalAttachmentID =3D =E2=80=9C=E2=80=9D, pwRemoteAttachmentID =3D =
=E2=80=9C=E2=80=9D, pwPeerAddr =3D =E2=80=9C3.3.3.3=E2=80=9D
>=20
> =20
>=20
> However, this contradicts RFC5601, specifically its definition in =
section 12 of the reverse-lookup table pwGenFecIndexMappingTable, which =
states that the {AGI, SAII, TAII} triplet must be unique for a PW using =
the generalized PWid FEC (type 129).
>=20
> =20
>=20
>   pwGenFecIndexMappingTable  OBJECT-TYPE
>=20
>      SYNTAX        SEQUENCE OF PwGenFecIndexMappingEntry
>=20
>      MAX-ACCESS    not-accessible
>=20
>      STATUS        current
>=20
>      DESCRIPTION
>=20
>           "This table enables the reverse mapping of the unique
>=20
>            PWid parameters [GroupAttachmentID, LocalAttachmentID,
>=20
>            and PeerAttachmentID] and the pwIndex.  The table is
>=20
>            only applicable for PW using the generalized FEC."
>=20
>      ::=3D { pwObjects 12 }
>=20
> =20
>=20
> Note that the corresponding reverse lookup table pwIndexMappingTable =
for type-128 FECs has a critical difference, in that it includes the =
peer IP Address as one of the unique PW identifiers:
>=20
> =20
>=20
>   pwIndexMappingTable  OBJECT-TYPE
>=20
>      SYNTAX        SEQUENCE OF PwIndexMappingEntry
>=20
>      MAX-ACCESS    not-accessible
>=20
>      STATUS        current
>=20
>      DESCRIPTION
>=20
>           "This table enables the reverse mapping of the unique
>=20
>            PWid parameters [peer IP, PW type, and PW ID] and the
>=20
>            pwIndex.  The table is not applicable for PWs created
>=20
>            manually or by using the generalized FEC."
>=20
>      ::=3D { pwObjects 7 }
>=20
> =20
>=20
> It seems to me that pwGenFecIndexMappingTable should have the peer IP =
address as a 4th =E2=80=9Cunique PWid parameter=E2=80=9D.  Otherwise, =
these parameters cannot uniquely identify a PW that belongs to an =
RFC4762-compliant VPLS.
>=20
> =20
>=20
> Please let me know what you think.  My apologies if this has already =
been discussed before.
>=20
> =20
>=20
> Thanks,
>=20
> =20
>=20
> Mike Bartlett
> mike.bartlett@metaswitch.com <mailto:mike.bartlett@metaswitch.com>
> =20
>=20
>=20
> _______________________________________________
> Pals mailing list
> Pals@ietf.org <mailto:Pals@ietf.org>
> https://www.ietf.org/mailman/listinfo/pals =
<https://www.ietf.org/mailman/listinfo/pals>
>=20
>=20


--Apple-Mail=_061AAA05-EB2A-4359-9DF8-8C5021EA3FF3
Content-Transfer-Encoding: quoted-printable
Content-Type: text/html;
	charset=utf-8

<html><head><meta http-equiv=3D"Content-Type" content=3D"text/html =
charset=3Dutf-8"></head><body style=3D"word-wrap: break-word; =
-webkit-nbsp-mode: space; -webkit-line-break: after-white-space;" =
class=3D"">Looks like a bug in the MIB to me. &nbsp;Tom/David were the =
authors so I=E2=80=99ll leave it to them to respond (am guessing here at =
David=E2=80=99s email), but might be worth raising an erratum.<div =
class=3D""><br class=3D""><div class=3D""><div><blockquote type=3D"cite" =
class=3D""><div class=3D"">On 8 Nov 2016, at 12:10, Andrew G. Malis =
&lt;<a href=3D"mailto:agmalis@gmail.com" =
class=3D"">agmalis@gmail.com</a>&gt; wrote:</div><br =
class=3D"Apple-interchange-newline"><div class=3D""><div dir=3D"ltr" =
class=3D""><div class=3D"">In case you missed this email on the PALS =
list ...</div><div class=3D""><br class=3D""></div><div =
class=3D"gmail_quote">---------- Forwarded message ----------<br =
class=3D"">From: <b class=3D"gmail_sendername">Mike Bartlett</b> <span =
dir=3D"ltr" class=3D"">&lt;<a href=3D"mailto:Mike.Bartlett@metaswitch.com"=
 class=3D"">Mike.Bartlett@metaswitch.com</a>&gt;</span><br =
class=3D"">Date: Mon, Nov 7, 2016 at 7:01 AM<br class=3D"">Subject: =
[Pals] Apparent inconsistency between RFC5061 and RFC4762<br =
class=3D"">To: "<a href=3D"mailto:pals@ietf.org" =
class=3D"">pals@ietf.org</a>" &lt;<a href=3D"mailto:pals@ietf.org" =
class=3D"">pals@ietf.org</a>&gt;<br class=3D""><br class=3D"">





<div lang=3D"EN-GB" link=3D"#0563C1" vlink=3D"#954F72" class=3D"">
<div class=3D"m_4001508998765223929WordSection1"><p =
class=3D"MsoNormal"><span =
style=3D"font-size:10.0pt;font-family:&quot;Arial&quot;,sans-serif;color:b=
lue" class=3D"">All,<u class=3D""></u><u class=3D""></u></span></p><p =
class=3D"MsoNormal"><span =
style=3D"font-size:10.0pt;font-family:&quot;Arial&quot;,sans-serif;color:b=
lue" class=3D""><u class=3D""></u>&nbsp;<u class=3D""></u></span></p><p =
class=3D"MsoNormal"><span =
style=3D"font-size:10.0pt;font-family:&quot;Arial&quot;,sans-serif;color:b=
lue" class=3D"">It seems to me that there is an inconsistency between =
RFC5601 (=E2=80=9CPseudowire MIB=E2=80=9D) and RFC4762 (=E2=80=9CVPLS =
Using LDP Signaling=E2=80=9D).&nbsp; I would like to hear people=E2=80=99s=
 views on
 whether this is indeed the case, or whether I have misunderstood.<u =
class=3D""></u><u class=3D""></u></span></p><p class=3D"MsoNormal"><span =
style=3D"font-size:10.0pt;font-family:&quot;Arial&quot;,sans-serif;color:b=
lue" class=3D""><u class=3D""></u>&nbsp;<u class=3D""></u></span></p><p =
class=3D"MsoNormal"><span =
style=3D"font-size:10.0pt;font-family:&quot;Arial&quot;,sans-serif;color:b=
lue" class=3D"">Let=E2=80=99s say I have 3 PEs =E2=80=9CPE1=E2=80=9D, =
=E2=80=9CPE2=E2=80=9D and =E2=80=9CPE3=E2=80=9D, with IP addresses =
1.1.1., 2.2.2.2 and 3.3.3.3 respectively.&nbsp; I want to create a =
full-mesh VPLS service with the pwTable
 specified in RFC5601, using the Generalized PWid FEC (i.e. FEC type =
129).&nbsp; The question is =E2=80=93 how do I configure the 2 pwTable =
rows on PE1?<u class=3D""></u><u class=3D""></u></span></p><p =
class=3D"MsoNormal"><span =
style=3D"font-size:10.0pt;font-family:&quot;Arial&quot;,sans-serif;color:b=
lue" class=3D""><u class=3D""></u>&nbsp;<u class=3D""></u></span></p><p =
class=3D"MsoNormal"><span =
style=3D"font-size:10.0pt;font-family:&quot;Arial&quot;,sans-serif;color:b=
lue" class=3D"">According to RFC4762, section 6.1.1, the AGI is the =
unique name of the VPLS (e.g. =E2=80=9CVPLS1=E2=80=9D), and the TAII and =
SAII are both null.&nbsp;
<u class=3D""></u><u class=3D""></u></span></p><p class=3D"MsoNormal"><b =
class=3D""><u class=3D""><span =
style=3D"font-size:10.0pt;font-family:&quot;Arial&quot;,sans-serif;color:b=
lue" class=3D""><u class=3D""></u><span style=3D"text-decoration:none" =
class=3D"">&nbsp;</span><u class=3D""></u></span></u></b></p><p =
class=3D"MsoNormal"><span style=3D"font-size: 8pt; font-family: 'Courier =
New';" class=3D"">&nbsp;&nbsp; Attachment Group Identifier (AGI), =
Length, Value: The unique name of<u class=3D""></u><u =
class=3D""></u></span></p><p class=3D"MsoNormal"><span style=3D"font-size:=
 8pt; font-family: 'Courier New';" class=3D"">&nbsp;&nbsp; this =
VPLS.&nbsp; The AGI identifies a type of name, and Length denotes the<u =
class=3D""></u><u class=3D""></u></span></p><p class=3D"MsoNormal"><span =
style=3D"font-size: 8pt; font-family: 'Courier New';" =
class=3D"">&nbsp;&nbsp; length of Value, which is the name of the =
VPLS.&nbsp; We use the term AGI<u class=3D""></u><u =
class=3D""></u></span></p><p class=3D"MsoNormal"><span style=3D"font-size:=
 8pt; font-family: 'Courier New';" class=3D"">&nbsp;&nbsp; =
interchangeably with VPLS identifier.<u class=3D""></u><u =
class=3D""></u></span></p><p class=3D"MsoNormal"><span style=3D"font-size:=
 8pt; font-family: 'Courier New';" class=3D""><u class=3D""></u>&nbsp;<u =
class=3D""></u></span></p><p class=3D"MsoNormal"><span style=3D"font-size:=
 8pt; font-family: 'Courier New';" class=3D"">&nbsp;&nbsp; Target =
Attachment Individual Identifier (TAII), Source Attachment<u =
class=3D""></u><u class=3D""></u></span></p><p class=3D"MsoNormal"><span =
style=3D"font-size: 8pt; font-family: 'Courier New';" =
class=3D"">&nbsp;&nbsp; Individual Identifier (SAII): These are null =
because the mesh of PWs<u class=3D""></u><u class=3D""></u></span></p><p =
class=3D"MsoNormal"><span style=3D"font-size: 8pt; font-family: 'Courier =
New';" class=3D"">&nbsp;&nbsp; in a VPLS terminates on MAC learning =
tables, rather than on<u class=3D""></u><u class=3D""></u></span></p><p =
class=3D"MsoNormal"><span style=3D"font-size: 8pt; font-family: 'Courier =
New';" class=3D"">&nbsp;&nbsp; individual attachment circuits.&nbsp; The =
use of non-null TAII and SAII is<u class=3D""></u><u =
class=3D""></u></span></p><p class=3D"MsoNormal"><span style=3D"font-size:=
 8pt; font-family: 'Courier New';" class=3D"">&nbsp;&nbsp; reserved for =
future enhancements.<u class=3D""></u><u class=3D""></u></span></p><p =
class=3D"MsoNormal"><b class=3D""><u class=3D""><span =
style=3D"font-size:10.0pt;font-family:&quot;Arial&quot;,sans-serif;color:b=
lue" class=3D""><u class=3D""></u><span style=3D"text-decoration:none" =
class=3D"">&nbsp;</span><u class=3D""></u></span></u></b></p><p =
class=3D"MsoNormal"><span =
style=3D"font-size:10.0pt;font-family:&quot;Arial&quot;,sans-serif;color:b=
lue" class=3D"">This suggests that the pwTable configuration on PE1 =
should look like this:<u class=3D""></u><u class=3D""></u></span></p><p =
class=3D"MsoNormal"><span =
style=3D"font-size:10.0pt;font-family:&quot;Arial&quot;,sans-serif;color:b=
lue" class=3D""><u class=3D""></u>&nbsp;<u class=3D""></u></span></p><p =
class=3D"m_4001508998765223929MsoListParagraph" =
style=3D"margin-left:18.0pt">
<u class=3D""></u><span =
style=3D"font-size:10.0pt;font-family:Symbol;color:blue" class=3D""><span =
class=3D"">=C2=B7<span style=3D"font:7.0pt &quot;Times New Roman&quot;" =
class=3D"">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
</span></span></span><u class=3D""></u><span =
style=3D"font-size:10.0pt;font-family:&quot;Arial&quot;,sans-serif;color:b=
lue" class=3D"">pwIndex =3D 1, pwGroupAttachmentID =3D =E2=80=9CVPLS1=E2=80=
=9D, pwLocalAttachmentID =3D =E2=80=9C=E2=80=9D, pwRemoteAttachmentID =3D =
=E2=80=9C=E2=80=9D, pwPeerAddr =3D =E2=80=9C2.2.2.2=E2=80=9D<u =
class=3D""></u><u class=3D""></u></span></p><p =
class=3D"m_4001508998765223929MsoListParagraph" =
style=3D"margin-left:18.0pt">
<u class=3D""></u><span =
style=3D"font-size:10.0pt;font-family:Symbol;color:blue" class=3D""><span =
class=3D"">=C2=B7<span style=3D"font:7.0pt &quot;Times New Roman&quot;" =
class=3D"">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
</span></span></span><u class=3D""></u><span =
style=3D"font-size:10.0pt;font-family:&quot;Arial&quot;,sans-serif;color:b=
lue" class=3D"">pwIndex =3D 2, pwGroupAttachmentID =3D =E2=80=9CVPLS1=E2=80=
=9D, pwLocalAttachmentID =3D =E2=80=9C=E2=80=9D, pwRemoteAttachmentID =3D =
=E2=80=9C=E2=80=9D, pwPeerAddr =3D =E2=80=9C3.3.3.3=E2=80=9D<u =
class=3D""></u><u class=3D""></u></span></p><p class=3D"MsoNormal"><span =
style=3D"font-size:10.0pt;font-family:&quot;Arial&quot;,sans-serif;color:b=
lue" class=3D""><u class=3D""></u>&nbsp;<u class=3D""></u></span></p><p =
class=3D"MsoNormal"><span =
style=3D"font-size:10.0pt;font-family:&quot;Arial&quot;,sans-serif;color:b=
lue" class=3D"">However, this contradicts RFC5601, specifically its =
definition in section 12 of the reverse-lookup table =
pwGenFecIndexMappingTable, which states that the {AGI, SAII,
 TAII} triplet must be unique for a PW using the generalized PWid FEC =
(type 129).<u class=3D""></u><u class=3D""></u></span></p><p =
class=3D"MsoNormal"><span =
style=3D"font-size:10.0pt;font-family:&quot;Arial&quot;,sans-serif;color:b=
lue" class=3D""><u class=3D""></u>&nbsp;<u class=3D""></u></span></p><p =
class=3D"MsoNormal"><span style=3D"font-size: 8pt; font-family: 'Courier =
New';" class=3D"">&nbsp;&nbsp;pwGenFecIndexMappingTable&nbsp; =
OBJECT-TYPE<u class=3D""></u><u class=3D""></u></span></p><p =
class=3D"MsoNormal"><span style=3D"font-size: 8pt; font-family: 'Courier =
New';" class=3D"">&nbsp;&nbsp;&nbsp;&nbsp; SYNTAX&nbsp;&nbsp; =
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;SEQUENCE OF PwGenFecIndexMappingEntry<u =
class=3D""></u><u class=3D""></u></span></p><p class=3D"MsoNormal"><span =
style=3D"font-size: 8pt; font-family: 'Courier New';" =
class=3D"">&nbsp;&nbsp;&nbsp;&nbsp; MAX-ACCESS&nbsp;&nbsp;&nbsp; =
not-accessible<u class=3D""></u><u class=3D""></u></span></p><p =
class=3D"MsoNormal"><span style=3D"font-size: 8pt; font-family: 'Courier =
New';" class=3D"">&nbsp;&nbsp;&nbsp;&nbsp; =
STATUS&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; current<u =
class=3D""></u><u class=3D""></u></span></p><p class=3D"MsoNormal"><span =
style=3D"font-size: 8pt; font-family: 'Courier New';" =
class=3D"">&nbsp;&nbsp;&nbsp;&nbsp; DESCRIPTION<u class=3D""></u><u =
class=3D""></u></span></p><p class=3D"MsoNormal"><span style=3D"font-size:=
 8pt; font-family: 'Courier New';" =
class=3D"">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; "This =
table enables the reverse mapping of the unique<u class=3D""></u><u =
class=3D""></u></span></p><p class=3D"MsoNormal"><span style=3D"font-size:=
 8pt; font-family: 'Courier New';" =
class=3D"">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; =
PWid parameters [GroupAttachmentID, LocalAttachmentID,<u class=3D""></u><u=
 class=3D""></u></span></p><p class=3D"MsoNormal"><span =
style=3D"font-size: 8pt; font-family: 'Courier New';" =
class=3D"">&nbsp;&nbsp;&nbsp;&nbsp; =
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;and PeerAttachmentID] and the =
pwIndex.&nbsp; The table is<u class=3D""></u><u =
class=3D""></u></span></p><p class=3D"MsoNormal"><span style=3D"font-size:=
 8pt; font-family: 'Courier New';" =
class=3D"">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; =
only applicable for PW using the generalized FEC."<u class=3D""></u><u =
class=3D""></u></span></p><p class=3D"MsoNormal"><span style=3D"font-size:=
 8pt; font-family: 'Courier New';" class=3D"">&nbsp;&nbsp;&nbsp;&nbsp; =
::=3D { pwObjects 12 }<u class=3D""></u><u class=3D""></u></span></p><p =
class=3D"MsoNormal"><span style=3D"font-size: 8pt; font-family: 'Courier =
New';" class=3D""><u class=3D""></u>&nbsp;<u class=3D""></u></span></p><p =
class=3D"MsoNormal"><span =
style=3D"font-size:10.0pt;font-family:&quot;Arial&quot;,sans-serif;color:b=
lue" class=3D"">Note that the corresponding reverse lookup table =
pwIndexMappingTable for type-128 FECs has a critical difference, in that =
it includes the peer IP Address as one of
 the unique PW identifiers:<u class=3D""></u><u =
class=3D""></u></span></p><p class=3D"MsoNormal"><span =
style=3D"font-size:10.0pt;font-family:&quot;Arial&quot;,sans-serif;color:b=
lue" class=3D""><u class=3D""></u>&nbsp;<u class=3D""></u></span></p><p =
class=3D"MsoNormal"><span style=3D"font-size: 8pt; font-family: 'Courier =
New';" class=3D"">&nbsp; pwIndexMappingTable&nbsp; OBJECT-TYPE<u =
class=3D""></u><u class=3D""></u></span></p><p class=3D"MsoNormal"><span =
style=3D"font-size: 8pt; font-family: 'Courier New';" =
class=3D"">&nbsp;&nbsp;&nbsp;&nbsp; =
SYNTAX&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; SEQUENCE OF =
PwIndexMappingEntry<u class=3D""></u><u class=3D""></u></span></p><p =
class=3D"MsoNormal"><span style=3D"font-size: 8pt; font-family: 'Courier =
New';" class=3D"">&nbsp;&nbsp;&nbsp;&nbsp; MAX-ACCESS&nbsp;&nbsp;&nbsp; =
not-accessible<u class=3D""></u><u class=3D""></u></span></p><p =
class=3D"MsoNormal"><span style=3D"font-size: 8pt; font-family: 'Courier =
New';" class=3D"">&nbsp;&nbsp;&nbsp;&nbsp; =
STATUS&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; current<u =
class=3D""></u><u class=3D""></u></span></p><p class=3D"MsoNormal"><span =
style=3D"font-size: 8pt; font-family: 'Courier New';" =
class=3D"">&nbsp;&nbsp;&nbsp;&nbsp; DESCRIPTION<u class=3D""></u><u =
class=3D""></u></span></p><p class=3D"MsoNormal"><span style=3D"font-size:=
 8pt; font-family: 'Courier New';" =
class=3D"">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; "This =
table enables the reverse mapping of the unique<u class=3D""></u><u =
class=3D""></u></span></p><p class=3D"MsoNormal"><span style=3D"font-size:=
 8pt; font-family: 'Courier New';" =
class=3D"">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; =
PWid parameters [peer IP, PW type, and PW ID] and the<u class=3D""></u><u =
class=3D""></u></span></p><p class=3D"MsoNormal"><span style=3D"font-size:=
 8pt; font-family: 'Courier New';" =
class=3D"">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; =
pwIndex.&nbsp; The table is not applicable for PWs created<u =
class=3D""></u><u class=3D""></u></span></p><p class=3D"MsoNormal"><span =
style=3D"font-size: 8pt; font-family: 'Courier New';" =
class=3D"">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; =
manually or by using the generalized FEC."<u class=3D""></u><u =
class=3D""></u></span></p><p class=3D"MsoNormal"><span style=3D"font-size:=
 8pt; font-family: 'Courier New';" class=3D"">&nbsp;&nbsp;&nbsp;&nbsp; =
::=3D { pwObjects 7 }<u class=3D""></u><u class=3D""></u></span></p><p =
class=3D"MsoNormal"><span =
style=3D"font-size:10.0pt;font-family:&quot;Arial&quot;,sans-serif;color:b=
lue" class=3D""><u class=3D""></u>&nbsp;<u class=3D""></u></span></p><p =
class=3D"MsoNormal"><span =
style=3D"font-size:10.0pt;font-family:&quot;Arial&quot;,sans-serif;color:b=
lue" class=3D"">It seems to me that pwGenFecIndexMappingTable should =
have the peer IP address as a 4<sup class=3D"">th</sup> =E2=80=9Cunique =
PWid parameter=E2=80=9D.&nbsp; Otherwise, these parameters cannot =
uniquely
 identify a PW that belongs to an RFC4762-compliant VPLS.<u =
class=3D""></u><u class=3D""></u></span></p><p class=3D"MsoNormal"><span =
style=3D"font-size:10.0pt;font-family:&quot;Arial&quot;,sans-serif;color:b=
lue" class=3D""><u class=3D""></u>&nbsp;<u class=3D""></u></span></p><p =
class=3D"MsoNormal"><span =
style=3D"font-size:10.0pt;font-family:&quot;Arial&quot;,sans-serif;color:b=
lue" class=3D"">Please let me know what you think.&nbsp; My apologies if =
this has already been discussed before.<u class=3D""></u><u =
class=3D""></u></span></p><p class=3D"MsoNormal"><span =
style=3D"font-size:10.0pt;font-family:&quot;Arial&quot;,sans-serif;color:b=
lue" class=3D""><u class=3D""></u>&nbsp;<u class=3D""></u></span></p><p =
class=3D"MsoNormal"><span =
style=3D"font-size:10.0pt;font-family:&quot;Arial&quot;,sans-serif;color:b=
lue" class=3D"">Thanks,<u class=3D""></u><u class=3D""></u></span></p><p =
class=3D"MsoNormal"><span =
style=3D"font-size:10.0pt;font-family:&quot;Arial&quot;,sans-serif;color:b=
lue" class=3D""><u class=3D""></u>&nbsp;<u class=3D""></u></span></p><p =
class=3D"MsoNormal"><span =
style=3D"font-size:10.0pt;font-family:&quot;Arial&quot;,sans-serif;color:b=
lue" class=3D"">Mike Bartlett<br class=3D"">
</span><span style=3D"color:blue" class=3D""><a =
href=3D"mailto:mike.bartlett@metaswitch.com" target=3D"_blank" =
class=3D""><b class=3D""><span =
style=3D"font-size:10.0pt;font-family:&quot;Arial&quot;,sans-serif;color:b=
lue" class=3D"">mike.bartlett@metaswitch.com</span></b></a></span><span =
style=3D"font-size:10.0pt;font-family:&quot;Arial&quot;,sans-serif;color:b=
lue" class=3D""><u class=3D""></u><u class=3D""></u></span></p><p =
class=3D"MsoNormal"><u class=3D""></u>&nbsp;<u class=3D""></u></p>
</div>
</div>

<br class=3D"">______________________________<wbr =
class=3D"">_________________<br class=3D"">
Pals mailing list<br class=3D"">
<a href=3D"mailto:Pals@ietf.org" class=3D"">Pals@ietf.org</a><br =
class=3D"">
<a href=3D"https://www.ietf.org/mailman/listinfo/pals" rel=3D"noreferrer" =
target=3D"_blank" class=3D"">https://www.ietf.org/mailman/<wbr =
class=3D"">listinfo/pals</a><br class=3D"">
<br class=3D""></div><br class=3D""></div>
</div></blockquote></div><br class=3D""></div></div></body></html>=

--Apple-Mail=_061AAA05-EB2A-4359-9DF8-8C5021EA3FF3--


From nobody Tue Nov  8 11:24:56 2016
Return-Path: <wwwrun@rfc-editor.org>
X-Original-To: l2vpn@ietfa.amsl.com
Delivered-To: l2vpn@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id A847F1296C6; Tue,  8 Nov 2016 11:24:48 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -105.699
X-Spam-Level: 
X-Spam-Status: No, score=-105.699 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, RCVD_IN_DNSWL_MED=-2.3, RP_MATCHES_RCVD=-1.497, SPF_HELO_PASS=-0.001, SPF_PASS=-0.001, USER_IN_WHITELIST=-100] autolearn=ham autolearn_force=no
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id m9qN4KRbknDW; Tue,  8 Nov 2016 11:24:47 -0800 (PST)
Received: from rfc-editor.org (rfc-editor.org [4.31.198.49]) (using TLSv1.2 with cipher AECDH-AES256-SHA (256/256 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 7F3A51295A0; Tue,  8 Nov 2016 11:24:47 -0800 (PST)
Received: by rfc-editor.org (Postfix, from userid 30) id 69548B817D3; Tue,  8 Nov 2016 11:24:47 -0800 (PST)
To: prakash.ragunathan@yahoo.com, mlasserre@alcatel-lucent.com, vach.kompella@alcatel-lucent.com
Subject: [Errata Held for Document Update] RFC4762 (4834)
X-PHP-Originating-Script: 30:errata_mail_lib.php
From: RFC Errata System <rfc-editor@rfc-editor.org>
Message-Id: <20161108192447.69548B817D3@rfc-editor.org>
Date: Tue,  8 Nov 2016 11:24:47 -0800 (PST)
Archived-At: <https://mailarchive.ietf.org/arch/msg/l2vpn/Q1Z9H0jNVGJ52k3WKVv0pWFAyBo>
Cc: l2vpn@ietf.org, iesg@ietf.org, db3546@att.com, rfc-editor@rfc-editor.org
X-BeenThere: l2vpn@ietf.org
X-Mailman-Version: 2.1.17
Precedence: list
List-Id: Layer 2 Virtual Private Networks <l2vpn.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/l2vpn>, <mailto:l2vpn-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/l2vpn/>
List-Post: <mailto:l2vpn@ietf.org>
List-Help: <mailto:l2vpn-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/l2vpn>, <mailto:l2vpn-request@ietf.org?subject=subscribe>
X-List-Received-Date: Tue, 08 Nov 2016 19:24:49 -0000

The following errata report has been held for document update 
for RFC4762, "Virtual Private LAN Service (VPLS) Using Label Distribution Protocol (LDP) Signaling". 

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=4762&eid=4834

--------------------------------------
Status: Held for Document Update
Type: Editorial

Reported by: Prakash Ragunathan <prakash.ragunathan@yahoo.com>
Date Reported: 2016-10-18
Held by: Deborah Brungard (IESG)

Section: 9.1

Original Text
-------------
For
   example, if a customer site A, is shut down, eventually the other PEs
   should unlearn A's MAC address.

Corrected Text
--------------
For example, if a customer site is shut down, eventually the other PEs
should unlearn the MAC address(es) of this site.

Notes
-----
Prakash noted the customer site name is not mentioned in example. Suggested naming the site (A1) gives clear info than just stating "customer site A".
After discussion with the Chairs and Authors, the above text was agreed.

--------------------------------------
RFC4762 (draft-ietf-l2vpn-vpls-ldp-09)
--------------------------------------
Title               : Virtual Private LAN Service (VPLS) Using Label Distribution Protocol (LDP) Signaling
Publication Date    : January 2007
Author(s)           : M. Lasserre, Ed., V. Kompella, Ed.
Category            : PROPOSED STANDARD
Source              : Layer 2 Virtual Private Networks INT
Area                : Internet
Stream              : IETF
Verifying Party     : IESG

