
From nobody Mon Jun 22 14:11:14 2015
Return-Path: <marc.blanchet@viagenie.ca>
X-Original-To: lager@ietfa.amsl.com
Delivered-To: lager@ietfa.amsl.com
Received: from localhost (ietfa.amsl.com [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 3AE211A8754 for <lager@ietfa.amsl.com>; Mon, 22 Jun 2015 14:11:13 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -1.911
X-Spam-Level: 
X-Spam-Status: No, score=-1.911 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, SPF_PASS=-0.001, T_RP_MATCHES_RCVD=-0.01] autolearn=ham
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id oB2KWH9U7qGY for <lager@ietfa.amsl.com>; Mon, 22 Jun 2015 14:11:12 -0700 (PDT)
Received: from jazz.viagenie.ca (jazz.viagenie.ca [IPv6:2620:0:230:8000::2]) by ietfa.amsl.com (Postfix) with ESMTP id E2A3B1A1B49 for <lager@ietf.org>; Mon, 22 Jun 2015 14:11:08 -0700 (PDT)
Received: from [10.0.7.238] (unknown [190.104.232.123]) by jazz.viagenie.ca (Postfix) with ESMTPSA id 56AF340372 for <lager@ietf.org>; Mon, 22 Jun 2015 17:11:10 -0400 (EDT)
From: "Marc Blanchet" <marc.blanchet@viagenie.ca>
To: lager@ietf.org
Date: Mon, 22 Jun 2015 18:10:55 -0300
Message-ID: <2E2A13B4-27CF-4C36-899F-9E74AC3FCE30@viagenie.ca>
MIME-Version: 1.0
Content-Type: text/plain; format=flowed
X-Mailer: MailMate (1.9.1r5084)
Archived-At: <http://mailarchive.ietf.org/arch/msg/lager/tdGJ8aJO9hNRI0WEUVqC9LKtOGg>
Subject: [Lager] wg charter being proposed
X-BeenThere: lager@ietf.org
X-Mailman-Version: 2.1.15
Precedence: list
List-Id: Label Generation Rules <lager.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/lager>, <mailto:lager-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/lager/>
List-Post: <mailto:lager@ietf.org>
List-Help: <mailto:lager-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/lager>, <mailto:lager-request@ietf.org?subject=subscribe>
X-List-Received-Date: Mon, 22 Jun 2015 21:11:13 -0000

Hello,
  this is the first email of the mailing list to trigger the archives. 
instead of sending a test message, herein is the proposed charter of the 
proposed wg.

Please comment.

Marc.
========
http://datatracker.ietf.org/wg/lager/charter/

Charter for proposed Working Group
Domain registries, particularly those implementing IDNA (RFC 5890
et.al), usually maintain a set of criteria (or "ruleset") that governs
permissible labels allowed for registration, such as [IANAIDNTABLES].
These rulesets are commonly a mixture of eligible code points along
with contextual criteria that must be met concerning the positioning of
certain code points. Some registries also specify rules regarding
variant labels and how they are to be handled. Domain registries
commonly need to share these rules, but there is no interoperable format
that can be used that can support many common use cases. This group
seeks to produce such a format, which will enable re-use and simpler
implementation of rulesets in registries.

A comprehensive format specification has been developed, named Label
Generation Rules, primarily to support the rules to be used for the
DNS Root Zone [Davies]. This group will use this specification as a
starting point to develop a common XML language that provides a superset
of functionality of current specifications
[RFC 3743, RFC 4290, et.al], along with other known use cases. This
single format is expected to supersede existing formats, and form the
basis for future rulesets used at different levels of the DNS hierarchy.

Work items:
- Standard Track Specification of the Label Generation Rules

References:
[Davies] https://datatracker.ietf.org/doc/draft-davies-idntables/
[IANAIDNTABLES] https://www.iana.org/domains/idn-tables

Proposed milestones
Date	Milestone
Dec 2015	Send the Label Generation Rules specification to the IESG
draft-davies-idntables


From nobody Thu Jun 25 06:48:35 2015
Return-Path: <kim.davies@icann.org>
X-Original-To: lager@ietfa.amsl.com
Delivered-To: lager@ietfa.amsl.com
Received: from localhost (ietfa.amsl.com [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 67D761A88C5 for <lager@ietfa.amsl.com>; Thu, 25 Jun 2015 06:48:34 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -3.431
X-Spam-Level: 
X-Spam-Status: No, score=-3.431 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, RCVD_IN_DNSWL_MED=-2.3, SPF_NEUTRAL=0.779, T_RP_MATCHES_RCVD=-0.01] autolearn=ham
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id txvHUr4033Zd for <lager@ietfa.amsl.com>; Thu, 25 Jun 2015 06:48:33 -0700 (PDT)
Received: from out.west.pexch112.icann.org (pfe112-ca-2.pexch112.icann.org [64.78.40.10]) (using TLSv1 with cipher ECDHE-RSA-AES256-SHA (256/256 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 26FBC1A887E for <lager@ietf.org>; Thu, 25 Jun 2015 06:48:33 -0700 (PDT)
Received: from PMBX112-W1-CA-1.pexch112.icann.org (64.78.40.21) by PMBX112-W1-CA-1.pexch112.icann.org (64.78.40.21) with Microsoft SMTP Server (TLS) id 15.0.1044.25; Thu, 25 Jun 2015 06:48:31 -0700
Received: from PMBX112-W1-CA-1.pexch112.icann.org ([64.78.40.21]) by PMBX112-W1-CA-1.PEXCH112.ICANN.ORG ([64.78.40.21]) with mapi id 15.00.1044.021; Thu, 25 Jun 2015 06:48:31 -0700
From: Kim Davies <kim.davies@icann.org>
To: "lager@ietf.org" <lager@ietf.org>
Thread-Topic: New Version Notification for draft-davies-idntables-10.txt
Thread-Index: AQHQrqAeP9pRekQAiUeWvlMrZev57Q==
Date: Thu, 25 Jun 2015 13:48:30 +0000
Message-ID: <48109185-0CBD-4E0A-9CF1-5EA8FE3BC050@icann.org>
References: <20150624170604.6251.20105.idtracker@ietfa.amsl.com>
Accept-Language: en-AU, en-US
Content-Language: en-US
X-MS-Has-Attach: 
X-MS-TNEF-Correlator: 
x-ms-exchange-transport-fromentityheader: Hosted
x-originating-ip: [192.0.32.234]
Content-Type: text/plain; charset="us-ascii"
Content-ID: <155BC085ACA22C4FADD5F7D17D72E9AE@pexch112.icann.org>
Content-Transfer-Encoding: quoted-printable
MIME-Version: 1.0
Archived-At: <http://mailarchive.ietf.org/arch/msg/lager/rkOz7cE-IGS11oZwYWlxn5d2isE>
Subject: [Lager] Fwd: New Version Notification for draft-davies-idntables-10.txt
X-BeenThere: lager@ietf.org
X-Mailman-Version: 2.1.15
Precedence: list
List-Id: Label Generation Rules <lager.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/lager>, <mailto:lager-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/lager/>
List-Post: <mailto:lager@ietf.org>
List-Help: <mailto:lager-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/lager>, <mailto:lager-request@ietf.org?subject=subscribe>
X-List-Received-Date: Thu, 25 Jun 2015 13:48:34 -0000

The latest revision of the draft LGR specification has been posted.

kim

> A new version of I-D, draft-davies-idntables-10.txt
> has been successfully submitted by Kim Davies and posted to the
> IETF repository.
>=20
> Name:		draft-davies-idntables
> Revision:	10
> Title:		Representing Label Generation Rulesets using XML
> Document date:	2015-06-24
> Group:		Individual Submission
> Pages:		66
> URL:            https://www.ietf.org/internet-drafts/draft-davies-idntabl=
es-10.txt
> Status:         https://datatracker.ietf.org/doc/draft-davies-idntables/
> Htmlized:       https://tools.ietf.org/html/draft-davies-idntables-10
> Diff:           https://www.ietf.org/rfcdiff?url2=3Ddraft-davies-idntable=
s-10
>=20
> Abstract:
>   This document describes a method of representing rules for validating
>   identifier labels and alternate representations of those labels using
>   Extensible Markup Language (XML).  These policies, known as "Label
>   Generation Rulesets" (LGRs), are used for the implementation of
>   Internationalized Domain Names (IDNs), for example.  The rulesets are
>   used to implement and share that aspect of policy defining which
>   labels and specific Unicode code points are permitted for
>   registrations, which alternative code points are considered variants,
>   and what actions may be performed on labels containing those
>   variants.
>=20
>=20
>=20
>=20
> Please note that it may take a couple of minutes from the time of submiss=
ion
> until the htmlized version and diff are available at tools.ietf.org.
>=20
> The IETF Secretariat
>=20

