
From michael@stroeder.com  Wed Aug  7 11:57:10 2013
Return-Path: <michael@stroeder.com>
X-Original-To: ldapext@ietfa.amsl.com
Delivered-To: ldapext@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 17A3121F9D9A for <ldapext@ietfa.amsl.com>; Wed,  7 Aug 2013 11:57:10 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -3.299
X-Spam-Level: 
X-Spam-Status: No, score=-3.299 tagged_above=-999 required=5 tests=[BAYES_00=-2.599, MIME_8BIT_HEADER=0.3, RCVD_IN_DNSWL_LOW=-1]
Received: from mail.ietf.org ([12.22.58.30]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id 6pB4GhYGcPqI for <ldapext@ietfa.amsl.com>; Wed,  7 Aug 2013 11:57:05 -0700 (PDT)
Received: from srv1.stroeder.com (srv1.stroeder.com [213.240.180.113]) by ietfa.amsl.com (Postfix) with ESMTP id 67F8F21F9E94 for <ldapext@ietf.org>; Wed,  7 Aug 2013 11:57:05 -0700 (PDT)
Received: from localhost (localhost [127.0.0.1]) by srv1.stroeder.com (Postfix) with ESMTP id 3A83360212 for <ldapext@ietf.org>; Wed,  7 Aug 2013 20:57:03 +0200 (CEST)
X-Virus-Scanned: amavisd-new at stroeder.com
Received: from srv1.stroeder.com ([127.0.0.1]) by localhost (srv1.stroeder.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id 6O-pyYLreQP4 for <ldapext@ietf.org>; Wed,  7 Aug 2013 20:56:50 +0200 (CEST)
Received: from nb2.stroeder.local (unknown [10.1.0.2]) (using TLSv1 with cipher ECDHE-RSA-AES256-SHA (256/256 bits)) (No client certificate requested) by srv1.stroeder.com (Postfix) with ESMTPS id 093C56018C for <ldapext@ietf.org>; Wed,  7 Aug 2013 18:56:50 +0000 (UTC)
Message-ID: <52029871.7030602@stroeder.com>
Date: Wed, 07 Aug 2013 20:56:49 +0200
From: =?UTF-8?B?TWljaGFlbCBTdHLDtmRlcg==?= <michael@stroeder.com>
User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:22.0) Gecko/20100101 Firefox/22.0 SeaMonkey/2.19
MIME-Version: 1.0
To: ldapext <ldapext@ietf.org>
References: <20130807185454.15858.35975.idtracker@ietfa.amsl.com>
In-Reply-To: <20130807185454.15858.35975.idtracker@ietfa.amsl.com>
X-Enigmail-Version: 1.5.2
X-Forwarded-Message-Id: <20130807185454.15858.35975.idtracker@ietfa.amsl.com>
Content-Type: multipart/signed; protocol="application/pkcs7-signature"; micalg=sha1; boundary="------------ms020901030608070900090005"
Subject: [ldapext] draft-stroeder-mailboxrelatedobject-03.txt
X-BeenThere: ldapext@ietf.org
X-Mailman-Version: 2.1.12
Precedence: list
List-Id: LDAP Extension Working Group <ldapext.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/ldapext>, <mailto:ldapext-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/ldapext>
List-Post: <mailto:ldapext@ietf.org>
List-Help: <mailto:ldapext-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/ldapext>, <mailto:ldapext-request@ietf.org?subject=subscribe>
X-List-Received-Date: Wed, 07 Aug 2013 18:57:10 -0000

This is a cryptographically signed message in MIME format.

--------------ms020901030608070900090005
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

HI!

Please review this draft intended to be published as informational RFC.
Thanks in advance.

Ciao, Michael.

-------- Original Message --------
Subject: ***UNCHECKED*** New Version Notification for
draft-stroeder-mailboxrelatedobject-03.txt
Date: Wed, 07 Aug 2013 11:54:54 -0700
From: internet-drafts@ietf.org
To: Michael Stroeder <michael@stroeder.com>


A new version of I-D, draft-stroeder-mailboxrelatedobject-03.txt
has been successfully submitted by Michael Stroeder and posted to the
IETF repository.

Filename:	 draft-stroeder-mailboxrelatedobject
Revision:	 03
Title:		 Lightweight Directory Access Protocol (LDAP): Auxiliary Object C=
lass
'mailboxRelatedObject'
Creation date:	 2013-08-07
Group:		 Individual Submission
Number of pages: 4
URL:
http://www.ietf.org/internet-drafts/draft-stroeder-mailboxrelatedobject-0=
3.txt
Status:
http://datatracker.ietf.org/doc/draft-stroeder-mailboxrelatedobject
Htmlized:        http://tools.ietf.org/html/draft-stroeder-mailboxrelated=
object-03
Diff:
http://www.ietf.org/rfcdiff?url2=3Ddraft-stroeder-mailboxrelatedobject-03=


Abstract:
   This document defines the auxiliary object class
   'mailboxRelatedObject' that can be used to associate an arbitrary
   object with a RFC 2822 mail address.  Furthermore a attribute
   'intlMailAdr' is defined for internationalized email addresses.




Please note that it may take a couple of minutes from the time of submiss=
ion
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat





--------------ms020901030608070900090005
Content-Type: application/pkcs7-signature; name="smime.p7s"
Content-Transfer-Encoding: base64
Content-Disposition: attachment; filename="smime.p7s"
Content-Description: S/MIME Cryptographic Signature
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--------------ms020901030608070900090005--

From medievalist@gmail.com  Wed Aug  7 12:20:05 2013
Return-Path: <medievalist@gmail.com>
X-Original-To: ldapext@ietfa.amsl.com
Delivered-To: ldapext@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 3607D11E80EC for <ldapext@ietfa.amsl.com>; Wed,  7 Aug 2013 12:20:05 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -2.3
X-Spam-Level: 
X-Spam-Status: No, score=-2.3 tagged_above=-999 required=5 tests=[BAYES_00=-2.599, MIME_8BIT_HEADER=0.3, NO_RELAYS=-0.001]
Received: from mail.ietf.org ([12.22.58.30]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id c1N1ult8gXP5 for <ldapext@ietfa.amsl.com>; Wed,  7 Aug 2013 12:20:04 -0700 (PDT)
Received: from mail-lb0-x22a.google.com (mail-lb0-x22a.google.com [IPv6:2a00:1450:4010:c04::22a]) by ietfa.amsl.com (Postfix) with ESMTP id 3A68211E80E9 for <ldapext@ietf.org>; Wed,  7 Aug 2013 12:20:03 -0700 (PDT)
Received: by mail-lb0-f170.google.com with SMTP id r10so1796962lbi.29 for <ldapext@ietf.org>; Wed, 07 Aug 2013 12:20:03 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20120113; h=mime-version:in-reply-to:references:date:message-id:subject:from:to :cc:content-type:content-transfer-encoding; bh=Ure/O1MWpCSN+ivd+tKVQEh/V8FI2Jz2b/Gjq9Az4g4=; b=OZsaefEoSTcxOnPxpCPygN1P5PqdSWAbQmiCWy3rAT9hBkvGl/Wgqw88/cIkklJM8l z1A0wlNTIG5e0mRz4sJrDXwNYUtjHWGOMyWJjFIzjBZqzQ08W/PXfclsbGZpbpe3MGgF ELTFCgRt1HejcsU4XNIiMA4gXyAJOoOeccOPRnsgwIhH/Mi2xQlWWsx8SqS7aVoQg1t2 apz/nxwr8lIFYJ/9nXEQKuOSqbVAI2VDpnN91K8fuKNbec9pb1/Yz0yOgN56UUnNAi1Z ZAYDnyJfHIkI+0n0KSwItX6Mif2e/XwlMhhEdpt4GdogFr8Rp09OzPUAIujpz48GWqnS Ns/g==
MIME-Version: 1.0
X-Received: by 10.112.57.49 with SMTP id f17mr883332lbq.26.1375903203021; Wed, 07 Aug 2013 12:20:03 -0700 (PDT)
Received: by 10.112.58.170 with HTTP; Wed, 7 Aug 2013 12:20:02 -0700 (PDT)
In-Reply-To: <52029871.7030602@stroeder.com>
References: <20130807185454.15858.35975.idtracker@ietfa.amsl.com> <52029871.7030602@stroeder.com>
Date: Wed, 7 Aug 2013 15:20:02 -0400
Message-ID: <CAJb3uA7oGBo=Tfi-7CLQ20NcdapuSLMuMKUcyOCpEKNCXMjVQQ@mail.gmail.com>
From: Charlie <medievalist@gmail.com>
To: =?ISO-8859-1?Q?Michael_Str=F6der?= <michael@stroeder.com>
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable
Cc: ldapext <ldapext@ietf.org>
Subject: Re: [ldapext] draft-stroeder-mailboxrelatedobject-03.txt
X-BeenThere: ldapext@ietf.org
X-Mailman-Version: 2.1.12
Precedence: list
List-Id: LDAP Extension Working Group <ldapext.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/ldapext>, <mailto:ldapext-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/ldapext>
List-Post: <mailto:ldapext@ietf.org>
List-Help: <mailto:ldapext-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/ldapext>, <mailto:ldapext-request@ietf.org?subject=subscribe>
X-List-Received-Date: Wed, 07 Aug 2013 19:20:05 -0000

Much needed.  Thank you for tilting at this windmill.

--Charlie

On Wed, Aug 7, 2013 at 2:56 PM, Michael Str=F6der <michael@stroeder.com> wr=
ote:
> HI!
>
> Please review this draft intended to be published as informational RFC.
> Thanks in advance.
>
> Ciao, Michael.
>
> -------- Original Message --------
> Subject: ***UNCHECKED*** New Version Notification for
> draft-stroeder-mailboxrelatedobject-03.txt
> Date: Wed, 07 Aug 2013 11:54:54 -0700
> From: internet-drafts@ietf.org
> To: Michael Stroeder <michael@stroeder.com>
>
>
> A new version of I-D, draft-stroeder-mailboxrelatedobject-03.txt
> has been successfully submitted by Michael Stroeder and posted to the
> IETF repository.
>
> Filename:        draft-stroeder-mailboxrelatedobject
> Revision:        03
> Title:           Lightweight Directory Access Protocol (LDAP): Auxiliary =
Object Class
> 'mailboxRelatedObject'
> Creation date:   2013-08-07
> Group:           Individual Submission
> Number of pages: 4
> URL:
> http://www.ietf.org/internet-drafts/draft-stroeder-mailboxrelatedobject-0=
3.txt
> Status:
> http://datatracker.ietf.org/doc/draft-stroeder-mailboxrelatedobject
> Htmlized:        http://tools.ietf.org/html/draft-stroeder-mailboxrelated=
object-03
> Diff:
> http://www.ietf.org/rfcdiff?url2=3Ddraft-stroeder-mailboxrelatedobject-03
>
> Abstract:
>    This document defines the auxiliary object class
>    'mailboxRelatedObject' that can be used to associate an arbitrary
>    object with a RFC 2822 mail address.  Furthermore a attribute
>    'intlMailAdr' is defined for internationalized email addresses.
>
>
>
>
> Please note that it may take a couple of minutes from the time of submiss=
ion
> until the htmlized version and diff are available at tools.ietf.org.
>
> The IETF Secretariat
>
>
>
>
>
> _______________________________________________
> Ldapext mailing list
> Ldapext@ietf.org
> https://www.ietf.org/mailman/listinfo/ldapext
>

From michael@stroeder.com  Thu Aug  8 00:24:48 2013
Return-Path: <michael@stroeder.com>
X-Original-To: ldapext@ietfa.amsl.com
Delivered-To: ldapext@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id CE5EF21F9FFB for <ldapext@ietfa.amsl.com>; Thu,  8 Aug 2013 00:24:48 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -3.299
X-Spam-Level: 
X-Spam-Status: No, score=-3.299 tagged_above=-999 required=5 tests=[BAYES_00=-2.599, MIME_8BIT_HEADER=0.3, RCVD_IN_DNSWL_LOW=-1]
Received: from mail.ietf.org ([12.22.58.30]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id W0f3AIeRt6W9 for <ldapext@ietfa.amsl.com>; Thu,  8 Aug 2013 00:24:44 -0700 (PDT)
Received: from srv1.stroeder.com (srv1.stroeder.com [213.240.180.113]) by ietfa.amsl.com (Postfix) with ESMTP id 3ADFC21F9097 for <ldapext@ietf.org>; Thu,  8 Aug 2013 00:24:44 -0700 (PDT)
Received: from localhost (localhost [127.0.0.1]) by srv1.stroeder.com (Postfix) with ESMTP id D31C660294 for <ldapext@ietf.org>; Thu,  8 Aug 2013 09:24:41 +0200 (CEST)
X-Virus-Scanned: amavisd-new at stroeder.com
Received: from srv1.stroeder.com ([127.0.0.1]) by localhost (srv1.stroeder.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id GwlfeHHpWa_m for <ldapext@ietf.org>; Thu,  8 Aug 2013 09:24:32 +0200 (CEST)
Received: from nb2.stroeder.local (unknown [10.1.0.2]) (using TLSv1 with cipher ECDHE-RSA-AES256-SHA (256/256 bits)) (No client certificate requested) by srv1.stroeder.com (Postfix) with ESMTPS id 01EBB6018C for <ldapext@ietf.org>; Thu,  8 Aug 2013 07:24:31 +0000 (UTC)
Message-ID: <520347AE.2080309@stroeder.com>
Date: Thu, 08 Aug 2013 09:24:30 +0200
From: =?UTF-8?B?TWljaGFlbCBTdHLDtmRlcg==?= <michael@stroeder.com>
User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:22.0) Gecko/20100101 Firefox/22.0 SeaMonkey/2.19
MIME-Version: 1.0
To: ldapext <ldapext@ietf.org>
References: <20130808072029.30689.91871.idtracker@ietfa.amsl.com>
In-Reply-To: <20130808072029.30689.91871.idtracker@ietfa.amsl.com>
X-Enigmail-Version: 1.5.2
X-Forwarded-Message-Id: <20130808072029.30689.91871.idtracker@ietfa.amsl.com>
Content-Type: multipart/signed; protocol="application/pkcs7-signature"; micalg=sha1; boundary="------------ms000600050000030807040900"
Subject: [ldapext] Fwd: New Version Notification for draft-stroeder-mailboxrelatedobject-04.txt
X-BeenThere: ldapext@ietf.org
X-Mailman-Version: 2.1.12
Precedence: list
List-Id: LDAP Extension Working Group <ldapext.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/ldapext>, <mailto:ldapext-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/ldapext>
List-Post: <mailto:ldapext@ietf.org>
List-Help: <mailto:ldapext-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/ldapext>, <mailto:ldapext-request@ietf.org?subject=subscribe>
X-List-Received-Date: Thu, 08 Aug 2013 07:24:49 -0000

This is a cryptographically signed message in MIME format.

--------------ms000600050000030807040900
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

HI!

Some modifications based on comments I received off-list.

Please review this draft intended to be published as informational RFC.
Thanks in advance.

Ouch! There's a typo in DESC of object class definition. Will change this=
 to
RFC 2821 in next version.

Ciao, Michael.

-------- Original Message --------
Subject: New Version Notification for draft-stroeder-mailboxrelatedobject=
-04.txt
Date: Thu, 08 Aug 2013 00:20:29 -0700
From: internet-drafts@ietf.org
To: Michael Stroeder <michael@stroeder.com>


A new version of I-D, draft-stroeder-mailboxrelatedobject-04.txt
has been successfully submitted by Michael Stroeder and posted to the
IETF repository.

Filename:	 draft-stroeder-mailboxrelatedobject
Revision:	 04
Title:		 Lightweight Directory Access Protocol (LDAP): Auxiliary Object C=
lass
'mailboxRelatedObject'
Creation date:	 2013-08-08
Group:		 Individual Submission
Number of pages: 5
URL:
http://www.ietf.org/internet-drafts/draft-stroeder-mailboxrelatedobject-0=
4.txt
Status:
http://datatracker.ietf.org/doc/draft-stroeder-mailboxrelatedobject
Htmlized:        http://tools.ietf.org/html/draft-stroeder-mailboxrelated=
object-04
Diff:
http://www.ietf.org/rfcdiff?url2=3Ddraft-stroeder-mailboxrelatedobject-04=


Abstract:
   This document defines the auxiliary object class
   'mailboxRelatedObject' that can be used to associate an arbitrary
   object with an Internet mail address.  Furthermore an attribute
   'intlMailAdr' is defined for storing fully internationalized Internet
   mail addresses.




Please note that it may take a couple of minutes from the time of submiss=
ion
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat





--------------ms000600050000030807040900
Content-Type: application/pkcs7-signature; name="smime.p7s"
Content-Transfer-Encoding: base64
Content-Disposition: attachment; filename="smime.p7s"
Content-Description: S/MIME Cryptographic Signature

MIAGCSqGSIb3DQEHAqCAMIACAQExCzAJBgUrDgMCGgUAMIAGCSqGSIb3DQEHAQAAoIIFfzCC
BXswggNjoAMCAQICAwxOfTANBgkqhkiG9w0BAQUFADB5MRAwDgYDVQQKEwdSb290IENBMR4w
HAYDVQQLExVodHRwOi8vd3d3LmNhY2VydC5vcmcxIjAgBgNVBAMTGUNBIENlcnQgU2lnbmlu
ZyBBdXRob3JpdHkxITAfBgkqhkiG9w0BCQEWEnN1cHBvcnRAY2FjZXJ0Lm9yZzAeFw0xMjEw
MDIyMDE3MDlaFw0xNDEwMDIyMDE3MDlaMD8xGDAWBgNVBAMUD01pY2hhZWwgU3Ry9mRlcjEj
MCEGCSqGSIb3DQEJARYUbWljaGFlbEBzdHJvZWRlci5jb20wggEiMA0GCSqGSIb3DQEBAQUA
A4IBDwAwggEKAoIBAQDo2SKth5GhtaDrCyfGtyUG+/hAAa/J52L0NFN4SSRvTtdGf9HfWwwd
NCtgae0TVGWk2lKDbXA9d5vmyIiRhuwxd90H6FLErhRBeB9G67qtw87E8WUoXt2DwPQEUTWV
hqHpPadlmgFw3+i3TGQQTe3O3W9MMMd4GJNhObem2VGRuCD37OXnzBksTcq0FPJgcWAhe3d/
0ItOkNWBqgq8Mf3p7WFBhaQ0a27BC/mKtH8fI3kPcS305imPRja69Msq3EwUZBc9ToVp6FRQ
NYKjfOBybDUzVkmRZl3H8xutQP2w8Zxb8m5f7Q1BfLLrIFScfYvIDgOERxTCd4lab8+/09XH
AgMBAAGjggFEMIIBQDAMBgNVHRMBAf8EAjAAMFYGCWCGSAGG+EIBDQRJFkdUbyBnZXQgeW91
ciBvd24gY2VydGlmaWNhdGUgZm9yIEZSRUUgaGVhZCBvdmVyIHRvIGh0dHA6Ly93d3cuQ0Fj
ZXJ0Lm9yZzAOBgNVHQ8BAf8EBAMCA6gwQAYDVR0lBDkwNwYIKwYBBQUHAwQGCCsGAQUFBwMC
BgorBgEEAYI3CgMEBgorBgEEAYI3CgMDBglghkgBhvhCBAEwMgYIKwYBBQUHAQEEJjAkMCIG
CCsGAQUFBzABhhZodHRwOi8vb2NzcC5jYWNlcnQub3JnMDEGA1UdHwQqMCgwJqAkoCKGIGh0
dHA6Ly9jcmwuY2FjZXJ0Lm9yZy9yZXZva2UuY3JsMB8GA1UdEQQYMBaBFG1pY2hhZWxAc3Ry
b2VkZXIuY29tMA0GCSqGSIb3DQEBBQUAA4ICAQC9ouXq3p/bDWMM4tBKgD3tl4HY5H0eECl8
q9/nqk0UL6YeWkrCiQdrDtNPW7DcGqNYtzdgtzmyTr1GhiAX+igrOjdk/ge5NRcQOpONK/4b
zrmpQEcIUyxSSDKLWh211/kcFfxxLEiJ5teF4GL8Fc1qbrLP4+DCvJXWfYaaR5NLjZMqm2VP
yKTv3qpXWnGohiRkGTwS/11QM2XCfIGdRsQT9a8mO4m2fn2tGPp2TEIoCLrDDrbGVeDWaOWB
OIeTrp4wa3Q4OI6yCptJhEqKvjhV96IBRYgM76nTBqsqnDzwxExAyhhWiUS5DunRHOr/+NyF
pUpD4883RBLO0g9kUEGOhtZNF1u+8zEL0YgMGvifAom9JEklLOXZuqj0MThypKs/3d/OyOQb
4gURnu6oZwcKZ7LskytWnlRKUxF6o0A8grtmyKkqe14TS7cQbg0NTaIYXPkHR+dfFmb3uEqn
BBjvpJXFcEtWI2lQXC/ET+au991pK797ExBOmpQwjIn3SjiW80vw/UoL6DMvqY/6JhVhyNTP
MJ2W5AX5kc27DIbVtVGZs8J4AYhuNALJUq9N9Ka7rPRj3RcYDrfehDLOkM5iMnarpmtuOpLK
d1SvZhqj/0N/JWGIDpPSTkTFOPP6ZN9I9Rqyf+9NGqb2sjo4DkIiZcHxt735/GJLwus5KLBl
2DGCA6EwggOdAgEBMIGAMHkxEDAOBgNVBAoTB1Jvb3QgQ0ExHjAcBgNVBAsTFWh0dHA6Ly93
d3cuY2FjZXJ0Lm9yZzEiMCAGA1UEAxMZQ0EgQ2VydCBTaWduaW5nIEF1dGhvcml0eTEhMB8G
CSqGSIb3DQEJARYSc3VwcG9ydEBjYWNlcnQub3JnAgMMTn0wCQYFKw4DAhoFAKCCAfUwGAYJ
KoZIhvcNAQkDMQsGCSqGSIb3DQEHATAcBgkqhkiG9w0BCQUxDxcNMTMwODA4MDcyNDMwWjAj
BgkqhkiG9w0BCQQxFgQUJyOsAnbxG9UD04ozUwKjaz7fFyAwbAYJKoZIhvcNAQkPMV8wXTAL
BglghkgBZQMEASowCwYJYIZIAWUDBAECMAoGCCqGSIb3DQMHMA4GCCqGSIb3DQMCAgIAgDAN
BggqhkiG9w0DAgIBQDAHBgUrDgMCBzANBggqhkiG9w0DAgIBKDCBkQYJKwYBBAGCNxAEMYGD
MIGAMHkxEDAOBgNVBAoTB1Jvb3QgQ0ExHjAcBgNVBAsTFWh0dHA6Ly93d3cuY2FjZXJ0Lm9y
ZzEiMCAGA1UEAxMZQ0EgQ2VydCBTaWduaW5nIEF1dGhvcml0eTEhMB8GCSqGSIb3DQEJARYS
c3VwcG9ydEBjYWNlcnQub3JnAgMMTn0wgZMGCyqGSIb3DQEJEAILMYGDoIGAMHkxEDAOBgNV
BAoTB1Jvb3QgQ0ExHjAcBgNVBAsTFWh0dHA6Ly93d3cuY2FjZXJ0Lm9yZzEiMCAGA1UEAxMZ
Q0EgQ2VydCBTaWduaW5nIEF1dGhvcml0eTEhMB8GCSqGSIb3DQEJARYSc3VwcG9ydEBjYWNl
cnQub3JnAgMMTn0wDQYJKoZIhvcNAQEBBQAEggEAp81p7IKFSbN78UroM3rCWkZ963eF1Nnj
yS62W6D/NVZJYG6JLYtyZHXmu+k16quow64c2IKaObym0bNn0Ej8Oqp4mAsxZChCFtpewDCm
slAO501RqKLnbE5VdPYXCMpz22RUHMy62sT1TnGYeqfTTfbGw+uHebdP2nja3LknZdVdDQ0E
qjAEO0I+il2/JF9L/qe3FGqKHsh0JeVxHgmiRNcauF6mjAqq4+f6pYegvoM0wR0JNF2CXzA3
bzFp3GQvRAmSTn+unnEcvKmf4fU3otfauJCznQreVCoHONqm3ssCXVsl5tPeg46feRIk6rM/
OdberPplL5yjKSOTtvWWMAAAAAAAAA==
--------------ms000600050000030807040900--

From alexey.melnikov@isode.com  Thu Aug  8 09:39:11 2013
Return-Path: <alexey.melnikov@isode.com>
X-Original-To: ldapext@ietfa.amsl.com
Delivered-To: ldapext@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 7144C11E81E9 for <ldapext@ietfa.amsl.com>; Thu,  8 Aug 2013 09:39:09 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -101.202
X-Spam-Level: 
X-Spam-Status: No, score=-101.202 tagged_above=-999 required=5 tests=[AWL=-0.299, BAYES_00=-2.599, MIME_8BIT_HEADER=0.3, MIME_QP_LONG_LINE=1.396, USER_IN_WHITELIST=-100]
Received: from mail.ietf.org ([12.22.58.30]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id 8O6npDSXK5jd for <ldapext@ietfa.amsl.com>; Thu,  8 Aug 2013 09:39:04 -0700 (PDT)
Received: from statler.isode.com (statler.isode.com [62.3.217.254]) by ietfa.amsl.com (Postfix) with ESMTP id 4A2BB11E81D0 for <ldapext@ietf.org>; Thu,  8 Aug 2013 09:39:03 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; t=1375979942; d=isode.com; s=selector; i=@isode.com; bh=OnvZLubrZy2vlvDIbNL6afUN5Uom+G5GObZ0+fDlZS8=; h=From:Sender:Reply-To:Subject:Date:Message-ID:To:Cc:MIME-Version: In-Reply-To:References:Content-Type:Content-Transfer-Encoding: Content-ID:Content-Description; b=uoLqwmPnyStDzN5JJh0zIM6N9CxLShJusXicdoHgBXTF5jv8/lKZcIp6ltYCbqlNbRmd+R zbByApCvOtWaZ3zNNf0m4wFNCX5fOFerK7DxEkyDICibRGZ88vQV7aNJJK799KIqpNBpu0 RimCC8U758sQ9QGBr8vbOZR/aQIAW9A=;
Received: from [172.17.128.46] (richard.isode.com [62.3.217.249])  by statler.isode.com (submission channel) via TCP with ESMTPA  id <UgPJowB9nsO4@statler.isode.com>; Thu, 8 Aug 2013 17:39:02 +0100
Message-ID: <5203C9AA.20805@isode.com>
Date: Thu, 08 Aug 2013 17:39:06 +0100
From: Alexey Melnikov <alexey.melnikov@isode.com>
User-Agent: Mozilla/5.0 (Windows NT 6.1; rv:17.0) Gecko/20130620 Thunderbird/17.0.7
To: =?ISO-8859-1?Q?Michael_Str=F6der?= <michael@stroeder.com>
References: <20130808072029.30689.91871.idtracker@ietfa.amsl.com> <520347AE.2080309@stroeder.com>
In-Reply-To: <520347AE.2080309@stroeder.com>
MIME-Version: 1.0
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-transfer-encoding: quoted-printable
Cc: ldapext <ldapext@ietf.org>
Subject: Re: [ldapext] Fwd: New Version Notification for draft-stroeder-mailboxrelatedobject-04.txt
X-BeenThere: ldapext@ietf.org
X-Mailman-Version: 2.1.12
Precedence: list
List-Id: LDAP Extension Working Group <ldapext.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/ldapext>, <mailto:ldapext-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/ldapext>
List-Post: <mailto:ldapext@ietf.org>
List-Help: <mailto:ldapext-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/ldapext>, <mailto:ldapext-request@ietf.org?subject=subscribe>
X-List-Received-Date: Thu, 08 Aug 2013 16:39:11 -0000

On 08/08/2013 08:24, Michael Str=F6der wrote:
> HI!
>
> Some modifications based on comments I received off-list.
>
> Please review this draft intended to be published as informational RFC.
> Thanks in advance.
>
> Ouch! There's a typo in DESC of object class definition. Will change this =
to
> RFC 2821 in next version.
Hi Michael,
I reviewed the document and it mostly looks quite sensible.

Some comments below:

2.  Attribute Type Definition

    The attribute type 'intlMailAdr' is defined for storing SMTPUTF8
    compliant addresses [RFC6530].

     ( 1.3.6.1.4.1.5427.1.389.4.18
       NAME 'intlMailAdr'
       DESC 'Internationalized Email Address'
       EQUALITY caseIgnoreMatch

You describe problems with case-insensitive matching later in this=20
section. Why not just use caseExactMatch? Strictly speaking left hand=20
sides of email addresses are not ASCII case-insensitive.

       SUBSTR caseIgnoreSubstringsMatch
       SYNTAX 1.3.6.1.4.1.1466.115.121.1.15 )


    Note that the directory will not ensure that values of this attribute
    conform to the <Mailbox> production [RFC2821].

RFC 2821 --> RFC 5321.


3.  Object Class Definition

    Entries of auxiliary object class 'mailboxRelatedObject' MAY contain
    the following optional attributes: 'mail' [RFC4524] 'displayName'
    [RFC2798] 'intlMailAdr'

     ( 1.3.6.1.4.1.5427.1.389.6.9
       NAME 'mailboxRelatedObject'
       DESC 'Associated RFC 2822 mailbox for any entry'

Please use RFC 5322 here, which obsoleted RFC 2822. This also needs to=20
be added to the Normative References. Unless you meant RFC 5321 here.

       AUXILIARY
       MAY ( displayName $ mail $ intlMailAdr ) )

Best Regards,
Alexey


From medievalist@gmail.com  Thu Aug  8 11:10:56 2013
Return-Path: <medievalist@gmail.com>
X-Original-To: ldapext@ietfa.amsl.com
Delivered-To: ldapext@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 2CDE411E81F9 for <ldapext@ietfa.amsl.com>; Thu,  8 Aug 2013 11:10:56 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -2.45
X-Spam-Level: 
X-Spam-Status: No, score=-2.45 tagged_above=-999 required=5 tests=[AWL=0.150,  BAYES_00=-2.599, NO_RELAYS=-0.001]
Received: from mail.ietf.org ([12.22.58.30]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id ojCuxnqyAVq4 for <ldapext@ietfa.amsl.com>; Thu,  8 Aug 2013 11:10:55 -0700 (PDT)
Received: from mail-la0-x236.google.com (mail-la0-x236.google.com [IPv6:2a00:1450:4010:c03::236]) by ietfa.amsl.com (Postfix) with ESMTP id A033F11E81DE for <ldapext@ietf.org>; Thu,  8 Aug 2013 11:10:54 -0700 (PDT)
Received: by mail-la0-f54.google.com with SMTP id ea20so2384731lab.27 for <ldapext@ietf.org>; Thu, 08 Aug 2013 11:10:53 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20120113; h=mime-version:in-reply-to:references:date:message-id:subject:from:to :cc:content-type:content-transfer-encoding; bh=cpJND8ryGM5RNTUcAofy4Mn5ejBtQcSdgBOteOwXqk8=; b=Qv4BeXE5szIjt3rW7L1YHPpKMt8oIE4+5B9fYhJoyRO68gnCcse1p7dWBo4i/+EZeS JUx/d4pXKyBiCS9mPgGTa1TflSQtNLlKVchaEPzn3aAXkGot46y1xdocqhsZKz+jNF/R dyqBTTLk25b11BqNdvVHarezzWqBgv1zxgk3oB1iO1EmdQzdnkZlvI8CVJ9V6TdgkBGO BNDVuZRzldNugdgAdVq7wZ6eM72GUJt9CbKKSfGGUDIfwhvbHcg6U8noxedp1Pd2KUep 1ahppAZWXguR3BhGt1rMDSuDxjdy90hRKzynK7XWBXi4ImFIJZcjAsYN6X1dOF9F4MDN Qh9Q==
MIME-Version: 1.0
X-Received: by 10.112.55.140 with SMTP id s12mr2918241lbp.42.1375985453317; Thu, 08 Aug 2013 11:10:53 -0700 (PDT)
Received: by 10.112.58.170 with HTTP; Thu, 8 Aug 2013 11:10:53 -0700 (PDT)
In-Reply-To: <5203C9AA.20805@isode.com>
References: <20130808072029.30689.91871.idtracker@ietfa.amsl.com> <520347AE.2080309@stroeder.com> <5203C9AA.20805@isode.com>
Date: Thu, 8 Aug 2013 14:10:53 -0400
Message-ID: <CAJb3uA6U8X7ev-gmKno_tDrhsFse-aywLjZY=FJU7ME72+DPjg@mail.gmail.com>
From: Charlie <medievalist@gmail.com>
To: Alexey Melnikov <alexey.melnikov@isode.com>
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable
Cc: ldapext <ldapext@ietf.org>, =?ISO-8859-1?Q?Michael_Str=F6der?= <michael@stroeder.com>
Subject: Re: [ldapext] Fwd: New Version Notification for draft-stroeder-mailboxrelatedobject-04.txt
X-BeenThere: ldapext@ietf.org
X-Mailman-Version: 2.1.12
Precedence: list
List-Id: LDAP Extension Working Group <ldapext.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/ldapext>, <mailto:ldapext-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/ldapext>
List-Post: <mailto:ldapext@ietf.org>
List-Help: <mailto:ldapext-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/ldapext>, <mailto:ldapext-request@ietf.org?subject=subscribe>
X-List-Received-Date: Thu, 08 Aug 2013 18:10:56 -0000

>You describe problems with case-insensitive matching later in this section=
. Why not just use caseExactMatch? Strictly speaking left hand sides of ema=
il addresses are not ASCII case-insensitive.

Because we already have lots of email schemas that are empirically
useless in the real world.

If you need a case-sensitive match, you just pull the
case-insensitively matched data from the server, and quickly perform a
second comparison in the client.  This is trivial and imposes no great
load on the server or client.

The vast majority of email addresses in use today are
case-insensitive.  If your schema prevents case-insensitive matching
on the server, all email address objects have to be pulled every
single time an email is processed, so that the client code can do
appropriately case-insensitive matching locally.

--Charlie
MeDiEVaLIsT@gMaIL.Com


On Thu, Aug 8, 2013 at 12:39 PM, Alexey Melnikov
<alexey.melnikov@isode.com> wrote:
> On 08/08/2013 08:24, Michael Str=F6der wrote:
>>
>> HI!
>>
>> Some modifications based on comments I received off-list.
>>
>> Please review this draft intended to be published as informational RFC.
>> Thanks in advance.
>>
>> Ouch! There's a typo in DESC of object class definition. Will change thi=
s
>> to
>> RFC 2821 in next version.
>
> Hi Michael,
> I reviewed the document and it mostly looks quite sensible.
>
> Some comments below:
>
> 2.  Attribute Type Definition
>
>    The attribute type 'intlMailAdr' is defined for storing SMTPUTF8
>    compliant addresses [RFC6530].
>
>     ( 1.3.6.1.4.1.5427.1.389.4.18
>       NAME 'intlMailAdr'
>       DESC 'Internationalized Email Address'
>       EQUALITY caseIgnoreMatch
>
> You describe problems with case-insensitive matching later in this sectio=
n.
> Why not just use caseExactMatch? Strictly speaking left hand sides of ema=
il
> addresses are not ASCII case-insensitive.
>
>       SUBSTR caseIgnoreSubstringsMatch
>       SYNTAX 1.3.6.1.4.1.1466.115.121.1.15 )
>
>
>    Note that the directory will not ensure that values of this attribute
>    conform to the <Mailbox> production [RFC2821].
>
> RFC 2821 --> RFC 5321.
>
>
> 3.  Object Class Definition
>
>    Entries of auxiliary object class 'mailboxRelatedObject' MAY contain
>    the following optional attributes: 'mail' [RFC4524] 'displayName'
>    [RFC2798] 'intlMailAdr'
>
>     ( 1.3.6.1.4.1.5427.1.389.6.9
>       NAME 'mailboxRelatedObject'
>       DESC 'Associated RFC 2822 mailbox for any entry'
>
> Please use RFC 5322 here, which obsoleted RFC 2822. This also needs to be
> added to the Normative References. Unless you meant RFC 5321 here.
>
>       AUXILIARY
>       MAY ( displayName $ mail $ intlMailAdr ) )
>
> Best Regards,
> Alexey
>
> _______________________________________________
> Ldapext mailing list
> Ldapext@ietf.org
> https://www.ietf.org/mailman/listinfo/ldapext

From michael@stroeder.com  Thu Aug  8 11:39:28 2013
Return-Path: <michael@stroeder.com>
X-Original-To: ldapext@ietfa.amsl.com
Delivered-To: ldapext@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 85ABE11E8163 for <ldapext@ietfa.amsl.com>; Thu,  8 Aug 2013 11:39:26 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -3.299
X-Spam-Level: 
X-Spam-Status: No, score=-3.299 tagged_above=-999 required=5 tests=[BAYES_00=-2.599, MIME_8BIT_HEADER=0.3, RCVD_IN_DNSWL_LOW=-1]
Received: from mail.ietf.org ([12.22.58.30]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id W6EmF41r5d31 for <ldapext@ietfa.amsl.com>; Thu,  8 Aug 2013 11:39:14 -0700 (PDT)
Received: from srv1.stroeder.com (srv1.stroeder.com [213.240.180.113]) by ietfa.amsl.com (Postfix) with ESMTP id 2C77211E80E2 for <ldapext@ietf.org>; Thu,  8 Aug 2013 11:39:13 -0700 (PDT)
Received: from localhost (localhost [127.0.0.1]) by srv1.stroeder.com (Postfix) with ESMTP id 941A460305; Thu,  8 Aug 2013 20:39:10 +0200 (CEST)
X-Virus-Scanned: amavisd-new at stroeder.com
Received: from srv1.stroeder.com ([127.0.0.1]) by localhost (srv1.stroeder.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id NzFbb5kN1Cnm; Thu,  8 Aug 2013 20:39:06 +0200 (CEST)
Received: from nb2.stroeder.local (unknown [10.1.0.2]) (using TLSv1 with cipher ECDHE-RSA-AES256-SHA (256/256 bits)) (No client certificate requested) by srv1.stroeder.com (Postfix) with ESMTPS id 93BD660207; Thu,  8 Aug 2013 18:39:05 +0000 (UTC)
Message-ID: <5203E5C9.3060704@stroeder.com>
Date: Thu, 08 Aug 2013 20:39:05 +0200
From: =?ISO-8859-1?Q?Michael_Str=F6der?= <michael@stroeder.com>
User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:23.0) Gecko/20100101 Firefox/23.0 SeaMonkey/2.20
MIME-Version: 1.0
To: Alexey Melnikov <alexey.melnikov@isode.com>
References: <20130808072029.30689.91871.idtracker@ietfa.amsl.com> <520347AE.2080309@stroeder.com> <5203C9AA.20805@isode.com>
In-Reply-To: <5203C9AA.20805@isode.com>
X-Enigmail-Version: 1.5.2
Content-Type: multipart/signed; protocol="application/pkcs7-signature"; micalg=sha1; boundary="------------ms030003000702000000030904"
Cc: ldapext <ldapext@ietf.org>
Subject: Re: [ldapext] Fwd: New Version Notification for draft-stroeder-mailboxrelatedobject-04.txt
X-BeenThere: ldapext@ietf.org
X-Mailman-Version: 2.1.12
Precedence: list
List-Id: LDAP Extension Working Group <ldapext.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/ldapext>, <mailto:ldapext-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/ldapext>
List-Post: <mailto:ldapext@ietf.org>
List-Help: <mailto:ldapext-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/ldapext>, <mailto:ldapext-request@ietf.org?subject=subscribe>
X-List-Received-Date: Thu, 08 Aug 2013 18:39:29 -0000

This is a cryptographically signed message in MIME format.

--------------ms030003000702000000030904
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

Alexey,

Alexey Melnikov wrote:
> Some comments below:

Thanks for your time.

> 2.  Attribute Type Definition
>=20
>    The attribute type 'intlMailAdr' is defined for storing SMTPUTF8
>    compliant addresses [RFC6530].
>=20
>     ( 1.3.6.1.4.1.5427.1.389.4.18
>       NAME 'intlMailAdr'
>       DESC 'Internationalized Email Address'
>       EQUALITY caseIgnoreMatch
>=20
> You describe problems with case-insensitive matching later in this sect=
ion.
> Why not just use caseExactMatch? Strictly speaking left hand sides of e=
mail
> addresses are not ASCII case-insensitive.

1. The definition of 'mail' in RFC 4524 also defines case-insensitive mat=
ching
rules. Mainly the text pointing out the issue was taken from RFC 4524.

2. All applications are used to that. Note that the most important use-ca=
se is
searching for / completing an e-mail address. Case-insensitive matching b=
y
default is more comfortable for that.

3. I'd rather expect only very few cases in which somebody want to add

intlMailAdr: joe@example.com
intlMailAdr: JOE@example.com

to a *single* entry meaning two *different* mailboxes. Do you know of any=

deployment like this? What would be the semantics for that?
Note that 'intlMailAdr' is not meant as multi-valued attribute for mail g=
roup
entries for which such a case would be slightly more likely.
Also note that case-insensitive matching is a different thing to
case-preserving storage. I will add a note about the latter.

I'd appreciate if you propose text making this more clear if you feel it'=
s needed.

> RFC 2821 --> RFC 5321.

Thanks. Updated all occurences in next version.

Ciao, Michael.


--------------ms030003000702000000030904
Content-Type: application/pkcs7-signature; name="smime.p7s"
Content-Transfer-Encoding: base64
Content-Disposition: attachment; filename="smime.p7s"
Content-Description: S/MIME Cryptographic Signature
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--------------ms030003000702000000030904--
