Subject: Changelog entries draft. Do not seem to find it.

From: "Natarajan SK" <[email-masked]>
Date: Wed, 01 Mar 2000 04:31:54 -0700

Hi ,
        The draft-ietf-ldup-replica-req-02.txt ( LDAP V3 Replication Requirements )        
draft specifies as a reference :

 [Changelog]  Gordon Good, "Definitions of an Object Class to Hold
      LDAP Change records", Internet Draft, draft-ietf-asid-changelog-
      00.txt,  November  1996. 

I do not seem to find the draft anywhere. Could anyone help?  Also is there any written material on LDAP changelogs otherwise? 

Aprpeciate anybody who can help. 

Regards,
Natarajan

S.K.Natarajan
Senior Software Engineer
Novell Software, Bangalore
E-mail [email-masked]
Ph. no. 91-80-572-1856/58 Extn. 2213
Fx 91-80-572-1870

---

From: Linda Grimaldi <[email-masked]>
Date: Thu, 02 Mar 2000 07:55:37 -0700

Just one note on changelog standardization.  I recently wrote a program to monitor change logs for audit purposes.  It worked great on Innosoft- I had to re-write chunks of it for Netscape.  I was quite pissed off, and cursed both the IETF and the LDAP working group for about a week (fortunately, to no effect). Mr. Benedict makes a good point about using the logs for other purposes.  From a developer's perspective, I would really appreciate some consistency here.

Linda

-----Original Message-----
From:	James Benedict [SMTP:[email-masked]]
Sent:	Thursday, March 02, 2000 6:32 AM
To:	Kurt D. Zeilenga; [email-masked]
Cc:	Natarajan SK; [email-masked]; Savitha R; [email-masked]
Subject:	RE: Changelog entries draft. Do not seem to find it.

Changelogs seem to be falling between the cracks (LDAP, LDUP, 
LCUP?).  The concept of changelogs is important to replication, but it also
has many other uses.

Accountability (Who did what? When?)
Problem Tracking (Why is my email address X)
Recovery (Whoops, I didn't really want to rename everyone in my directory)
Client-side caching (Give me all the changes to a subtree)

If LDUP is going to subsume the role of maintaining changes for replication
purposes, then I think it is important to make sure that mechanisms are 
in place to deal with these other uses as well.  Otherwise, I think
changelogs should become part of the LDAP standard, not just informational.

It doesn't really matter how the directory server maintains this
information, but clients need to have a consistent way of accessing it.

James A Benedict
Advisor, IP Directory Systems Architecture
Preside Policy Services
NORTEL NETWORKS
Ph:  (613) 763-3909

> -----Original Message-----
> From: Kurt D. Zeilenga [mailto:[email-masked]]
> Sent: Wednesday, March 01, 2000 1:30 PM
> To: [email-masked]
> Cc: Natarajan SK; [email-masked]; Savitha R;
> [email-masked]
> Subject: Re: Changelog entries draft. Do not seem to find it.
> 
> 
> At 10:04 AM 3/1/00 -0800, Gordon Good wrote:
> >While I'm happy to resurrect the changelog draft and discuss 
> publishing it as a standards-track document (informational,
> >probably), it's not going to be a part of  the LDUP specification.
> 
> I would support publication of the Changelog draft as an
> Informational RFC as it would document existing practices.
> The document would have to be amended, of course, to contain
> appropriate statements concerning IETF work in this area.
> 
> Kurt
> 
 << File: ATT00002.htm >>

---

From: "Jim Sermersheim" <[email-masked]>
Date: Thu, 02 Mar 2000 10:26:43 -0700

LDUP/LCUP should include include enough functionality to achieve a client-side cache. For the other three issues you mention, maybe someone should author an audit draft.

Jim

>>> "James Benedict" <[email-masked]> 3/2/00 6:38:35 AM >>>

James A Benedict

---

From: "James Benedict" <[email-masked]>
Date: Thu, 2 Mar 2000 14:15:35 -0500

So lets try to get a list of all the current uses of changelogs
(good or bad), and see if we can identify viable alternatives for them.
If not, then I think we've got a good reason to look at changelog
standardization.

I'll start with my original list
> Client-side caching (Give me all the changes to a subtree)

and add,

Change Monitoring (a new addition to the changelog means something
changed somewhere... it's kind of a caching issue, but a little 
different)

Anyone else?

James A Benedict

> From: Linda Grimaldi [mailto:[email-masked]]
> Sent: Thursday, March 02, 2000 9:56 AM
> To: Benedict, James [CAR:5N41-M:EXCH]; Kurt D. Zeilenga;
> [email-masked]
> Just one note on changelog standardization.  I recently wrote 
> a program to monitor change logs for audit purposes.  It 
> worked great on Innosoft- I had to re-write chunks of it for 
> Netscape.  I was quite pissed off, and cursed both the IETF 
> and the LDAP working group for about a week (fortunately, to 
> no effect). Mr. Benedict makes a good point about using the 
> logs for other purposes.  From a developer's perspective, I 
> would really appreciate some consistency here.
> 
> Linda
>