Subject: LDUP management operations

From: "Jim Sermersheim" <[email-masked]>
Date: Mon, 06 Mar 2000 16:31:03 -0700

I remember reading - though I can't find it now - something that essentially said we haven't yet defined the mechanisms that will be used to manage naming contexts, replicas, and update sessions.  I think that much of the management that needs to happen can be done using existing ldap operations on the appropriate elements of the info model.

I've listed all the management operations that we currently use with our directory and divided them into two groups - operations on elements of the info model, and update operations.

Some people have suggested that all of these operations should be exposed as LDAP extended requests. I think that as long as it's not overly complex, the operations on the info model should be exposed as normal LDAP operations, while the update operations should be exposed as extended requests.

What does everyone else think?

Operations on the info model:
· Add a new replica
· Remove a replica
· Change a replica's type
· Join partition (delete naming context)
· Split partition (add a naming context)
· List partitions (list naming contexts)
· Get partition entry count (get # of entries in a naming context)
· Get partition info (various data about naming context)

Update operations:
· Send all updates
· Receive all updates
· Request partition sync
· Request schema sync
· Repair timestamps

Jim

---

From: [email-masked] (John Merrells)
Date: Mon, 06 Mar 2000 15:38:28 -0800

> What does everyone else think?

I strongly agree that they should be regular LDAP operations.

John

---

From: Chris Apple <[email-masked]>
Date: Mon, 06 Mar 2000 20:33:42 -0500

I think that's a reasonable way to proceed. It minimizes complexity
in verifying compliance if as much as possible is expressed as a
profile of normal LDAP operations.

> I remember reading - though I can't find it now - something that essentially said we haven't yet defined the mechanisms that will be used to manage naming contexts, replicas, and update sessions.…

Its in the LDUP WG charter and is one of the missing deliverables:

Am I to assume that you are offering to edit the deliverable on
LDAPv3 Mandatory Replica Management?

I believe Ed Reed and Mark Wahl were going to draft it, but have not
seen any signs of it.

Ed and Mark: any objections to Jim taking first shot at this? Perhaps
the three of you can work together after his first draft?

Chris.

-- 
------------------------------------------------------------------------
Chris Apple                     Business Site: AnyWho Directory Service
Internet Directory Group                       http://www.anywho.com
AT&T Labs
[email-masked]
+1 973 236 6470                 Tired of slow directories?  Try AnyWho.
------------------------------------------------------------------------

---

From: Mark Wahl <[email-masked]>
Date: Wed, 29 Mar 2000 20:44:44 -0600

I have only about 13 pages done of the replica management and do not have the 
termination cases worked out.  I haven't had much time to work on it since
the last meeting.  If Jim would like to continue on this, that would be 
helpful.

Mark Wahl, Directory Product Architect
Innosoft International, Inc.