Subject: Fw: I-D ACTION:draft-langer-ldup-mdcr-00.txt

From: "John Strassner" <[email-masked]>
Date: Tue, 11 Apr 2000 12:32:41 -0700

LDUPers,

as mentioned in the draft minutes from our latest meeting in
Adelaide, here is the announcement of Albert's draft. Please
do read this as soon as possible (but not before you send
comments on the minutes ;-) ) and let's start discussing
this on this list. Remember, the goal is to reach a
consensus as to what actions to take by the end of this
month (that would be April, by the way ;-) ).

The questions on the floor that this draft addresses are:

  1) is the requirements document as currently written
     too vague? That is, should we delay sending it to
     IETF last call? Please read sections 1 and 3 of
     this draft to answer this question.
  2) should we add this draft as another possible
     conflict resolution method, or should we replace
     URP with this draft, or should URP stay as the
     only method of conflict resolution.

regards,
John
----- Original Message -----
From: <[email-masked]>
To: <IETF-Announce: ;>
Sent: Tuesday, April 11, 2000 3:52 AM
Subject: I-D ACTION:draft-langer-ldup-mdcr-00.txt

> A New Internet-Draft is available from the on-line
Internet-Drafts directories.
>
>
> Title : LDUP Multiple Draft Conflict Resolution (MDCR)
> Author(s) : A. Langer
> Filename : draft-langer-ldup-mdcr-00.txt
> Pages : 19
> Date : 10-Apr-00
>
> Concurrent changes in a Multi-Master directory are a
partially
> ordered tree. 'LDUP Update Reconciliation Procedures'
(URP) uses
> timestamps to impose a strict linear order on this tree,
and merges
> changes to fit that imposed order. Merged changes violate
the
> semantics of the LDAP/X.500 data model. No specific
'modifierName'
> can be assigned to a merged change and requirements to
support audit
> trails and access controls and not to break applications
or impede
> future work on transactions cannot be met. The current
LDUP
> requirements draft avoids dealing with these critical
issues.
>
> A URL for this Internet-Draft is:
>
http://www.ietf.org/internet-drafts/draft-langer-ldup-mdcr-0
0.txt
>
> Internet-Drafts are also available by anonymous FTP. Login
with the username
> "anonymous" and a password of your e-mail address. After
logging in,
> type "cd internet-drafts" and then
> "get draft-langer-ldup-mdcr-00.txt".
>
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>
>
> Internet-Drafts can also be obtained by e-mail.
>
> Send a message to:
> [email-masked].
> In the body type:
> "FILE /internet-drafts/draft-langer-ldup-mdcr-00.txt".
>
> NOTE: The mail server at ietf.org can return the document
in
> MIME-encoded form by using the "mpack" utility.  To use
this
> feature, insert the command "ENCODING mime" before the
"FILE"
> command.  To decode the response(s), you will need
"munpack" or
> a MIME-compliant mail reader.  Different MIME-compliant
mail readers
> exhibit different behavior, especially when dealing with
> "multipart" MIME messages (i.e. documents which have been
split
> up into multiple messages), so check your local
documentation on
> how to manipulate these messages.
>
>
> Below is the data which will enable a MIME compliant mail
reader
> implementation to automatically retrieve the ASCII version
of the
> Internet-Draft.

---

From: "Ryan Moats" <[email-masked]>
Date: Wed, 12 Apr 2000 09:03:10 -0500

Well, since nobody has said anything yet, I'll take the
plunge:

I've read the MDCR draft, and the introduction discusses
various attributes being broken by URP.  Now, the only
way that I can see these problems occurring is if URP
does not maintain atomicity of LDAP operations across
replications.  I thought it did, but I'll admit that
a quick glance at the URP draft didn't turn up "chapter and
verse".  If somebody can quote the portion of the
URP draft that shows that atomicity is maintained,
please do.  Otherwise, the URP draft needs to be edited
to make this concept explicit.

Once we've shown that URP maintains atomicity of LDAP changes,
I really don't see what else the MDCR draft is looking for...

Ryan Moats

| LDUPers,
| 
| as mentioned in the draft minutes from our latest meeting in
| Adelaide, here is the announcement of Albert's draft. Please
| do read this as soon as possible (but not before you send
| comments on the minutes ;-) ) and let's start discussing
| this on this list. Remember, the goal is to reach a
| consensus as to what actions to take by the end of this
| month (that would be April, by the way ;-) ).
| 
| The questions on the floor that this draft addresses are:
| 
|   1) is the requirements document as currently written
|      too vague? That is, should we delay sending it to
|      IETF last call? Please read sections 1 and 3 of
|      this draft to answer this question.
|   2) should we add this draft as another possible
|      conflict resolution method, or should we replace
|      URP with this draft, or should URP stay as the
|      only method of conflict resolution.
| 
| regards,
| John

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Thu, 13 Apr 2000 14:46:07 +0200

>      this draft to answer this question.

The only thing that addresses consistency of the type Albert is bothered
about (from what I read in his draft) in the current requirements document is:

       6.12 Multiple LDAP changes to a single server: If transactional
            consistency is propagated during replication, then multiple LDAP
            changes submitted to a single server SHOULD BE treated as a
            single 'atomic unit of work'.

I agree with Albert that the consistency requirements are glossed over 
quite quickly in the current requirements doc; however, Albert's draft 
gives a solution only for a particular type of inconsistency: Multiple 
changes to unconnected attribute sets of an LDAP entry.

>      only method of conflict resolution.

My current view is that URP gives you a directory with a certain 
consistency model. The requirements doc talks about a range of consistency 
models; somewhere on that scale is URP; somewhere else is Albert's draft.

Unfortunately, I think both examples fall within "Model 2" of the 
requirements document, which is not fine-grained enough to show criteria 
whereby the two can be differentiated.

Neither draft addresses inter-entry consistency, such as the case where two 
persons swap telephone numbers, with multiple persons trying to update the 
directory with this info - both procedures can lead to a situation where 
both persons have the same telephone listed.

The important thing is IMHO documenting IN DETAIL what consistency the 
procedures guarantee; the requirement that the procedure proposals do 
should be in the requirements document.

Apart from that, I think requirements are ready to go.

                   Harald

--
Harald Tveit Alvestrand, EDB Maxware, Norway
[email-masked]