Subject: Comments on protocol-02

From: Zachary Amsden <[email-masked]>
Date: Wed, 26 Jul 2000 18:18:25 -0700

In sections 5.2 and 5.5, StartReplicationResponse and End
ReplicationResponse are defined as extended requests
  ::= [APPLICATION 23]

Why are they not categorized as extended responses?  This is
rather counterintuitive.  The framing draft as proposed had
requests and responses defined correctly, but gave
request/response pairs different OIDs.  This is also
counter-intuitive, as other extended operations use the same
OID on the request and response.

Thanks,
Zach Amsden
[email-masked]

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Wed, 26 Jul 2000 19:23:53 -0700

>OID on the request and response.

I suggest the no OID be specified with the response as
it clear by the semantics of the protocol that it is
paired with the request (this is, after all, why it is
OPTIONAL).  Or follow the StartTLS example and use the
same OID for paired request and responses (the OID
identifies the "operation" instead of the PDU).

Kurt