Subject: RE: LDAP Client Update: consideration of alternative proposals

From: "Ramsay, Ron" <[email-masked]>
Date: Thu, 29 May 2003 14:38:20 +1000

I'm simply the devil's advocate. Is the purpose to synchronise meta-directories? I don't know.

Surely the real point is that you (Kurt) seem to have admitted that it is under-spacified, or potentially under-specified, by referring to the draft that would say how it is done. This seems to reflect LDUP in miniature. That attempt failed, so show why yours won't. Or, to cut the Gaudion knot, why should the WG go down that path (again).

Ron

-----Original Message-----
From: Kurt D. Zeilenga [mailto:[email-masked]]
Sent: Thursday, 29 May 2003 14:23
To: [email-masked]
Cc: Ramsay, Ron; [email-masked]
Subject: RE: LDAP Client Update: consideration of alternative proposals

At 08:48 PM 5/28/2003, Chris Apple wrote:
>Does this mean that you agree with Ron's point? Or not?

I don't dispute Ron's point that LCUP (draft-ietf-ldup-lcup)
is meant to provide a simple synchronization tool.  However, I
added that I believe that LDAP-Sync (draft-zeilenga-ldup-sync)
is also meant to provide a simple synchronization tool.  I'll
leave it to Ron to say whether he concurs with my additional
point.

>Chris Apple - Principal Architect
>
>DSI Consulting, Inc.
>
>mailto:[email-masked]
>
>http://www.dsi-consulting.com
>
>At 06:07 PM 5/28/2003, Ramsay, Ron wrote:
>>1) LCUP is meant to provide a simple synchronisation tool, similar to
>persistent search.
>
>I content that LDAP-Sync is meant to provide a simple
>synchronization tool, similar to persistent search, as well. The
>primary applications being considered for both solutions is the
>same: meta-directory, address-books, etc..

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Wed, 28 May 2003 22:34:07 -0700

>I'm simply the devil's advocate. Is the purpose to synchronise meta-directories? I don't know.

In my opinion, the purpose of our deliverable is to provide a
LDAP content synchronization mechanism suitable for a broad range
of applications, including meta-directory applications.  If its
suitable for meta-directory, it also should be suitable for
applications (like master/slave LDAP replication) which have
similar content synchronization requirements.

>Surely the real point is that you (Kurt) seem to have admitted that it is under-spacified, or potentially under-specified, by referring to the draft that would say how it is done.

Surely not.

When I said:
>While Jong and I certainly intend to use LDAP Sync as a basis
>for single-master replication, this I-D does not attempt to
>detail how LDAP Sync might be used for single-master replication.
>(We saved that for a future draft.)

my point was that specification how a future LDAP Relication
specification might use LDAP Sync is beyond the scope of
draft-zeilenga-ldup-sync as draft-zeilenga-ldup-sync is
intended to be a complete technical specification of the
LDAP Content Sychronization Operation (a LDAPv3 client update
protocol).  Jong and I do believe draft-zeilenga-ldup-sync
is complete.

Kurt

---

From: "Chris Apple" <[email-masked]>
Date: Thu, 29 May 2003 11:37:22 -0400

Speaking as a WG Member:

The definition for the purpose of LCUP that you
give below is broader than that which is currently
chartered:

o LDAPv3 Client Update

        A protocol that enables an LDAP client to
        synchronize with the content of a directory
        information tree (DIT) stored by an LDAP server
        and to be notified about the changes to that
        content.

My opinion is that the existing LCUP draft contains
a protocol specification which is tightly focused on
what is chartered. My opinion is that it does so in
a way that balances purely technical merit with realistic
real world deployment concerns.

Past discussions have indicated that the LCUP
deliverable should have an applicability
statement that at least in part outlines the
conditions and perhaps even the classes of
applications for which the protocol is thought
to be a good match.

What you have described below is actually not the
purpose of the deliverable as chartered, but
your interpretation that its applicability should
encompass a wide range of applications and 
operational paradigms.

Perhaps one source of difficulty in discussions
related to this topic is that there is not
agreement between yourself and the editors
of LCUP as to how broad a range of applicability
is appropriate for the LCUP deliverable?

Speaking as WG Co-Chair:

John and I need input from as many WG Members
as possible on these questions:

   How would you define applicability for LCUP in
   terms of applications and operational paradigms?

   From your perspective, is that definition different
   for the existing WG deliverable and
   draft-zeilenga-ldup-sync?

Again, it is very difficult to judge consensus
based on silence. Please keep the discussion moving.
Many thanks to those who have already taken the time
to post their thoughts.

In a prior posting, when I mentioned that we
could handle wordsmithing of the applicability
statement during WG Last Call for LCUP, I meant
in part that we could address the addition of
statements as needed to express application-
and paradigm-specific applicability.

We may still end up doing that to the LCUP
deliverable during its WG Last Call regardless
of which document the deliverable is based on.

My next posting will be CC'd to the WG Mailing List
and will be an official request to our ADs to slip
the milestone date for LCUP WG Last Call. This will
hopefully enable us to discuss this thread further
without missing another deadline.

DSI Consulting, Inc.

-----Original Message-----
From: Kurt D. Zeilenga [mailto:[email-masked]] 
Sent: Thursday, May 29, 2003 1:34 AM
To: Ramsay, Ron
Cc: [email-masked]; [email-masked]
Subject: RE: LDAP Client Update: consideration of alternative proposals

>Surely the real point is that you (Kurt) seem to have admitted that it is
under-spacified, or potentially under-specified, by referring to the draft
that would say how it is done.

Surely not.

Kurt