Subject: OIDs for LDUP schema, controls, etc..

From: John McMeeking <[email-masked]>
Date: Fri, 21 Nov 2003 10:09:51 -0600

Do we want to request OIDs for the infomod schema, protocol extended ops,
etc.?

If so, do we want to request one overall "LDUP-OID" and assign LDUP-OID.1,
LDUP-OID.2, etc?  Or do we want to do this on a per document basis
(ldup-infomod-oid.1, ... ldup-protocol-oid.1, ...)?

Also, there are a few references to other drafts I'm not sure we've sorted
out:
  draft-zeilenga-ldap-uuid-xx
  draft-zeilenga-ldap-grouping-xx.txt
What is happening with these drafts?

John  McMeeking

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Sat, 22 Nov 2003 18:36:18 -0800

>Do we want to request OIDs for the infomod schema, protocol extended ops,

I suggest that you include requests for IANA actions in the
document (and, hence, defer actual assignment until the I-D
becomes an RFC-to-be).  See BCP 64 for details.

>(ldup-infomod-oid.1, ... ldup-protocol-oid.1, ...)?

BCP 64 says "Only one OID per specification will be assigned."
A specification, such as for LDAP Replication, can be spread over
multiple documents.  Of course, one could consider some LDAP
Replication documents (such as a CSN I-D) to separate specifications.

>What is happening with these drafts?

I plan on progressing UUID very soon (within a week or two).  I plan
on progressing grouping with transactions soon (within the next
few months).

Kurt