Subject: [Ledger] AGENDA - Interledger Community Call - 21 September - 3pm UTC

From: Adrian Hope-Bailie <[email-masked]>
Date: Mon, 18 Sep 2017 20:01:29 -0700

This week we'll discuss the Bilateral Transfer Protocol (BTP) (previously
called the Common Ledger Protocol (CLP)).

This has been under development for a number of weeks and is now frozen so
we can focus on implementations and interop testing.

The best place to review it is here:
https://github.com/interledger/rfcs/blob/726705c99d0324d352ab698eb618ae28d369eef1/00XX-bilateral-transfer-protocol/00XX-bilateral-transfer-protocol.md

It is documented as PR 291 <https://github.com/interledger/rfcs/pull/291/>

The purpose of this protocol is to establish a common standard for
communications between nodes on the Interledger encompassing both messaging
and transfers.

Looking forward to the discussion!

---

From: Adrian Hope-Bailie <[email-masked]>
Date: Tue, 19 Sep 2017 00:43:19 -0700

Hi Per,

I'm not sure what you are referring to? Can you be more specific.

Adrian

On 18 September 2017 at 22:57, Per Lind <[email-masked]> wrote:

> I would like to know why NTT and Ripple is now claiming credit for the
> Interledger project! Anyone?
>
> Best,
>
> Per Lind
> Co-founder
> IOTA Foundation
> +66 8 1110 7667
>
> On 19 Sep 2017 10:03, "Adrian Hope-Bailie" <[email-masked]> wrote:
>
>> This has been under development for a number of weeks and is now frozen
>> so we can focus on implementations and interop testing.
>>
>> The best place to review it is here: https://github.com/interledger
>> /rfcs/blob/726705c99d0324d352ab698eb618ae28d369eef1/00XX-
>> bilateral-transfer-protocol/00XX-bilateral-transfer-protocol.md
>>
>> It is documented as PR 291
>> <https://github.com/interledger/rfcs/pull/291/>
>>

---

From: Per Lind <[email-masked]>
Date: Tue, 19 Sep 2017 12:57:50 +0700

Best,

Per Lind
Co-founder
IOTA Foundation
+66 8 1110 7667

On 19 Sep 2017 10:03, "Adrian Hope-Bailie" <[email-masked]> wrote:

> The best place to review it is here: https://github.com/
> interledger/rfcs/blob/726705c99d0324d352ab698eb618ae
> 28d369eef1/00XX-bilateral-transfer-protocol/00XX-
> bilateral-transfer-protocol.md
>

---

From: Per Lind <[email-masked]>
Date: Tue, 19 Sep 2017 14:47:57 +0700

https://www.coindesk.com/old-flames-new-code-ripple-hyperledger-reunite-interledger-effort/

On 19 Sep 2017 14:43, "Adrian Hope-Bailie" <[email-masked]> wrote:

Hi Per,

Adrian

On 18 September 2017 at 22:57, Per Lind <[email-masked]> wrote:

>> /rfcs/blob/726705c99d0324d352ab698eb618ae28d369eef1/00XX-bil
>> ateral-transfer-protocol/00XX-bilateral-transfer-protocol.md
>>

---

From: Adrian Hope-Bailie <[email-masked]>
Date: Tue, 19 Sep 2017 15:06:57 -0700

Ripple and NTT (actually, primarily a subsidiary of NTT, Everis) are
initiating a new project at the Hyperledger Foundation which will be
focused on interoperability.
The project will be an implementation of the Interledger protocol and will
be written in Java, Taking the existing Java implementations as it's
starting code base.

These two companies have been the primary contributors to the Java
implementations so I'm not sure why it's surprising they'd be the sponsors
of this project?

This new project doesn't replace the existing ILP community which is
focused on development of the protocol and standards.
i.e. The community deliverables are specifications, the new project's
deliverables will be code libraries (implementations of the protocol).

The existing Java code libraries do not have a "home" today as there is no
neutral legal entity to which the licenses can be attributed and no
governance framework or contributor agreements.
The Hyperledger foundation offers such a framework (in the same way that
the JS Foundation already does for the Javascript code components).

More details in the proposal:
https://docs.google.com/document/d/1KVrakb2JsqgMo2aG-QIYl743VHsU9NWYKxy7n-WeXv4/edit

If IOTA is able to commit resources to contributing to this project that
would be great, we'd love to share that commitment with the TSC at
Hyperledger when we meet next week.

On 19 September 2017 at 00:47, Per Lind <[email-masked]> wrote:

>>> This week we'll discuss the Bilateral Transfer Protocol (BTP)
>>> (previously called the Common Ledger Protocol (CLP)).
>>>

---

From: Adrian Hope-Bailie <[email-masked]>
Date: Wed, 20 Sep 2017 09:45:43 -0700

NO CALL on 21 September

Apologies for the date mix-up. The call was earlier today (as usual on a
Wednesday).
Next call is in 2 weeks (Wednesday 4 October).