Subject: Re: [Lime] AD review: draft-ietf-lime-yang-connectionless-oam-methods

From: Benoit Claise <[email-masked]>
Date: Fri, 1 Sep 2017 13:23:03 +0200

Thanks Qin,

See in-line (I removed the addressed points).
>
> Thank for valuable comments, your comments have been addressed in 
> v-(06) with other comments on the list:
>
> https://datatracker.ietf.org/doc/draft-ietf-lime-yang-connectionless-oam-methods/
>
Good, but I still see some warnings at 
http://www.claise.be/IETFYANGPageCompilation.html
>
> -Qin
>
> *发件人:*Lime [mailto:[email-masked]] *代表 *Benoit Claise
> *发送时间:*2017年8月11日23:12
> *收件人:[email-masked]
> *抄送:*Carl Moberg (camoberg)
> *主题:*[Lime] AD review: draft-ietf-lime-yang-connectionless-oam-methods
>
> Dear all,
>
> Here is my AD review.
>
> - " This document presents a retrieval method YANG Data model for 
> connectionless OAM protocols" is this right?
>
>    rpc path-discovery {
>          description
>            "Generates path discovery as per RFC7276 
> <https://tools.ietf.org/html/rfc7276>.";
>
>    rpc continuity-check {
>          if-feature coam:continuity-check;
>          description
>            "Generates continuity-check as per RFC7276 
> <https://tools.ietf.org/html/rfc7276>.";
>
> AFACT, the RPC triggers an "on-demand" (as opposed to proactive 
> draft-ietf-lime-yang-connectionless-oam, to use the 
> draft-ietf-lime-yang-connectionless-oam term) OAM mechanism and 
> retrieves the results directly.
> " This document presents a retrieval method YANG Data model for 
> connectionless OAM protocols" makes it sound like "polling" the 
> results, which could also be "proactive". You should improve the text
>
Please let me know how this has been addressed.
It seems that this draft is not only about a retrieval, but also an 
activation, in case of "on demand". I believe we should make it clear.
If we need a 5 min call (maybe I don't express myself correctly), don't 
hesitate to let me know.
>
>
> After hours spent on the two LIME drafts ...
> If the continuity-check RPC is really "on-demand", why do we have the 
> session-type-enum as input?
>
> rpc continuity-check {
>     if-feature "coam:continuity-check";
>     description
>       "Generates continuity-check as per RFC7276 
> <https://tools.ietf.org/html/rfc7276>.";
>     input {
>       container destination-tp {
>         uses coam:tp-address;
>         description
>           "Destination test point.";
>       }
>       uses coam:session-type;         <==============
>       leaf source-interface {
>         type if:interface-ref;
>         description
>           "Source interface.";
>       }
>
> From the other draft (why, btw?)
>
>     grouping session-type {
>       description
>         "This object indicates the current session
>          definition.";
>       leaf session-type-enum {
>         type enumeration {
>           enum "proactive" {
>             description
>               "The current session is proactive";
>           }
>           enum "on-demand" {
>             description
>               "The current session is on-demand.";
>           }
>         }
>         default "on-demand";
>         description
>           "Session type enum";
>       }
>     }
>
> This should always be "on-demand", right?
>
>
Regards, Benoit

---

From: Qin Wu <[email-masked]>
Date: Fri, 1 Sep 2017 11:40:31 +0000

The warning comes from network instance yang model which is referenced in this draft. To fix it, network instance model draft should be updated.

Sent from HUAWEI AnyOffice
发件人： bclaise
收件人： Qin Wu; [email-masked];
抄送： Carl Moberg (camoberg); Jan Lindblad;
主题： Re: [Lime] AD review: draft-ietf-lime-yang-connectionless-oam-methods
时间： 2017-09-01 19:23:18

Thanks Qin,

See in-line (I removed the addressed points).
Thank for valuable comments, your comments have been addressed in v-(06) with other comments on the list:
https://datatracker.ietf.org/doc/draft-ietf-lime-yang-connectionless-oam-methods/
Good, but I still see some warnings at http://www.claise.be/IETFYANGPageCompilation.html

-Qin
发件人: Lime [mailto:[email-masked]] 代表 Benoit Claise
发送时间: 2017年8月11日 23:12
收件人: [email-masked]<mailto:[email-masked]>
抄送: Carl Moberg (camoberg)
主题: [Lime] AD review: draft-ietf-lime-yang-connectionless-oam-methods

Dear all,

Here is my AD review.

- " This document presents a retrieval method YANG Data model for connectionless OAM protocols" is this right?

   rpc path-discovery {

         description

           "Generates path discovery as per RFC7276<https://tools.ietf.org/html/rfc7276>.";

   rpc continuity-check {

         description

           "Generates continuity-check as per RFC7276<https://tools.ietf.org/html/rfc7276>.";
AFACT, the RPC triggers an "on-demand" (as opposed to proactive draft-ietf-lime-yang-connectionless-oam, to use the draft-ietf-lime-yang-connectionless-oam term) OAM mechanism and retrieves the results directly.
" This document presents a retrieval method YANG Data model for connectionless OAM protocols" makes it sound like "polling" the results, which could also be "proactive". You should improve the text
Please let me know how this has been addressed.
It seems that this draft is not only about a retrieval, but also an activation, in case of "on demand". I believe we should make it clear.
If we need a 5 min call (maybe I don't express myself correctly), don't hesitate to let me know.

After hours spent on the two LIME drafts ...
If the continuity-check RPC is really "on-demand", why do we have the session-type-enum as input?

 rpc continuity-check {

    description

      "Generates continuity-check as per RFC7276<https://tools.ietf.org/html/rfc7276>.";

    input {

        uses coam:tp-address;

        description

      }

      leaf source-interface {

        type if:interface-ref;

        description

          "Source interface.";

      }

    grouping session-type {

      description

         definition.";

      leaf session-type-enum {

        type enumeration {

          enum "proactive" {

            description

          }

          enum "on-demand" {

            description

          }

        }

        default "on-demand";

        description

          "Session type enum";

      }

    }

Regards, Benoit

---

From: Qin Wu <[email-masked]>
Date: Fri, 1 Sep 2017 14:17:56 +0000

See my comments inline below.
发件人: Benoit Claise [mailto:[email-masked]]
发送时间: 2017年9月1日 19:23
收件人: Qin Wu; [email-masked]
抄送: Carl Moberg (camoberg); Jan Lindblad
主题: Re: [Lime] AD review: draft-ietf-lime-yang-connectionless-oam-methods

Thanks Qin,

-Qin

Dear all,

Here is my AD review.

   rpc path-discovery {

         description

   rpc continuity-check {

         description

[Qin]: Sorry t miss your message, I think we could support on-demand data retrieval and proactive( periodical) data retrieval. In CL method model, 'ietf-connectionless-oam-methods 'module defined in the normative part of method draft support on-demand activation while 'example-cl-oam-persistent-methods ' support both on-demand activation and proactive activation.

[Qin]: The concept is separate retrieved-data from retrieval procedure, retrieved-data is defined in CL model draft, the retrieval-procedure is defined in CL method model draft. Session-type-enum is part of retrieved-data defined CL model, that’s why we can have one data retrieval model only support on-demand activation, we can have another data-retrieval model support proactive activation. This will allow more flexibility. This has been clarified in the introduction section of method model draft. We can make it more clear by distinct model proposed in the normative part from the model proposed in the appendix.

 rpc continuity-check {

    description

    input {

        uses coam:tp-address;

        description

      }

      leaf source-interface {

        type if:interface-ref;

        description

          "Source interface.";

      }

    grouping session-type {

      description

         definition.";

      leaf session-type-enum {

        type enumeration {

          enum "proactive" {

            description

          }

          enum "on-demand" {

            description

          }

        }

        default "on-demand";

        description

          "Session type enum";

      }

    }
[Qin]: See above.
Regards, Benoit