Subject: [Lime] draft-ietf-lime-yang-connectionless-oam-methods YANG module issue

From: Benoit Claise <[email-masked]>
Date: Wed, 20 Sep 2017 11:33:45 -0700

Dear authors,

Thanks for posting the version 7 of this draft.
There is however an issue to extract your YANG module out the draft.
Can you please check this.
https://tools.ietf.org/rfcdiff?url2=draft-ietf-lime-yang-connectionless-oam-methods-07.txt#diff0004

$ xym draft-ietf-lime-yang-connectionless-oam-methods-07.txt

Extracting [email-masked]'
    ERROR: 'draft-ietf-lime-yang-connectionless-oam-methods-07.txt', 
Line 1226 - 'module' statement within another module
No models created.
bclaise@bclaise-VirtualBox:~/ietf/my-id-mirror$

Line 1226 points to

   module example-cl-oam-persistent-methods {
   namespace "http://example.com/cl-oam-persistent-methods";

There is something suspicious around

And a missing } at the end?

Regards, Benoit

---

From: Qin Wu <[email-masked]>
Date: Wed, 20 Sep 2017 20:26:37 +0000

Fixed in  v-(08)
https://datatracker.ietf.org/doc/draft-ietf-lime-yang-connectionless-oam-methods/
发件人: Benoit Claise [mailto:[email-masked]]
发送时间: 2017年9月21日 2:34
收件人: [email-masked]
抄送: [email-masked]
主题: draft-ietf-lime-yang-connectionless-oam-methods YANG module issue

Dear authors,

Extracting [email-masked]<mailto:[email-masked]>'
   ERROR: 'draft-ietf-lime-yang-connectionless-oam-methods-07.txt', Line 1226 - 'module' statement within another module
No models created.
bclaise@bclaise-VirtualBox:~/ietf/my-id-mirror$

Line 1226 points to

  module example-cl-oam-persistent-methods {
  namespace "http://example.com/cl-oam-persistent-methods"<http://example.com/cl-oam-persistent-methods>;

Regards, Benoit