Subject: [Lime] AD review: draft-ietf-lime-yang-connectionless-oam-methods-08

From: Benoit Claise <[email-masked]>
Date: Mon, 2 Oct 2017 16:30:50 +0200

Dear authors,

Thanks for progressing this draft.
Can you help me understand something.
Where do the status code come from? status-code and status-sub-code are 
identities
I see this description below

   output {
       container error-code {
         leaf status-code {
           type identityref{
          base status-code;
        }
         mandatory true;
         description
          "Error code for continuity-check message. For example, Error code in
          ICMPv6 message includes
          1-Destination Unreachable
          2- Packet Too Big
          3- Time Exceeded
          4- Parameter Problem [RFC4443].";
         }
         leaf status-sub-code {
           type identityref{
           base status-sub-code;
           }

The status codes are the status code of the protocol used for the 
continuity check? So the context depend on the tp-location-type (IPv4 or 
IPv6)
But then, what if someone would use OWAMP, IP SLA, or another protocol?

Regards, Benoit

---

From: "Deepak Kumar (dekumar)" <[email-masked]>
Date: Tue, 3 Oct 2017 06:03:43 +0000

Hi Benoit,

We will upload new draft fixing the description.

Thanks,
Deepak

---

From: Benoit Claise <[email-masked]>
Date: Tue, 3 Oct 2017 08:54:35 +0200

Hi Deepak,
> We will upload new draft fixing the description.
Not only the YANG description. Have some text around about the error codes.
Also, explains how you can determine which protocol is used.

Regards, Benoit
> .

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Tue, 3 Oct 2017 18:09:33 +0000

Hi Deepak,

> On Oct 3, 2017, at 2:54 AM, Benoit Claise (bclaise) <[email-masked]> wrote:
> 
> Hi Deepak,
>> Hi Benoit,
>> 

Additionally, and for completeness, please fix and update this both for continuity-check as well as for path-discovery.

Thanks!

Carlos.

> _______________________________________________
> Lime mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lime