Subject: [Lime] Ben Campbell's No Objection on draft-ietf-lime-yang-connectionless-oam-14: (with COMMENT)

From: Ben Campbell <[email-masked]>
Date: Wed, 25 Oct 2017 18:26:24 -0700

Ben Campbell has entered the following ballot position for
draft-ietf-lime-yang-connectionless-oam-14: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-lime-yang-connectionless-oam/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I have some mostly editorial comments:

- I agree with Adam's comments about readability. Please also consider an
editing pass for grammar--I noted some missing articles, plural disagreement,
etc.

- Please check IDNits. It has some complaints about references. I will leave it
to the authors to determine if they are real.

-1, paragraph starting with "The different OAM tools...": The phrase "After the
connection is established" is missing an article.

-2.2: "RPC operation - A specific Remote Procedure Call.": That seems like a
circular definition.

-3, first paragraph: 'The model augments "/networks/network/node" path...':
missing article.

-3.1, 6th paragraph: "... these parameters are not explicit configured":
s/explicit/explicitly

-5.2.1.2, 2nd paragraph: s/user/users

-6, third paragraph: " writable/creatable/deletable": Please don't use "/" as a
substitute for conjunctions.

---

From: Qin Wu <[email-masked]>
Date: Thu, 26 Oct 2017 04:48:26 +0000

Thanks Ben.
-----邮件原件-----
发件人: Ben Campbell [mailto:[email-masked]] 
发送时间: 2017年10月26日 9:26
收件人: The IESG
抄送: [email-masked]; Ron Bonica; Carlos Pignataro; [email-masked]; [email-masked]; [email-masked]
主题: Ben Campbell's No Objection on draft-ietf-lime-yang-connectionless-oam-14: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

- I agree with Adam's comments about readability. Please also consider an editing pass for grammar--I noted some missing articles, plural disagreement, etc.

[Qin]: Will fix them. Thanks.

- Please check IDNits. It has some complaints about references. I will leave it to the authors to determine if they are real.

[Qin]: will investigate, thanks.

-1, paragraph starting with "The different OAM tools...": The phrase "After the connection is established" is missing an article.

[Qin]: Good catch, will fix this.
-2.2: "RPC operation - A specific Remote Procedure Call.": That seems like a circular definition.

[Qin]: This follows definition in terminology section of RFC7950, we can add reference to RFC7950 for this.

[Qin]: Okay.

[Qin]:Okay, will fix this.

[Qin]: Okay.

-6, third paragraph: " writable/creatable/deletable": Please don't use "/" as a substitute for conjunctions.

[Qin]: This follows template defined in YANG security guideline
https://trac.ietf.org/trac/ops/wiki/yang-security-guidelines
But if you like, we can change this.

---

From: Ben Campbell <[email-masked]>
Date: Thu, 26 Oct 2017 00:00:47 -0500

[…]

> On Oct 25, 2017, at 11:48 PM, Qin Wu <[email-masked]> wrote:
> 

It probably makes sense to stick with the template.

---

From: Qin Wu <[email-masked]>
Date: Thu, 26 Oct 2017 05:01:23 +0000

Thanks Ben.
-----邮件原件-----
发件人: Ben Campbell [mailto:[email-masked]] 
发送时间: 2017年10月26日 13:01
收件人: Qin Wu
抄送: The IESG; Ron Bonica; [email-masked]; [email-masked]; [email-masked]; [email-masked]
主题: Re: Ben Campbell's No Objection on draft-ietf-lime-yang-connectionless-oam-14: (with COMMENT)

[…]