Subject: [Lime] Adam Roach's No Objection on draft-ietf-lime-yang-connectionless-oam-14: (with COMMENT)

From: Adam Roach <[email-masked]>
Date: Tue, 24 Oct 2017 22:45:39 -0700

Adam Roach has entered the following ballot position for
draft-ietf-lime-yang-connectionless-oam-14: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-lime-yang-connectionless-oam/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Please expand "EXP", "VPLS", and "LAG" on first use.

Section 3.2 refers to the "lime base model". Please define or expand "lime" or
provide a citation that does so.

The id-nits tool reports that there are 6 instances of overly-long lines in the
document. Given that these exist in code elements, the authors can probably
make better decisions about how to resolve these than the RFC editor can.

Section 3.3 contains the following definition:

                list oam-neighboring-tps {
                  key "index";
                  leaf index {
                     type uint16 {
                        range "0..65536";
                     }

uint16 cannot represent 65536.

----------------------------------------

Later in the model:

 container timestamp-80bit {
 when "derived-from-or-self(../timestamp-type, 'cl-oam:ptp80')"{
         description
          "Only applies when 80bit PTP Timestamp.";
        }
  if-feature ptp-long-format;
      leaf timestamp-sec {
      type uint64 {
      range "0..281474976710656";
      }
      description
        "48bit Timestamp in seconds as per IEEE1588v2.";
       }
      leaf timestamp-nanosec {
      type uint32;
      description
        "Fractional part in nanoseconds as per IEEE1588v2
         or Fractional part in 64-bit NTP timestamp.";
      }
      description
      "Container for 64bit timestamp.";
    }

Issue 1: The 48-bit range should be 0..281474976710655, not 0..281474976710656

Issue 2: The description for this 80-bit timestamp container contains a
description of "Container for 64bit timestamp."

----------------------------------------

Similar to issue 2 above, ntp-timestamp-32bit describes itself as a 64-bit
timestamp.

---

From: Qin Wu <[email-masked]>
Date: Wed, 25 Oct 2017 10:17:11 +0000

Thanks Adam, we will fix these typos in next version.

-Qin
-----邮件原件-----
发件人: Adam Roach [mailto:[email-masked]] 
发送时间: 2017年10月25日 13:46
收件人: The IESG
抄送: [email-masked]; Ron Bonica; Carlos Pignataro; [email-masked]; [email-masked]; [email-masked]
主题: Adam Roach's No Objection on draft-ietf-lime-yang-connectionless-oam-14: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

Section 3.2 refers to the "lime base model". Please define or expand "lime" or provide a citation that does so.

The id-nits tool reports that there are 6 instances of overly-long lines in the document. Given that these exist in code elements, the authors can probably make better decisions about how to resolve these than the RFC editor can.

Later in the model:

Issue 2: The description for this 80-bit timestamp container contains a description of "Container for 64bit timestamp."

Similar to issue 2 above, ntp-timestamp-32bit describes itself as a 64-bit timestamp.