Subject: [link-relations] where to spec the "license" link relation [was: NEW RELATION REQUEST: Relation name: "next"]

From: "Michael(tm) Smith" <[email-masked]>
Date: Thu, 7 Oct 2010 00:29:20 +0900

Mark Nottingham <[email-masked]>, 2010-09-02 21:34 +1000:

> 3) Updating registrations from other sources, including:
>   license / up / last / first
> 
> These might need a bit more discussion, especially license,
> which is currently defined by RFC4946. Is there any reason that
> its definition isn't adequate for HTML5?

After some further thought about this, I think the reason is to
keep the definition at point of use in the HTML5 spec unless
there's a really compelling need not to.

I personally would not feel terrifically confident trying to argue
that readers of the HTML5 spec would be particularly well-served
by being required to read a separate protocol spec -- one that is
arguably relatively obscure and one in which the definition of the
"license" link relation is a relatively small part -- rather than
just having a definition at point of use in the HTML5 spec.

Another suggested way to handle this would seem to be to leave the
text in the HTML5 spec and RFC4946 as-is, but to:

  1. Have somebody create a tiny Internet Draft that provides a
     general explanation of what the "license" link relation is.

  2. Have that ID cite both the HTML5 spec and RFC4946 for details
     about how the "license" link relation is used in the
     technologies defined by those two specs.

-- 
Michael(tm) Smith
http://people.w3.org/mike

---

From: "Michael(tm) Smith" <[email-masked]>
Date: Thu, 7 Oct 2010 00:32:28 +0900

Mark Nottingham <[email-masked]>, 2010-09-02 21:34 +1000:

> 2) Registering new relations, including:
>   archives / icon / noreferer / tag / pingback / prefetch / sidebar / external / author / nofollow / search 
> 
> 'pingback' and 'search' refer to external specifications. We'll need to talk through the implications of that.

Should we have the discussion about those on the public-html list?

  --Mike

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 29 Oct 2010 15:35:37 +1100

Hi Michael,

Sorry about the delay; been travelling and catching up (badly).

I think having an I-D define the license relation is certainly workable, but it'd be easier to just note the format-specific implications directly in the registration; e.g.,

---8<---

Relation Name:
 license

Description:
 Refers to a license associated with the link's context.

Reference:
 [RFC4946]

Notes:
  For implications of use in HTML, see: http://www.w3.org/TR/html5/links.html#link-type-license

--->---

Is that workable for the HTML WG?

Cheers,

--
Mark Nottingham   http://www.mnot.net/

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 29 Oct 2010 15:55:21 +1100

> Should we have the discussion about those on the public-html list?

I think what needs to happen here is that the DEs need to discuss it among themselves. I'll try to get a result for you ASAP.

Thanks,