Subject: Re: [lisp] [tcmtf] TCMTF: two kinds of services

From: "Jose Saldana" <[email-masked]>
Date: Fri, 19 Oct 2012 18:04:28 +0200

Luigi,

What about this protocol stack for LISP within TCMTF?

(to be seen in Courier letters)

    TCP/IP   UDP/IP  RTP/UDP/IP

         \     |     /

          \    |    /                     ------------------------------

           \   |   /

Nothing or ROHC or ECRTP or IPHC             header compressing layer

               |

               |                          ------------------------------

               |

   PPPMUX or other mux protocols                multiplexing layer

           /   |     \

          /    |      \                   ------------------------------

         /    LISP     \

        /      |        \

GRE or L2TP   UDP        \                        tunneling layer

       |       |        MPLS

       |       |                           ------------------------------

       IP      IP

I don’t know if LISP could be included into TCMTF draft. What do you think?
Should it be defined inside the LISP WG?

We have to talk about that LISP signaling which could be used in TCMTF, as
you say.

Thanks,

Jose

> -----Mensaje original-----

> De: [email-masked] [mailto:[email-masked]] En nombre de

> Luigi Iannone

> Enviado el: jueves, 11 de octubre de 2012 9:11

> Para: [email-masked]

> CC: [email-masked]

> Asunto: Re: [tcmtf] TCMTF: two kinds of services

> Hi Jose,

> I would put LISP in two different layers.

> You can consider LISP as composed of two main parts:

> 1. the encap/decap operations (i.e., the tunnelling)

> 2. the mapping system (basically controlling which traffic is tunnelled).

> The first can be used  at the tunnelling layer, beside GRE/MPLS/L2TP
(having

> multiple options is always a good thing ;-) ), to perform the tunnelling.
Some

> parts of the LISP header might be exploited to carry TE information (e.g.,
the

> Instance ID can be used as QoS tag).

> The second can be used at Mux/Demux layer. The LISP mapping system

> might be extended to perform tcmtf negotiation by  leveraging on a

> particular form of mappings. The advantage is that there is already quite
a bit

> of signalling machinery out there that can be easily re-used/extended.

> Ciao

> Luigi

> On 10 Oct. 2012, at 13:48 , Jose Saldana < <mailto:[email-masked]>
[email-masked]> wrote:

> > Luigi,

> > Where would you include LISP here? With GRE/L2TP, or with MPLS?

> > We are also thinking about including other tunneling schemes, as VLAN,

> etc.

> > (to be seen in Courier letters)

> >    TCP/IP   UDP/IP  RTP/UDP/IP

> >         \     |     /

> >          \    |    /                     ------------------------------

> >           \   |   /

> > Nothing or ROHC or ECRTP or IPHC             header compressing layer

> >               |

> >               |                          ------------------------------

> >               |

> >   PPPMUX or other mux protocols                multiplexing layer

> >               |

> >              / \                         ------------------------------

> >             /   \

> >            /     \

> >   GRE or L2TP     \                              tunneling layer

> >          |        MPLS

> >          |                               ------------------------------

> >          IP

> > Thanks,

> > Jose

> >> -----Mensaje original-----

> >> De:  <mailto:[email-masked]> [email-masked] [
<mailto:[email-masked]> mailto:[email-masked]] En nombre

> >> de Luigi Iannone Enviado el: miércoles, 10 de octubre de 2012 10:23

> >> Para:  <mailto:[email-masked]> [email-masked]

> >> CC:  <mailto:[email-masked]> [email-masked]

> >> Asunto: Re: [tcmtf] TCMTF: two kinds of services

> >> Hi All,

> >> On 10 Oct. 2012, at 09:58 , Jose Saldana < <mailto:[email-masked]>
[email-masked]> wrote:

> >>> - Tunneling will be used to send the multiplexed packets end-to-end.

> >>> The options in this layer are L2TP, GRE and MPLS.

> >> I was wondering if the group might be interested in exploring also

> >> other

> > form

> >> of tunnelling, e.g., LISP.

> >> Obviously, since LISP is an experimental effort, it cannot be tagged

> >> as

> > "best

> >> current practice" and included in document (A).

> >> However, the group may have a slightly "larger" scope and include

> >> alternative forms of tunnelling (and/or multiplexing and/or header

> >> compression) (may be documented separately).

> >> Thoughts?

> >> ciao

> >> Luigi

> >> _______________________________________________

> >> tcmtf mailing list

> >>  <mailto:[email-masked]> [email-masked]

> >>  <https://www.ietf.org/mailman/listinfo/tcmtf>
https://www.ietf.org/mailman/listinfo/tcmtf

> _______________________________________________

> tcmtf mailing list

>  <mailto:[email-masked]> [email-masked]

>  <https://www.ietf.org/mailman/listinfo/tcmtf>
https://www.ietf.org/mailman/listinfo/tcmtf

---

From: Luigi Iannone <[email-masked]>
Date: Sun, 21 Oct 2012 16:13:41 +0200

Hi Jose,

comments inline.

> (to be seen in Courier letters)

The graph looks good to me.

Concerning whether or not to include it in the draft, may be it is not necessary to include details about LISP just mention that can be used. The usage of LISP, because of its experimental nature compare to other tunnelling options, can be documented in a different document, which, if people are interested, I can (with your help) write.

> Should it be defined inside the LISP WG?

I`ll let the LISP WG chairs answer on this point.
Nevertheless, IMHO,  the LISP WG is chartered for the main spec. Other usages of LISP can be discussed in other, more pertinent, WGs. Obviously some form of collaboration will be necessary at least to make the LISP WG aware of how other WGs plan to use LISP.

> We have to talk about that LISP signaling which could be used in TCMTF, as you say.

As I said before, these details can be documented elsewhere. If LISP is mentioned in the main draft, then it can also be stated that the re-use of the LISP signalling machinery in the context of TCMTF is explored in a different document.

ciao

L.

> > The first can be used  at the tunnelling layer, beside GRE/MPLS/L2TP (having
> > multiple options is always a good thing ;-) ), to perform the tunnelling. Some
> > parts of the LISP header might be exploited to carry TE information (e.g., the
> > particular form of mappings. The advantage is that there is already quite a bit
> > On 10 Oct. 2012, at 13:48 , Jose Saldana <[email-masked]> wrote:
> >
> > > Luigi,
> > >
> > >> De: [email-masked] [mailto:[email-masked]] En nombre
> > >> On 10 Oct. 2012, at 09:58 , Jose Saldana <[email-masked]> wrote:
> > >>
> > >> [email-masked]
> > [email-masked]

---

From: "Joel M. Halpern" <[email-masked]>
Date: Sun, 21 Oct 2012 14:56:04 -0400

As a general comment from a chair, a document which references LISP does 
not need to be done in he LISP WG.  (Telling us about it is 
appreciated.)  A document which defines how to use LISP to do something 
needs to be coordinated with the LISP WG.

Yours,
Joel

On 10/21/2012 10:13 AM, Luigi Iannone wrote:
> Hi Jose,
>
> comments inline.
>
>
> On 19 Oct. 2012, at 18:04 , Jose Saldana <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>> Luigi,
> Concerning whether or not to include it in the draft, may be it is not
> necessary to include details about LISP just mention that can be used.
> The usage of LISP, because of its experimental nature compare to other
> tunnelling options, can be documented in a different document, which, if
> people are interested, I can (with your help) write.
>
>
> Nevertheless, IMHO,  the LISP WG is chartered for the main spec. Other
> usages of LISP can be discussed in other, more pertinent, WGs. Obviously
> some form of collaboration will be necessary at least to make the LISP
> WG aware of how other WGs plan to use LISP.
>
> As I said before, these details can be documented elsewhere. If LISP is
> mentioned in the main draft, then it can also be stated that the re-use
> of the LISP signalling machinery in the context of TCMTF is explored in
> a different document.
>
> ciao
>
> L.
>
>
>> Thanks,
>> Jose
>> >De:[email-masked]
>> <mailto:[email-masked]>[mailto:[email-masked]
>> <mailto:[email-masked]>] En nombre de
>> >Luigi Iannone
>> >Para:[email-masked] <mailto:[email-masked]>
>> >CC:[email-masked] <mailto:[email-masked]>
>> > On 10 Oct. 2012, at 13:48 , Jose Saldana <[email-masked] <mailto:[email-masked]>> wrote:
>> >
>> > > Luigi,
>> > >
>> > >> De:[email-masked]
>> <mailto:[email-masked]>[mailto:[email-masked]] En nombre
>> > >> Para:[email-masked] <mailto:[email-masked]>
>> > >> CC:[email-masked] <mailto:[email-masked]>
>> > >> On 10 Oct. 2012, at 09:58 , Jose Saldana <[email-masked] <mailto:[email-masked]>> wrote:
>> > >>
>> > >>[email-masked] <mailto:[email-masked]>
>> >[email-masked] <mailto:[email-masked]>
> lisp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lisp
>