Subject: Re: [lisp] Last Call: <draft-ietf-lisp-eid-block-03.txt> (LISP EID Block) to Informational RFC

From: [email-masked] (Noel Chiappa)
Date: Wed, 21 Nov 2012 15:48:05 -0500 (EST)

> From: "Joel M. Halpern" <[email-masked]>

    > I have to say I rather lik[e] the i[d]ea of a query to the mapping
    > system that asks for a simple, small set of prefixes

It makes the code one heck of a lot more complicated, and for very little
benefit. If we have those engineering cycles available to burn, I have a
_long_ list of more valuable things we can spend them on (e.g. better
security, caching bindings in MRs, yadda yadda).

	Noel

---

From: Sander Steffann <[email-masked]>
Date: Wed, 21 Nov 2012 22:04:18 +0100

> benefit.

I think making sure that LISP is flexible enough to last a long time is a huge benefit.

This WG is designing a protocol that might well be the basis for a huge part of the future internet. Hard-coding prefixes in code now to save some development effort is the worst thing we can do. I know it's easy for me to say as I'm not writing the code, but compare a few days/weeks of extra development work to years and years of everybody being limited by a bad decision now.

- Sander