Subject: Re: [lisp] Last Call: <draft-ietf-lisp-eid-block-03.txt> (LISP EID Block) to Informational RFC

From: Luigi Iannone <[email-masked]>
Date: Thu, 15 Nov 2012 15:46:53 +0100

Hi Bert,

On 15 Nov. 2012, at 11:55 , Bert Wijnen (IETF) <[email-masked]> wrote:

[snip]
> 
> So it is not asking just a /16 but also asking for reservation of a /12.
> 
> Pretty big space.
> 
> And in the list of reasons, I mainly read that it is "sufficiently large",
> but not much about why it needs to be this big. Why would a smaller
> allocation not be sufficient?
> 

Well, to keep it short, the WG felt that /16 is the "right size", and that if the growth of LISP would be so important as to need a bigger space would be nice to have it contiguous (so implementations can just change the prefix length). 

Luigi

> Bert

---

From: "Bert Wijnen (IETF)" <[email-masked]>
Date: Thu, 15 Nov 2012 11:55:16 +0100

On Tue, Nov 13, 2012 at 3:45 PM, The IESG <iesg-secretary at ietf.org> wrote:
 >
 > The IESG has received a request from the Locator/ID Separation Protocol
 > WG (lisp) to consider the following document:
 > - 'LISP EID Block'
 >   <draft-ietf-lisp-eid-block-03.txt> as Informational RFC
 >
 > The IESG plans to make a decision in the next few weeks, and solicits
 > final comments on this action. Please send substantive comments to the
 > ietf at ietf.org mailing lists by 2012-11-27. Exceptionally, comments may be
 > sent to iesg at ietf.org instead. In either case, please retain the
 > beginning of the Subject line to allow automated sorting.
 >
 > Abstract
 >
 >
 >    This is a direction to IANA to allocate a /16 IPv6 prefix for use
 >    with the Locator/ID Separation Protocol (LISP).  The prefix will be
 >    used for local intra-domain routing and global endpoint
 >    identification, by sites deploying LISP as EID (Endpoint IDentifier)
 >    addressing space.

Mmm... In section 5 it states:

    The working group reached consensus on an initial allocation of a /16
    prefix out of a /12 block which is asked to remain reserved for
    future use as EID space.  The reason of such consensus is manifold:

Pretty big space.

Bert

---

From: "Bert Wijnen (IETF)" <[email-masked]>
Date: Thu, 15 Nov 2012 15:46:53 +0100

Nice to try and keep it short.

But I was hoping for some more detail and explanation.
I have not followed the discussions (if any) in the WG
so I may be missing the reasons why you need this much
space. I would hope that the WG (if they have consensus
(which may be something different than "the WG felt"))
could elaborate or summarize the discussions that lead
to the conclusion that this amount of space is needed
and makes sense.

Pointers to the WG mlist discussions where the pros
and cons of various prefixes sizes are discussed or
summarize would also be welcome.

Bert