Subject: Re: [lisp] Comments on https://datatracker.ietf.org/doc/html/draft-ietf-lisp-mn-10

From: Vasilenko Eduard <[email-masked]>
Date: Thu, 12 Aug 2021 17:11:41 +0000

One additional comment:
4. I have seen assumptions that Map server and proxy to Non-LISP are on the same box. It is a potential bottleneck in the future.
DHCP would deliver only 1 Map Server IP to RLOC. Hence all overlays would share the same Map Server.
Proxy is a router with a low capacity CPU. It could become a bottleneck if LISP implementation would become big enough.
It is better to assume initially the general case that Map Server and Proxy are different boxes (not collocated).

Eduard
From: Vasilenko Eduard
Sent: Thursday, August 12, 2021 7:23 PM
To: [email-masked]' <[email-masked]>
Subject: Comments on https://datatracker.ietf.org/doc/html/draft-ietf-lisp-mn-10

Hi Guru,
I have looked subject and have a few comments:

1.       The draft does mention a few times "without triangle routing in the data path".
But section 7.4: "As a result, packets may be natively forwarded to non-LISP sites by an ITR (the return path will through a PITR, however, since the packet flow will be non-LISP site to LISP site)."
Do I understand right that it is exactly "triangle routing"? Encapsulation in both directions would be needed if you insist on "without triangle routing" or you could delete the requirement.

2.       All discussions are in the style that it is "handover", not "roaming". "Roaming" has been mentioned 28 times in the draft but it is exactly what was *not* implemented.
I mean: what if the next RLOC would be from a completely different administrative domain? What if not just link would be switched but Carrier would be switched?
IMHO: "roaming" is a mandatory case for the word "Mobile" in the title of the draft.
Please, at least rename "roaming" to "handover" till roaming would be proposed. It is better to be accurate with Mobile terminology.

3.       It has been mentioned that there is a requirement for "multi-homing", but it has not been discussed at all later.
IMHO: an additional section is needed to explain how "TCP connections to stay alive while roaming" - probably "multi-homing" should help with this.

Best Regards
Eduard Vasilenko
Senior Architect
Europe Standardization & Industry Development Department
Tel: +7(985) 910-1105, +7(916) 800-5506

---

From: Dino Farinacci <[email-masked]>
Date: Thu, 12 Aug 2021 10:20:40 -0700

> 4. I have seen assumptions that Map server and proxy to Non-LISP are on the same box. It is a potential bottleneck in the future.

That is a deployment decision and not an architectural requirement.

> DHCP would deliver only 1 Map Server IP to RLOC. Hence all overlays would share the same Map Server.

Not true. The map-server(s) are configured in ETRs. They can be distinct addresses or anycast addresses.

> Proxy is a router with a low capacity CPU. It could become a bottleneck if LISP implementation would become big enough.

The PxTR needs to be built (by equipment vendors) like any other type of router and the capacity depends where it is deployed and the speed of links and aggregation of traffic comes to it. Clustering solutions make PxTRs scale.

> It is better to assume initially the general case that Map Server and Proxy are different boxes (not collocated).

Yes, it is assumed by default and co-locating it is a deployment decision.

Dino