Subject: Re: [lmap] Comments on draft-schulzrinne-lmap-requirements-00 - file formats and retrieval

From: Henning Schulzrinne <[email-masked]>
Date: Mon, 5 Nov 2012 01:12:53 +0000

Inline, in color, since Outlook doesn't do >.

________________________________________
From: [email-masked] [[email-masked]] on behalf of Shane Amante [[email-masked]]
Sent: Tuesday, September 25, 2012 12:06 PM
To: [email-masked]
Subject: [lmap] Comments on draft-schulzrinne-lmap-requirements-00

1) It seems critical to look at creation of a data model and/or file format that allows this architecture to bundle together *both* the measurement parameters/criteria used as input to a measurement test /and/ the measurement results collected as part of that particular measurement run. This will be critical if/when measurement results are analyzed historically, particularly by third-parties (e.g.: researchers) who may not have originally initiated the tests.

If an existing format (e.g., IPFIX) is used for exchange, this might solve itself. My inclination would be to stick as close as possible to the on-the-wire format, with record delimiters, as this avoids having to evolve two formats or worry about that new on-the-wire capabilities can't be represented in the file, which would obviously be rather unpleasant.

3) The draft doesn't appear to mention anything about providing an ability for entities to query for and attain historical measurements that have already been collected. (With respect to "query for", again, it would be nice to have a data model that represented the measurement parameters used as input to a test so those could help winnow down the data sets that match a given criteria of interest that is to analyzed. See #1.) Presumably, this would be a valuable capability. Is this within the purview of the draft/architecture?

There seem to be two cases here: Retrieve the whole file (for which ftp or similar would presumably suffice) or a more elaborate query, as in "Give me all measurements for client X during the 6-7 pm UTC hour, measurement 42" or even "Give me all measurements ... that have a value greater than 55 ms." The latter seems to get awfully close to an SQL-like query language. Indeed, not too surprisingly, this is what the current FCC infrastructure uses. Or did you have something else in mind?

Henning

---

From: Robert Kisteleki <[email-masked]>
Date: Mon, 05 Nov 2012 09:14:41 +0100

As a meta-thread: either the mailing list is wonky, or Henning wrote about a
dozen or so emails lately with *many* different signatures :-)

Also: without quoting it's very difficult to follow which parts are from the
original mails. See below. Colors don't work well in text mails.

Robert

On 2012.11.05. 2:12, Henning Schulzrinne wrote:
> _______________________________________________
> lmap mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lmap
>

---

From: Henning Schulzrinne <[email-masked]>
Date: Mon, 5 Nov 2012 13:08:29 +0000

My apologies - our Outlook web client doesn't do standard > quoting, so I used HTML mark-up, which obviously did not survive the trip through the mailing list manager. I will try to re-send with more textual quoting.

(Private) suggestions on how to make responses work within the constraints of Outlook are appreciated.

________________________________________
From: Robert Kisteleki [[email-masked]]
Sent: Monday, November 05, 2012 3:14 AM
To: Henning Schulzrinne
Cc: Shane Amante; [email-masked]
Subject: Re: [lmap] Comments on draft-schulzrinne-lmap-requirements-00 - file formats and retrieval

Robert