Subject: [lmap] Terminology: Basic Elements

From: "STARK, BARBARA H" <[email-masked]>
Date: Wed, 2 Jan 2013 18:01:40 +0000

Beyond terminology for roles, I think there also needs to be some terminology for commonly discussed elements. I'm proposing the following:

Measurement: <we seem to talk about this a lot, so I won't try to define it; this term is *not* specific to "lmap" or large-scale performance measurements>
Measurement function: Code that instantiates what is specifically and directly needed to "do" a particular Measurement.
A Measurement can be a Passive Measurement or an Active Measurement. For Active Measurements, nothing is implied as to whether the Measurement function initiates or simply responds to messages sent from another Measurement function.

Measurement Agent (MA): A function that contains one or more Measurement functions. [I read a recommendation on this list not to use "client" and server", since often the same, um, "thing" can act both as initiator or responder, and the terms could be confusing in certain contexts. "Agent" was suggested. I think this term will occur often, so I gave it an abbreviation. In reading discussions on this list, there seems to be a need to distinguish between distinct Measurement functions and a collection of Measurement functions that could be called a "Measurement Agent".]

CPN Device: A physical device that exists inside the Customer Premises Network. A CPN Device can have 0, 1, or more Measurement Agents. [Consistent with my thinking that roles should be considered according to their relationship to the End User, I also think that we need to have an idea of "inside the CPN" and "outside the CPN".]
Network Element: A physical "device" that exists external to the CPN. E.g., network router, DSLAM, web server. A Network Element can have 0, 1, or more Measurement Agents.
User Interface: Allows a human being to access functionality or data. It could be locally or remotely displayed (in physical relationship to the functionality that generates the User Interface). For example, a screen on a CPN Device could be used to display locally, and a browser on a computer could be used to display remotely. [We haven't really touched on this explicitly, but we seem to come repeatedly to the question of how measurement data is made available to various people. When it comes to providing people with access to measurement data, the User Interface is an important concept.]

Barbara

---

From: Shane Amante <[email-masked]>
Date: Wed, 2 Jan 2013 14:29:49 -0700

Barbara,

Thanks also to you for reinitiating the conversation.  I've been thinking more about LMAP and wanted to get your (and, others) thoughts wrt a refinement of your proposed definitions below.

> A Measurement can be a Passive Measurement or an Active Measurement. For Active Measurements, nothing is implied as to whether the Measurement function initiates or simply responds to messages sent…

I'm wondering if we should further refine active measurements.  Specifically, I think there are probably two sub-cases:
a)  Automated (Not [Residential] End-User Initiated?) Active Measurement: An example here would be periodic (automated) active, network performance measurements that are "running in the background" for a "long" period of time, e.g.: days, weeks, months?, until shut-off. 
b)  Ad-hoc ([Residential] End-User initiated?) Active Measurement: An example here might be examples you've provided in the past where either an end-user, or some one acting on their behalf, initiates a one-time, ad-hoc ping, traceroute, "speedtest", ICSI NetAlyzer or other diagnostic program to "measure" some aspect(s) of performance.

FWIW, perhaps such a classification (or, start of one) may help us focus LMAP work on case (a) above, where end-users won't typically be involved beyond, say, initially consenting to have such testing done using their device(s), e.g.: "opt-in".

I'm sure we can come up with much more precise definitions than what I've provided above, but hopefully they are enough to grasp the concept of differentiating between the scope of measurements LMAP (or, really, participants on the mailing list) want to or should focus on.

Thanks,

-shane

> _______________________________________________
> lmap mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lmap
>

---

From: "Weil, Jason" <[email-masked]>
Date: Thu, 3 Jan 2013 10:39:14 -0500

Shane/Barbara,

This seems like a useful distinction for the two general active test
measurement cases and maps into the first two use cases from the LMAP
draft and the subsequent breakout LMAP Use Case draft.

Personally I like "User Initiated Active Measurement" or alternatively
"User On Demand Active Measurement" for the user controlled test cases
For the other "Coordinated Active Measurement" (Could easily substitute
Coordinated with "Managed" or "Scheduled")

Comment on Term: The CPN Device definition should be generic enough and
maybe even explicitly state that this could include a computer/laptop in
addition to a stand alone device that seems implied here like a router,
modem or dongle.

General Comment: I also agree with Shane that we should focus on the
Coordinated LMAP use case in the current discussion as there does not
appear to be consensus on taking on the User Initiated testing in the IETF
at this time.

Thanks,

Jason

On 1/2/13 4:29 PM, "Shane Amante" <[email-masked]> wrote:

>Barbara,
>
>Thanks also to you for reinitiating the conversation.  I've been thinking
>more about LMAP and wanted to get your (and, others) thoughts wrt a
>refinement of your proposed definitions below.
>
>> Beyond terminology for roles, I think there also needs to be some
>>terminology for commonly discussed elements. I'm proposing the following:
>>
>> Measurement: <we seem to talk about this a lot, so I won't try to
>>define it; this term is *not* specific to "lmap" or large-scale
>>performance measurements>
>> Measurement function: Code that instantiates what is specifically and
>>directly needed to "do" a particular Measurement.
>> A Measurement can be a Passive Measurement or an Active Measurement.
>>For Active Measurements, nothing is implied as to whether the
>>Measurement function initiates or simply responds to messages sent from
>>another Measurement function.
>
>I'm wondering if we should further refine active measurements.
>Specifically, I think there are probably two sub-cases:
>a)  Automated (Not [Residential] End-User Initiated?) Active Measurement:
>An example here would be periodic (automated) active, network performance
>measurements that are "running in the background" for a "long" period of
>time, e.g.: days, weeks, months?, until shut-off.
>b)  Ad-hoc ([Residential] End-User initiated?) Active Measurement: An
>example here might be examples you've provided in the past where either
>an end-user, or some one acting on their behalf, initiates a one-time,
>ad-hoc ping, traceroute, "speedtest", ICSI NetAlyzer or other diagnostic
>program to "measure" some aspect(s) of performance.
>
>FWIW, perhaps such a classification (or, start of one) may help us focus
>LMAP work on case (a) above, where end-users won't typically be involved
>beyond, say, initially consenting to have such testing done using their
>device(s), e.g.: "opt-in".
>
>I'm sure we can come up with much more precise definitions than what I've
>provided above, but hopefully they are enough to grasp the concept of
>differentiating between the scope of measurements LMAP (or, really,
>participants on the mailing list) want to or should focus on.
>
>Thanks,
>
>-shane
>
>
>
>> Measurement Agent (MA): A function that contains one or more
>>Measurement functions. [I read a recommendation on this list not to use
>>"client" and server", since often the same, um, "thing" can act both as
>>initiator or responder, and the terms could be confusing in certain
>>contexts. "Agent" was suggested. I think this term will occur often, so
>>I gave it an abbreviation. In reading discussions on this list, there
>>seems to be a need to distinguish between distinct Measurement functions
>>and a collection of Measurement functions that could be called a
>>"Measurement Agent".]
>>
>> CPN Device: A physical device that exists inside the Customer Premises
>>Network. A CPN Device can have 0, 1, or more Measurement Agents.
>>[Consistent with my thinking that roles should be considered according
>>to their relationship to the End User, I also think that we need to have
>>an idea of "inside the CPN" and "outside the CPN".]
>> Network Element: A physical "device" that exists external to the CPN.
>>E.g., network router, DSLAM, web server. A Network Element can have 0,
>>1, or more Measurement Agents.
>> User Interface: Allows a human being to access functionality or data.
>>It could be locally or remotely displayed (in physical relationship to
>>the functionality that generates the User Interface). For example, a
>>screen on a CPN Device could be used to display locally, and a browser
>>on a computer could be used to display remotely. [We haven't really
>>touched on this explicitly, but we seem to come repeatedly to the
>>question of how measurement data is made available to various people.
>>When it comes to providing people with access to measurement data, the
>>User Interface is an important concept.]
>>
>> Barbara
>>

This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Thu, 3 Jan 2013 23:16:49 +0000

In-line.
Barbara

> Personally I like "User Initiated Active Measurement" or alternatively "User
> On Demand Active Measurement" for the user controlled test cases For the
> other "Coordinated Active Measurement" (Could easily substitute
<bhs> I agree with having some sort of distinction, but I'm not sure if user-initiation is the right distinction. Some ISPs have web sites where the user can log in and initiate on-demand tests against their line. Since the tests are actually done from the ISP, I would still call them coordinated and perhaps even managed. To me, the distinction is whether the End User is initiating the testing using Measurement Agents that are wholly managed and controlled by the End User. The End User-owned Measurement Agent might allow scheduled or on-demand testing.

> addition to a stand alone device that seems implied here like a router,
<bhs> It was my intention that "CPN Device" should include every single IP-connected device inside the Customer Premises Network. We should certainly make that explicit. I was also wanting to include mobile devices connected to a mobile network (not in-home Wi-Fi) in the definition.  

> appear to be consensus on taking on the User Initiated testing in the IETF at
> this time.
<bhs> I definitely agree that we don't need to focus on Measurement Agents that are managed/controlled by the End User. In addition, I agree that we don't need to describe how to provide End Users with access to controlled-by-other-entity Measurement Agent functionality and data. It should certainly be possible for such access to be provided, if desired. It just isn't very hard to do, so not really something that needs focus. Such access doesn't necessarily need to involve "initiation" of tests, and it could even provide results of passive Measurements. 
 
> >Thanks also to you for reinitiating the conversation.  I've been
> >thinking more about LMAP and wanted to get your (and, others) thoughts
> >wrt a refinement of your proposed definitions below.
> >
> >>performance measurements>  Measurement function: Code that
> >>instantiates what is specifically and directly needed to "do" a
> >>particular Measurement.
> >>Measurement function initiates or simply responds to messages sent
> >>from another Measurement function.
> >
> >An example here would be periodic (automated) active, network
> >performance measurements that are "running in the background" for a
> >"long" period of time, e.g.: days, weeks, months?, until shut-off.
> >ad-hoc ping, traceroute, "speedtest", ICSI NetAlyzer or other
> >diagnostic program to "measure" some aspect(s) of performance.
> >
> >FWIW, perhaps such a classification (or, start of one) may help us
> >focus LMAP work on case (a) above, where end-users won't typically be
> >involved beyond, say, initially consenting to have such testing done
> >using their device(s), e.g.: "opt-in".
> >
> >I'm sure we can come up with much more precise definitions than what
> >I've provided above, but hopefully they are enough to grasp the concept
> >of differentiating between the scope of measurements LMAP (or, really,
> >>Measurement functions. [I read a recommendation on this list not to
> >>use "client" and server", since often the same, um, "thing" can act
> >>both as initiator or responder, and the terms could be confusing in
> >>certain contexts. "Agent" was suggested. I think this term will occur
> >>often, so I gave it an abbreviation. In reading discussions on this
> >>list, there seems to be a need to distinguish between distinct
> >>Measurement functions and a collection of Measurement functions that
> >>could be called a "Measurement Agent".]
> >>
> >> CPN Device: A physical device that exists inside the Customer
> >>Premises Network. A CPN Device can have 0, 1, or more Measurement
> Agents.
> >>to their relationship to the End User, I also think that we need to
> >>have an idea of "inside the CPN" and "outside the CPN".]  Network
> >>Element: A physical "device" that exists external to the CPN.