Subject: [lmap] a note on buffer bloat

From: "Bugenhagen, Michael K" <[email-masked]>
Date: Mon, 4 Feb 2013 16:52:05 +0000

James, Marc,

At the last IETF meeting we had a discussion on buffer bloat now being an issue.
I'm now hearing that this may have been part of some newly deployed technologies and the tweaks to those implementations have fixed the issue.

I'm hoping that someone can validate that in the Next IETF meeting, was it a transitional problem, or is it still an issue.

Thanks,
Mike

---

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 4 Feb 2013 18:58:47 +0200

Hi Michael, 

have a look at the recently updated congestion control workshop were we discussed this and similar issues:
http://tools.ietf.org/html/draft-iab-cc-workshop-report-00

Ciao
Hannes

On Feb 4, 2013, at 6:52 PM, Bugenhagen, Michael K wrote:

> I’m now hearing that this may have been part of some newly deployed technologies and the tweaks to those implementations have fixed the issue.
>  
> I’m hoping that someone can validate that in the Next IETF meeting, was it a transitional problem, or is it still an issue.
>  
> Thanks,
> Mike
> _______________________________________________
> lmap mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lmap

---

From: Henning Schulzrinne <[email-masked]>
Date: Mon, 4 Feb 2013 17:23:08 +0000

For one recent perspective, see:

Mark Allman.  Comments on Bufferbloat, ACM SIGCOMM Computer Communication Review, 43(1), January 2013.

http://www.icir.org/mallman/papers/bufferbloat-ccr13.pdf

My summary would be: it occurs, but may not be quite as common as sometimes claimed. There are also some fairly easy fixes (smaller buffers) and some more complicated ones (new TCP).

________________________________
From: [email-masked] [[email-masked]] on behalf of Bugenhagen, Michael K [[email-masked]]
Sent: Monday, February 04, 2013 11:52 AM
To: 'James Miller'; Marc Linsner
Cc: [email-masked]'; 'Al Morton'; [email-masked]
Subject: [lmap] a note on buffer bloat

James, Marc,

Thanks,
Mike

---

From: Nicholas Weaver <[email-masked]>
Date: Mon, 4 Feb 2013 09:42:51 -0800

> My summary would be: it occurs, but may not be quite as common as sometimes claimed. There are also some fairly easy fixes (smaller buffers) and some more complicated ones (new TCP).

It also depends on how much latency under load you can tolerate.

If you can tolerate 100ms of additional latency under load (the 90% solution) there is a ton of available options out there, from just shorter buffers sized in delays to cool stuff like Remote Active Queue Management.

If you need 20ms or less of latency under load, you need multiple queues in the bottleneck and smart queue management that can recognize (or is suitably marked) the realtime traffic and make sure it doesn't see induced delays when the bottleneck is congested.

---

From: "Bugenhagen, Michael K" <[email-masked]>
Date: Mon, 4 Feb 2013 18:30:21 +0000

Henning,

   Yes that reflects what I heard, the best practices now reflect the smaller settings and only operators who haven't picked that up yet would still have a problem.

 Good test problem to solve (at test that could conclude buffer bloat), but the problem may now be much less prolific, that is unless a new technology brings the issue back.

Regards, and thanks,
Mike

-----Original Message-----
From: Henning Schulzrinne [mailto:[email-masked]] 
Sent: Monday, February 04, 2013 11:23 AM
To: Bugenhagen, Michael K; 'James Miller'; Marc Linsner
Cc: [email-masked]'; 'Al Morton'; [email-masked]
Subject: RE: a note on buffer bloat

James, Marc,

Thanks,
Mike

---

From: Henning Schulzrinne <[email-masked]>
Date: Mon, 4 Feb 2013 19:11:11 +0000

I suspect there are still a fair number of cable/DSL modems out there that have excessive buffers and offer no DiffServ; I see bufferbloat more as a network failure mode rather than an average performance issue.

________________________________________
From: Bugenhagen, Michael K [[email-masked]]
Sent: Monday, February 04, 2013 1:30 PM
To: Henning Schulzrinne; 'James Miller'; Marc Linsner
Cc: [email-masked]'; 'Al Morton'; [email-masked]
Subject: RE: a note on buffer bloat

Henning,

Regards, and thanks,
Mike

-----Original Message-----
From: Henning Schulzrinne [mailto:[email-masked]]
Sent: Monday, February 04, 2013 11:23 AM
To: Bugenhagen, Michael K; 'James Miller'; Marc Linsner
Cc: [email-masked]'; 'Al Morton'; [email-masked]
Subject: RE: a note on buffer bloat

James, Marc,

Thanks,
Mike

---

From: "Sharam Hakimi" <[email-masked]>
Date: Mon, 4 Feb 2013 15:57:32 -0500

I would say that it is becoming more of a congestion control issue. With
home networks capable of autonomous communication (gaming, internal
streaming, etc.) while other devices communicate with the internet these
modems/routers have to have some buffer in order to operate effectively.

Sharam

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Henning Schulzrinne
Sent: Monday, February 04, 2013 2:11 PM
To: Bugenhagen, Michael K; 'James Miller'; Marc Linsner
Cc: [email-masked]; [email-masked]'; 'Al Morton'
Subject: Re: [lmap] a note on buffer bloat

I suspect there are still a fair number of cable/DSL modems out there
that have excessive buffers and offer no DiffServ; I see bufferbloat
more as a network failure mode rather than an average performance issue.

Henning,

   Yes that reflects what I heard, the best practices now reflect the
smaller settings and only operators who haven't picked that up yet would
still have a problem.

 Good test problem to solve (at test that could conclude buffer bloat),
but the problem may now be much less prolific, that is unless a new
technology brings the issue back.

Regards, and thanks,
Mike

-----Original Message-----
From: Henning Schulzrinne [mailto:[email-masked]]
Sent: Monday, February 04, 2013 11:23 AM
To: Bugenhagen, Michael K; 'James Miller'; Marc Linsner
Cc: [email-masked]'; 'Al Morton'; [email-masked]
Subject: RE: a note on buffer bloat

Mark Allman.  Comments on Bufferbloat, ACM SIGCOMM Computer
Communication Review, 43(1), January 2013.

My summary would be: it occurs, but may not be quite as common as
sometimes claimed. There are also some fairly easy fixes (smaller
buffers) and some more complicated ones (new TCP).

________________________________
From: [email-masked] [[email-masked]] on behalf of
Bugenhagen, Michael K [[email-masked]]
Sent: Monday, February 04, 2013 11:52 AM
To: 'James Miller'; Marc Linsner
Cc: [email-masked]'; 'Al Morton'; [email-masked]
Subject: [lmap] a note on buffer bloat

James, Marc,

At the last IETF meeting we had a discussion on buffer bloat now being
an issue.
I'm now hearing that this may have been part of some newly deployed
technologies and the tweaks to those implementations have fixed the
issue.

I'm hoping that someone can validate that in the Next IETF meeting, was
it a transitional problem, or is it still an issue.

Thanks,
Mike

---

From: "Livingood, Jason" <[email-masked]>
Date: Thu, 7 Feb 2013 21:54:47 +0000

I have no idea whatsoever if it will be ready on time or not, but a few of us are working on buffer bloat demo for bits and bytes. Still lots to do among other priorities but we're working on it. :-)

- Jason

On 2/4/13 11:52 AM, "Bugenhagen, Michael K" <[email-masked]<mailto:[email-masked]>> wrote:

James, Marc,

Thanks,
Mike