Subject: [lmap] LMAP: Voluntary or compulsory?

From: Benoit Claise <[email-masked]>
Date: Thu, 07 Mar 2013 12:04:59 +0100

Dear all,

Another clarifying question: are those LMAP measurements based on 
voluntary participation or not?
Or maybe it depends on the use cases described in 
draft-linsner-lmap-use-cases-02

   2  Use Cases . . . . . . . . . . . . . . . . . . . . . . . . . . .  3
      2.1 Internet Service Provider (ISP) Use Case . . . . . . . . . .  3
      2.2 End User Network Diagnostics . . . . . . . . . . . . . . . .  4
      2.3 Multi-provider Network Measurements  . . . . . . . . . . . .  4
      2.4 Over the Top Providers . . . . . . . . . . . . . . . . . . .  4
      2.5 Regulators . . . . . . . . . . . . . . . . . . . . . . . . .  5

Some more discussions, on the mailing list or during the BoF, on this 
topic would be appreciated.

Regards, Benoit

---

From: "Bugenhagen, Michael K" <[email-masked]>
Date: Thu, 7 Mar 2013 22:10:59 +0000

Benoit,

    I believe the answer here is yes, both.   If a Service provider wants to obtain the performance evaluations in a smaller region, then they need to be able to conduct testing without the additional work of obtaining samples via some large continual campaign to recruit volunteers.   This also directly infers that any and all testing can not have an impact on the customers ability to use the service.   

    Given a customer themself may want to run a test, there should be a method to allow them to do so even with their own equipment, or they could be given the capability to execute a test if the provider has placed equipment. This however directly infers that the customer has the ability to repeat the same test as the service provider or we end up with apples and oranges results.

Mike

Sent from my iPhone

On Mar 7, 2013, at 5:09 AM, "Benoit Claise" <[email-masked]> wrote:

> Dear all,
> 
> Another clarifying question: are those LMAP measurements based on voluntary participation or not?
> Or maybe it depends on the use cases described in draft-linsner-lmap-use-cases-02
> 
> Some more discussions, on the mailing list or during the BoF, on this topic would be appreciated.
> 
> Regards, Benoit
> 
> _______________________________________________
> lmap mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lmap

---

From: Alissa Cooper <[email-masked]>
Date: Mon, 11 Mar 2013 11:31:45 -0400

+1

IMO the LMAP framework should be able to accommodate all of the modes of operation that Mike describes: (1) customers voluntary signing up to join a panel that incurs ongoing measurements over time, (2) operators conducting measurements across entire customer segments or all customers, and (3) customers triggering their own measurement tests at will. Depending on the data collected, out-of-band mechanisms for informing customers about the measurements taking place and for obtaining customer sign-up (case 1) or consent (case 2) will likely be required/desired.

Alissa