Subject: [lmap] Measurement Cycle term for draft-eardley-lmap-terminology-00.txt

From: "MORTON JR., ALFRED C (AL)" <[email-masked]>
Date: Mon, 15 Apr 2013 09:27:47 -0400

Hi Juergen,

Thanks for your comments on the Terminology draft.
One clarification I'd like to ask (changing subject line):

you wrote:
> l) We found it very useful to talk about something we call a
>    Measurement Cycle.
> 
>    Measurement Cycle: A collection of Measurement Results collected
>    for over a given time period and/or for a specific purpose,
>    typically with a consistent set of measurement parameters and a
>    consistent Measurement Schedule.
> 
>    We found it very helpful to have data tagged with a Measurement
>    Cycle identifier when it is received by the collector. This allows
>    to filter out data easily during data analysis without having to
>    track when an updated was actually pushed to an MA.

(in the last line above, what was updated? the definition of the Cycle?)

It seems that the Measurement Cycle refers only to a set of Results
which are the product of an Instruction (as we've currently defined it):

   Instruction: The description of Measurement Tasks to perform and the
   details of the Report to send; a specific instance of the Data Model.
   The Instruction is sent by a Controller to a Complete-MA.

So, if there was a unique identifier for each Instruction, and all MAs
operating that Instruction tagged their results with that same identifier
when reporting to the Collector, would it satisfy the goal for a 
Measurement Cycle identifier?

Alternatively, we could re-name the term Instruction as Measurement Cycle,
if that's more descriptive.

regards,
Al

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 15 Apr 2013 15:55:36 +0200

> if that's more descriptive.

I think Instruction is a good term, I would not rename it. The way we
use a Measurement Cycle it is really a tag carried with an Instruction
to a device. Now, if a device restarts and looses context, it will get
a new Instruction to reinstall the state driving the measurements -
however as long as we are in the same measurement cycle, this new
Instruction will carry the same tag. There might also be Instruction
within the same Measurement Cycle that reschedule measurements without
really affecting the measurement itself (e.g. you move tests forward
or backward in the schedule to make room for other measurements).
Hence, I think a Measurement Cycle has not a 1:1 relationship to an
Instruction but is really a tag carried in an Instruction and echoed
back to the Collector.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: <[email-masked]>
Date: Thu, 18 Apr 2013 08:48:16 +0100

I quite like Measurement Cycle. Seems it could be a useful approach

> > >    consistent Measurement Schedule.

Is it best to define Measurement Cycle as
- a set of Measurement Tasks (which are expected to produce comparable results, most likely because they all use the same Measurement Method with the same parameters)
- a collection of Measurement Results produced by those Tasks
- a tag, which is attached to all those Results inside the Report (the tag earlier being set in an Instruction)

I attempted to include a bit of all 3...

Measurement Cycle: A collection of Measurement Tasks that are expected to produce comparable Measurement Results, which are all tagged with the same "cycle identifier" in Report(s). Typically the Measurement Tasks all operate the same Measurement Method with the same values for its parameters.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Juergen Schoenwaelder
> Sent: 15 April 2013 14:56
> To: MORTON JR., ALFRED C (AL)
> Cc: [email-masked]
> Subject: Re: [lmap] Measurement Cycle term for draft-eardley-lmap-
> terminology-00.txt
> 
> > operating that Instruction tagged their results with that same
> > identifier when reporting to the Collector, would it satisfy the goal
> > for a Measurement Cycle identifier?
> >
> > Alternatively, we could re-name the term Instruction as Measurement
> > Cycle, if that's more descriptive.
> 
> really affecting the measurement itself (e.g. you move tests forward or
> backward in the schedule to make room for other measurements).
> _______________________________________________
> lmap mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lmap

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 18 Apr 2013 09:50:45 +0200

> Measurement Cycle: A collection of Measurement Tasks that are expected to produce comparable Measurement Results, which are all tagged with the same "cycle identifier" in Report(s). Typically the M…

Works for me.

/js