Subject: [lmap] Bootstrap protocol (was RE: comments on draft-eardley-lmap-terminology-00.txt)

From: <[email-masked]>
Date: Thu, 18 Apr 2013 09:35:53 +0100

> 
> k) I think the last paragraph in section 4 should not be there. In
>    fact, I likely won't agree to it as it goes far beyond talking
>    about terminology. So I propose to remove this paragraph and
>    instead to define the term Bootstrap Protocol, e.g. like this:
> 
>    Bootstrap Protocol: A protocol that initializes a Complete-MA
>    with the information necessary to talk to a Controller.
> 
>    If you want to keep text in section 4, you may mention that there
>    might be different bootstrap protocols and that organizations other
>    than the IETF might design their own bootstrap protocols (e.g., BBF
>    based on TR-069).
> 

Should standardising a Bootstrap Protocol be outside lmap wg's initial scope?
I tend to think it should be outside. For many types of device, as you say there'll be other organisations that define their own bootstrap protocols. 
There may well be some types of device that need the ietf to define a bootstrap protocol, but I think that can be a phase 2 activity, so that in the initial work we concentrate on things that are required for all devices.

Ps your definition of Bootstrap Protocol works for me.

Thanks
phil

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 18 Apr 2013 11:05:12 +0200

> There may well be some types of device that need the ietf to define a bootstrap protocol, but I think that can be a phase 2 activity, so that in the initial work we concentrate on things that are r…

I assume there will be multiple different Bootstrap Protocols since
they tend to be specific to certain deployments. As such, I am fine to
leave Bootstrap Protocols out of the first phase of LMAP. However,
LMAP should clearly define in the first phase what a Bootstrap
Protocols needs to deliver for LMAP to work.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "MORTON JR., ALFRED C (AL)" <[email-masked]>
Date: Thu, 18 Apr 2013 07:37:51 -0400

reply at the bottom...

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Juergen Schoenwaelder
> Sent: Thursday, April 18, 2013 5:05 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [lmap] Bootstrap protocol (was RE: comments on draft-eardley-
> lmap-terminology-00.txt)
> 
> > I tend to think it should be outside. For many types of device, as you
> say there'll be other organisations that define their own bootstrap
> protocols.
> > There may well be some types of device that need the ietf to define a
> bootstrap protocol, but I think that can be a phase 2 activity, so that in
> the initial work we concentrate on things that are required for all
> devices.
> 

Perhaps we could define the more generic "Bootstrap Process"
and identify the information other LMAP protocols need (as Juergen said). 
This could be loaded at manufacture, updated locally via USB port, 
or orchestrated via a protocol in some cases, so it need not always
be a protocol (as we define protocol here in IETF). 

This way, we can recognize the process and put the exact definition
of one or more protocols aside, too.

Al

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 18 Apr 2013 16:37:06 +0200

> of one or more protocols aside, too.

Works for me.

/js