Subject: Re: [lmap] lmap charter - draft 2

From: Henning Schulzrinne <[email-masked]>
Date: Mon, 3 Jun 2013 21:40:51 +0000

Currently, both sets of devices (or, rather, the measurement devices ["white boxes"] directly attached to them) use the exact same (proprietary) protocol, so there's existence proof that this works in practice. We're talking IP-level measurements, not PHY, so I'm not sure why the nature of the wireline service would make a major difference. It would be helpful if you could state the technical reason why this should matter, not just in the abstract. All the IPPM measurements, as well as the MBA measurements, are IP-and-above (ICMP, UDP, TCP, etc.), and the measurement end point is typically not on the same infrastructure.

-----Original Message-----
From: STARK, BARBARA H [mailto:[email-masked]] 
Sent: Friday, May 31, 2013 9:16 AM
To: Henning Schulzrinne; 'Romascanu, Dan (Dan)'; [email-masked]
Subject: RE: lmap charter - draft 2

> A good example are DOCSIS cable modems - consumers can and do buy 
> those at retail, and they are portable across ISPs. The same is true 
> for DSL modems in Europe, which are routinely bought from third 
> parties (FritzBox being one example).

And is the same set of protocols the right answer for both of these?

I suggested to Shane that an "architecture profile" or "device profile" (as done in v6ops) might be appropriate, that identified the set of protocols for a particular environment, rather than suggesting that the same protocol was "right" for all situations.

Personally, I would also think that a DOCSIS modem device profile would be better defined by CableLabs, who has a critical mass of people who understand cable environments, and who could also really and truly ensure interoperability through their testing program. Similarly, I think a European DSL modem device profile would be better defined by HGI, who has a critical mass of experts understanding their environment, and who has a certification program that can truly ensure interoperability. If the providers who operate in these environments want IETF to define device profiles for them, I have no objection to that. But if they want to do their profiles in CableLabs or HGI, I don't think IETF needs to insist on inserting itself into that process. 
Barbara

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Tue, 4 Jun 2013 13:40:15 +0000

> Currently, both sets of devices (or, rather, the measurement devices ["white
> boxes"] directly attached to them) use the exact same (proprietary)
> protocol, so there's existence proof that this works in practice. We're talking
> IP-level measurements, not PHY, so I'm not sure why the nature of the
> wireline service would make a major difference. It would be helpful if you
> could state the technical reason why this should matter, not just in the
> abstract. All the IPPM measurements, as well as the MBA measurements,
> are IP-and-above (ICMP, UDP, TCP, etc.), and the measurement end point is
> typically not on the same infrastructure.

It's not the nature of the underlying PHY service that makes a difference. It's the nature of the entity who intends to deploy measurement capabilities: what protocols are they familiar and comfortable and experienced with, what protocols are currently well-proven and used in their embedded base of equipment, what protocols are used by systems already integrated into their operations network, what protocols do they currently have certification labs built for, what protocols have many vendors offering systems and solutions to those entities, what protocols are offered by vendors that the entities are comfortable with (because of the quality of work, level of support), in what SIGs are those entities' needs and requirements actively listened, in what SIGs does a critical mass of expertise exist in that understands the operational environments of such entities, etc. 

The point that a proprietary protocol was successfully used is indeed existence proof that it does not matter what protocol an entity or SIG chooses for devices deployed or managed by members of that SIG (as long as the protocol is able to do the job). 

And the point that many (certainly not all) existing devices and other equipment may be upgradable to support lmap measurements, using their existing management interfaces and systems, should not be discounted as "undesirable", since this is potentially a very cost-effective way to support lmap measurements. Even where re-using existing devices is not possible, it may still be possible to re-use existing OA&M systems that have already been integrated into an entity's OA&M network, which would be more cost-effective than deploying new systems that require new interfaces be built to other O&AM systems of the entity. Many operators already have systems designed for collecting measured data from massive quantities of end devices. 

Demanding that these operators go to enormous expense to deploy and integrate new systems, when existing systems may be able to do the job, doesn't sit well with me as a consumer. As a consumer, I don't want my broadband bill going up just because someone dictated that measurements had to be reported using IPFIX instead of IPDR. Since it's already not possible to use a DOCSIS modem on a European operator's DSL network, the fact that DOCSIS modems bought at a US electronics store and DSL modems bought in Europe may use different protocols for control and reporting of measurement data is not something that needs to be prevented. The organizations that already specify and certify these devices (CableLabs and HGI, respectively) need to continue to do so.
Barbara