Subject: [lmap] Feedback on draft-eardley-lmap-framework-01

From: "Weil, Jason" <[email-masked]>
Date: Wed, 24 Jul 2013 18:05:40 -0400

Here are my comments and questions on the draft:

Section 1. [use-cases]
Regulators: I would drop the word 'several' from this description. It reads as if regulators are targeting certain providers purposefully out of a group which is not typically the case.
---
The example given in Diversity seems to be another example supporting the interoperability benefits that come with the earlier bullet on Standardization.  A MA on a CPE router and another MA on a WiFi device behind the router or a MA running as a software client on a laptop/desktop might be  a better example?
---
Section 2.

   The MA functions are implemented either in specialised hardware or as
   code on general purpose devices like a PC, tablet or smartphone.  The
   Measurement Peer may be an LMAP device or a normal, non-LMAP device
   (for example if the MA measures the time for a DNS response or a
   webpage download from www.example.com).

A Measurement Peer is an LMAP functional element. It would seem to me that as long as an entity performs in the role of a Measurement Peer it would be considered an LMAP device whether or not it was purpose built for a single test or simply performing as a Measurement Peer based on its normal operational role such as a recursive resolver. As such I don’t believe a Measurement Peer would ever be considered a non-LMAP device if it was being used for a test by the MA.

--

Section 3.

3.2. Each MA may only have a single Controller at any point in time – The 'may' in this sentence makes me wonder where the constraint exists. Is the constraint that it must only take direction from a single Controller at any given time?
--
The topic on NAT an firewalls suggesting a pull model may be better as a separate constraint topic by itself.

Thanks,

Jason

________________________________
This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.

---

From: <[email-masked]>
Date: Thu, 25 Jul 2013 15:51:46 +0100

Thanks!
In-line belwo
phil

From: [email-masked] [mailto:[email-masked]] On Behalf Of Weil, Jason
Sent: 24 July 2013 23:06
To: [email-masked]
Subject: [lmap] Feedback on draft-eardley-lmap-framework-01

Section 1. [use-cases]

   webpage download from www.example.com<http://www.example.com>).

A Measurement Peer is an LMAP functional element. It would seem to me that as long as an entity performs in the role of a Measurement Peer it would be considered an LMAP device whether or not it was purpose built for a single test or simply performing as a Measurement Peer based on its normal operational role such as a recursive resolver. As such I don't believe a Measurement Peer would ever be considered a non-LMAP device if it was being used for a test by the MA.

[phil] so I'll re-phrase something like "The Measurement Peer may be a special-purpose device or a device performing its normal operational role (for example....

--

Section 3.

3.2. Each MA may only have a single Controller at any point in time - The 'may' in this sentence makes me wonder where the constraint exists. Is the constraint that it must only take direction from a single Controller at any given time?

[phil] yes

[phil] seems a good suggestion to me

Thanks,

Jason