Subject: [lmap] comments on draft-eardley-lmap-framework-02

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 23 Jul 2013 13:02:18 +0000

Hi,

Here are a few comments at the first reading of draft-eardley-lmap-franework-02. I appreciate that this is one of the pre-wg-document contributions, so my comments and questions are rather high level than trying to point to details. 

1. I am confused by the way the I-D describes the interaction between controllers and MAs. In Section 3.2 I see: 

To avoid problems with NAT and firewalls, it is likely that the MA
   'pulls' the configuration from its Controller, as identified by the
   Initialiser.

But then in the diagram in Figure 1 the arrow points from the Controller to the MA, and later the examples of possible protocols in Section 5.3 include such 'push' protocols as SNMP and NETCONF. 

2. I have a problem imagining what the 'Initialiser' is. Is it a task (running where?) aiming to ensure consistent configuration of controllers in an LMAP system. Or another 'box' in the architecture, part of an hierarchical system, a 'box' not represented because it is out of the LMAP scope? If the later I would prefer to add it to the diagram, maybe together with the other non-LMAP entities (Subscriber Parameter Database, Results Database) so that we can have a full picture of the whole system, with clear representation of what is in scope for LMAP. 

3. Do we also need to include in the diagram (and discussion) some kind a certificate authority to ensure that controllers and MAs, MAs and peers, MA and collectors, are authenticated to each other, as the security considerations section demands. 

4. In a couple of instances OAM is wrongly expanded as Operations, Administrations and Management, and not as per BCP 161. 

5. In Section 5.1 there are a few instances where some procedures or blocks are being defined as 'out (or beyond) the scope of the IETF'. It would be more correct to say 'out of scope for LMAP' as we can make statements about what we do (or do not do) in LMAP but not for the IETF as a whole. 

Thanks and Regards, 

Dan
(as contributor)

---

From: <[email-masked]>
Date: Thu, 25 Jul 2013 14:34:33 +0100

> 2. I have a problem imagining what the 'Initialiser' is. Is it a task
> (running where?) aiming to ensure consistent configuration of
> controllers in an LMAP system. Or another 'box' in the architecture,
> part of an hierarchical system, a 'box' not represented because it is
> out of the LMAP scope? If the later I would prefer to add it to the
> diagram, maybe together with the other non-LMAP entities (Subscriber
> Parameter Database, Results Database) so that we can have a full
> picture of the whole system, with clear representation of what is in
> scope for LMAP.

The latter - a 'box' outside lmap scope. 
In the next version I'll battle with asci art to add a pic showing all the non-lmap entities. For a preview, see the framework slides (in wg meeting, similar ones in BoF)

One example, the 'box' could be an ACS which uses TR-069 to configure (ie lmap-initialise) a Broadband Forum compliant home gateway. Another example might be that the Measurement Agent is an app downloaded to your tablet, with pre-configuration information coded into the app. 

> 
> 3. Do we also need to include in the diagram (and discussion) some kind
> a certificate authority to ensure that controllers and MAs, MAs and
> peers, MA and collectors, are authenticated to each other, as the
> security considerations section demands.

I can add this - another 'box' outside lmap scope

> 
> 4. In a couple of instances OAM is wrongly expanded as Operations,
> Administrations and Management, and not as per BCP 161.

Thanks. (I actually did try to identify the correct ietf phrase and abbreviation - but failed!)
> 
> 5. In Section 5.1 there are a few instances where some procedures or
> blocks are being defined as 'out (or beyond) the scope of the IETF'. It
> would be more correct to say 'out of scope for LMAP' as we can make
> statements about what we do (or do not do) in LMAP but not for the IETF
> as a whole.

Ok

Thanks
phil