Subject: [lmap] draft-eardley-lmap-framework: Extensibility

From: "STARK, BARBARA H" <[email-masked]>
Date: Wed, 31 Jul 2013 10:43:19 +0000

I read through the current draft and had a comment on the inclusion of the "Extensible" bullet in the Introduction.

I can't find anything in the rest of the framework or the charter + deliverables that really has anything to do with extensibility; but if it is to be called out as a desirable feature in the Introduction, I would expect some discussion of how to achieve it or what's being done to work towards achieving it. Or don't call it out so strongly. Or call it out and state that while it is desirable, the current proposed framework does nothing to address it. 

Or state that extensibility of Measurement Methods is being provided by the ippm-defined registry (which will be a "living" registry?)?; and the lmap Information Model and protocols/data models will ensure that this extensibility of Measurement Methods is supported so MAs. I think that there's also the intention for MAs to be able to express to a controller which measurements they support / what they're capable of -- which helps in the area of extensibility. This would need to be in the information model. 

I prefer the last of these options, if that is what we're planning.

BTW, extensibility areas that aren't currently in scope of lmap are being able to upgrade Measurement Methods in a MA, or upgrade the MA software version. These would be functions of bootstrap/initialization, which aren't in scope.

---

From: <[email-masked]>
Date: Wed, 31 Jul 2013 13:57:37 +0100

Barbara

If I remember, when I wrote this 'extensibility' bullet in the Intro I had in mind the last of your options.
Will think about this more

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of STARK, BARBARA H [[email-masked]]
Sent: 31 July 2013 11:43
To: [email-masked]
Subject: [lmap] draft-eardley-lmap-framework: Extensibility

BTW, extensibility areas that aren't currently in scope of lmap are being able to upgrade Measurement Methods in a MA, or upgrade the MA software version. These would be functions of bootstrap/initialization, which aren't in scope.
_______________________________________________
lmap mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lmap