Subject: [lmap] Information Model Attributes - MA Identifier

From: "Carey, Timothy (Timothy)" <[email-masked]>
Date: Tue, 8 Oct 2013 22:23:08 +0000

In the July draft of the Information Model the Measurement Agent has an attribute for the Identifier that is referencing a MAC address.
In the past we have seen issues with MAC addresses as identifiers for devices (e.g, which address to use when a device has multiple MACs, devices without MAC Addresses).

One suggestion is to make this identifier a UUID based on RFC 4122
UUID

string(36:36)

Universally Unique Identifier. See [RFC4122].

Thoughts regarding this would be appreciated

BR,
Tim

---

From: <[email-masked]>
Date: Wed, 9 Oct 2013 08:21:40 +0100

The MA ID (Measurement Agent Identifier) is currently just expressed as a String in the Information Model. The MAC Address is a separate and different parameter in the model.

I think we were always imagining it might be a UUID.

Trevor.

Trevor Burbridge
Network Infrastructure & Innovation | BT Innovate & Design
Tel: 01473 645115
Fax: 01473 640929

This email contains BT information, which may be privileged or confidential. It's meant only for the individual(s) or entity named above. If you're not the intended recipient, note that disclosing, copying, distributing or using this information is prohibited. If you've received this email in error, please let me know immediately on the email address above. Thank you.
We monitor our email system, and may record your emails.
British Telecommunications plc
Registered office: 81 Newgate Street London EC1A 7AJ
Registered in England no: 1800000

From: [email-masked] [mailto:[email-masked]] On Behalf Of Carey, Timothy (Timothy)
Sent: 08 October 2013 23:23
To: [email-masked]
Subject: [lmap] Information Model Attributes - MA Identifier

string(36:36)

BR,
Tim

---

From: marcelo bagnulo braun <[email-masked]>
Date: Wed, 09 Oct 2013 09:27:46 +0200

Hi Tim,

I agree with you. I think our idea was to use UUID (moreover, in 
http://tools.ietf.org/html/draft-bagnulo-lmap-http-00 we already reflect 
that)

Regards, marcelo

El 09/10/13 00:23, Carey, Timothy (Timothy) escribió:
>
> In the July draft of the Information Model the Measurement Agent has 
> an attribute for the Identifier that is referencing a MAC address.
>
> In the past we have seen issues with MAC addresses as identifiers for 
> devices (e.g, which address to use when a device has multiple MACs, 
> devices without MAC Addresses).
>
> Universally Unique Identifier. See [RFC4122 <#R.RFC4122>].
>
> _______________________________________________
> lmap mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lmap

---

From: Brian Trammell <[email-masked]>
Date: Wed, 9 Oct 2013 09:29:11 +0200

hi Marcelo, Tim, all,

Ah, good. 

Note also that using UUIDs for MAs may have benefits for privacy as well, at least with respect to accidentally leaked identifiers: they cannot be correlated to SLAAC addresses or to device manufacturers as MAC addresses can.

Cheers,

Brian

On Oct 9, 2013, at 9:27 AM, marcelo bagnulo braun <[email-masked]> wrote:

> Hi Tim,
> 
> I agree with you. I think our idea was to use UUID (moreover, in http://tools.ietf.org/html/draft-bagnulo-lmap-http-00 we already reflect that)
> 
> Regards, marcelo
> 
>

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Wed, 9 Oct 2013 08:14:51 -0400

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Brian Trammell
...
> Note also that using UUIDs for MAs may have benefits for privacy as well,
> at least with respect to accidentally leaked identifiers: they cannot be
> correlated to SLAAC addresses or to device manufacturers as MAC addresses
> can.
> 

We can take the above as a comment/additional consideration to mention
in the framework privacy section, so thanks for that!

Al

---

From: "Carey, Timothy (Timothy)" <[email-masked]>
Date: Wed, 9 Oct 2013 15:09:10 +0000

Trevor,

Thanks for the information - then I must have missed that it was separate.
What is the MAC Address used for?

BR,
Tim

From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, October 09, 2013 2:22 AM
To: Carey, Timothy (Timothy); [email-masked]
Subject: RE: Information Model Attributes - MA Identifier

Trevor.

Trevor Burbridge

string(36:36)

BR,
Tim

---

From: <[email-masked]>
Date: Wed, 9 Oct 2013 16:12:31 +0100

It should be optional - basically a way in some deployment scenarios for the Controller to be able to identify the physical device (and thereby things like address it was shipped to and who to contact about it etc.).

Trevor.

Trevor Burbridge

From: Carey, Timothy (Timothy) [mailto:[email-masked]]
Sent: 09 October 2013 16:09
To: Burbridge,T,Trevor,TUB8 R; [email-masked]
Subject: RE: Information Model Attributes - MA Identifier

Trevor,

BR,
Tim

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: Wednesday, October 09, 2013 2:22 AM
To: Carey, Timothy (Timothy); [email-masked]<mailto:[email-masked]>
Subject: RE: Information Model Attributes - MA Identifier

Trevor.

Trevor Burbridge

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Carey, Timothy (Timothy)
Sent: 08 October 2013 23:23
To: [email-masked]<mailto:[email-masked]>
Subject: [lmap] Information Model Attributes - MA Identifier

string(36:36)

BR,
Tim

---

From: "Carey, Timothy (Timothy)" <[email-masked]>
Date: Wed, 9 Oct 2013 15:46:00 +0000

So in the information model it is MA MAC; does the name make sense or should it be MADeviceID? If it is truly a device identifier do we want to type it as a MAC Address or just allow it to be a URN?

BR,
Tim

From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, October 09, 2013 10:13 AM
To: Carey, Timothy (Timothy); [email-masked]
Subject: RE: Information Model Attributes - MA Identifier

Trevor.

Trevor Burbridge

Trevor,

BR,
Tim

Trevor.

Trevor Burbridge

string(36:36)

BR,
Tim

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 10 Oct 2013 11:42:01 +0200

On Wed, Oct 09, 2013 at 03:46:00PM +0000, Carey, Timothy (Timothy) wrote:

> So in the information model it is MA MAC; does the name make sense
> or should it be MADeviceID? If it is truly a device identifier do we
> want to type it as a MAC Address or just allow it to be a URN?

I think this makes sense since in the use cases I have seen this MAC
address seems to be used primarily as a device ID. And this device ID
may be one of the MAC addresses of a device - this is what you often
find printed on the back of home router like devices.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>