Subject: [lmap] LMAP Information Model - BBF Questions and Comments

From: "Carey, Timothy (Timothy)" <[email-masked]>
Date: Wed, 9 Oct 2013 19:57:02 +0000

Hello,

During the 3Q2013 BBF meeting, the BBHome group had an opportunity to review the LMAP information model.
I have tried to incorporate the comments and questions here:

1)      It was unclear what the definition was for the CrossTraffic attribute.
Upon further discussion in the group we thought that the CrossTraffic parameter was an indication that the Result of a measurement might be suspect because there was other traffic detected by the measurement agent that might cause an invalid measurement.

If this is true - should we rename this attribute to something like SuspectResult and type it as a Boolean?

I also suggest this description:
This parameter indicates if the measurement agent has determined that the result may be suspect. Events that cause a result to be suspect is specific to the implementation of the measurement agent but may include events such as indications of other traffic or an unusual CPU load that may interfere with test.

2)     In the Measurement Agent there is an attribute supported measurements that is a list of entries to the Registry
This seems fine; the group did ask for a clarification if a device could support more than one Measurement Agent.

3)     When we reviewed the Options for a Task we were not sure if this was something where each option was a Name/Value pair that could be individually maintained or if they options should be maintained as a bulk list of Name/Value pairs. What this would mean is if you wanted to add, edit or delete on option you have to resend entire option list.

Thoughts?

Thanks,
Tim

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 10 Oct 2013 13:38:23 +0000

Hi,

Thank you for you input. Just to make sure that we understand your comments in the right context - you are referring in your mail to https://datatracker.ietf.org/doc/draft-burbridge-lmap-information-model/, right? Please confirm.

Thanks and Regards,

Dan
(LMAP co-chair)

From: [email-masked] [mailto:[email-masked]] On Behalf Of Carey, Timothy (Timothy)
Sent: Wednesday, October 09, 2013 10:57 PM
To: [email-masked]
Subject: [lmap] LMAP Information Model - BBF Questions and Comments

Hello,

Thoughts?

Thanks,
Tim

---

From: "Carey, Timothy (Timothy)" <[email-masked]>
Date: Thu, 10 Oct 2013 13:40:02 +0000

Yes these questions are on the information model.

From: Romascanu, Dan (Dan) [mailto:[email-masked]]
Sent: Thursday, October 10, 2013 8:38 AM
To: Carey, Timothy (Timothy); [email-masked]
Subject: RE: LMAP Information Model - BBF Questions and Comments

Hi,

Thanks and Regards,

Dan
(LMAP co-chair)

Hello,

Thoughts?

Thanks,
Tim

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 10 Oct 2013 16:03:19 +0200

> This seems fine; the group did ask for a clarification if a device could support more than one Measurement Agent.

This is somewhat difficult to answer since we do not have a strict
definition of what is a 'device'. In many use cases today, you likely
have only one MA per device but I can also envision 'devices' that
have multiple embedded MAs. I think the framework and information
model should allow this as long as this does not add significant
complexity to LMAP solutions.
 
> 3)     When we reviewed the Options for a Task we were not sure if this was something where each option was a Name/Value pair that could be individually maintained or if they options should be main…

I think this is a protocol issue, not really an information model
issue. Some protocols may only allow to modify the set as a complete
unit while others may provide the flexibility to modify arbitrary
subsets of the options.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "Carey, Timothy (Timothy)" <[email-masked]>
Date: Thu, 10 Oct 2013 18:16:24 +0000

Juergen thanks for the response - my comments inline <TAC>

-----Original Message-----
From: Juergen Schoenwaelder [mailto:[email-masked]] 
Sent: Thursday, October 10, 2013 9:03 AM
To: Carey, Timothy (Timothy)
Cc: [email-masked]
Subject: Re: [lmap] LMAP Information Model - BBF Questions and Comments

<TAC> Thanks - I would agree that a device may support multiple agents; I haven't see it become a complex problem; the issue was directly related to how to retrieve the measurements supported - was it the device or agent; we will place it on the agent.

<TAC> I certainly am fine with this approach although that is not what in draft-bagnulo-lmap-http-00 which doesn't address the management of the information model in any great detail; since I didn't see the rules there I thought I would ask.

/js

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 10 Oct 2013 20:35:24 +0200

> <TAC> Thanks - I would agree that a device may support multiple agents; I haven't see it become a complex problem; the issue was directly related to how to retrieve the measurements supported - was…

Yes, I would also place it on the agent.
  
> <TAC> I certainly am fine with this approach although that is not what in draft-bagnulo-lmap-http-00 which doesn't address the management of the information model in any great detail; since I didn'…

This is a -00 draft and there are many things not fully worked out. The
next revision hopefully is more complete.

/js

---

From: <[email-masked]>
Date: Fri, 11 Oct 2013 10:07:57 +0100

I think that cross-traffic should not be a simple Boolean, nor subsumed into a general 'suspect' parameter.

It needs to be a counter such as bytes of traffic sent/received over the WAN interface. The reason for this is that the level of traffic needs to be captured to determine the impact on different tests and different results. The threshold will be varied depending on both the test that was running and the analysis being performed.

Furthermore it can also be used to determine the effectiveness of test back-off procedures in the presence of user traffic and to analyse the impact the tests are having on user experience.

Trevor.

From: [email-masked] [mailto:[email-masked]] On Behalf Of Carey, Timothy (Timothy)
Sent: 09 October 2013 20:57
To: [email-masked]
Subject: [lmap] LMAP Information Model - BBF Questions and Comments

Hello,

Thoughts?

Thanks,
Tim

---

From: "Carey, Timothy (Timothy)" <[email-masked]>
Date: Fri, 11 Oct 2013 14:42:42 +0000

Trevor,

But isn't what you are describing elements of what would be considered the "context" of the test result; which changes based on the test I would imagine. Maybe that is all that is necessary is to flush out all the elements you want to place in the context?

BR,
Tim

From: [email-masked] [mailto:[email-masked]]
Sent: Friday, October 11, 2013 4:08 AM
To: Carey, Timothy (Timothy); [email-masked]
Subject: RE: LMAP Information Model - BBF Questions and Comments

Trevor.

Hello,

Thoughts?

Thanks,
Tim

---

From: <[email-masked]>
Date: Thu, 17 Oct 2013 10:55:53 +0100

I wonder if both things are valid:

-       For all (?) tests, it would be interesting to report that the MA suspects the results may be dodgy.

-       For specific tests it may be interesting to know the amount of cross-traffic. A lot of cross-traffic may or may not indicate that the result is dodgy

phil

From: [email-masked] [mailto:[email-masked]] On Behalf Of Carey, Timothy (Timothy)
Sent: 11 October 2013 15:43
To: Burbridge,T,Trevor,TUB8 R; [email-masked]
Subject: Re: [lmap] LMAP Information Model - BBF Questions and Comments

Trevor,

BR,
Tim

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: Friday, October 11, 2013 4:08 AM
To: Carey, Timothy (Timothy); [email-masked]<mailto:[email-masked]>
Subject: RE: LMAP Information Model - BBF Questions and Comments

Trevor.

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Carey, Timothy (Timothy)
Sent: 09 October 2013 20:57
To: [email-masked]<mailto:[email-masked]>
Subject: [lmap] LMAP Information Model - BBF Questions and Comments

Hello,

Thoughts?

Thanks,
Tim

---

From: "Carey, Timothy (Timothy)" <[email-masked]>
Date: Thu, 17 Oct 2013 11:26:41 +0000

Yes that is the way I have seen the Suspect Boolean used.

From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, October 17, 2013 11:56 AM
To: Carey, Timothy (Timothy); [email-masked]; [email-masked]
Subject: RE: LMAP Information Model - BBF Questions and Comments

phil

Trevor,

BR,
Tim

Trevor.

Hello,

Thoughts?

Thanks,
Tim

---

From: <[email-masked]>
Date: Thu, 17 Oct 2013 12:32:18 +0100

Perhaps a 'suspect code' rather than a boolean [cross-traffic, CPU on MA, overload on Measurement Peer, etc]
?

From: Carey, Timothy (Timothy) [mailto:[email-masked]]
Sent: 17 October 2013 12:27
To: Eardley,PL,Philip,TUB8 R; Burbridge,T,Trevor,TUB8 R; [email-masked]
Subject: RE: LMAP Information Model - BBF Questions and Comments

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: Thursday, October 17, 2013 11:56 AM
To: Carey, Timothy (Timothy); [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: RE: LMAP Information Model - BBF Questions and Comments

phil

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Carey, Timothy (Timothy)
Sent: 11 October 2013 15:43
To: Burbridge,T,Trevor,TUB8 R; [email-masked]<mailto:[email-masked]>
Subject: Re: [lmap] LMAP Information Model - BBF Questions and Comments

Trevor,

BR,
Tim

Trevor.

Hello,

Thoughts?

Thanks,
Tim

---

From: "Carey, Timothy (Timothy)" <[email-masked]>
Date: Thu, 17 Oct 2013 11:36:36 +0000

You could but then you have to specify the domain of what is suspected. It would be list because there could be multiple conditions.

From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, October 17, 2013 1:32 PM
To: Carey, Timothy (Timothy); [email-masked]; [email-masked]
Subject: RE: LMAP Information Model - BBF Questions and Comments

phil

Trevor,

BR,
Tim

Trevor.

Hello,

Thoughts?

Thanks,
Tim

---

From: <[email-masked]>
Date: Mon, 21 Oct 2013 09:34:35 +0100

Sorry  - I've been away. I still think the best way is to simply report the bytes of cross-traffic. What I tried to get across in my first response is that the level I want to filter at is not simply dependent on the test being operated. It will also depend on what I am trying to do with the data. It is a simple approach that covers all possible eventualities.

Trevor.

Trevor Burbridge
Network Infrastructure & Innovation | BT Innovate & Design
Tel: 01473 645115
Fax: 01473 640929

This email contains BT information, which may be privileged or confidential. It's meant only for the individual(s) or entity named above. If you're not the intended recipient, note that disclosing, copying, distributing or using this information is prohibited. If you've received this email in error, please let me know immediately on the email address above. Thank you.
We monitor our email system, and may record your emails.
British Telecommunications plc
Registered office: 81 Newgate Street London EC1A 7AJ
Registered in England no: 1800000

From: Carey, Timothy (Timothy) [mailto:[email-masked]]
Sent: 17 October 2013 12:37
To: Eardley,PL,Philip,TUB8 R; Burbridge,T,Trevor,TUB8 R; [email-masked]
Subject: RE: LMAP Information Model - BBF Questions and Comments

From: Carey, Timothy (Timothy) [mailto:[email-masked]]
Sent: 17 October 2013 12:27
To: Eardley,PL,Philip,TUB8 R; Burbridge,T,Trevor,TUB8 R; [email-masked]<mailto:[email-masked]>
Subject: RE: LMAP Information Model - BBF Questions and Comments

phil

Trevor,

BR,
Tim

Trevor.

Hello,

Thoughts?

Thanks,
Tim

---

From: "Carey, Timothy (Timothy)" <[email-masked]>
Date: Mon, 21 Oct 2013 10:30:56 +0000

Trevor,

So then what do we do about measurements that are suspect for other conditions than cross traffic?

Could you provide a good, description that could be used in the Information model for Cross Traffic that would cover all possible eventualities.
The reason for the description is that we would want developers to implement the element in such a way that 2 implementations would have the same result for the same test instance....

BR,
Tim

From: [email-masked] [mailto:[email-masked]]
Sent: Monday, October 21, 2013 3:35 AM
To: Carey, Timothy (Timothy); [email-masked]; [email-masked]
Subject: RE: LMAP Information Model - BBF Questions and Comments

Trevor.

Trevor Burbridge

phil

Trevor,

BR,
Tim

Trevor.

Hello,

Thoughts?

Thanks,
Tim

---

From: <[email-masked]>
Date: Mon, 21 Oct 2013 11:52:28 +0100

What other MA-reportable conditions (other than cross-traffic)?

If the case is strong enough then I'd say these need to be additional columns in the measurement report.

For cross traffic it would probably be total bytes sent/received over the broadband interface (that the test was using) for the duration of the test. This could be total bytes (from which we then subtract test traffic, but would be better pre-calculated as bytes of non-test traffic (so the test does not need to report test bytes sent/received if not otherwise desired).

Trevor.

From: Carey, Timothy (Timothy) [mailto:[email-masked]]
Sent: 21 October 2013 11:31
To: Burbridge,T,Trevor,TUB8 R; Eardley,PL,Philip,TUB8 R; [email-masked]
Subject: RE: LMAP Information Model - BBF Questions and Comments

Trevor,

BR,
Tim

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: Monday, October 21, 2013 3:35 AM
To: Carey, Timothy (Timothy); [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: RE: LMAP Information Model - BBF Questions and Comments

Trevor.

Trevor Burbridge

phil

Trevor,

BR,
Tim

Trevor.

Hello,

Thoughts?

Thanks,
Tim

---

From: "Carey, Timothy (Timothy)" <[email-masked]>
Date: Mon, 21 Oct 2013 10:54:49 +0000

High CPU load in the MA or MA peer for one, right?

From: [email-masked] [mailto:[email-masked]]
Sent: Monday, October 21, 2013 5:52 AM
To: Carey, Timothy (Timothy); [email-masked]; [email-masked]
Subject: RE: LMAP Information Model - BBF Questions and Comments

Trevor.

Trevor,

BR,
Tim

Trevor.

Trevor Burbridge

phil

Trevor,

BR,
Tim

Trevor.

Hello,

Thoughts?

Thanks,
Tim