Subject: [lmap] degrees of Measurement Suppression

From: "STARK, BARBARA H" <[email-masked]>
Date: Tue, 12 Nov 2013 16:50:06 +0000

A number of providers have discussed a model of Measurement Suppression that supports more granular degrees of suppression (other than just suppress and don't suppress). Michael Bugenhagen presented the original version of this model, and he said it would be ok if I brought it up to IETF.

Following are highlights of the proposal (with some modifications I've included as a result of additional discussion):

1. Measurement Methods (or perhaps Tasks) have a configurable parameter that indicates whether the Controller operator considers them to be "critical for OAM", "not critical, but not resource intensive", and "not critical and resource intensive".

2. The Controller can specify degrees of Measurement Suppression, which should include: halt all non-critical tasks immediately but allow OAM tasks; halt resource-intensive tasks immediately but allow non-resource-intensive tasks; finish resource intensive tasks but do not start new resource-intensive tasks and allow all non-resource-intensive tasks; allow all tasks.

3. It may also be possible for the unspecified bootstrap mechanism to instruct the MA to suppress measurements. Where multiple channels exist for Measurement Suppression (e.g., Controller and bootstrap), the MA is to use the most restrictive setting.

Barbara

---

From: <[email-masked]>
Date: Wed, 27 Nov 2013 16:58:48 +0000

(sorry, been away - catching up on mail backlog)

Interesting idea.

I'm inclined to think that, in lmap 1.0, we should keep it as simple as possible and just go for suppress /don't suppress - as this would be easier to implement for the MA and Controller, and avoid failure issues (eg MA not understanding what "suppress type 3" means). After all, suppression is intended to be a temporary thing in an unexpected situation. 

The multi-levels sounds a bit odd to me - something like: a few of my tests create lots of load and should only be run when the network is really quiet. Anyway, if you really want, you could get something like this by sending the suppression message to a subset of the MAs. 
If we really want this, then why not go a step further and allow the Controller to signal (to a MA) arbitrary profiles of {sets of Measurement Tasks} and then the Measurement Schedule references one of these profiles. 

I'm not sure if anyone already operating a large-scale measurement system has found it necessary to go for multiple levels of suppression? If they have, then I could be persuaded. If not, I think we should probably leave this for lmap2.0.

I think I agree that there might be a device-specific protocol (eg TR-069) that can also signal suppress. Don't think the framework needs to mention this. 

On a related topic, I think I heard someone mention the idea of the Measurement Peer sending a similar "suppress" message. I don't think an explicit msg is needed - but there are some related ideas in S5.3 (of the framework) "Starting and stopping Measurement Tasks"

Thanks
phil

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> STARK, BARBARA H
> Sent: 12 November 2013 16:50
> To: [email-masked]
> Subject: [lmap] degrees of Measurement Suppression
> 
> A number of providers have discussed a model of Measurement Suppression
> that supports more granular degrees of suppression (other than just
> suppress and don't suppress). Michael Bugenhagen presented the original
> version of this model, and he said it would be ok if I brought it up to
> IETF.
> 
> Following are highlights of the proposal (with some modifications I've
> included as a result of additional discussion):
> 
> 1. Measurement Methods (or perhaps Tasks) have a configurable parameter
> that indicates whether the Controller operator considers them to be
> "critical for OAM", "not critical, but not resource intensive", and
> "not critical and resource intensive".
> 
> 2. The Controller can specify degrees of Measurement Suppression, which
> should include: halt all non-critical tasks immediately but allow OAM
> tasks; halt resource-intensive tasks immediately but allow non-
> resource-intensive tasks; finish resource intensive tasks but do not
> start new resource-intensive tasks and allow all non-resource-intensive
> tasks; allow all tasks.
> 
> 3. It may also be possible for the unspecified bootstrap mechanism to
> instruct the MA to suppress measurements. Where multiple channels exist
> for Measurement Suppression (e.g., Controller and bootstrap), the MA is
> to use the most restrictive setting.
> 
> Barbara
> 
> 
> _______________________________________________
> lmap mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lmap