Subject: [lmap] 3 Suggested adds/ Edits for the LMAP Draft

From: "Bugenhagen, Michael K" <[email-masked]>
Date: Wed, 6 Nov 2013 17:03:30 +0000

Phil,

   Reviewing the draft http://www.ietf.org/id/draft-folks-lmap-framework-00.txt

Add's (in Red)

Page 6 definitions -  Consider adding ....

1)      Add Measurement Agent testing protocol
                Measurement Agent Protocol: The control messages from one MA to another used to conduct a test.

2)      Add Service Attributes
                Service Attributes:  The normative Service attribute values that are pertinent to a test results during the timeframe the test was conducted.
                Examples  -
                         Sold speed  - may equal the current service capacity attribute for the timeframe the test is conducted.
                         In use -
                        Service state - under maintenance, down, up, ....

Tweaks -
Page 11 LMAP phases - suggested change for the "measurement task being performed"

*       MA Test Engine
        The MA execution of actual Measurement Tasks are performed.
        A MA evaluates running tasks based on environment constraints, and service attributes, and runs test tasks
       Recording (logs and captures test results) the type of test completion state (successful, aborted, .....)
       It conducts Active Measurement Task involves sending test traffic between the Measurement Agent and a Measurement Peer,
        whilst a Passive Measurement Task involves (only) the Measurement Agent observing existing user traffic.  The
      LMAP WG does not define Measurement Methods, however the IPPM WG
      does.

Questions -

1)      Lack of a Consumer / subscriber test point Discover Method -
        The draft states that "comparable" test points are used to allow comparability between test results.
        Is the assumption that ONLY the controller presents the test points, or we the framework leverage something broader and more transparent such as a DNS or other registry for test       points, logically some points are already DNS named, but it seems we are adding some that do not normally get named, or we may what some ACL type restrictions to....

---

From: <[email-masked]>
Date: Tue, 26 Nov 2013 16:29:08 +0000

Mike,
Sorry for the slow response, been away a lot recently.

Btw, the relevant draft is http://tools.ietf.org/html/draft-ietf-lmap-framework-01
(don't think there are too many differences, phew!)

On your question - the idea is that the Measurement Peer could be a specialised lmap device but could also be a general server, such as DNS or web server.

On the terminology, would prefer not to adjust this unless we really need to.
On the 2nd suggestion about Service Attributes, this is basically covered in the discussion of Subscriber Parameter Database (section 3, towards the end of page 9). The reason I didn't try and craft a definition is that it's in the 'out of scope' area of Figure 1 (so I figured that we wouldn't re-use the definition much)
Thanks!
Phil

--

From: Bugenhagen, Michael K [mailto:[email-masked]]
Sent: 06 November 2013 17:04
To: Eardley,PL,Philip,TUB8 R; [email-masked]'
Subject: 3 Suggested adds/ Edits for the LMAP Draft

Phil,

Add's (in Red)

1.     Add Measurement Agent testing protocol
                Measurement Agent Protocol: The control messages from one MA to another used to conduct a test.

2.  Add Service Attributes
                Service Attributes:  The normative Service attribute values that are pertinent to a test results during the timeframe the test was conducted.
                Examples -
                        Sold speed - may equal the current service capacity attribute for the timeframe the test is conducted.
                        In use -
                        Service state - under maintenance, down, up, ....

Tweaks -

*         MA Test Engine

Questions -

1.       Lack of a Consumer / subscriber test point Discover Method -
        The draft states that "comparable" test points are used to allow comparability between test results.
        Is the assumption that ONLY the controller presents the test points, or we the framework leverage something broader and more transparent such as a DNS or other registry for test        points, logically some points are already DNS named, but it seems we are adding some that do not normally get named, or we may what some ACL type restrictions to....