Subject: [lmap] Measurement Suppression (WGLC comments on draft-ietf-lmap-framework-03)

From: <[email-masked]>
Date: Mon, 17 Feb 2014 15:02:13 +0000

There were a number of comments about Suppression. There was also some discussion in WT-304 (Broadband forum) and it would be very nice to keep BBF & LMAP in step.

Here's a proposal how to handle the various comments:

-       A couple of people suggested that Suppression should also be able to affect the Measurement Peer. I'm proposing not to include this, because Suppression is part of the Instruction and M Peers don't get instructions.

-       Suppression should affect all M Tasks, not just Active ones. Reason: simplicity. Avoids having to classify tasks as active or passive. Also, you may want to suppress passive tasks - perhaps they are generating a lot of Reports, or an active task has been mis-classified as a passive task, or there is some privacy issue that means passive Tasks need to be suppressed.

-       There should be an option in Suppression to stop on-going Tasks (the current text stops any new Tasks and says the impact on on-going Tasks is undefined). Reason: on-going Tasks may be long-running and generating a lot of traffic. Comment: I wrote "a request that the MA stops on-going Measurement Tasks" rather than "the MA stops on-going Measurement Tasks" - not sure that the MA would be able to stop all Tasks

So the suppression section would look like this:-

5.2.1<http://tools.ietf.org/html/draft-ietf-lmap-framework-03#section-5.2.1>.  Measurement Suppression

   Measurement Suppression is used if the measurement system wants to

   eliminate inessential traffic, because there is some unexpected

   network issue for example.  The Controller instructs the MA to

   temporarily not begin new Measurement Tasks.  By default,

   suppression applies to all Measurement Tasks, starts

   immediately and continues until an un-suppress message is received.

   Optionally the suppress message may include:

   o  a set of Active Measurement Tasks to suppress; the others are not

      suppressed.  For example, a particular Measurement Task may be

      overloading a Measurement Peer.

   o  a set of Measurement Schedules to suppress; the others are not

      suppressed.  For example, suppose the measurement system has

      defined two Schedules, one with the most critical

      Measurement Tasks and the other with less critical ones that

      create a lot of traffic, then it may only want to suppress the

      second.

   o  a start time, at which suppression begins

   o  an end time, at which suppression ends.

   o  a request that the MA stops on-going Measurement Tasks (by default, it is not defined what the impact of Suppression is on on-going Measurement Tasks; see Section 5.3<http://tools.ietf.org/html/draft-ietf-lmap-framework-03#section-5.3>)

   Note that Suppression is not intended to permanently stop a

   Measurement Task (instead, the Controller should send a new

   Measurement Schedule), nor to permanently disable a MA (instead, some

   kind of management action is suggested).

   +-----------------+                                   +-------------+

   |                 |                                   | Measurement |

   |  Controller     |===================================|  Agent      |

   +-----------------+                                   +-------------+

   Suppress:

   [(Measurement Task),                     ->

    (Measurement Schedule),

    start time, end time,

    stop on-going Tasks?]

                                            <-              ACK

   Un-suppress                              ->

                                            <-              ACK

--
Comments?
Thanks
phil

---

From: KEN KO <[email-masked]>
Date: Mon, 17 Feb 2014 17:50:30 +0000

Phil,

Looks good to me with one minor edit. There is still one instance of "Active Measurement" (in the first bullet) where I think you just mean "Measurement."

Ken

From: lmap [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, February 17, 2014 10:02 AM
To: [email-masked]
Subject: [lmap] Measurement Suppression (WGLC comments on draft-ietf-lmap-framework-03)

      second.

   |                 |                                   | Measurement |

   Suppress:

   [(Measurement Task),                     ->

    (Measurement Schedule),

    start time, end time,

    stop on-going Tasks?]

                                            <-              ACK

   Un-suppress                              ->

                                            <-              ACK

--
Comments?
Thanks
phil