Subject: [lmap] Definition of Instruction (WGLC comments on draft-ietf-lmap-framework-03)

From: <[email-masked]>
Date: Mon, 17 Feb 2014 12:15:11 +0000

Some comments made me realise the definition of Instruction needed clarifying - in particular, Ken pointed out that sometimes Instruction refers to the information in the MA (and Controller) - and sometimes to the message between the Controller and MA.

I've worked with Ken, Charles and others (thank-you!) - proposed definition is as follows (hopeful this would be aligned with Broadband forum's definition) -

Instruction:
The description of Measurement Tasks for a MA to perform and the details of the Report(s) for it to send. It is the collective description of the set of Measurement Schedules, the set of Measurement Task configurations, the configuration of the Report Channel(s) and details of Suppression (if any). The Controller sends a message over the Control Channel to the MA, in order to update the Instruction or elements of it

(there was a comment about the term 'Control Channel' which I'll get to later)

One thing to notice about this definition is that Suppression is part of the Instruction.

phil

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 17 Feb 2014 12:25:06 +0000

Maybe we should talk explicitly (and define) not only Instruction (and I am fine with the definition below) but also' Instruction message' or 'message carrying Instruction'.

Dan

From: lmap [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, February 17, 2014 2:15 PM
To: [email-masked]
Subject: [lmap] Definition of Instruction (WGLC comments on draft-ietf-lmap-framework-03)

Instruction:

phil