Subject: [lmap] draft-ietf-lmap-framework-03 - WGLC concluded

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 10 Feb 2014 10:11:25 +0000

The WGLC on draft-ietf-lmap-framework-03 is now concluded. We received a set of consistent reviews, thanks to all commenters, and I expect the document authors to prepare responses and proposals for resolution and the WG to entertain a lovely and lively discussion in London.

BTW - if you did not have the time to review but plan to do it sometimes soon please keep on sending these comments. Of course, the sooner, the better.

Thanks and Regards,

Dan

---

From: "Weil, Jason" <[email-masked]>
Date: Mon, 10 Feb 2014 19:08:11 -0500

I have a few chair comments that may already be addressed, but I will state them here just to be sure. Overall I think  the document is in good shape and appreciate the responses we have received in Last Call. There are two points I do want to raise with respect to making sure the document aligns with our charter:

1) Multiple Address Family support
The Charter states: "The LMAP architecture will allow for measurements that utilize either IPv4 or IPv6, or possibly both. Devices containing Measurement Agents may have several interfaces using different link technologies. Multiple address families and interfaces must be considered in the Control and Report protocols."

The Diversity bullet in the Intro begins to address this requirement and then a point in Section 6.2.3 dealing with consideration options in the MA goes on to I believe suggest the recommended solution for this. I am to understand that the recommendation is to treat multiple address families as a multi-homed device?

It may also be useful to point out that a test may run in 3 different modes: IPv4, IPv6 or dual-stack. I think it would be useful to make sure the system could measurement system could support all three with the goal that you may want to explicitly test a certain protocol in some cases or just use whatever protocol is preferred in other cases when both are configured on a device.

2) Reporting of Service Parameters by MA if available
The Charter includes this sentence on the topic of Service Parameters: "However, if the service parameters are available to the MAs, they could be reported with the measurement results in the Report Protocol"

Discovery of Service Parameters is out of scope per the Charter, but I believe there has been some discussion on the list that if the MA has the information it may be included in the Reporting Protocol. It is stated as a 'could' but I think it would be useful to state this somewhere in the discussion of the Report Protocol. There currently is this bullet which seems to imply that only the Results are to be delivered to the collector and not the Service Parameters but I may be reading too much into this bullet:

   o  a Report Protocol, which delivers a Report from the MA to a
      Collector.  The Report contains the Measurement Results.

Thanks,

Jason

From: <Romascanu>, "Romascanu, Dan (Dan)" <[email-masked]<mailto:[email-masked]>>
Date: Monday, February 10, 2014 5:11 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [lmap] draft-ietf-lmap-framework-03 - WGLC concluded

BTW – if you did not have the time to review but plan to do it sometimes soon please keep on sending these comments. Of course, the sooner, the better.

Thanks and Regards,

Dan

________________________________
This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.