Subject: [lmap] One example of a "passive measurement peer"

From: Matt Mathis <[email-masked]>
Date: Fri, 7 Mar 2014 02:10:34 -0800

>From the Internet Archive:

http://web.archive.org/web/20071005130953/http://www-didc.lbl.gov/SCNM/

Thanks,
--MM--
The best way to predict the future is to create it.  - Alan Kay

Privacy matters!  We know from recent events that people are using our
services to speak in defiance of unjust governments.   We treat privacy and
security as matters of life and death, because for some users, they are.

---

From: "Aamer Akhter (aakhter)" <[email-masked]>
Date: Fri, 7 Mar 2014 10:20:43 +0000

Thanks Matt,

This is a good example of a measurement peer—and to be honest hadn’t considered this type of tying as part of the LMAP usage. It can be of course.

I would think that taking the ‘active’ out of ‘active measurement peer’ would address this. However, there is an unknown of why some people were not happy with the distinction removal.

aa

From: lmap [mailto:[email-masked]] On Behalf Of Matt Mathis
Sent: Friday, March 7, 2014 5:11 AM
To: [email-masked]
Subject: [lmap] One example of a "passive measurement peer"

http://web.archive.org/web/20071005130953/http://www-didc.lbl.gov/SCNM/<http://web.archive.org/web/20071005130953/http:/www-didc.lbl.gov/SCNM/>

Thanks,
--MM--

Privacy matters!  We know from recent events that people are using our services to speak in defiance of unjust governments.   We treat privacy and security as matters of life and death, because for some users, they are.

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 10 Mar 2014 13:31:15 +0000

My other example of a ‘passive management peer’ is an RTP peer which receives RTCP messages about the state of the other side of the connection and the parameters of the received traffic at the other end. All these are part of RTP/RTCP, there is no interaction between the controller and the MP, so I believe it can be considered passive in LMAP terms.

Regards,

Dan

From: lmap [mailto:[email-masked]] On Behalf Of Matt Mathis
Sent: Friday, March 07, 2014 12:11 PM
To: [email-masked]
Subject: [lmap] One example of a "passive measurement peer"

Thanks,
--MM--

---

From: Brian Trammell <[email-masked]>
Date: Tue, 11 Mar 2014 14:29:41 +0100

hi Dan,

Hm. I don't really consider this passive measurement -- we discussed this a bit in the ippm registry design team, but I'm pretty sure there's a difference between (1) metrics derived from the operation of a protocol at one of the endpoints participating in it and (2) metrics derived from the passive observation of packets emitted by those protocols. I've always thought of passive measurement as the latter, and (1) as something like "endpoint measurement", since metrics in (1) can also be derived from internal state at each endpoint not synchronized over the protocol or otherwise hard to derive. 

One could say that a midpath observation point (i.e. any observation point other than an endpoint) has as many "passive peers" as there are observable senders and recipients, while an "endpoint measurement agent" would have a single "endpoint peer".

(This becomes a much more interesting distinction as soon as you consider encrypting absolutely everything you can, of course. At that point everything you're reduced to endpoint measurement for everything other than the "envelope" and/or things you derive through behavioral traffic analysis. But that's a separate discussion, I think.)

In any case, I stand by my statement that I'd like to see peers defined _only_ as much as is absolutely necessary to make sense of the resulting control and reporting protocols.

Cheers,

Brian

On 10 Mar 2014, at 14:31, Romascanu, Dan (Dan) <[email-masked]> wrote:

> _______________________________________________
> lmap mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lmap

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Tue, 11 Mar 2014 09:35:01 -0400

+1, I briefly tried to explain this to Dan in the back of the LMAP
meeting room (while the meeting was still in-progress, I think).

For me, it's a key distinction that the RTCP-reported end-point
measurements have a priori knowledge of the stream in RTP (like active),
while true passive measurements (at mid points) do not.

Al

> -----Original Message-----
> From: lmap [mailto:[email-masked]] On Behalf Of Brian Trammell
> Sent: Tuesday, March 11, 2014 9:30 AM
> To: Dan Romascanu
> Cc: Matt Mathis; [email-masked]
> Subject: Re: [lmap] One example of a "passive measurement peer"
> 
> hi Dan,
> 
> Hm. I don't really consider this passive measurement -- we discussed this
> a bit in the ippm registry design team, but I'm pretty sure there's a
> difference between (1) metrics derived from the operation of a protocol at
> one of the endpoints participating in it and (2) metrics derived from the
> passive observation of packets emitted by those protocols. I've always
> thought of passive measurement as the latter, and (1) as something like
> "endpoint measurement", since metrics in (1) can also be derived from
> internal state at each endpoint not synchronized over the protocol or
> otherwise hard to derive.
> 
> One could say that a midpath observation point (i.e. any observation point
> other than an endpoint) has as many "passive peers" as there are
> observable senders and recipients, while an "endpoint measurement agent"
> would have a single "endpoint peer".
> 
> (This becomes a much more interesting distinction as soon as you consider
> encrypting absolutely everything you can, of course. At that point
> everything you're reduced to endpoint measurement for everything other
> than the "envelope" and/or things you derive through behavioral traffic
> analysis. But that's a separate discussion, I think.)
> 
> In any case, I stand by my statement that I'd like to see peers defined
> _only_ as much as is absolutely necessary to make sense of the resulting
> control and reporting protocols.
> 
> Cheers,
> 
> Brian
> 
> 
> > My other example of a 'passive management peer' is an RTP peer which
> receives RTCP messages about the state of the other side of the connection
> and the parameters of the received traffic at the other end. All these are
> part of RTP/RTCP, there is no interaction between the controller and the
> MP, so I believe it can be considered passive in LMAP terms.
> >
> > Regards,
> >
> > Dan
> >
> >
> services to speak in defiance of unjust governments.   We treat privacy
> and security as matters of life and death, because for some users, they
> are.

---

From: "Bugenhagen, Michael K" <[email-masked]>
Date: Tue, 11 Mar 2014 13:36:23 +0000

Just my 2 cents - but a word on future proofing... 

The word passive is contextual...

Which directly infers that we should "contextualize" it buy saying "x" passive.
As the technology disturbers add new dimensions that also contain passive/active stuff this is going to get more confused....

We're seriously having a problem with this at NFV / Cloud technology SDO's where we've virtualized NIC's (Vnic's) and Vswitches both of which can be suspended (stopped)..

It may prove difficult to do passive measurements on a virtual x,y,z component.
Given Broadband Modems have this virtualized stuff, we should consider future proofing our terms.

Summary - contextualizing passive may be a great thing to future proof... for virtualization, those proof of concepts are in the works now.

Cheers,
Mike

-----Original Message-----
From: lmap [mailto:[email-masked]] On Behalf Of Brian Trammell
Sent: Tuesday, March 11, 2014 8:30 AM
To: Dan Romascanu
Cc: Matt Mathis; [email-masked]
Subject: Re: [lmap] One example of a "passive measurement peer"

hi Dan,

Cheers,

Brian

On 10 Mar 2014, at 14:31, Romascanu, Dan (Dan) <[email-masked]> wrote:

> My other example of a 'passive management peer' is an RTP peer which receives RTCP messages about the state of the other side of the connection and the parameters of the received traffic at the other end. All these are part of RTP/RTCP, there is no interaction between the controller and the MP, so I believe it can be considered passive in LMAP terms.
>  
> Regards,
>  
> Dan
>  
>

---

From: Nalini Elkins <[email-masked]>
Date: Tue, 11 Mar 2014 06:37:56 -0700 (PDT)

Passive (or hybrid) measurements need not be at "midpoints".   They may be at "end points".   That is the client itself.
 
Thanks,

Nalini Elkins
Inside Products, Inc.
(831) 659-8360
www.insidethestack.com

________________________________
 From: "MORTON, ALFRED C (AL)" <[email-masked]>
To: Brian Trammell <[email-masked]>; Dan Romascanu <[email-masked]> 
Cc: Matt Mathis <[email-masked]>; "[email-masked]" <[email-masked]> 
Sent: Tuesday, March 11, 2014 6:35 AM
Subject: Re: [lmap] One example of a "passive measurement peer"

Al

---

From: "Aamer Akhter (aakhter)" <[email-masked]>
Date: Tue, 11 Mar 2014 14:05:05 +0000

"Passive (or hybrid) measurements need not be at "midpoints".   They may be at "end points".   That is the client itself."

Indeed this can be wireshark on the end system, and that would be a passive measurement on an end system.

But I don't think that is what Al and Brian were getting at. SIP, RTP, RTCP are part of one set of joined interactions.  This is not too dissimilar from a TWAMP/OWAMP + whatever traffic they generate at that point in my mind. So if we had to pick between active and passive, it's much on the active side.

But keep in mind that we are really talking about a user application.

From: lmap [mailto:[email-masked]] On Behalf Of Nalini Elkins
Sent: Tuesday, March 11, 2014 9:38 AM
To: MORTON, ALFRED C (AL); Brian Trammell; Dan Romascanu
Cc: Matt Mathis; [email-masked]
Subject: Re: [lmap] One example of a "passive measurement peer"

Thanks,

Nalini Elkins
Inside Products, Inc.
(831) 659-8360
www.insidethestack.com<http://www.insidethestack.com>

________________________________
From: "MORTON, ALFRED C (AL)" <[email-masked]<mailto:[email-masked]>>
To: Brian Trammell <[email-masked]<mailto:[email-masked]>>; Dan Romascanu <[email-masked]<mailto:[email-masked]>>
Cc: Matt Mathis <[email-masked]<mailto:[email-masked]>>; "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, March 11, 2014 6:35 AM
Subject: Re: [lmap] One example of a "passive measurement peer"

Al

> From: lmap [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Brian Trammell
> Cc: Matt Mathis; [email-masked]<mailto:[email-masked]>
> On 10 Mar 2014, at 14:31, Romascanu, Dan (Dan) <[email-masked]<mailto:[email-masked]>> wrote:
>
> > From: lmap [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Matt Mathis
> > To: [email-masked]<mailto:[email-masked]>
> > [email-masked]<mailto:[email-masked]>
> [email-masked]<mailto:[email-masked]>

_______________________________________________
lmap mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lmap

---

From: Nalini Elkins <[email-masked]>
Date: Tue, 11 Mar 2014 07:21:08 -0700 (PDT)

Agreed.
 
Thanks,

Nalini Elkins
Inside Products, Inc.
(831) 659-8360
www.insidethestack.com

________________________________
 From: Aamer Akhter (aakhter) <[email-masked]>
To: Nalini Elkins <[email-masked]>; "MORTON, ALFRED C (AL)" <[email-masked]>; Brian Trammell <[email-masked]>; Dan Romascanu <[email-masked]> 
Cc: Matt Mathis <[email-masked]>; "[email-masked]" <[email-masked]> 
Sent: Tuesday, March 11, 2014 7:05 AM
Subject: Re: [lmap] One example of a "passive measurement peer"

“Passive (or hybrid) measurements need not be at "midpoints".   They may be at "end points".   That is the client itself.”

But I don’t think that is what Al and Brian were getting at. SIP, RTP, RTCP are part of one set of joined interactions.  This is not too dissimilar from a TWAMP/OWAMP + whatever traffic they generate at that point in my mind. So if we had to pick between active and passive, it’s much on the active side. 

From:lmap [mailto:[email-masked]] On Behalf Of Nalini Elkins

Thanks,
 
Nalini Elkins
Inside Products, Inc.
(831) 659-8360
www.insidethestack.com

From:"MORTON, ALFRED C (AL)" <[email-masked]>

Al

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 11 Mar 2014 15:59:13 +0100

Hi,

I do not think we need the term 'passive measurement peer' in the
framework so perhaps the best thing is to not spent cycles trying to
define it.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "Aamer Akhter (aakhter)" <[email-masked]>
Date: Tue, 11 Mar 2014 15:03:42 +0000

I agree on the removal of 'passive' in 'passive measurement peer' but if I remember correctly where was some discontent with just that as the solution. 

Do we have any clarity on where the discontent was coming from 

-----Original Message-----
From: lmap [mailto:[email-masked]] On Behalf Of Juergen Schoenwaelder
Sent: Tuesday, March 11, 2014 10:59 AM
To: Bugenhagen, Michael K
Cc: 'Brian Trammell'; [email-masked]'; 'Matt Mathis'; 'Dan Romascanu'
Subject: Re: [lmap] One example of a "passive measurement peer"

Hi,

I do not think we need the term 'passive measurement peer' in the framework so perhaps the best thing is to not spent cycles trying to define it.

/js

On Tue, Mar 11, 2014 at 01:36:23PM +0000, Bugenhagen, Michael K wrote:
> (This becomes a much more interesting distinction as soon as you 
> consider encrypting absolutely everything you can, of course. At that 
> point everything you're reduced to endpoint measurement for everything 
> other than the "envelope" and/or things you derive through behavioral 
> traffic analysis. But that's a separate discussion, I think.)
>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 11 Mar 2014 16:08:00 +0100

Hi,

I do not recall having seen 'passive measurement peer' in the
framework nor do I recall that it was suggested that this term be
added.

At the meeting, we discussed to remove 'active' from a new proposed
definition of Measurement Agent (and I though we were slowly
converging to this change - but I am biased of course).

/js

---

From: "Aamer Akhter (aakhter)" <[email-masked]>
Date: Tue, 11 Mar 2014 15:08:58 +0000

My mistake. You are right it was 'active' in 'active measurement peer'. 

Aa (in need of coffee) 

-----Original Message-----
From: Juergen Schoenwaelder [mailto:[email-masked]] 
Sent: Tuesday, March 11, 2014 11:08 AM
To: Aamer Akhter (aakhter)
Cc: Bugenhagen, Michael K; 'Brian Trammell'; [email-masked]'; 'Matt Mathis'; 'Dan Romascanu'
Subject: Re: [lmap] One example of a "passive measurement peer"

Hi,

I do not recall having seen 'passive measurement peer' in the framework nor do I recall that it was suggested that this term be added.

At the meeting, we discussed to remove 'active' from a new proposed definition of Measurement Agent (and I though we were slowly converging to this change - but I am biased of course).

/js

On Tue, Mar 11, 2014 at 03:03:42PM +0000, Aamer Akhter (aakhter) wrote:
> > consider encrypting absolutely everything you can, of course. At 
> > that point everything you're reduced to endpoint measurement for 
> > everything other than the "envelope" and/or things you derive 
> > through behavioral traffic analysis. But that's a separate 
> > discussion, I think.)
> > 
> > > http://web.archive.org/web/20071005130953/http://www-didc.lbl.gov/
> > > SC
> > > NM/
> > > 
> > > Thanks,
> > > --MM--

---

From: Nalini Elkins <[email-masked]>
Date: Tue, 11 Mar 2014 08:15:52 -0700 (PDT)

Guys,

If I look in http://tools.ietf.org/html/draft-eardley-lmap-terminology-02, I see the definition of measurement peer as:

Measurement Peer: The function that receives control messages and test packets from a Measurement Agent and may reply to the
Measurement Agent as defined by the Measurement Method. 

Is this correct?

Now, imagine the following scenario in a hybrid measurement technique:

1.  In the MA, the hybrid technique is to have the MA to append x bytes of diagnostic data to each passive packet.  For example, via a command to the operating system.

2.  The MA resides in the client

3. It would be ideal to have the partner that the client is having the session with (let's call it "server") also participate in this appending of x bytes of diagnostic data from his side.  (Leaving aside for the moment the potential for this to be a DoS vector.  That is a separate discussion). 

4.  In this case, could the MA not ask the "other end" to participate in extra data gathering?  This would be a control message from an MA as defined above.

Would this be an example of a Measurement Peer in a hybrid scenario?

I ask because this is what we are thinking we may want to do.

What am I missing?  Is my understanding of this OK?  Please advise.

Thanks,

Nalini Elkins
Inside Products, Inc.
(831) 659-8360
www.insidethestack.com

________________________________
From: Aamer Akhter (aakhter) <[email-masked]>
To: Juergen Schoenwaelder <[email-masked]>; "Bugenhagen, Michael K" <[email-masked]> 
Cc: 'Brian Trammell' <[email-masked]>; 'Dan Romascanu' <[email-masked]>; 'Matt Mathis' <[email-masked]>; "[email-masked]'" <[email-masked]> 
Sent: Tuesday, March 11, 2014 8:03 AM
Subject: Re: [lmap] One example of a "passive measurement peer"

-----Original Message-----
From: lmap [mailto:[email-masked]] On Behalf Of Juergen Schoenwaelder
Sent: Tuesday, March 11, 2014 10:59 AM
To: Bugenhagen, Michael K
Cc: 'Brian Trammell'; [email-masked]'; 'Matt Mathis'; 'Dan Romascanu'
Subject: Re: [lmap] One example of a "passive measurement peer"

Hi,

/js

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 11 Mar 2014 16:46:14 +0100

> Measurement Agent as defined by the Measurement Method. 
 
Note that the terminology was moved into

http://tools.ietf.org/html/draft-ietf-lmap-framework-03

and there is another udpate of this document pending...
 
> What am I missing?  Is my understanding of this OK?  Please advise.

Sure, an MA can have a control dialog with a remote MP. TWAMP and
OWAMP would be examples of such control protocols. From an LMAP
perspective, this interaction is out of scope of the LMAP protocol(s).

/js

---

From: Nalini Elkins <[email-masked]>
Date: Tue, 11 Mar 2014 08:55:00 -0700 (PDT)

I thought the discussion was could there possibly be a "passive measurement peer".

If I am not mistaken, the scenario below would be a "hybrid measurement peer".

Why would this interaction be out of scope if OWAMP and TWAMP control protocols are in scope?   

Thanks,

Nalini Elkins
Inside Products, Inc.
(831) 659-8360
www.insidethestack.com

----- Original Message -----
From: Juergen Schoenwaelder <[email-masked]>
To: Nalini Elkins <[email-masked]>
Cc: Aamer Akhter (aakhter) <[email-masked]>; "Bugenhagen, Michael K" <[email-masked]>; 'Brian Trammell' <[email-masked]>; 'Dan Romascanu' <[email-masked]>; 'Matt Mathis' <[email-masked]>; "[email-masked]'" <[email-masked]>
Sent: Tuesday, March 11, 2014 8:46 AM
Subject: Re: [lmap] One example of a "passive measurement peer"

/js

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 11 Mar 2014 16:05:42 +0000

Hi Al,

You tried to explain by you did not convince me :-) 

I do not see the remote RTP end-point as 'active'. There is nothing it does differently (no 'activity') as the result of being  a measurement peer. 

However, I agree that removing 'active' from this document solves the dispute. If there is no 'active' there is no need to define 'passive'. 

Regards,

Dan

> From: lmap [mailto:[email-masked]] On Behalf Of MORTON, ALFRED
> C (AL)
> Sent: Tuesday, March 11, 2014 3:35 PM
> To: Brian Trammell; Romascanu, Dan (Dan)
> > Hm. I don't really consider this passive measurement -- we discussed
> > this a bit in the ippm registry design team, but I'm pretty sure
> > there's a difference between (1) metrics derived from the operation of
> > a protocol at one of the endpoints participating in it and (2) metrics
> > derived from the passive observation of packets emitted by those
> > protocols. I've always thought of passive measurement as the latter,
> > and (1) as something like "endpoint measurement", since metrics in (1)
> > can also be derived from internal state at each endpoint not
> > synchronized over the protocol or otherwise hard to derive.
> >
> > One could say that a midpath observation point (i.e. any observation
> > point other than an endpoint) has as many "passive peers" as there are
> > In any case, I stand by my statement that I'd like to see peers
> > defined _only_ as much as is absolutely necessary to make sense of the
> > resulting control and reporting protocols.
> >
> > Cheers,
> >
> > Brian
> >
> >
> > receives RTCP messages about the state of the other side of the
> > connection and the parameters of the received traffic at the other
> > end. All these are part of RTP/RTCP, there is no interaction between
> > the controller and the MP, so I believe it can be considered passive in LMAP
> terms.
> > >
> > > Regards,
> > >
> > > Dan
> > >
> > >
> > > http://web.archive.org/web/20071005130953/http://www-
> didc.lbl.gov/SC
> > > NM/
> > >
> > > Thanks,
> > > --MM--
> > and security as matters of life and death, because for some users,
> > they are.

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 11 Mar 2014 17:06:19 +0100

> Why would this interaction be out of scope if OWAMP and TWAMP control protocols are in scope?   

OWAMP and TWAMP are not in scope of LMAP either.

/js

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Tue, 11 Mar 2014 16:13:06 +0000

> I do not recall having seen 'passive measurement peer' in the framework nor
> do I recall that it was suggested that this term be added.
> 
> definition of Measurement Agent (and I though we were slowly converging
> to this change - but I am biased of course).
> 
> /js

+1
What Phil proposed in the Friday meeting "Framework" slides (https://tools.ietf.org/agenda/89/slides/slides-89-lmap-2.pdf) was 
- Measurement Peer: A function assists a Measurement Agent with Active Measurement Tasks but has no Controller interface

The proposal was to remove "Active" from this. There was lackluster humming for and against which seems to have been due to needing better understanding. I admit to also having needed better understanding. I think I understand much better now and am very much in favor of the proposal.

Brian admitted to having led the opposition humming. I'm wondering if Brian's statement in this thread of
> In any case, I stand by my statement that I'd like to see peers defined _only_ as much as is absolutely necessary to make sense of the resulting control and reporting protocols.

might also indicate that we could get rid of "Active" in the proposed definition and be done with it?
Barbara

---

From: Nalini Elkins <[email-masked]>
Date: Tue, 11 Mar 2014 09:14:34 -0700 (PDT)

Sorry, did not understand.

Thanks for the clarification.
 
Thanks,

Nalini Elkins
Inside Products, Inc.
(831) 659-8360
www.insidethestack.com

----- Original Message -----
From: Juergen Schoenwaelder <[email-masked]>
To: Nalini Elkins <[email-masked]>
Cc: Aamer Akhter (aakhter) <[email-masked]>; "Bugenhagen, Michael K" <[email-masked]>; 'Brian Trammell' <[email-masked]>; 'Dan Romascanu' <[email-masked]>; 'Matt Mathis' <[email-masked]>; "[email-masked]'" <[email-masked]>
Sent: Tuesday, March 11, 2014 9:06 AM
Subject: Re: [lmap] One example of a "passive measurement peer"

/js

---

From: Sharam Hakimi <[email-masked]>
Date: Tue, 11 Mar 2014 16:16:21 +0000

I am still trying figure out what it means to have a passive measurement peer. The entire point of a passive measurement is to be transparent to the network, so how could something transparent have a peer.

I believe the discussions were around not prohibiting passive measurements, which I believe by definition will be transparent to the network.

Sharam

-----Original Message-----
From: lmap [mailto:[email-masked]] On Behalf Of Juergen Schoenwaelder
Sent: Tuesday, March 11, 2014 12:06 PM
To: Nalini Elkins
Cc: [email-masked]'; 'Dan Romascanu'; 'Matt Mathis'; 'Brian Trammell'; Aamer Akhter (aakhter); Bugenhagen, Michael K
Subject: Re: [lmap] One example of a "passive measurement peer"

/js

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Tue, 11 Mar 2014 12:17:12 -0400

Hi Dan,

I don't see the RTP end-point as purely active of course,
but not purely passive either, because of the measure of 
knowledge of its streams and control over them (e.g., in
response to RTCP reports, the stream characteristics 
might be adjusted). 

I think RTP end-points fit within the taxonomy of hybrid 
(aspects which are both active & passive) techniques,
like the IPv6 PDM, packet coloring, and others.

Al

> From: Romascanu, Dan (Dan) [mailto:[email-masked]]
> To: MORTON, ALFRED C (AL); Brian Trammell
> Subject: RE: [lmap] One example of a "passive measurement peer"
> 
> Hi Al,
> 
> I do not see the remote RTP end-point as 'active'. There is nothing it
> does differently (no 'activity') as the result of being  a measurement
> peer.
> 
> However, I agree that removing 'active' from this document solves the
> dispute. If there is no 'active' there is no need to define 'passive'.
> 
> Regards,
> 
> Dan
> 
>

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 11 Mar 2014 16:22:51 +0000

Hi Al, 

The behavior that you describe has nothing to do with LMAP. It belongs to the RTP protocol. No traffic is generated as a result of the fact that the remote endpoint is a peer. 

Regards,

Dan

> From: MORTON, ALFRED C (AL) [mailto:[email-masked]]
> Sent: Tuesday, March 11, 2014 6:17 PM
> To: Romascanu, Dan (Dan); Brian Trammell
> I don't see the RTP end-point as purely active of course, but not purely
> passive either, because of the measure of knowledge of its streams and
> control over them (e.g., in response to RTCP reports, the stream
> characteristics might be adjusted).
> 
> I think RTP end-points fit within the taxonomy of hybrid (aspects which are
> both active & passive) techniques, like the IPv6 PDM, packet coloring, and
> others.
> 
> Al
> 
> > > From: lmap [mailto:[email-masked]] On Behalf Of MORTON,
> > > ALFRED C (AL)
> > > measurements have a priori knowledge of the stream in RTP (like
> > > active), while true passive measurements (at mid points) do not.
> > >
> > > Al
> > >
> > > > Hm. I don't really consider this passive measurement -- we
> > > > discussed this a bit in the ippm registry design team, but I'm
> > > > pretty sure there's a difference between (1) metrics derived from
> > > > the operation of a protocol at one of the endpoints participating
> > > > in it and (2) metrics derived from the passive observation of
> > > > packets emitted by those protocols. I've always thought of passive
> > > > measurement as the latter, and (1) as something like "endpoint
> > > > measurement", since metrics in (1) can also be derived from
> > > > One could say that a midpath observation point (i.e. any
> > > > observation point other than an endpoint) has as many "passive
> > > > peers" as there are observable senders and recipients, while an
> > > > "endpoint measurement
> > > agent"
> > > > defined _only_ as much as is absolutely necessary to make sense of
> > > > the resulting control and reporting protocols.
> > > >
> > > > Cheers,
> > > >
> > > > Brian
> > > >
> > > >
> > > > On 10 Mar 2014, at 14:31, Romascanu, Dan (Dan)
> > > > <[email-masked]>
> > > wrote:
> > > >
> > > > end. All these are part of RTP/RTCP, there is no interaction
> > > > between the controller and the MP, so I believe it can be
> > > > considered passive
> > in LMAP
> > > terms.
> > > > >
> > > > > Regards,
> > > > >
> > > > > Dan
> > > > >
> > > > >

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Tue, 11 Mar 2014 12:42:18 -0400

Dan, perhaps the connection to LMAP is obscure, but the RTCP-XR
metrics need to appear in the Registry (which is currently
split into passive and active sub-registries), so that the
LMAP Control and Collection protocols can refer to them.

And this is an area where IPPM'ers seek LMAP'er comments.
Al

> Sent: Tuesday, March 11, 2014 12:23 PM
> The behavior that you describe has nothing to do with LMAP. It belongs to
> the RTP protocol. No traffic is generated as a result of the fact that the
> remote endpoint is a peer.
> 
> Regards,
> 
> Dan
> 
>

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 11 Mar 2014 16:51:06 +0000

OK - so maybe it is there (in IPPM) where 'active' and 'passive' need to be defined. The criteria in my mind was whether traffic was generated beyond the payload and control traffic that belongs to the protocols on the network with the explicit purpose of executing a measurement procedure. I need however to read more on the IPPM context. 

Regards, 

Dan

> Sent: Tuesday, March 11, 2014 6:42 PM
> Dan, perhaps the connection to LMAP is obscure, but the RTCP-XR metrics
> need to appear in the Registry (which is currently split into passive and active
> sub-registries), so that the LMAP Control and Collection protocols can refer
> to them.
> 
> > The behavior that you describe has nothing to do with LMAP. It belongs
> > to the RTP protocol. No traffic is generated as a result of the fact
> > that the remote endpoint is a peer.
> >
> > Regards,
> >
> > Dan
> >
> >
> > > I don't see the RTP end-point as purely active of course, but not
> > > purely passive either, because of the measure of knowledge of its
> > > streams and control over them (e.g., in response to RTCP reports,
> > > the stream characteristics might be adjusted).
> > >
> > > I think RTP end-points fit within the taxonomy of hybrid (aspects
> > > which
> > are
> > > both active & passive) techniques, like the IPv6 PDM, packet
> > > coloring,
> > and
> > > others.
> > >
> > > Al
> > >
> > > > I do not see the remote RTP end-point as 'active'. There is
> > > > nothing it does differently (no 'activity') as the result of being
> > > > a measurement peer.
> > > >
> > > > However, I agree that removing 'active' from this document solves
> > > > the dispute. If there is no 'active' there is no need to define 'passive'.
> > > >
> > > > Regards,
> > > >
> > > > Dan
> > > >
> > > >
> > > > > +1, I briefly tried to explain this to Dan in the back of the
> > > > > +LMAP
> > > > > > pretty sure there's a difference between (1) metrics derived
> > > > > > from the operation of a protocol at one of the endpoints
> > > > > > participating in it and (2) metrics derived from the passive
> > > > > > observation of packets emitted by those protocols. I've always
> > > > > > thought of passive measurement as the latter, and (1) as
> > > > > > something like "endpoint measurement", since metrics in (1)
> > > > > > synchronized over the protocol
> > or
> > > > > > peers" as there are observable senders and recipients, while
> > > > > > an "endpoint measurement
> > > > > agent"
> > > > > > (This becomes a much more interesting distinction as soon as
> > > > > > you consider encrypting absolutely everything you can, of
> > > > > > course. At that point everything you're reduced to endpoint
> > > > > > measurement for everything other than the "envelope" and/or
> > > > > > things you derive through behavioral traffic analysis. But
> > > > > > that's a separate discussion, I think.)
> > > > > >
> > > > > > In any case, I stand by my statement that I'd like to see
> > > > > > peers defined _only_ as much as is absolutely necessary to
> > > > > > make sense of the resulting control and reporting protocols.
> > > > > >
> > > > > > Cheers,
> > > > > >
> > > > > > Brian
> > > > > >
> > > > > >
> > > > > > receives RTCP messages about the state of the other side of
> > > > > > the connection and the parameters of the received traffic at
> > > > > > the other end. All these are part of RTP/RTCP, there is no
> > > > > > interaction between the controller and the MP, so I believe it
> > > > > > can be considered passive
> > > > in LMAP
> > > > > terms.
> > > > > > >
> > > > > > > Regards,
> > > > > > >
> > > > > > > Dan
> > > > > > >
> > > > > > >
> > > > > > and security as matters of life and death, because for some
> > > > > > users, they are.

---

From: "Bugenhagen, Michael K" <[email-masked]>
Date: Tue, 11 Mar 2014 17:14:22 +0000

Here's what I meant by contextualization of the "verb" passive...

Passive means "not to react" to something..(if we're sticking to Webster's definition)
So contextually a 

1) Passive test - means the test of the subject would not react - so the service resources, and service flow are NOT impacted
2) Passive peer (should not exist.. because it wouldn't react ? ... right 

I think the real issue here is that we're talking about the different layer reactors (server entities) 

That are in a protocol like Ping, OWAMP, TWAMP, ... 
Vs.
A LMAP probe "server function" 

You could have a test that is passive to a LMAP probe level, but Active at a lower protocol level.
This is why we introduced a hierarchy like this on the BBF side.

Suggestion to un wrinkle this--

1) Describe the probe agent layer terms
	Protocol based Measurement agent (distributed control / self contained control)

	Vs. LMAP based MA - 

Then Active / Passive starts making sense again.

Regards,
Mike

-----Original Message-----
From: lmap [mailto:[email-masked]] On Behalf Of Romascanu, Dan (Dan)
Sent: Tuesday, March 11, 2014 11:51 AM
To: MORTON, ALFRED C (AL); Brian Trammell
Cc: Matt Mathis; [email-masked]
Subject: Re: [lmap] One example of a "passive measurement peer"

Regards, 

Dan

> metrics need to appear in the Registry (which is currently split into 
> passive and active sub-registries), so that the LMAP Control and 
> Collection protocols can refer to them.
> 
> > The behavior that you describe has nothing to do with LMAP. It 
> > belongs to the RTP protocol. No traffic is generated as a result of 
> > the fact that the remote endpoint is a peer.
> >
> > Regards,
> >
> > Dan
> >
> >
> > > > nothing it does differently (no 'activity') as the result of 
> > > > being a measurement peer.
> > > >
> > > > However, I agree that removing 'active' from this document 
> > > > solves the dispute. If there is no 'active' there is no need to define 'passive'.
> > > >
> > > > Regards,
> > > >
> > > > Dan
> > > >
> > > >
> > > > > For me, it's a key distinction that the RTCP-reported 
> > > > > end-point measurements have a priori knowledge of the stream 
> > > > > in RTP (like active), while true passive measurements (at mid points) do not.
> > > > >
> > > > > Al
> > > > >
> > > > > > discussed this a bit in the ippm registry design team, but 
> > > > > > I'm pretty sure there's a difference between (1) metrics 
> > > > > > derived from the operation of a protocol at one of the 
> > > > > > endpoints participating in it and (2) metrics derived from 
> > > > > > the passive observation of packets emitted by those 
> > > > > > protocols. I've always thought of passive measurement as the 
> > > > > > latter, and (1) as something like "endpoint measurement", 
> > > > > > since metrics in (1) can also be derived from internal state 
> > > > > > at each endpoint not synchronized over the protocol
> > or
> > > > > > observation point other than an endpoint) has as many 
> > > > > > "passive peers" as there are observable senders and 
> > > > > > recipients, while an "endpoint measurement
> > > > > agent"
> > > > > > interaction between the controller and the MP, so I believe 
> > > > > > it can be considered passive
> > > > in LMAP
> > > > > terms.
> > > > > > >
> > > > > > > Regards,
> > > > > > >
> > > > > > > Dan
> > > > > > >
> > > > > > >

---

From: "Bugenhagen, Michael K" <[email-masked]>
Date: Tue, 11 Mar 2014 17:35:42 +0000

Waiting for someone to call me out on 3 levels vs. 2 level... 

i.e.... 

LMAP / WT-304
Specific OAM level MA (Y.1731, OWAMP, TWAMP)
Protocol level

One could group LMAP/WT-304 along with specific OAM level protocols... or we could split them..

-----Original Message-----
From: lmap [mailto:[email-masked]] On Behalf Of Bugenhagen, Michael K
Sent: Tuesday, March 11, 2014 12:14 PM
To: 'Romascanu, Dan (Dan)'; 'MORTON, ALFRED C (AL)'; 'Brian Trammell'
Cc: 'Matt Mathis'; [email-masked]'
Subject: Re: [lmap] One example of a "passive measurement peer"

Passive means "not to react" to something..(if we're sticking to Webster's definition) So contextually a 

	Vs. LMAP based MA - 

Regards,
Mike

-----Original Message-----
From: lmap [mailto:[email-masked]] On Behalf Of Romascanu, Dan (Dan)
Sent: Tuesday, March 11, 2014 11:51 AM
To: MORTON, ALFRED C (AL); Brian Trammell
Cc: Matt Mathis; [email-masked]
Subject: Re: [lmap] One example of a "passive measurement peer"

Regards, 

Dan

---

From: "Bugenhagen, Michael K" <[email-masked]>
Date: Tue, 11 Mar 2014 18:11:08 +0000

Suggestion / proposal for responder types / layers

In terms of Agent / Responder types...  I think we'd have to decompose the agent / responders to the following levels.

This way it's very clear what's being done (and more important at which layer the resources are being hit)
Which layer does Test Admin restrictions (TWAMP has it's own)
Which layer does Node level Resource checks (over all CAC functions) ....

i.e. - All tests hit some level (tracking counters is passive to traffic but consume cpu & memory) so they hit the counter level resource.
	Ping Tests hit the IP protocol stack resource.

The "passive test peer" - actually said it doesn't impact the "peer level" service probe layer, but could impact the OAM / Application layers

Again - I think an OAM probe could be either Service layer or application specific (MEF does that approach with Multi-class of service OAM).

So Probe level / Layer wise I'm suggesting it would look like this (define the parts so we can define the relationship between the parts).

Service Probe Layer           -------
General purpose 			|	|	
Test anything Agent		|	|
					-------

OAM and Application 
Specific responder layer      -------
Y.1731 				|	|	
O/T WAMP				|	|
RTP/RTCP / Timing			-------

IP protocol responder Layer   -------
PING / ICMP				|	|	
					|	|
					-------

Counter and Atomic level	-------
Resources / Agents		|	|
					|	|
					-------

-----Original Message-----
From: Bugenhagen, Michael K 
Sent: Tuesday, March 11, 2014 12:36 PM
To: Bugenhagen, Michael K; 'Romascanu, Dan (Dan)'; 'MORTON, ALFRED C (AL)'; 'Brian Trammell'
Cc: 'Matt Mathis'; [email-masked]'
Subject: RE: [lmap] One example of a "passive measurement peer"

i.e.... 

LMAP / WT-304
Specific OAM level MA (Y.1731, OWAMP, TWAMP) Protocol level

-----Original Message-----
From: lmap [mailto:[email-masked]] On Behalf Of Bugenhagen, Michael K
Sent: Tuesday, March 11, 2014 12:14 PM
To: 'Romascanu, Dan (Dan)'; 'MORTON, ALFRED C (AL)'; 'Brian Trammell'
Cc: 'Matt Mathis'; [email-masked]'
Subject: Re: [lmap] One example of a "passive measurement peer"

	Vs. LMAP based MA - 

Regards,
Mike

-----Original Message-----
From: lmap [mailto:[email-masked]] On Behalf Of Romascanu, Dan (Dan)
Sent: Tuesday, March 11, 2014 11:51 AM
To: MORTON, ALFRED C (AL); Brian Trammell
Cc: Matt Mathis; [email-masked]
Subject: Re: [lmap] One example of a "passive measurement peer"

Regards, 

Dan

---

From: Brian Trammell <[email-masked]>
Date: Tue, 11 Mar 2014 21:38:11 +0100

On 11 Mar 2014, at 17:51, Romascanu, Dan (Dan) <[email-masked]> wrote:

> OK - so maybe it is there (in IPPM) where 'active' and 'passive' need to be defined.

Indeed, we'll refine this within IPPM as part of the registry effort, the three core documents of which will be adopted as working groups drafts shortly.

> The criteria in my mind was whether traffic was generated beyond the payload and control traffic that belongs to the protocols on the network with the explicit purpose of executing a measurement procedure. I need however to read more on the IPPM context. 

There's no hard definition yet. I recall during the design team discussions this being a point (passive vs "endpoint") being a point which will require further refinement.

Regards,

Brian

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 12 Mar 2014 07:53:57 +0100

> In terms of Agent / Responder types...  I think we'd have to decompose the agent / responders to the following levels.

[...]

I do not think any decomposition is needed for doing the LMAP work
in the IETF.

/js