Subject: [lmap] Progress on Framework

From: <[email-masked]>
Date: Thu, 13 Mar 2014 15:29:27 +0000

I'm trying to resolve the issues raised in WG Last call about the framework http://tools.ietf.org/html/draft-ietf-lmap-framework-03

1.    Especially if you weren't in London, please can you check the slides to make sure you're happy with the proposed consensus on the various issues. http://tools.ietf.org/agenda/89/slides/slides-89-lmap-2.pdf   (ignore slides 5, 6, 7 - see link below instead)

2.    I prepared some slides about the MA vs MP terminology in action. Do these examples help clarify things? They could be turned into some text for the next version of the framework  http://www.leone-project.eu/drupal/sites/default/files/public_downloads/lmap-framework-examples-13march2014.pdf

I plan to work on the framework i-d next week, so please let me know if you have any comments.

Background: A group of us met for a side meeting in London and (we think) reached consensus on all the open issues. I presented the proposals during the WG meeting in London. We had some good discussion, especially about the terminology for Measurement Peer, which led to consensus round a slightly revised wording, and the suggestion that the i-d should include some explanatory examples, to illustrate the MA vs MP terminology in action.

Thanks!
Best wishes
phil

---

From: Greg Mirsky <[email-masked]>
Date: Wed, 19 Mar 2014 17:49:18 -0700

Hi Phil,
I've got a question on:
Basic  distinction  between  MA  and  Measurement  Peer
- MA  interacts  with  Controller  and  Collector
- MP  doesn't
My question What would call a node that doesn't interact with Controller
but does interact with Collector? Would characterize it as MA or MP? Or
you believe that such scenario is not realistic or must not be allowed?
If we consider, for example, OWAMP as in Example 1b but with minor
modification. Fetch-Client (acts as Collector) may retrieve measurements
from Server/Session-Receiver and not be co-located with Session-Sender
(acts as MA). Would Session-Receiver be viewed as MA since Server is part
of Controller or as MP?

Regards,
Greg

On Thu, Mar 13, 2014 at 8:29 AM, <[email-masked]> wrote:

> I'm trying to resolve the issues raised in WG Last call about the
> framework http://tools.ietf.org/html/draft-ietf-lmap-framework-03
>
>
>
> 1.    Especially if you weren't in London, please can you check the
> slides to make sure you're happy with the proposed consensus on the various
> issues. http://tools.ietf.org/agenda/89/slides/slides-89-lmap-2.pdf
> (ignore slides 5, 6, 7 - see link below instead)
>
> 2.    I prepared some slides about the MA vs MP terminology in action. Do
> these examples help clarify things? They could be turned into some text for
> the next version of the framework
> http://www.leone-project.eu/drupal/sites/default/files/public_downloads/lmap-framework-examples-13march2014.pdf
>
>
>
> Background: A group of us met for a side meeting in London and (we think)
> reached consensus on all the open issues. I presented the proposals during
> the WG meeting in London. We had some good discussion, especially about the
> terminology for Measurement Peer, which led to consensus round a slightly
> revised wording, and the suggestion that the i-d should include some
> explanatory examples, to illustrate the MA vs MP terminology in action.
>
>
>
> Thanks!
>
> Best wishes
>
> phil
>
> _______________________________________________
> lmap mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lmap
>
>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 20 Mar 2014 08:35:09 +0100

> you believe that such scenario is not realistic or must not be allowed?

How does such a node know to which controller(s) to send data, how
frequently, which security credentials to use? Do you assume all this
information typically provided by a controller is hardwired?

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Paul Aitken <[email-masked]>
Date: Thu, 20 Mar 2014 10:55:20 +0000

> information typically provided by a controller is hardwired?

+1. A node shouldn't interact with the Collector unless + until it has 
been instructed to do so by a Controller.

Even if the node is pre-set to report to a specific Collector (eg, it's 
factory programmed), it MUST be possible for a Collector to disable the 
reporting.
(eg, years later when the Collector is no longer in use, or the 
Collector's IP has been re-assigned.)

Arguably it should always be possible for a Controller to reconfigure a 
device, no matter how simple it is.

So basic requirements are surely:

     (a) enable / disable reports, and
     (b) set a new Collector address.

P.

---

From: <[email-masked]>
Date: Thu, 20 Mar 2014 11:04:18 +0000

I agree with this.

It is always possible that a node may do something outside the LMAP framework (perhaps even a MP could ignore Juergen's caveat and, without being instructed by a Controller, send results to a Collector, perhaps even using lmap's report protocol). It is perfectly ok for people to use some parts of lmap in new ways. But I think we should worry about the main use case. 

Best wishes
phil

> -----Original Message-----
> From: Paul Aitken [mailto:[email-masked]]
> Sent: 20 March 2014 10:55
> To: Greg Mirsky; Eardley,PL,Philip,TUB8 R; [email-masked]
> Subject: Re: [lmap] Progress on Framework
> 
> >> My question What would call a node that doesn't interact with
> >> Controller but does interact with Collector? Would characterize it
> as
> >> MA or MP? Or you believe that such scenario is not realistic or must
> not be allowed?

---

From: marcelo bagnulo braun <[email-masked]>
Date: Thu, 20 Mar 2014 12:12:14 +0100

yes, i agree.
even if a MA is not initiating measurement tasks, there must be a 
communication with the controller to schedule the reporting tasks.

El 20/03/14 11:55, Paul Aitken escribió:
>>> Controller
> Even if the node is pre-set to report to a specific Collector (eg, 
> it's factory programmed), it MUST be possible for a Collector to 
> disable the reporting.
> Arguably it should always be possible for a Controller to reconfigure 
> a device, no matter how simple it is.
>

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Thu, 20 Mar 2014 08:19:01 -0400

So here's where I come out on this:

Strictly speaking, the MP does not participate in LMAP protocols (in the typical use)
and
 - it assists a measurement function that is governed by an MA by participating in 
   a measurement (or other) protocol.

Al

> From: lmap [mailto:[email-masked]] On Behalf Of marcelo bagnulo
> braun
> Sent: Thursday, March 20, 2014 7:12 AM
> To: [email-masked]

---

From: Sharam Hakimi <[email-masked]>
Date: Thu, 20 Mar 2014 14:24:04 +0000

There is nothing in the LMAP frame work to prohibit a rouge reporter. Normally the controller would have to provide the collector's information to the MA. This would be part of an implementation to make sure reports are coming from a commissioned MA in my opinion.

/Sharam 

Al

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Thu, 20 Mar 2014 10:27:12 -0400

to address Dan's Last Call comment, there will be material in the
security section to address this attack.

Al,
assuming
s/rouge/rogue/
is what you meant

> From: Sharam Hakimi [mailto:[email-masked]]
> Sent: Thursday, March 20, 2014 10:24 AM
> To: MORTON, ALFRED C (AL); marcelo bagnulo braun; [email-masked]
> Subject: RE: [lmap] Progress on Framework
> 
> There is nothing in the LMAP frame work to prohibit a rouge reporter.
> Normally the controller would have to provide the collector's information
> to the MA. This would be part of an implementation to make sure reports
> are coming from a commissioned MA in my opinion.
> 
> /Sharam
> 
>

---

From: Sharam Hakimi <[email-masked]>
Date: Thu, 20 Mar 2014 14:38:18 +0000

Sorry, yes rogue is what I meant. Typing too fast.

/Sharam

Al,
assuming
s/rouge/rogue/
is what you meant

---

From: marcelo bagnulo braun <[email-masked]>
Date: Thu, 20 Mar 2014 15:47:27 +0100

In any case, imh the defintion of an MP should state that the MP does 
not communicate neither with the controller nor the collector. If it has 
communication with any of these elements, it is considered an MA.

I think the important point is to make a clear distinction so to have a 
proper defintion

---

From: Greg Mirsky <[email-masked]>
Date: Thu, 20 Mar 2014 09:55:03 -0700

Hi Marcelo,
I agree and clarification is what I've asked about initially.
As possible way for MP to obtain information about Collector I've been
thinking of bootstrapping process, similar to bootstrapping MA with
Controller, security and etc. information. Would LMAP-wise bootstrapping
apply to MP? What may be scope of it, if bootstrapping MP is required? And
what is optional?

Regards,
Greg

On Thu, Mar 20, 2014 at 7:47 AM, marcelo bagnulo braun
<[email-masked]>wrote:

> In any case, imh the defintion of an MP should state that the MP does not
> communicate neither with the controller nor the collector. If it has
>> to the MA. This would be part of an implementation to make sure reports are
>> coming from a commissioned MA in my opinion.
>>
>> /Sharam
>>
>>
>>>>>> but does interact with Collector? Would characterize it as MA or MP?
>>>>>>
>>>>> Or
>>>
>>>> you believe that such scenario is not realistic or must not be
>>>>>>
>>>>> allowed?
>>>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 20 Mar 2014 18:15:50 +0100

> apply to MP? What may be scope of it, if bootstrapping MP is required? And

Quoting the framework:

   The MA needs to be bootstrapped with initial details about its
   Controller, including authentication credentials.  The LMAP WG
   considers the bootstrap process, since it affects the Information
   Model.  However, it does not define a bootstrap protocol, since it is
   likely to be technology specific and could be defined by the
   Broadband Forum, CableLabs or IEEE depending on the device.  Possible
   protocols are SNMP, NETCONF or (for Home Gateways) CPE WAN Management
   Protocol (CWMP) from the Auto Configuration Server (ACS) (as
   specified in TR-069).

/js

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Thu, 20 Mar 2014 17:22:00 +0000

> > Controller, security and etc. information. Would LMAP-wise
> > bootstrapping apply to MP? What may be scope of it, if bootstrapping
> > MP is required? And what is optional?
> 
> Quoting the framework:
> 

I wonder if I could re-suggest what I'd said earlier, that maybe the definition of MP is:
A function that assists a Measurement Agent with Measurement Tasks. All other interfaces to a MP are undefined.

Barbara