Subject: [lmap] BBF Review - IETF Information Model - Timers

From: "Carey, Timothy (Timothy)" <[email-masked]>
Date: Thu, 20 Mar 2014 13:30:06 +0000

Trevor,

We reviewed the IETF draft information model as instantiated in a TR-069 (TR-181) device 2 data model last week.

There was a question from William Lupton of Cisco regarding the concept of Randomness in the Timers of the Information model.

I will post it here for comment.

  *   need to define randomness parameters more rigorously, e.g. upper limit and lower limit don't obviously relate to (mean,sigma); I am guessing that mean is zero and spread is the same as sigma? also, what is poisson here? isn't poisson a discrete distribution; also need units and examples
Any help would be appreciative

BR,
Tim

---

From: <[email-masked]>
Date: Thu, 20 Mar 2014 14:04:40 +0000

Yes this does need to be clarified. I was assuming a distribution about the mean (i.e. the timing given is the mean). The spread would be the standard deviation (could use mean deviation or something else but I see no advantage as long as we all know what it refers to) and need to change to a float. The upper and lower cuts would be in seconds +/- the mean (also needs to change to float) and are simply used to trim the function - obviously needed on a uniform distribution but useful to constrain other functions.

I will make all this clear in the next release.

As for poisson I think there are 3 options:

-        Use a continuous form instead

-        Have the discrete interval implicit in the function choice e.g."poisson_1_sec"

-        Add an interval to the information model.

I was really thinking about the first, but I don't see the problem with the second. However I wouldn't do the third unless they was a demonstrable value to supporting discrete functions (rather than continuous versions of them).

Trevor.

From: lmap [mailto:[email-masked]] On Behalf Of Carey, Timothy (Timothy)
Sent: 20 March 2014 13:30
To: [email-masked]
Subject: [lmap] BBF Review - IETF Information Model - Timers

Trevor,

BR,
Tim