Subject: [lmap] Question on Information Model - Interface attribute on Channels

From: "Carey, Timothy (Timothy)" <[email-masked]>
Date: Tue, 13 May 2014 19:18:53 +0000

Trevor,

During the BBF review of the LMAP information model, the group had a question regarding the usage of the Channel's interface name.

Specifically they wanted to know if there was any limitations on the type of interface (e.g., Layer 3 interface only, WAN only)...
<TAC> My opinion is that any interface could be used and we shouldn't limit the interface.

Also - what is the behavior if the Interface name is not provided?
<TAC> My opinion if the Interface is used; the channel is restricted to the interface; if it is not any available interface could be used...

BR,
Tim

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 13 May 2014 23:52:31 +0200

> <TAC> My opinion is that any interface could be used and we shouldn't limit the interface.

This is also my interpretation.
 
> <TAC> My opinion if the Interface is used; the channel is restricted to the interface; if it is not any available interface could be used...

Normally, the specification of the interface name is not needed since
the IP layer decides which interface to use. An explicit interface
definition is needed in cases where multiple choices are possible and
it is necessary to exercise explicit control over the choice. So yes,
it is any interface could be used (and which is being actually used is
determined by the lower layers of the networking stack).

I agree that this could be more explicitely described.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>