Subject: Re: [lmap] FW: New Version Notification for draft-ietf-lmap-framework-04.txt

From: Greg Mirsky <[email-masked]>
Date: Fri, 2 May 2014 18:49:51 -0700

Hi Juergen, et. al,
is the Suppression viewed as result of explicit command from MA Controller
to MA Agent or it may be implicitly determined by an MA based on certain
conditions of network environment? If that is the former, then I think that
there may be not one but two types of Suppression:

   - suppression of Measurement Task(s)
   - suppression of reporting Results (but not suppressing failure
   notification)

And if that is the latter, then both types seems be valid as well:

   - certain Measurement Tasks may be suppressed as resource utilization
   threshold crossed
   - posting Results would be suppressed if Data Collector deemed
   unavailable

But I'm not sure to what level of details we need to characterize and
describe Suppression mechanism in the framework document. I think that
details may be placed and explained in specification of the Control
protocol while LMAP framework would mention Suppression mechanism in very
generic terms leaving details for further study.

Regards,
Greg

On Mon, Apr 28, 2014 at 1:23 PM, Juergen Schoenwaelder <
[email-masked]> wrote:

> On Mon, Apr 28, 2014 at 02:15:38PM -0600, Charles Cook wrote:
> > It is good we are having this discussion.  I am not sure if I am saying
> > the same as what Juergen is saying in b), but my understanding is that:
> >
> > Default Suppression means that all Measurement Tasks that generate
> > traffic are suppressed (however the MA decides how to do that -
> > filtering at the MA so that no traffic is generated could be one way to
> > do it, cancelling the current instance of the Measurement Task could be
> > another way to do it).  Schedules stay in place such that if an
> > un-Suppression is received, that a scheduled Measurement Task will
> > commence when the time comes (as long as the scheduled time for the
> > Measurement Task to be executed occurs after the un-Suppression has been
> > received).
> >
>
> I prefer to have a precise definition what suppression means. I can
> easily picture measurement tasks where leaving the task running while
> temporarily block the traffic leads to different results compared to
> stopping the task and restarting it later. In terms of the traffic
> generated during suppression, the result may be the same but a restart
> causes measurement task internal context information to get lost,
> which can be more disruptive to the measurement.
>
> /js
>
> --
> Juergen Schoenwaelder           Jacobs University Bremen gGmbH
> Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
> Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>
>
> _______________________________________________
> lmap mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lmap
>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Sat, 3 May 2014 14:57:42 +0200

>    - suppression of reporting Results (but not suppressing failure

In the -00 information model, suppression is communicated from the
Controller to the MA and suppression can be time scheduled.
 
> generic terms leaving details for further study.

There was some discussion to consider reporting a reporting task that
gets schedulued list a measurement task and in that case suppression
could easily applied to both kind of tasks. But this is not in -00.

/js

---

From: 邓灵莉/Lingli Deng <[email-masked]>
Date: Sun, 4 May 2014 14:47:19 +0800

Hi all,

Following up the suppression discussion, I also have a question (inline below) regarding the framework draft.

Lingli

> -----Original Message-----
> From: lmap [mailto:[email-masked]] On Behalf Of Juergen
> Schoenwaelder
> Sent: Saturday, May 03, 2014 8:58 PM
> To: Greg Mirsky
> Cc: [email-masked]; Charles Cook; [email-masked]; [email-masked]
> Subject: Re: [lmap] FW: New Version Notification for
> draft-ietf-lmap-framework-04.txt
> 
[邓灵莉/Lingli Deng] There is an element in the instruction structure, under the name of "suppression information (if any)" in the current framework draft.
When I read through the draft, I assumed that it was for the second case that Greg mentioned as suppressions "implicitly determined by an MA based on certain
conditions of network environment". However, I could not find any clear explanation in the text to justify this speculation. As it simply states " (see Section 5.2.1.1) " and without any further information actually given in Section 5.2.1.1. I would like to see more text to clarify the purpose and content of this element.

---

From: <[email-masked]>
Date: Tue, 6 May 2014 10:56:59 +0100

> [邓灵莉/Lingli Deng] There is an element in the instruction structure,
> under the name of "suppression information (if any)" in the current
> framework draft.
> When I read through the draft, I assumed that it was for the second
> case that Greg mentioned as suppressions "implicitly determined by an
> MA based on certain conditions of network environment". However, I
> could not find any clear explanation in the text to justify this
> speculation. As it simply states " (see Section 5.2.1.1) " and without
> any further information actually given in Section 5.2.1.1. I would like
> to see more text to clarify the purpose and content of this element.
> >

There's a typo in the reference - it should be "see Section 5.3.1.1"
Suppression is part of the Instruction, ie what the Controller tells the MA to do.
It is also possible that the MA can decide not to run Task(s), "implicitly determined by an
MA based on certain conditions of network environment". This is not suppression. It is discussed in S5.4.1, "Starting and stopping Measurement Tasks" (S5 is about how the MA operates Measurement Tasks).

Thanks
phil

---

From: 邓灵莉/Lingli Deng <[email-masked]>
Date: Tue, 6 May 2014 18:21:19 +0800

Hi Phil,

Thanks for the clarification. 
However, I really doubt that we are looking at the same version of the document.
Plz see more inline.

Lingli

> From: lmap [mailto:[email-masked]] On Behalf Of
> [email-masked]
> Sent: Tuesday, May 06, 2014 5:57 PM
> To: [email-masked]; [email-masked];
> [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked]
[邓灵莉/Lingli Deng] I am afraid I cannot find Section 5.3.1.1 in the current -04 version.

> MA based on certain conditions of network environment". This is not
> suppression. It is discussed in S5.4.1, "Starting and stopping Measurement
> Tasks" (S5 is about how the MA operates Measurement Tasks).
[邓灵莉/Lingli Deng] I understand your point. However, in the version that I am looking at, "Starting and stopping Measurement Tasks" is labeled as Section 5.3.1 rather than 5.4.1.

---

From: <[email-masked]>
Date: Tue, 6 May 2014 11:25:05 +0100

Sorry, you're right about the section numbering (was looking at my working version of -05)

> From: 邓灵莉/Lingli Deng [mailto:[email-masked]]
> Sent: 06 May 2014 11:21
> To: Eardley,PL,Philip,TUB8 R; [email-masked];
> [email-masked]
> Subject: RE: [lmap] FW: New Version Notification for draft-ietf-lmap-
> framework-04.txt
> 
> Hi Phil,
> 
> > > case that Greg mentioned as suppressions "implicitly determined by
> > > an MA based on certain conditions of network environment". However,
> > > I could not find any clear explanation in the text to justify this
> > > speculation. As it simply states " (see Section 5.2.1.1) " and
> > > without any further information actually given in Section 5.2.1.1.
> I
> > > would like to see more text to clarify the purpose and content of
> this element.
> > > >
> >
> > It is also possible that the MA can decide not to run Task(s),
> > "implicitly determined by an MA based on certain conditions of
> network
> > environment". This is not suppression. It is discussed in S5.4.1,
> > "Starting and stopping Measurement Tasks" (S5 is about how the MA
> > operates Measurement Tasks).
> [邓灵莉/Lingli Deng] I understand your point. However, in the version
> that I am looking at, "Starting and stopping Measurement Tasks" is
> labeled as Section 5.3.1 rather than 5.4.1.
> >
> > Thanks
> > phil