Subject: Re: [lmap] Timer: Poisson distribution question

From: "Carey, Timothy (Timothy)" <[email-masked]>
Date: Sat, 10 May 2014 18:52:50 +0000

Ken,

I am in the process of commenting on the BBF model TR-181i2a8 for StrawBallot.
While you are correct in your assumption the Ti isn't really known when you setup the timer (which also could be used for multiple Tis). So I plan to keep what Marc was saying.

My question to the group is should we limit the Randomness to just the distribution to what Marc suggested or should we keep the capability for multiple distributions. - If so is this the Uniform-Discrete distribution?

Thanks,
Tim

-----Original Message-----
From: KEN KO [mailto:[email-masked]] 
Sent: Thursday, April 24, 2014 7:17 AM
To: marc.ibrahim; Sharam Hakimi; Juergen Schoenwaelder
Cc: Carey, Timothy (Timothy); [email-masked]; [email-masked]
Subject: RE: [lmap] Timer: Poisson distribution question

Since Ti+Xmin is non-random, Xmin is not really needed as a separate parameter. Just offset Ti to the desired minimum time and let the spread range from Ti to Ti+Xmax.

Other than that nit, +1

-----Original Message-----
From: marc.ibrahim [mailto:[email-masked]] 
Sent: Wednesday, April 23, 2014 7:08 PM
To: KEN KO; Sharam Hakimi; Juergen Schoenwaelder
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [lmap] Timer: Poisson distribution question

Based on what has been exchanged, I suggest the following:

1- Exact randomness definition and operation
--------------------------------------------
IMHO, we need to define how exactly the randomness is applied.

For a given event E (e.g. running a measurement task, start reporting,...), let Ti be the predefined (scheduled) instant of the ith occurrence of E. 
Adding randomness means that the event E will happen at time Ti + X instead of Ti, where X is a random variable. If Xmin and Xmax denote the minimum and maximum possible values of X repectively, then the event E will take place at an instant randomly chosen between 
Ti+Xmin and Ti+Xmax. The spread is equal to Xmax-Xmin

      Ti+Xmin             Ti                 Ti+Xmax
---------|-----------------|-------------------|-----------

         <------------------------------------->
                        Spread

Note that Xmin could be negative if E can occur before Ti like in the figure. I think that the most common values of Xmin would be 0 or (-spread/2).

2- Random generation of X
---------------------------
To make it simple as stated by many, X could an integer number of milliseconds uniformly chosen in the interval [Xmin, Xmax].
Xmin, Xmax, and hence spread, are all integers (milliseconds).

Then the MA has to define a function UNIF(Xmin, Xmax) or equivalently UNIF(Xmin, spread) that generates a random number of milliseconds from [Xmin, Xmax] interval.
The controller has just to send two integer variables (Xmin, Xmax) or (Xmin, spread) to the MA in the timing object.

In this minimalist approach, no need to specify the nature of distribution in the timing object since it is assumed to be the uniform one. 

BR,

Marc.

On Wed, 23 Apr 2014 18:55:39 +0000, KEN KO wrote
> This example confuses resolution of the measurement result with resolution and 
> accuracy of the time at which the measurement is initiated. Measuring round 
> trip latencies on a Gigabit LAN may well require microsecond resolution, which 
> could be within the capabilities of a higher end MA. But that doesn't require 
> microsecond resolution of the time at which the measurement is initiated. In 
> addition, for microsecond resolution on the Timer to be meaningful would 
> require synchronization to that resolution across different MAs in the network.
> 
> I'm in favor of keeping things simple and specifying Timer resolution in milliseconds.
> 
> -----Original Message-----
> From: lmap [mailto:[email-masked]] On Behalf Of Sharam Hakimi
> Sent: Wednesday, April 23, 2014 11:33 AM
> To: Juergen Schoenwaelder; marc.ibrahim
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: Re: [lmap] Timer: Poisson distribution question
> 
> It depends what the performance goal of the measurement is. A ping packet in a 
> Gigabit network is just under 1 microseconds and with fast processors a packet 
> can be sent and received at the same time if granularity is milliseconds.
> 
> This does not even take into account 10Gig networks, not that they would be at 
> consumer sites, but they would sure exist inside a ISP network.
> 
> Sharam
> 
> -----Original Message-----
> From: Juergen Schoenwaelder [mailto:[email-masked]]
> Sent: Wednesday, April 23, 2014 11:11 AM
> To: marc.ibrahim
> Cc: [email-masked]; Sharam Hakimi; [email-masked]; 
[email-masked]
> Subject: Re: [lmap] Timer: Poisson distribution question
> 
> I believe randomization with a granularity of milliseconds is good enough. 
> Within an implementation of a measurement task, one may use more precise 
> timers. But for the randomization of the start of measurement tasks or the 
> sending of reports, milliseconds seem to be sufficient (since there will be 
> likely other delays introduced by the operating system that may get into the 
> some order for starting a measurement task or triggering a report).
> 
> /js
> 
> On Wed, Apr 23, 2014 at 06:02:45PM +0300, marc.ibrahim wrote:
> > I would say that choosing the millisecond as atomic time alleviates 
> > constraints on both timer granularity and generator capacity.
> > 
> > I still don't see a real measurement example where few microseconds would really 
matter.
> > 
> > Practically, can a program deal with microseconds timers in computers and 
smartphones? 
> > This is the scale of the OS, no?
> > 
> > Marc.
> > 
> > On Wed, 23 Apr 2014 15:22:08 +0100, trevor.burbridge wrote
> > > So the question is really do we want to design for extremely 
> > > constrained devices? I'd argue that if this is a problem for them 
> > > then they are really going to struggle with the Instruction information or 
measurement results.
> > > 
> > > Trevor.
> > > 
> > > >-----Original Message-----
> > > >From: marc.ibrahim [mailto:[email-masked]]
> > > >Sent: 23 April 2014 15:00
> > > >To: Burbridge,T,Trevor,TUB8 R; [email-masked]; 
> > > >[email-masked]; [email-masked]
> > > >Subject: Re: [lmap] Timer: Poisson distribution question
> > > >
> > > >Here is how I see the problem.
> > > >
> > > >First we have to separate time granularity and random generation.
> > > >
> > > >Time granularity depends on the timer running on the MA. e.g 
> > > >microseconds scale means that the MA timer increment each microsecond.
> > > >
> > > >When MA wants to generate a random time, he has to choose an 
> > > >integer number of microseconds to count. So the problem is always 
> > > >an integer (discrete) number generation.
> > > >
> > > >Now, if the random generator can attain the maximum integer (so the 
> > > >maximum possible random time), then, as Trevor says, no need for 
> > > >the timeStep I talked about, since all possible durations will be expressed as 
multiple of microseconds.
> > > >
> > > >
> > > >For example, a 32 bits random generator could generate up to a 
> > > >maximum value of 4 billions. In microseconds, this is equal to less than 2 hours.
> > > >
> > > >It all depends on the capacity of the generator.
> > > >Marc.
> > > >
> > > >
> > > >On Wed, 23 Apr 2014 14:13:34 +0100, trevor.burbridge wrote
> > > >> So what is the argument for the latter (discrete) option?
> > > >>
> > > >> Trevor.
> > > >>
> > > >> >-----Original Message-----
> > > >> >From: marc.ibrahim [mailto:[email-masked]]
> > > >> >Sent: 23 April 2014 14:10
> > > >> >To: Burbridge,T,Trevor,TUB8 R; [email-masked]; 
> > > >> >[email-masked]; [email-masked]
> > > >> >Subject: Re: [lmap] Timer: Poisson distribution question
> > > >> >
> > > >> >Trevor, you're right.
> > > >> >it is just about whether we want a discrete or continuous generator.
> > > >> >If we use a continuous uniform generator, than it is enough to 
> > > >> >specify the maximum time.
> > > >> >With a discrete random generator, you need to specify an 
> > > >> >additional time granularity.
> > > >> >
> > > >> >BR,
> > > >> >
> > > >> >Marc.
> > > >> >
> > > >> >
> > > >> >On Wed, 23 Apr 2014 14:03:40 +0100, trevor.burbridge wrote
> > > >> >> I'm not sure I get the point of allowing coarser granularity 
> > > >> >> that the MA is capable of. If I want the MA to test/report 
> > > >> >> sometime within a minute window, why not allow that to happen 
> > > >> >> with the maximum resolution the MA is capable
> > > >> >of?
> > > >> >>
> > > >> >> Trevor.
> > > >> >>
> > > >> >> Trevor Burbridge
> > > >> >> Network Infrastructure & Innovation | BT Innovate & Design
> > > >> >> Tel: 01473 645115
> > > >> >> Fax: 01473 640929
> > > >> >>
> > > >> >> This email contains BT information, which may be privileged or confidential.
> > > >> >> It's meant only for the individual(s) or entity named above. 
> > > >> >> If you're not the intended recipient, note that disclosing, 
> > > >> >> copying, distributing or using this information is prohibited. 
> > > >> >> If you've received this email in error, please let me know 
> > > >> >> immediately on the email address above. Thank you. We monitor 
> > > >> >> our email system, and may record your emails. British 
> > > >> >> Telecommunications plc Registered
> > > >> >> office: 81 Newgate Street London EC1A 7AJ Registered in 
> > > >> >> England
> > > >> >no:
> > > >> >> 1800000
> > > >> >>
> > > >> >> From: lmap [mailto:[email-masked]] On Behalf Of Sharam 
> > > >> >> Hakimi
> > > >> >> Sent: 23 April 2014 13:58
> > > >> >> To: Carey, Timothy (Timothy); Burbridge,T,Trevor,TUB8 R; 
> > > >> >> [email-masked]
> > > >> >> Subject: Re: [lmap] Timer: Poisson distribution question
> > > >> >>
> > > >> >> Marc's suggestion works for me. That allows better 
> > > >> >> interoperability in my
> > > >> >opinion.
> > > >> >>
> > > >> >> I do agree that we need a common "structure" and "names".
> > > >> >>
> > > >> >> Thanks,
> > > >> >> Sharam
> > > >> >>
> > > >> >> From: Carey, Timothy (Timothy) 
> > > >> >> [mailto:[email-masked]]
> > > >> >> Sent: Wednesday, April 23, 2014 8:47 AM
> > > >> >> To: [email-masked]<mailto:[email-masked]>; 
> > > >> >> Sharam
> > > >> >Hakimi;
> > > >> >[email-masked]<mailto:[email-masked]>
> > > >> >> Subject: RE: Timer: Poisson distribution question
> > > >> >>
> > > >> >> Trevor,
> > > >> >>
> > > >> >> No - I am using the variable of your Information Model 
> > > >> >> (LowerLimit,
> > > >> >UpperLimit,
> > > >> >>  Spread) - works so far. Marc suggested a TimeStep parameter 
> > > >> >> so we don't lockin on a specific microsecond, millisecond, 
> > > >> >> second thing - I am open
> > > >to that.
> > > >> >>
> > > >> >> BR,
> > > >> >> Tim
> > > >> >>
> > > >> >> From: [email-masked]<mailto:[email-masked]>
> > > >> >[mailto:[email-masked]]
> > > >> >> Sent: Wednesday, April 23, 2014 7:41 AM
> > > >> >> To: Carey, Timothy (Timothy);
> > > >> >> [email-masked]<mailto:[email-masked]>;
> > > >> >[email-masked]<mailto:[email-masked]>
> > > >> >> Subject: RE: Timer: Poisson distribution question
> > > >> >>
> > > >> >> Agree we need to have well defined function names. I thought 
> > > >> >> you were also suggesting different functions needed different input 
parameters.
> > > >> >>
> > > >> >> Trevor.
> > > >> >>
> > > >> >> Trevor Burbridge
> > > >> >> Network Infrastructure & Innovation | BT Innovate & Design
> > > >> >> Tel: 01473 645115
> > > >> >> Fax: 01473 640929
> > > >> >>
> > > >> >> This email contains BT information, which may be privileged or confidential.
> > > >> >> It's meant only for the individual(s) or entity named above. 
> > > >> >> If you're not the intended recipient, note that disclosing, 
> > > >> >> copying, distributing or using this information is prohibited. 
> > > >> >> If you've received this email in error, please let me know 
> > > >> >> immediately on the email address above. Thank you. We monitor 
> > > >> >> our email system, and may record your emails. British 
> > > >> >> Telecommunications plc Registered
> > > >> >> office: 81 Newgate Street London EC1A 7AJ Registered in 
> > > >> >> England
> > > >> >no:
> > > >> >> 1800000
> > > >> >>
> > > >> >> From: Carey, Timothy (Timothy) 
> > > >> >> [mailto:[email-masked]]
> > > >> >> Sent: 23 April 2014 13:36
> > > >> >> To: Sharam Hakimi; Burbridge,T,Trevor,TUB8 R;
> > > >> >[email-masked]<mailto:[email-masked]>
> > > >> >> Subject: RE: Timer: Poisson distribution question
> > > >> >>
> > > >> >> Its not that the Measurement controller has to configure the 
> > > >> >> timer for the
> > > >MA.
> > > >> >>
> > > >> >> If we do not specify the functions and variable names, the 
> > > >> >> measurement controller doesn't have a standard way of configuring a timer.
> > > >> >>
> > > >> >> For example - If I specify for a Uniform distribution function 
> > > >> >> called "Uniform" you have a  variable called "UpperLimit", the 
> > > >> >> MA will implement the specification; the controller will 
> > > >> >> implement the
> > > >specification and things work.
> > > >> >>
> > > >> >> If I do not specify anything for the Uniform distribution 
> > > >> >> function
> > > >> >> - MA vendor
> > > >> >> 1 can call it "UniformDF" and "UL - which is typed real" and 
> > > >> >> maybe an
> > > >"Enable"
> > > >> >> parameter for good measure; MA vendor 2 can call it "U" and 
> > > >> >> have an attribute "X that is an integer".
> > > >> >>
> > > >> >> Now put that variation on steroids based on the number of MA 
> > > >> >> vendors - That is why we specify things, right?
> > > >> >>
> > > >> >> BR,
> > > >> >> Tim
> > > >> >>
> > > >> >> From: Sharam Hakimi [mailto:[email-masked]]
> > > >> >> Sent: Wednesday, April 23, 2014 7:24 AM
> > > >> >> To: Carey, Timothy (Timothy);
> > > >> >> [email-masked]<mailto:[email-masked]>;
> > > >> >[email-masked]<mailto:[email-masked]>
> > > >> >> Subject: RE: Timer: Poisson distribution question
> > > >> >>
> > > >> >> The measurement controller has to communicate what tests have 
> > > >> >> to be run on
> > > >> >an
> > > >> >> MA, for how long, when to run them, what test results are 
> > > >> >> generated, etc. Why would configuring this parameter be any 
> > > >> >> different. Maybe I am missing
> > > >> >something.
> > > >> >>
> > > >> >> From: Carey, Timothy (Timothy) 
> > > >> >> [mailto:[email-masked]]
> > > >> >> Sent: Wednesday, April 23, 2014 8:16 AM
> > > >> >> To: Sharam Hakimi;
> > > >> >[email-masked]<mailto:[email-masked]>;
> > > >> >[email-masked]<mailto:[email-masked]>
> > > >> >> Subject: RE: Timer: Poisson distribution question
> > > >> >>
> > > >> >> So the burden is on the Measurement controller to know the 
> > > >> >> functions and inputs specifications for each possible MA 
> > > >> >> vendor; not something I would want to have to do as a 
> > > >> >> Measurement controller
> > > >vendor.
> > > >> >>
> > > >> >> From: Sharam Hakimi [mailto:[email-masked]]
> > > >> >> Sent: Wednesday, April 23, 2014 7:14 AM
> > > >> >> To: Carey, Timothy (Timothy);
> > > >> >> [email-masked]<mailto:[email-masked]>;
> > > >> >[email-masked]<mailto:[email-masked]>
> > > >> >> Subject: RE: Timer: Poisson distribution question
> > > >> >>
> > > >> >> I do not see why vendor A or B or C matters. They would all be 
> > > >> >> under the control of one Measurement Controller which would 
> > > >> >> specify what inputs to use for all MAs in a group.
> > > >> >>
> > > >> >> As Trevor also mentioned this timer can be used for both 
> > > >> >> testing and reporting and I would strongly suggest to have 
> > > >> >> microsecond granularity. For reporting one could choose 
> > > >> >> seconds in terms of
> > > >microseconds.
> > > >> >>
> > > >> >> Thanks,
> > > >> >> Sharam
> > > >> >>
> > > >> >> From: Carey, Timothy (Timothy) 
> > > >> >> [mailto:[email-masked]]
> > > >> >> Sent: Wednesday, April 23, 2014 8:04 AM
> > > >> >> To: [email-masked]<mailto:[email-masked]>; 
> > > >> >> Sharam
> > > >> >Hakimi;
> > > >> >[email-masked]<mailto:[email-masked]>
> > > >> >> Subject: RE: Timer: Poisson distribution question
> > > >> >>
> > > >> >> Trevor,
> > > >> >>
> > > >> >> If we don't define the inputs for each function (leaving the 
> > > >> >> inputs
> > > >> >> opaque)  you will have interop problems. MA vendor 1 uses 
> > > >> >> these 2 inputs
> > > >named "A"
> > > >> >and
> > > >> >> "B"; MA vendor 2 uses 3 inputs named "A", "X" and "Y" for the 
> > > >> >> same
> > > >function.
> > > >> >>
> > > >> >> I think we need to avoid that if we realistically want the 
> > > >> >> Randomness function to be used efficiently.
> > > >> >>
> > > >> >> BR,
> > > >> >> Tim
> > > >> >>
> > > >> >> From: [email-masked]<mailto:[email-masked]>
> > > >> >[mailto:[email-masked]]
> > > >> >> Sent: Wednesday, April 23, 2014 2:55 AM
> > > >> >> To: Carey, Timothy (Timothy);
> > > >> >> [email-masked]<mailto:[email-masked]>;
> > > >> >[email-masked]<mailto:[email-masked]>
> > > >> >> Subject: RE: Timer: Poisson distribution question
> > > >> >>
> > > >> >> The random timing can be used for both specifying when a test 
> > > >> >> runs, or when a report is sent (or any other task such as 
> > > >> >> contacting the Controller). It doesn't have to be used, but it can be.
> > > >> >>
> > > >> >> I don't really want different input variable for different 
> > > >> >> functions. I don't see we need to. Also if we do, then we 
> > > >> >> would have to have schema for each function to specify which 
> > > >> >> inputs are expected (like the measurement task registry). I'd like to avoid 
that.
> > > >> >>
> > > >> >> Trevor.
> > > >> >>
> > > >> >> Trevor Burbridge
> > > >> >> Network Infrastructure & Innovation | BT Innovate & Design
> > > >> >> Tel: 01473 645115
> > > >> >> Fax: 01473 640929
> > > >> >>
> > > >> >> This email contains BT information, which may be privileged or confidential.
> > > >> >> It's meant only for the individual(s) or entity named above. 
> > > >> >> If you're not the intended recipient, note that disclosing, 
> > > >> >> copying, distributing or using this information is prohibited. 
> > > >> >> If you've received this email in error, please let me know 
> > > >> >> immediately on the email address above. Thank you. We monitor 
> > > >> >> our email system, and may record your emails. British 
> > > >> >> Telecommunications plc Registered
> > > >> >> office: 81 Newgate Street London EC1A 7AJ Registered in 
> > > >> >> England
> > > >> >no:
> > > >> >> 1800000
> > > >> >>
> > > >> >> From: Carey, Timothy (Timothy) 
> > > >> >> [mailto:[email-masked]]
> > > >> >> Sent: 22 April 2014 22:07
> > > >> >> To: Sharam Hakimi; [email-masked]<mailto:[email-masked]>;
> > > >> >> Burbridge,T,Trevor,
> > > >> >> TUB8 R Subject: RE: Timer: Poisson distribution question
> > > >> >>
> > > >> >> Sharam,
> > > >> >>
> > > >> >> We are talking about offsets for when to report; in the world 
> > > >> >> we live in milliseconds is sufficient - IMHO.
> > > >> >>
> > > >> >> From: Sharam Hakimi [mailto:[email-masked]]
> > > >> >> Sent: Tuesday, April 22, 2014 3:59 PM
> > > >> >> To: Carey, Timothy (Timothy); 
> > > >> >> [email-masked]<mailto:[email-masked]>;
> > > >> >[email-masked]<mailto:[email-masked]>
> > > >> >> Subject: RE: Timer: Poisson distribution question
> > > >> >>
> > > >> >> Tim,
> > > >> >> I think the min/max should have microseconds granularity.
> > > >> >> Milliseconds would not be accurate enough.
> > > >> >>
> > > >> >> Personally, I would not trust my periodic tests in a large 
> > > >> >> scale deployment to a random number generator and would want 
> > > >> >> to know exactly how and when
> > > >> >tests
> > > >> >> would be run.
> > > >> >>
> > > >> >> Thanks,
> > > >> >> Sharam
> > > >> >>
> > > >> >> From: Carey, Timothy (Timothy) 
> > > >> >> [mailto:[email-masked]]
> > > >> >> Sent: Tuesday, April 22, 2014 3:16 PM
> > > >> >> To: Sharam Hakimi; [email-masked]<mailto:[email-masked]>;
> > > >> >[email-masked]<mailto:[email-masked]>
> > > >> >> Subject: RE: Timer: Poisson distribution question
> > > >> >>
> > > >> >> Trevor,
> > > >> >>
> > > >> >> The data model is extensible by vendors so we can add 
> > > >> >> functions and input variables as we need.
> > > >> >>
> > > >> >> However we have to decide on which small subset we actually 
> > > >> >> want to
> > > >> >standardize.
> > > >> >>
> > > >> >> You suggested the Uniform and Normal which is fine but for the 
> > > >> >> model we need to go farther by defining the specific function 
> > > >> >> along with which inputs are used by the function to derive 
> > > >> >> what random number. Otherwise we will have 2 implementers of 
> > > >> >> the same standard algorithm implement different variations. -  Not good.
> > > >> >>
> > > >> >> So I suggest we keep this simple.
> > > >> >>
> > > >> >> Uniform Discrete - input variables - maximum [positive 
> > > >> >> integer] Gaussian -input variables - mean of min/max, spread = 
> > > >> >> standard deviation
> > > >> >>
> > > >> >> The min/max would be milliseconds - Spread would be an integer.
> > > >> >>
> > > >> >> This sound OK?
> > > >> >>
> > > >> >> BR
> > > >> >> Tim
> > > >> >>
> > > >> >> From: Sharam Hakimi [mailto:[email-masked]]
> > > >> >> Sent: Tuesday, April 22, 2014 8:23 AM
> > > >> >> To: Carey, Timothy (Timothy); 
> > > >> >> [email-masked]<mailto:[email-masked]>;
> > > >> >[email-masked]<mailto:[email-masked]>
> > > >> >> Subject: RE: Timer: Poisson distribution question
> > > >> >>
> > > >> >> Tim,
> > > >> >> I think the Periodic Timer distribution needs to have closer 
> > > >> >> configuration control by the user and I think your 2nd  choice 
> > > >> >> attempts to provide it but having a discrete interval 
> > > >> >> definition is a better way
> > > >to go.
> > > >> >>
> > > >> >> Sharam
> > > >> >>
> > > >> >> From: lmap [mailto:[email-masked]] On Behalf Of
> > > >> >[email-masked]<mailto:[email-masked]>
> > > >> >> Sent: Tuesday, April 22, 2014 4:35 AM
> > > >> >> To: 
> > > >> >> [email-masked]<mailto:timothy.carey@alcatel-
> > > >> >lucent.com>;
> > > >> >> [email-masked]<mailto:[email-masked]> Subject: Re: [lmap] Timer:
> > > >> >> Poisson distribution question
> > > >> >>
> > > >> >> On continuous counterparts of Poisson I'm far from any expert 
> > > >> >> and it would certainly be up to the user to decide if such 
> > > >> >> functions were suitable replacements for the discrete Poisson 
> > > >> >> function. Yes it would be a different function even if there 
> > > >> >> was perfect fit (which they are not) as one is continuous and one is 
discrete:
> > > >> >> http://cmscience.blogspot.co.uk/2008/04/mt-
> > > >> >6-
> > > >> >> poisson-and-gamma-distribution.html 
> > > >> >> http://arxiv.org/abs/1303.5990
> > > >> >>
> > > >> >> As I tried to say the current Information Model can take 
> > > >> >> either discrete or continuous functions - only that there is 
> > > >> >> currently no explicit support for specifying the interval used 
> > > >> >> for a discrete function. I was questioning the need to add this.
> > > >> >>
> > > >> >> Personally I'd think that Normal and Uniform distributions 
> > > >> >> would cover most needs, but the framework should be flexible in this regard.
> > > >> >>
> > > >> >> Trevor.
> > > >> >>
> > > >> >> From: lmap [mailto:[email-masked]] On Behalf Of Carey, 
> > > >> >> Timothy
> > > >> >(Timothy)
> > > >> >> Sent: 19 April 2014 20:24
> > > >> >> To: [email-masked]<mailto:[email-masked]>
> > > >> >> Subject: [lmap] Timer: Poisson distribution question
> > > >> >>
> > > >> >> Team,
> > > >> >>
> > > >> >> The BBF is looking at standardizing the model for Timers as 
> > > >> >> suggested by the IETF LMAP information model.
> > > >> >>
> > > >> >> During the review of the timers we had addition questions 
> > > >> >> regarding Trevors response to the Poisson distribution for the 
> > > >> >> Randomness of the
> > > >Periodic Timer.
> > > >> >>
> > > >> >> Trevor responded:
> > > >> >>
> > > >> >> "Yes this does need to be clarified. I was assuming a 
> > > >> >> distribution about the mean (i.e. the timing given is the 
> > > >> >> mean). The spread would be the standard deviation (could use 
> > > >> >> mean deviation or something else but I see no advantage as 
> > > >> >> long as we all know what it refers to) and need to change to a 
> > > >> >> float. The upper and lower cuts would be in seconds +/- the 
> > > >> >> mean (also needs to change
> > > >> >to
> > > >> >> float) and are simply used to trim the function - obviously 
> > > >> >> needed on a uniform distribution but useful to constrain other functions.
> > > >> >>
> > > >> >> I will make all this clear in the next release.
> > > >> >>
> > > >> >> As for poisson I think there are 3 options:
> > > >> >>
> > > >> >> -        Use a continuous form instead
> > > >> >>
> > > >> >> -        Have the discrete interval implicit in the function choice
> > > >> >e.g."poisson_1_sec"
> > > >> >>
> > > >> >> -        Add an interval to the information model.
> > > >> >>
> > > >> >> I was really thinking about the first, but I don't see the 
> > > >> >> problem with the second. However I wouldn't do the third 
> > > >> >> unless they was a demonstrable value to supporting discrete 
> > > >> >> functions (rather than continuous
> > > >versions of them). "
> > > >> >>
> > > >> >> But as people looked at Trevors response there were additional questions:
> > > >> >>
> > > >> >> I don't understand what Trevor means about the Poisson 
> > > >> >> distribution.  As far as I know, it is a discrete 
> > > >> >> distribution, so a "continuous form" would be a different 
> > > >> >> distribution and not Poisson.  And I believe that we do need a continuous 
distribution.
> > > >> >> But what matters is that the definition is clear,  not the 
> > > >> >> particular
> > distribution
> > > >(I don't have an opinion on that).
> > > >> >>
> > > >> >> Could some please clarify this for us - Are we planning 
> > > >> >> something other than Poisson method; better yet is there a 
> > > >> >> definition for the types of
> > > >> >> distribution: Poisson, Normal and Uniform.
> > > >> >>
> > > >> >> Thanks,
> > > >> >> Tim
> > > >> >
> > > >> >
> > > >> >--
> > > >> >Open WebMail Project (http://openwebmail.org)
> > > >>
> > > >> _______________________________________________
> > > >> lmap mailing list
> > > >> [email-masked]
> > > >> https://www.ietf.org/mailman/listinfo/lmap
> > > >
> > > >
> > > >--
> > > >Open WebMail Project (http://openwebmail.org)
> > > 
> > > _______________________________________________
> > > lmap mailing list
> > > [email-masked]
> > > https://www.ietf.org/mailman/listinfo/lmap
> > 
> > 
> > --
> > Open WebMail Project (http://openwebmail.org)
> > 
> > _______________________________________________
> > lmap mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/lmap
> 
> -- 
> Juergen Schoenwaelder           Jacobs University Bremen gGmbH
> Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
> Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>
> 
> _______________________________________________
> lmap mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lmap
> 
> _______________________________________________
> lmap mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lmap

--
Open WebMail Project (http://openwebmail.org)

---

From: "marc.ibrahim" <[email-masked]>
Date: Sat, 10 May 2014 23:16:55 +0300

Tim,

> While you are correct in your assumption the Ti isn't really known when you 
> setup the timer (which also could be used for multiple Tis). So I plan to keep 
> what Marc was saying.

I agree with Ken that Xmin is superfluous. The essential parameter is the spread. I 
suggested Xmin just to be able to control the spread  around Ti, but this is not really 
important. We can just say that the time values will be chosen between Ti and Ti+spread.

> My question to the group is should we limit the Randomness to just the 
> distribution to what Marc suggested or should we keep the capability for 
> multiple distributions.

As the draft says, the goal of randomness is to spread the load by preventing multiple 
events from occurring simultaneously. Given the spread interval, the uniform 
distribution is mathematically the best to achieve it. I don't see why we should use  
normal distribution, which will tend to concentrate values around some mean.

>If so is this the Uniform-Discrete distribution?

I suggested to express the randomness as an integer number of milliseconds. So the 
answer is yes.

Finally, I would like to add a comment about the Poisson distribution that was the 
initial cause of this discussion about timer. I think that there was a confusion with 
the Poisson process used to randomize the instants of packets transmission in active 
measurements. In fact, Poisson in measurement context is a process describing the 
occurrence of events and not a probability distribution for a time interval (the related 
distribution is exponential as explained below). So, if a Poisson process is to be used 
in lmap context, it applies in my opinion only to periodic schedules as follows:

    - The period specified in the timing object is in fact an average period. For 
example, if an MA event occurs at Ti, the next event will occur in average at Ti+period
    
    - After an event occurs at Ti, the MA will choose a real number X according to an 
exponential distribution of mean = period. Next event will then occur at Ti+X.

    - When the inter-event time is exponential, the whole process is known as a Poisson 
process of rate =  1/period. 

    - In this approach, we do not specify a spread around predefined instants Tis. We 
rather randomize the whole interval separating two consecutive Tis.

This could be another viable (but may be more complicated??) approach for periodic 
events. 

BR,

Marc.

On Sat, 10 May 2014 18:52:50 +0000, Carey, Timothy (Timothy) wrote
> While you are correct in your assumption the Ti isn't really known when you 
> setup the timer (which also could be used for multiple Tis). So I plan to keep 
> what Marc was saying.
> 
> My question to the group is should we limit the Randomness to just the 
> distribution to what Marc suggested or should we keep the capability for 
> multiple distributions. - If so is this the Uniform-Discrete distribution?
> 
> Thanks,
> Tim
> 
> Since Ti+Xmin is non-random, Xmin is not really needed as a separate 
> parameter. Just offset Ti to the desired minimum time and let the spread range 
> from Ti to Ti+Xmax.
> 
> Other than that nit, +1
> 
> For a given event E (e.g. running a measurement task, start reporting,...),
>  let Ti be the predefined (scheduled) instant of the ith occurrence of E. 
> Adding randomness means that the event E will happen at time Ti + X instead of 
> Ti, where X is a random variable. If Xmin and Xmax denote the minimum and 
> maximum possible values of X repectively, then the event E will take place at 
> an instant randomly chosen between Ti+Xmin and Ti+Xmax. The spread is equal to 
> Xmax-Xmin
> 
>       Ti+Xmin             Ti                 Ti+Xmax
> Note that Xmin could be negative if E can occur before Ti like in the figure. 
> I think that the most common values of Xmin would be 0 or (-spread/2).
> 
> To make it simple as stated by many, X could an integer number of milliseconds 
> uniformly chosen in the interval [Xmin, Xmax]. Xmin, Xmax, and hence spread, 
> are all integers (milliseconds).
> 
> Then the MA has to define a function UNIF(Xmin, Xmax) or equivalently 
> UNIF(Xmin, spread) that generates a random number of milliseconds from [Xmin,
>  Xmax] interval. The controller has just to send two integer variables (Xmin,
>  Xmax) or (Xmin, spread) to the MA in the timing object.
> 
> In this minimalist approach, no need to specify the nature of distribution in 
> the timing object since it is assumed to be the uniform one.
> 
> BR,
> 
> Marc.
>

---

From: "Carey, Timothy (Timothy)" <[email-masked]>
Date: Sat, 10 May 2014 20:43:54 +0000

Marc,

So we can do Xmin + spread or Xmax - spread or Xmax-Xmin but you need the offset from Ti to allow for a negative spread from Ti, right?

BR,
Tim

-----Original Message-----
From: marc.ibrahim [mailto:[email-masked]] 
Sent: Saturday, May 10, 2014 3:17 PM
To: Carey, Timothy (Timothy); KEN KO; Sharam Hakimi; Juergen Schoenwaelder
Cc: [email-masked]; [email-masked]
Subject: RE: [lmap] Timer: Poisson distribution question

Tim,

    

BR,

Marc.

---

From: "marc.ibrahim" <[email-masked]>
Date: Sun, 11 May 2014 00:03:14 +0300

The simplest to do, is to spread starting from Ti. So, all you need is to specify only 
one parameter: the spread. random values will be picked from between Ti and Ti+spread.

If you want to control spread position, then yes, you need an offset parameter. Random 
values will then be picked between Ti+offset and Ti+offset + spread.

BR,

Marc.

On Sat, 10 May 2014 20:43:54 +0000, Carey, Timothy (Timothy) wrote
> Marc,
> 
> So we can do Xmin + spread or Xmax - spread or Xmax-Xmin but you need the 
> offset from Ti to allow for a negative spread from Ti, right?
> 
> BR,
> Tim
> 
> I agree with Ken that Xmin is superfluous. The essential parameter is the 
> spread. I suggested Xmin just to be able to control the spread  around Ti, but 
> this is not really important. We can just say that the time values will be 
> chosen between Ti and Ti+spread.
> 
> As the draft says, the goal of randomness is to spread the load by preventing 
> multiple events from occurring simultaneously. Given the spread interval, the 
> uniform distribution is mathematically the best to achieve it. I don't see why 
> we should use  normal distribution, which will tend to concentrate values 
> around some mean.
> 
> I suggested to express the randomness as an integer number of milliseconds. So 
> the answer is yes.
> 
> Finally, I would like to add a comment about the Poisson distribution that was 
> the initial cause of this discussion about timer. I think that there was a 
> confusion with the Poisson process used to randomize the instants of packets 
> transmission in active measurements. In fact, Poisson in measurement context 
> is a process describing the occurrence of events and not a probability 
> distribution for a time interval (the related distribution is exponential as 
> explained below). So, if a Poisson process is to be used in lmap context, it 
> applies in my opinion only to periodic schedules as follows:
> 
>     - The period specified in the timing object is in fact an average period. 
> For example, if an MA event occurs at Ti, the next event will occur in average 
> at Ti+period
> 
>     - After an event occurs at Ti, the MA will choose a real number X 
> according to an exponential distribution of mean = period. Next event will 
> then occur at Ti+X.
> 
>     - When the inter-event time is exponential, the whole process is known as 
> a Poisson process of rate =  1/period.
> 
>     - In this approach, we do not specify a spread around predefined instants 
> Tis. We rather randomize the whole interval separating two consecutive Tis.
> 
> This could be another viable (but may be more complicated??) approach for 
> periodic events.
> 
> BR,
> 
> Marc.
>

---

From: <[email-masked]>
Date: Wed, 14 May 2014 10:53:37 +0100

Just to acknowledge that this (just having spread as a positive from Ti) is what I'll implement in the next revision of the Information Model unless there are further discussions.

Trevor Burbridge

>Sent: 10 May 2014 22:03
>Cc: Burbridge,T,Trevor,TUB8 R; [email-masked]
>If you want to control spread position, then yes, you need an offset parameter.
>Random values will then be picked between Ti+offset and Ti+offset + spread.
>
>BR,
>
>Marc.
>
>
>> So we can do Xmin + spread or Xmax - spread or Xmax-Xmin but you need
>> the offset from Ti to allow for a negative spread from Ti, right?
>>
>> BR,
>> Tim
>>
>> > While you are correct in your assumption the Ti isn't really known
>> > when you setup the timer (which also could be used for multiple
>> > Tis). So I plan to keep what Marc was saying.
>>
>> I agree with Ken that Xmin is superfluous. The essential parameter is
>> the spread. I suggested Xmin just to be able to control the spread
>> around Ti, but this is not really important. We can just say that the
>> time values will be chosen between Ti and Ti+spread.
>>
>> > My question to the group is should we limit the Randomness to just
>> > the distribution to what Marc suggested or should we keep the
>> > capability for multiple distributions.
>>
>> As the draft says, the goal of randomness is to spread the load by
>> preventing multiple events from occurring simultaneously. Given the
>> spread interval, the uniform distribution is mathematically the best
>> to achieve it. I don't see why we should use  normal distribution,
>> which will tend to concentrate values around some mean.
>>
>> I suggested to express the randomness as an integer number of
>> milliseconds. So the answer is yes.
>>
>> Finally, I would like to add a comment about the Poisson distribution
>> that was the initial cause of this discussion about timer. I think
>> that there was a confusion with the Poisson process used to randomize
>> the instants of packets transmission in active measurements. In fact,
>> Poisson in measurement context is a process describing the occurrence
>> of events and not a probability distribution for a time interval (the
>> related distribution is exponential as explained below). So, if a
>> Poisson process is to be used in lmap context, it applies in my opinion only to
>periodic schedules as follows:
>>
>> For example, if an MA event occurs at Ti, the next event will occur in
>> average at Ti+period
>>
>> according to an exponential distribution of mean = period. Next event
>> will then occur at Ti+X.
>>
>>     - When the inter-event time is exponential, the whole process is
>> known as a Poisson process of rate =  1/period.
>>
>>     - In this approach, we do not specify a spread around predefined
>> instants Tis. We rather randomize the whole interval separating two
>consecutive Tis.
>>
>> This could be another viable (but may be more complicated??) approach
>> for periodic events.
>>
>> BR,
>>
>> Marc.
>>
>> > While you are correct in your assumption the Ti isn't really known
>> > when you setup the timer (which also could be used for multiple
>> > Tis). So I plan to keep what Marc was saying.
>> >
>> > My question to the group is should we limit the Randomness to just
>> > the distribution to what Marc suggested or should we keep the
>> > capability for multiple distributions. - If so is this the Uniform-Discrete
>distribution?
>> >
>> > Thanks,
>> > Tim
>> >
>> > parameter. Just offset Ti to the desired minimum time and let the
>> > spread range from Ti to Ti+Xmax.
>> >
>> > Other than that nit, +1
>> >
>> > For a given event E (e.g. running a measurement task, start
>> > reporting,...),  let Ti be the predefined (scheduled) instant of the ith
>occurrence of E.
>> > Adding randomness means that the event E will happen at time Ti + X
>> > instead of Ti, where X is a random variable. If Xmin and Xmax denote
>> > the minimum and maximum possible values of X repectively, then the
>> > event E will take place at an instant randomly chosen between
>> > To make it simple as stated by many, X could an integer number of
>> > milliseconds uniformly chosen in the interval [Xmin, Xmax]. Xmin,
>> > Xmax, and hence spread, are all integers (milliseconds).
>> >
>> > Then the MA has to define a function UNIF(Xmin, Xmax) or
>> > equivalently UNIF(Xmin, spread) that generates a random number of
>> > milliseconds from [Xmin,  Xmax] interval. The controller has just to
>> > send two integer variables (Xmin,
>> > In this minimalist approach, no need to specify the nature of
>> > distribution in the timing object since it is assumed to be the uniform one.
>> >
>> > BR,
>> >
>> > Marc.
>> >
>> > > This example confuses resolution of the measurement result with
>> > > resolution and accuracy of the time at which the measurement is
>> > > initiated. Measuring round trip latencies on a Gigabit LAN may
>> > > well require microsecond resolution, which could be within the
>> > > capabilities of a higher end MA. But that doesn't require
>> > > microsecond resolution of the time at which the measurement is
>> > > initiated. In addition, for microsecond resolution on the Timer to be
>meaningful would require synchronization to that resolution across different MAs
>in the network.
>> > >
>> > > I'm in favor of keeping things simple and specifying Timer
>> > > resolution in
>> milliseconds.
>> > >
>> > > It depends what the performance goal of the measurement is. A ping
>> > > packet in a Gigabit network is just under 1 microseconds and with
>> > > fast processors a packet can be sent and received at the same time if
>granularity is milliseconds.
>> > >
>> > > This does not even take into account 10Gig networks, not that they
>> > > would be at consumer sites, but they would sure exist inside a ISP network.
>> > >
>> > > Sharam
>> > >
>> > > From: Juergen Schoenwaelder
>> > > [mailto:[email-masked]]
>> > > Within an implementation of a measurement task, one may use more
>> > > precise timers. But for the randomization of the start of
>> > > measurement tasks or the sending of reports, milliseconds seem to
>> > > be sufficient (since there will be likely other delays introduced
>> > > by the operating system that may get into the some order for starting a
>measurement task or triggering a report).
>> > >
>> > > /js
>> > >
>> > > > I would say that choosing the millisecond as atomic time
>> > > > alleviates constraints on both timer granularity and generator capacity.
>> > > >
>> > > > > constrained devices? I'd argue that if this is a problem for
>> > > > > them then they are really going to struggle with the
>> > > > > Instruction information or
>> > measurement results.
>> > > > >
>> > > > > Trevor.
>> > > > >
>> > > > > >integer number of microseconds to count. So the problem is
>> > > > > >always an integer (discrete) number generation.
>> > > > > >
>> > > > > >Now, if the random generator can attain the maximum integer
>> > > > > >(so the maximum possible random time), then, as Trevor says,
>> > > > > >no need for the timeStep I talked about, since all possible
>> > > > > >durations will be expressed
>as
>> > > > > >For example, a 32 bits random generator could generate up to
>> > > > > >a maximum value of 4 billions. In microseconds, this is equal
>> > > > > >to less than 2
>> hours.
>> > > > > >
>> > > > > >> >If we use a continuous uniform generator, than it is
>> > > > > >> >enough to specify the maximum time.
>> > > > > >> >> I'm not sure I get the point of allowing coarser
>> > > > > >> >> granularity that the MA is capable of. If I want the MA
>> > > > > >> >> to test/report sometime within a minute window, why not
>> > > > > >> >> allow that to happen with the maximum resolution the MA
>> > > > > >> >> is capable
>> > > > > >> >of?
>> > > > > >> >>
>> > > > > >> >> Trevor.
>> > > > > >> >>
>> > > > > >> >> Trevor Burbridge
>> > > > > >> >> This email contains BT information, which may be
>> > > > > >> >> privileged or
>> confidential.
>> > > > > >> >> If you're not the intended recipient, note that
>> > > > > >> >> disclosing, copying, distributing or using this information is
>prohibited.
>> > > > > >> >> If you've received this email in error, please let me
>> > > > > >> >> know immediately on the email address above. Thank you.
>> > > > > >> >> We monitor our email system, and may record your emails.
>> > > > > >> >> British Telecommunications plc Registered
>> > > > > >> >> Sharam Hakimi
>> > > > > >> >>  Spread) - works so far. Marc suggested a TimeStep
>> > > > > >> >> parameter so we don't lockin on a specific microsecond,
>> > > > > >> >> millisecond, second thing - I am open
>> > > > > >to that.
>> > > > > >> >>
>> > > > > >> >> BR,
>> > > > > >> >> Tim
>> > > > > >> >>
>> > > > > >> >> From:
>> > > > > >> >> Agree we need to have well defined function names. I
>> > > > > >> >> thought you were also suggesting different functions
>> > > > > >> >> needed different input
>> > parameters.
>> > > > > >> >>
>> > > > > >> >> Trevor.
>> > > > > >> >>
>> > > > > >> >> Trevor Burbridge
>> > > > > >> >> This email contains BT information, which may be
>> > > > > >> >> privileged or
>> confidential.
>> > > > > >> >> If you're not the intended recipient, note that
>> > > > > >> >> disclosing, copying, distributing or using this information is
>prohibited.
>> > > > > >> >> If you've received this email in error, please let me
>> > > > > >> >> know immediately on the email address above. Thank you.
>> > > > > >> >> We monitor our email system, and may record your emails.
>> > > > > >> >> British Telecommunications plc Registered
>> > > > > >> >> Its not that the Measurement controller has to configure
>> > > > > >> >> the timer for the
>> > > > > >MA.
>> > > > > >> >>
>> > > > > >> >> If we do not specify the functions and variable names,
>> > > > > >> >> the measurement controller doesn't have a standard way
>> > > > > >> >> of configuring a
>timer.
>> > > > > >> >>
>> > > > > >> >> For example - If I specify for a Uniform distribution
>> > > > > >> >> function called "Uniform" you have a  variable called
>> > > > > >> >> "UpperLimit", the MA will implement the specification;
>> > > > > >> >> the controller will implement the
>> > > > > >> >> If I do not specify anything for the Uniform
>> > > > > >> >> distribution function
>> > > > > >> >> - MA vendor
>> > > > > >> >> 1 can call it "UniformDF" and "UL - which is typed real"
>> > > > > >> >> and maybe an
>> > > > > >"Enable"
>> > > > > >> >> parameter for good measure; MA vendor 2 can call it "U"
>> > > > > >> >> and have an attribute "X that is an integer".
>> > > > > >> >>
>> > > > > >> >> Now put that variation on steroids based on the number
>> > > > > >> >> of MA vendors - That is why we specify things, right?
>> > > > > >> >>
>> > > > > >> >> BR,
>> > > > > >> >> Tim
>> > > > > >> >>
>> > > > > >> >> The measurement controller has to communicate what tests
>> > > > > >> >> have to be run on
>> > > > > >> >an
>> > > > > >> >> MA, for how long, when to run them, what test results
>> > > > > >> >> are generated, etc. Why would configuring this parameter
>> > > > > >> >> be any different. Maybe I am missing
>> > > > > >> >something.
>> > > > > >> >>
>> > > > > >> >> So the burden is on the Measurement controller to know
>> > > > > >> >> the functions and inputs specifications for each
>> > > > > >> >> possible MA vendor; not something I would want to have
>> > > > > >> >> to do as a Measurement controller
>> > > > > >vendor.
>> > > > > >> >>
>> > > > > >> >> I do not see why vendor A or B or C matters. They would
>> > > > > >> >> all be under the control of one Measurement Controller
>> > > > > >> >> which would specify what inputs to use for all MAs in a group.
>> > > > > >> >>
>> > > > > >> >> testing and reporting and I would strongly suggest to
>> > > > > >> >> have microsecond granularity. For reporting one could
>> > > > > >> >> choose seconds in terms of
>> > > > > >microseconds.
>> > > > > >> >>
>> > > > > >> >> Thanks,
>> > > > > >> >> Sharam
>> > > > > >> >>
>> > > > > >> >> If we don't define the inputs for each function (leaving
>> > > > > >> >> the inputs
>> > > > > >> >> opaque)  you will have interop problems. MA vendor 1
>> > > > > >> >> uses these 2 inputs
>> > > > > >named "A"
>> > > > > >> >and
>> > > > > >> >> "B"; MA vendor 2 uses 3 inputs named "A", "X" and "Y"
>> > > > > >> >> for the same
>> > > > > >function.
>> > > > > >> >>
>> > > > > >> >> I think we need to avoid that if we realistically want
>> > > > > >> >> the Randomness function to be used efficiently.
>> > > > > >> >>
>> > > > > >> >> BR,
>> > > > > >> >> Tim
>> > > > > >> >>
>> > > > > >> >> From:
>> > > > > >> >> The random timing can be used for both specifying when a
>> > > > > >> >> test runs, or when a report is sent (or any other task
>> > > > > >> >> such as contacting the Controller). It doesn't have to be used, but
>it can be.
>> > > > > >> >>
>> > > > > >> >> I don't really want different input variable for
>> > > > > >> >> different functions. I don't see we need to. Also if we
>> > > > > >> >> do, then we would have to have schema for each function
>> > > > > >> >> to specify which inputs are expected (like the
>> > > > > >> >> measurement task registry). I'd like to
>> avoid
>> > that.
>> > > > > >> >>
>> > > > > >> >> Trevor.
>> > > > > >> >>
>> > > > > >> >> Trevor Burbridge
>> > > > > >> >> This email contains BT information, which may be
>> > > > > >> >> privileged or
>> confidential.
>> > > > > >> >> If you're not the intended recipient, note that
>> > > > > >> >> disclosing, copying, distributing or using this information is
>prohibited.
>> > > > > >> >> If you've received this email in error, please let me
>> > > > > >> >> know immediately on the email address above. Thank you.
>> > > > > >> >> We monitor our email system, and may record your emails.
>> > > > > >> >> British Telecommunications plc Registered
>> > > > > >> >> We are talking about offsets for when to report; in the
>> > > > > >> >> world we live in milliseconds is sufficient - IMHO.
>> > > > > >> >>
>> > > > > >> >> Personally, I would not trust my periodic tests in a
>> > > > > >> >> large scale deployment to a random number generator and
>> > > > > >> >> would want to know exactly how and when
>> > > > > >> >tests
>> > > > > >> >> would be run.
>> > > > > >> >>
>> > > > > >> >> Thanks,
>> > > > > >> >> Sharam
>> > > > > >> >>
>> > > > > >> >> However we have to decide on which small subset we
>> > > > > >> >> actually want to
>> > > > > >> >standardize.
>> > > > > >> >>
>> > > > > >> >> You suggested the Uniform and Normal which is fine but
>> > > > > >> >> for the model we need to go farther by defining the
>> > > > > >> >> specific function along with which inputs are used by
>> > > > > >> >> the function to derive what random number. Otherwise we
>> > > > > >> >> will have 2 implementers of the same standard algorithm
>implement different variations. -  Not good.
>> > > > > >> >>
>> > > > > >> >> integer] Gaussian -input variables - mean of min/max,
>> > > > > >> >> spread = standard deviation
>> > > > > >> >>
>> > > > > >> >> I think the Periodic Timer distribution needs to have
>> > > > > >> >> closer configuration control by the user and I think
>> > > > > >> >> your 2nd  choice attempts to provide it but having a
>> > > > > >> >> discrete interval definition is a better way
>> > > > > >to go.
>> > > > > >> >>
>> > > > > >> >> Sharam
>> > > > > >> >>
>> > > > > >> >> On continuous counterparts of Poisson I'm far from any
>> > > > > >> >> expert and it would certainly be up to the user to
>> > > > > >> >> decide if such functions were suitable replacements for
>> > > > > >> >> the discrete Poisson function. Yes it would be a
>> > > > > >> >> different function even if there was perfect fit (which
>> > > > > >> >> they are not) as one is continuous and one is
>> > discrete:
>> > > > > >> >> either discrete or continuous functions - only that
>> > > > > >> >> there is currently no explicit support for specifying
>> > > > > >> >> the interval used for a discrete function. I was questioning the
>need to add this.
>> > > > > >> >>
>> > > > > >> >> Personally I'd think that Normal and Uniform
>> > > > > >> >> distributions would cover most needs, but the framework
>> > > > > >> >> should be flexible in this
>> regard.
>> > > > > >> >>
>> > > > > >> >> Trevor.
>> > > > > >> >>
>> > > > > >> >> Carey, Timothy
>> > > > > >> >> The BBF is looking at standardizing the model for Timers
>> > > > > >> >> as suggested by the IETF LMAP information model.
>> > > > > >> >>
>> > > > > >> >> During the review of the timers we had addition
>> > > > > >> >> questions regarding Trevors response to the Poisson
>> > > > > >> >> distribution for the Randomness of the
>> > > > > >Periodic Timer.
>> > > > > >> >>
>> > > > > >> >> Trevor responded:
>> > > > > >> >>
>> > > > > >> >> distribution about the mean (i.e. the timing given is
>> > > > > >> >> the mean). The spread would be the standard deviation
>> > > > > >> >> (could use mean deviation or something else but I see no
>> > > > > >> >> advantage as long as we all know what it refers to) and
>> > > > > >> >> need to change to a float. The upper and lower cuts
>> > > > > >> >> would be in seconds +/- the mean (also needs to change
>> > > > > >> >to
>> > > > > >> >> float) and are simply used to trim the function -
>> > > > > >> >> obviously needed on a uniform distribution but useful to
>> > > > > >> >> constrain other
>functions.
>> > > > > >> >>
>> > > > > >> >> I was really thinking about the first, but I don't see
>> > > > > >> >> the problem with the second. However I wouldn't do the
>> > > > > >> >> third unless they was a demonstrable value to supporting
>> > > > > >> >> discrete functions (rather than continuous
>> > > > > >versions of them). "
>> > > > > >> >>
>> > > > > >> >> But as people looked at Trevors response there were
>> > > > > >> >> additional
>questions:
>> > > > > >> >>
>> > > > > >> >> distribution, so a "continuous form" would be a
>> > > > > >> >> different distribution and not Poisson.  And I believe
>> > > > > >> >> that we do need a
>continuous
>> > distribution.
>> > > > > >> >> But what matters is that the definition is clear,  not
>> > > > > >> >> the particular
>> > > > distribution
>> > > > > >> >> something other than Poisson method; better yet is there
>> > > > > >> >> a definition for the types of

---

From: "Carey, Timothy (Timothy)" <[email-masked]>
Date: Wed, 14 May 2014 11:27:33 +0000

Trevor,

I think we said, because we wanted negative offsets, that we would need the LowerLimit (offset) and spread.

Thanks,
Tim

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Wednesday, May 14, 2014 4:54 AM
To: [email-masked]; Carey, Timothy (Timothy); [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: [lmap] Timer: Poisson distribution question

Trevor Burbridge

---

From: KEN KO <[email-masked]>
Date: Wed, 14 May 2014 11:51:11 +0000

Tim,

I'm still not sure *why* you want negative offsets. Several people have commented that having a uniform spread from Ti to Ti+Xmax (or equivalently, Tmin to Tmax) is sufficient to assure randomness. I think there needs to be a good reason to add an additional  parameter.

Thanks,
Ken

-----Original Message-----
From: Carey, Timothy (Timothy) [mailto:[email-masked]] 
Sent: Wednesday, May 14, 2014 7:28 AM
To: [email-masked]; [email-masked]; KEN KO; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: [lmap] Timer: Poisson distribution question

Trevor,

Thanks,
Tim

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Wednesday, May 14, 2014 4:54 AM
To: [email-masked]; Carey, Timothy (Timothy); [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: [lmap] Timer: Poisson distribution question

Trevor Burbridge

---

From: "Carey, Timothy (Timothy)" <[email-masked]>
Date: Wed, 14 May 2014 11:54:32 +0000

Ken,

I personally do not care; I thought we left it at offset+spread; just trying to capture the result.

BR,
Tim

-----Original Message-----
From: KEN KO [mailto:[email-masked]] 
Sent: Wednesday, May 14, 2014 6:51 AM
To: Carey, Timothy (Timothy); [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: [lmap] Timer: Poisson distribution question

Tim,

Thanks,
Ken

-----Original Message-----
From: Carey, Timothy (Timothy) [mailto:[email-masked]] 
Sent: Wednesday, May 14, 2014 7:28 AM
To: [email-masked]; [email-masked]; KEN KO; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: [lmap] Timer: Poisson distribution question

Trevor,

Thanks,
Tim

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Wednesday, May 14, 2014 4:54 AM
To: [email-masked]; Carey, Timothy (Timothy); [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: [lmap] Timer: Poisson distribution question

Trevor Burbridge

---

From: "Carey, Timothy (Timothy)" <[email-masked]>
Date: Wed, 14 May 2014 12:24:02 +0000

I am good with this.

-----Original Message-----
From: KEN KO [mailto:[email-masked]] 
Sent: Wednesday, May 14, 2014 7:22 AM
To: Carey, Timothy (Timothy); [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: [lmap] Timer: Poisson distribution question

Tim, thanks for the clarification. 

On rereading this extended thread I see a number of views expressed. But in the more recent comments, I *think* I see support from multiple people, and perhaps the beginnings of consensus, for:
- One distribution (Discrete Uniform)
- One time increment (milliseconds)
- One parameter (spread)

That is a simplification from the existing text in the information model but it seems sufficient to me. Is it something to which others can agree?

Best regards,
Ken

-----Original Message-----
From: Carey, Timothy (Timothy) [mailto:[email-masked]] 
Sent: Wednesday, May 14, 2014 7:55 AM
To: KEN KO; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: [lmap] Timer: Poisson distribution question

Ken,

BR,
Tim

-----Original Message-----
From: KEN KO [mailto:[email-masked]] 
Sent: Wednesday, May 14, 2014 6:51 AM
To: Carey, Timothy (Timothy); [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: [lmap] Timer: Poisson distribution question

Tim,

Thanks,
Ken

-----Original Message-----
From: Carey, Timothy (Timothy) [mailto:[email-masked]] 
Sent: Wednesday, May 14, 2014 7:28 AM
To: [email-masked]; [email-masked]; KEN KO; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: [lmap] Timer: Poisson distribution question

Trevor,

Thanks,
Tim

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Wednesday, May 14, 2014 4:54 AM
To: [email-masked]; Carey, Timothy (Timothy); [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: [lmap] Timer: Poisson distribution question

Trevor Burbridge

---

From: KEN KO <[email-masked]>
Date: Wed, 14 May 2014 12:22:21 +0000

Best regards,
Ken

-----Original Message-----
From: Carey, Timothy (Timothy) [mailto:[email-masked]] 
Sent: Wednesday, May 14, 2014 7:55 AM
To: KEN KO; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: [lmap] Timer: Poisson distribution question

Ken,

BR,
Tim

-----Original Message-----
From: KEN KO [mailto:[email-masked]] 
Sent: Wednesday, May 14, 2014 6:51 AM
To: Carey, Timothy (Timothy); [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: [lmap] Timer: Poisson distribution question

Tim,

Thanks,
Ken

-----Original Message-----
From: Carey, Timothy (Timothy) [mailto:[email-masked]] 
Sent: Wednesday, May 14, 2014 7:28 AM
To: [email-masked]; [email-masked]; KEN KO; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: [lmap] Timer: Poisson distribution question

Trevor,

Thanks,
Tim

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Wednesday, May 14, 2014 4:54 AM
To: [email-masked]; Carey, Timothy (Timothy); [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: [lmap] Timer: Poisson distribution question

Trevor Burbridge

---

From: "Marc Ibrahim" <[email-masked]>
Date: Wed, 14 May 2014 15:37:25 +0300

Ok for me.

Marc.

-----Original Message-----
From: lmap [mailto:[email-masked]] On Behalf Of KEN KO
Sent: Wednesday, May 14, 2014 3:22 PM
To: Carey, Timothy (Timothy); [email-masked];
[email-masked]; [email-masked];
[email-masked]
Cc: [email-masked]
Subject: Re: [lmap] Timer: Poisson distribution question

On rereading this extended thread I see a number of views expressed. But in
the more recent comments, I *think* I see support from multiple people, and
perhaps the beginnings of consensus, for:
- One distribution (Discrete Uniform)
- One time increment (milliseconds)
- One parameter (spread)

That is a simplification from the existing text in the information model but
it seems sufficient to me. Is it something to which others can agree?

Best regards,
Ken

-----Original Message-----
From: Carey, Timothy (Timothy) [mailto:[email-masked]] 
Sent: Wednesday, May 14, 2014 7:55 AM
To: KEN KO; [email-masked]; [email-masked];
[email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: [lmap] Timer: Poisson distribution question

Ken,

I personally do not care; I thought we left it at offset+spread; just trying
to capture the result.

BR,
Tim

-----Original Message-----
From: KEN KO [mailto:[email-masked]] 
Sent: Wednesday, May 14, 2014 6:51 AM
To: Carey, Timothy (Timothy); [email-masked];
[email-masked]; [email-masked];
[email-masked]
Cc: [email-masked]
Subject: RE: [lmap] Timer: Poisson distribution question

Tim,

I'm still not sure *why* you want negative offsets. Several people have
commented that having a uniform spread from Ti to Ti+Xmax (or equivalently,
Tmin to Tmax) is sufficient to assure randomness. I think there needs to be
a good reason to add an additional  parameter.

Thanks,
Ken

-----Original Message-----
From: Carey, Timothy (Timothy) [mailto:[email-masked]] 
Sent: Wednesday, May 14, 2014 7:28 AM
To: [email-masked]; [email-masked]; KEN KO;
[email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: [lmap] Timer: Poisson distribution question

Trevor,

I think we said, because we wanted negative offsets, that we would need the
LowerLimit (offset) and spread.

Thanks,
Tim

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Wednesday, May 14, 2014 4:54 AM
To: [email-masked]; Carey, Timothy (Timothy); [email-masked];
[email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: [lmap] Timer: Poisson distribution question

Just to acknowledge that this (just having spread as a positive from Ti) is
what I'll implement in the next revision of the Information Model unless
there are further discussions.

Trevor Burbridge