Subject: [lmap] how would MA-Controller channel be impacted by suppression?

From: "STARK, BARBARA H" <[email-masked]>
Date: Tue, 10 Jun 2014 14:51:36 +0000

Something that's been nagging at my brain is the idea that the communication between MA and Controller is a "task" (this been said during the suppression flag discussions) that could potentially be suppressed.

I thought that establishment of this communication was defined by a ma-channel-obj that has its own timing info as to when to establish the connection. And I didn't think it was possible to include a ma-channel-obj in the suppression list. 

Going up the chain, to objects that point to ma-channel-obj, I don't see how the following could be impacted by suppression:
ma-preconfig-obj (which sets the ma-ma-to-controller-channel and the ma-instruction-channel) [BTW is there something that requires the ma-channel-target of these 2 ma-channel-obj parameters to be the same, because both of these should be MA-Controller communication, just potentially with different timing? Currently it looks like there could be a separate "Controller" communicated with for ma-to-controller instruction purposes but we said only one Controller for a MA? Do we need 2?] 
ma-config-obj (which can also set the ma-instruction-channel)
ma-instruction-obj (which presumably gets updated or overwritten per the ma-instruction-channel's connectivity and timing info)
ma-status-obj (which uses the ma-ma-to-controller-channel?)

It reads as if ma-log-obj (which relates to the logging of various info) can be impacted by suppression, because logs are described as scheduled tasks. But the lack of pointers between ma-log-obj and any other objects makes this very unclear.

>From what I can see, only Measurement Tasks (ma-task-obj) and Schedules can be directly impacted by Suppression, which will impact associated Reports and logs.
The MA will continue to communicate with the Controller at the Channel-specified times and allow for updating of the Instruction and providing status.

Or am I reading this wrong?
Barbara

---

From: <[email-masked]>
Date: Wed, 11 Jun 2014 13:29:40 +0100

i think you're reading this right - think the gap is that the information model i-d needs an update
they should all be tasks with schedules
incidentally, also suggestion is (will be) to merge config and bootstrap into single object (since they affect the same info)

phil
________________________________________
From: lmap [[email-masked]] On Behalf Of STARK, BARBARA H [[email-masked]]
Sent: 10 June 2014 15:51
To: [email-masked]
Subject: [lmap] how would MA-Controller channel be impacted by suppression?

_______________________________________________
lmap mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lmap

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Wed, 11 Jun 2014 15:32:42 +0000

> i think you're reading this right - think the gap is that the information model i-
> d needs an update they should all be tasks with schedules incidentally, also
> suggestion is (will be) to merge config and bootstrap into single object (since
> they affect the same info)

I'll have to wait to see the changes. If one of the changes is to remove ma-channel-timing from ma-channel-obj and place it elsewhere, so that when to establish a channel connection is  associated with a ma-schedule-obj and not a ma-channel-obj, then I need to see this change in order to grasp (and agree with) it. I'm also concerned with turning configuration and receipt of Instruction into ma-task entries. (If that's what I'm understanding? But I need to see what you're really saying.) Currently, there is reasonable correlation between ma-task and Measurement Task. I can even see the status and capability info as Measurement Task. But I can't see configuration and Instruction receipt as Measurement Tasks. If that happens, then we need to specifically say that Measurement Tasks are a subset of ma-task entries, and somehow know which ma-task entries represent Measurement Tasks. Because Suppression applies to Measurement Tasks. It can only apply to a ma-task entry if that ma-task entry is representing a Measurement Task. Suppression must not be modeled in a way that could cause it to apply to all possible activities (tasks) performed by a MA. Just the Measurement Tasks.

Anyway, I'll wait to see the proposed changes before discussing this further. It's hard to discuss in the absence of something concrete to point to (i.e., information-model-01).
Barbara

> Something that's been nagging at my brain is the idea that the
> communication between MA and Controller is a "task" (this been said during
> the suppression flag discussions) that could potentially be suppressed.
> 
> I thought that establishment of this communication was defined by a ma-
> channel-obj that has its own timing info as to when to establish the
> connection. And I didn't think it was possible to include a ma-channel-obj in
> the suppression list.
> 
> Going up the chain, to objects that point to ma-channel-obj, I don't see how
> the following could be impacted by suppression:
> ma-preconfig-obj (which sets the ma-ma-to-controller-channel and the ma-
> instruction-channel) [BTW is there something that requires the ma-channel-
> target of these 2 ma-channel-obj parameters to be the same, because both
> of these should be MA-Controller communication, just potentially with
> different timing? Currently it looks like there could be a separate "Controller"
> communicated with for ma-to-controller instruction purposes but we said
> only one Controller for a MA? Do we need 2?] ma-config-obj (which can also
> set the ma-instruction-channel) ma-instruction-obj (which presumably gets
> updated or overwritten per the ma-instruction-channel's connectivity and
> timing info) ma-status-obj (which uses the ma-ma-to-controller-channel?)
> 
> It reads as if ma-log-obj (which relates to the logging of various info) can be
> impacted by suppression, because logs are described as scheduled tasks. But
> the lack of pointers between ma-log-obj and any other objects makes this
> very unclear.
> 
> >From what I can see, only Measurement Tasks (ma-task-obj) and Schedules
> can be directly impacted by Suppression, which will impact associated
> Reports and logs.
> The MA will continue to communicate with the Controller at the Channel-
> specified times and allow for updating of the Instruction and providing status.
>