Subject: [lmap] I-D Action: draft-ietf-lmap-information-model-01.txt

From: [email-masked]
Date: Fri, 27 Jun 2014 07:48:21 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Large-Scale Measurement of Broadband Performance Working Group of the IETF.

        Title           : Information Model for Large-Scale Measurement Platforms (LMAP)
        Authors         : Trevor Burbridge
                          Philip Eardley
                          Marcelo Bagnulo
                          Juergen Schoenwaelder
	Filename        : draft-ietf-lmap-information-model-01.txt
	Pages           : 35
	Date            : 2014-06-26

Abstract:
   This Information Model applies to the Measurement Agent within a
   Large-Scale Measurement Platform.  As such it outlines the
   information that is (pre-)configured on the MA or exists in
   communications with a Controller or Collector within an LMAP
   framework.  The purpose of such an Information Model is to provide a
   protocol and device independent view of the MA that can be
   implemented via one or more Control and Report protocols.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-lmap-information-model/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-lmap-information-model-01

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-lmap-information-model-01

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Fri, 27 Jun 2014 15:52:29 +0000

It seems the discussion of "Active Measurement" and "Passive Measurement" could be removed from information-model since nothing in the actual model cares about this distinction and we took it out of framework?

It's clear from the text that not all ma-task-obj instances are Measurement Tasks. That's fine. But this does create some ambiguity for me around Suppression. Framework-07 clearly defines Suppression as a temporary cessation of Measurement Tasks. It makes no mention of other sorts of "tasks" that may or may not be indistinguishable from Measurement Tasks in the information-model.

So I think that information-model needs to have an explicit statement regarding behavior around suppression of non Measurement Task ma-task-obj instances that happen to be included as a ma-suppression-task-name in a ma-suppression-obj .

I see 2 possibilities. Either such ma-task-obj instances
 - will not be suppressed or 
 - whether or not they will be suppressed is left up to the implementation and suppression / non-suppression cannot be assumed
Barbara

> -----Original Message-----
> From: lmap [mailto:[email-masked]] On Behalf Of internet-
> [email-masked]
> Sent: Friday, June 27, 2014 10:48 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [lmap] I-D Action: draft-ietf-lmap-information-model-01.txt
> 
> 
> _______________________________________________
> lmap mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lmap

---

From: <[email-masked]>
Date: Mon, 30 Jun 2014 09:59:34 +0100

There is an explcit statement at the moment about what will happen:

- every task can use the "suppress-by-default flag"
- the suppression will affect ALL tasks in the Instruction - by default if the above flag is TRUE (default is TRUE) or explicitly if listed.

i.e. the information model is completely agnostic to the concepts of active vs. passive and measurement vs. non-measurement.

We can, of course, discuss if this is what you want to happen! I took this as the concensus opinion of the various discussions over the last month.

Trevor.

>From: lmap [mailto:[email-masked]] On Behalf Of STARK, BARBARA H
>Sent: 27 June 2014 16:52
>To: [email-masked]
>Subject: Re: [lmap] I-D Action: draft-ietf-lmap-information-model-01.txt
>
>It seems the discussion of "Active Measurement" and "Passive Measurement"
>could be removed from information-model since nothing in the actual model
>cares about this distinction and we took it out of framework?
>
>It's clear from the text that not all ma-task-obj instances are Measurement Tasks.
>That's fine. But this does create some ambiguity for me around Suppression.
>Framework-07 clearly defines Suppression as a temporary cessation of
>Measurement Tasks. It makes no mention of other sorts of "tasks" that may or
>may not be indistinguishable from Measurement Tasks in the information-model.
>
>So I think that information-model needs to have an explicit statement regarding
>behavior around suppression of non Measurement Task ma-task-obj instances
>that happen to be included as a ma-suppression-task-name in a ma-suppression-
>obj .
>
> - whether or not they will be suppressed is left up to the implementation and
>suppression / non-suppression cannot be assumed Barbara
>
>> Please note that it may take a couple of minutes from the time of
>> submission until the htmlized version and diff are available at tools.ietf.org.
>>

---

From: KEN KO <[email-masked]>
Date: Mon, 30 Jun 2014 12:39:31 +0000

I agree with Trevor - let's use the mechanism we've just defined for all Tasks, Measurement and Otherwise.

- Ken

-----Original Message-----
From: lmap [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, June 30, 2014 5:00 AM
To: [email-masked]; [email-masked]
Subject: Re: [lmap] I-D Action: draft-ietf-lmap-information-model-01.txt

Trevor.

>could be removed from information-model since nothing in the actual 
>model cares about this distinction and we took it out of framework?
>
>Measurement Tasks. It makes no mention of other sorts of "tasks" that 
>may or may not be indistinguishable from Measurement Tasks in the information-model.
>
>So I think that information-model needs to have an explicit statement 
>regarding behavior around suppression of non Measurement Task 
>ma-task-obj instances that happen to be included as a 
>ma-suppression-task-name in a ma-suppression- obj .
>
> - whether or not they will be suppressed is left up to the 
>implementation and suppression / non-suppression cannot be assumed 
>Barbara
>
>>  This draft is a work item of the Large-Scale Measurement of 
>> Broadband Performance Working Group of the IETF.
>>