Subject: Re: [lmap] Follow-up on recent discussion about draft-ietf-lmap-framework-05.txt

From: Mach Chen <[email-masked]>
Date: Tue, 3 Jun 2014 06:28:51 +0000

Hi Phil,

> Passive Measurement Task: A Measurement Task in which a Measurement Agent
> observes existing traffic but does not inject Active Measurement Traffic.

Given that there are some existing passive measurement solutions (e.g., Y.1731, RFC6374 (direct mode)) that may inject extra traffic to help measuring, I am not sure whether "does not inject Active Measurement Traffic" is still one of the characteristics of Passive Measurement. IMHO, it's better from the tested object point of view (e.g., for a measurement task, whether the tested object is the existing traffic or injected traffic) to describe what is Passive and Active measurement. 

In addition, I like Greg's idea to change "observes" to "collects information of". 

Best regards,
Mach

> -----Original Message-----
> From: Mach Chen
> Sent: Tuesday, June 03, 2014 1:53 PM
> To: Mach Chen
> Subject: FW: [lmap] Follow-up on recent discussion about
> draft-ietf-lmap-framework-05.txt
> 
> 
> 
> From: lmap [mailto:[email-masked]] On Behalf Of [email-masked]
> Sent: Monday, June 02, 2014 11:10 PM
> To: [email-masked]
> Subject: [lmap] Follow-up on recent discussion about
> draft-ietf-lmap-framework-05.txt
> 
> Following up on the thread (after holidays)
> 
> current definitions:-
> Passive Measurement Method (Task): A Measurement Method (Task) in which a
> Measurement Agent observes existing traffic but does not inject Active
> Measurement Traffic.
> 
> Active Measurement Task: A Measurement Task in which a Measurement Agent
> creates or receives Active Measurement Traffic, by coordinating with one or
> more other Measurement Agents or Measurement Peers using protocols
> outside the initial LMAP work scope.
> 
> --
> My view is that the Task is about what the MA does. To answer Barbara's quiz
> question, it is possible to define the activity as two small Tasks or one larger
> integrated Task.
> 
> I can understand the desire to talk 'holistically' about the whole measurement
> system. But looking at say Fig A4 in
> http://tools.ietf.org/html/draft-ietf-lmap-framework-05#section-10 The passive
> monitor is an MA running Passive Task. It observes existing traffic from entities
> that are, from its perspective, MPs. This traffic could be user traffic or actually
> generated by another (Active) Task. As far as the function labelled Passive
> Monitor is concerned, it doesn't care.
> 
> I thought Barbara's example of UDP echo makes the good point that the client
> and server ends have a different role so may well have to point to different
> registry entries.
> 
> I agree with Al that passive and active are two end points of a continuum and
> there are techniques in-between the extremes (like Nalini's colour marking of
> pkts). I'd prefer to leave it to ippm to work on the subtleties - as far as lmap is
> concerned we know that there's a registry of tests, which ippm is proposing to
> sub-divide into active and passive. Maybe later ippm will decide which
> sub-registry in-between tests should be in, or that a new registry is needed, or
> whatever. I think lmap can live with this slight uncertainty.
> So I think it's better for the definition of Passive to stick with "observes".
> 
> 
> Greg didn't like the formulation "Active Measurement Method (Task)" - if I
> remember, he thought it was unclear and wanted it split into two definitions.
> Since we already have definitions for Measurement Method and Measurement
> Task, I actually think it's unnecessary to distinguish Method & Task in the Passive
> & Active definitions. So I suggest deleting the 'Active Measurement Method'
> definition, and similarly making the Passive definition just about 'Passive
> Measurement Task'.
> 
> Greg also didn't like the way the Active definition talks about coordination. I
> think the point is: whilst some Active Tasks involve the MA coordinating with
> other MPs (examples A1 and A2 in the Appendix - eg web server responds to
> client request), in others (example A3) the Controller controls the other MA and
> the first MA just sends it traffic (the MAs don't really coordinate with each
> other).
> 
> --
> 
> Proposal:-
> In the Intro, add to the paragraph about Active & Passive Tasks:
> There may also be Measurement Tasks that are intermediate between Passive
> and Active ones; consideration is outside the initial LMAP work scope.
> 
> In terminology, tweak the definitions:-
> Passive Measurement Task: A Measurement Task in which a Measurement Agent
> observes existing traffic but does not inject Active Measurement Traffic.
> 
> Active Measurement Task: A Measurement Task in which a Measurement Agent
> sends Active Measurement Traffic to, or receives it from, one or more other
> Measurement Agents or Measurement Peers, and perhaps coordinates with
> them using protocols outside the initial LMAP work scope.
> 
> 
> Best wishes
> phil
> 
>

---

From: <[email-masked]>
Date: Wed, 4 Jun 2014 16:59:34 +0100

[phil] so i think this means your proposal is that we define: Active - measure injected traffic.  Passive = measure existing traffic (may or may not inject traffic)
i come back to Al's comment. there are pure passive tests, there are pure active ones. there are hybrid ones, which lmap hasn't thought too much about. all lmap cares about is that a test will be defined by a registry; ippm subdivide this registry into active and passive, so it's their job to decide which side of the line different hybrid tests sit. 
my opinion is that we shouldn't worry about these hybrid tests.

[phil] my opinion is that it isn't worth further agonising over the definition of Passive vs Active. (btw, i disagree with your proposed definitions).
i suggest we should either go with the definitions we've got, or we should delete the active/passive definitions and do some small re-write so it isn't needed (particularly in the privacy section)

phil

---

From: Sharam Hakimi <[email-masked]>
Date: Wed, 4 Jun 2014 16:24:12 +0000

Phil,
 A couple of points,

1) I do not think ACTIVE in "inject Active Measurement Traffic" is necessary. I suggest to change it to "inject Measurement Traffic"

2) For Passive  I think if we change OBSERVE in " A Measurement Task in which a Measurement Agent
> observes existing traffic" to "Collects" that it would resolve the issue. Even to observe, one has to collect first before observing. The rest of what is done after collection of traffic from the network is out of scope of LMAP.

Sharam

-----Original Message-----
From: lmap [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, June 04, 2014 12:00 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [lmap] Follow-up on recent discussion about draft-ietf-lmap-framework-05.txt

phil
_______________________________________________
lmap mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lmap

---

From: Mach Chen <[email-masked]>
Date: Fri, 6 Jun 2014 03:17:57 +0000

Hi Phil,

Thanks for your response!

> From: [email-masked] [mailto:[email-masked]]
> Sent: Thursday, June 05, 2014 12:00 AM
> To: Mach Chen
> Cc: [email-masked]
> Subject: RE: [lmap] Follow-up on recent discussion about
> > Passive Measurement Task: A Measurement Task in which a Measurement
> > Agent observes existing traffic but does not inject Active Measurement Traffic.
> 
> Given that there are some existing passive measurement solutions (e.g., Y.1731,
> RFC6374 (direct mode)) that may inject extra traffic to help measuring, I am not
> sure whether "does not inject Active Measurement Traffic" is still one of the
> characteristics of Passive Measurement. IMHO, it's better from the tested object
> point of view (e.g., for a measurement task, whether the tested object is the
> existing traffic or injected traffic) to describe what is Passive and Active
> measurement.
> 
> [phil] so i think this means your proposal is that we define: Active - measure
> injected traffic.  Passive = measure existing traffic (may or may not inject traffic)

Yes.

> i come back to Al's comment. there are pure passive tests, there are pure active
> ones. there are hybrid ones, which lmap hasn't thought too much about. all lmap
> cares about is that a test will be defined by a registry; ippm subdivide this registry
> into active and passive, so it's their job to decide which side of the line different
> hybrid tests sit.

Yes, I agree, and let's leave the job to IPPM.

> 
> [phil] my opinion is that it isn't worth further agonising over the definition of
> Passive vs Active. (btw, i disagree with your proposed definitions).
> i suggest we should either go with the definitions we've got, or we should delete
> the active/passive definitions and do some small re-write so it isn't needed
> (particularly in the privacy section)

If we cannot achieve an agreement on the definitions of active/passive (mainly for passive) , I'd prefer to the later. 

Thanks,
Mach