Subject: [lmap] 回复： new version of framework

From: 邓灵莉/Lingli Deng <[email-masked]>
Date: Sat, 14 Jun 2014 10:52:43 +0800

Hi Phil,

There is a small issue with 5.2.2.1, where the start time, end time and on going suppress in a suppression message are stated as optional in the text, but are not marked as optional in the figure with brackets.

Lingli

----------
发自我的vivo智能手机

[email-masked]：

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Sun, 15 Jun 2014 13:26:16 -0400

Lingli,

In the figure for the Instruction (5.2.2), a combination of  optional and 
mandatory items are listed inside the square brackets. It seems to be the 
similar to Suppression in 5.2.2.1.

The figures are protocol models, as described in
http://tools.ietf.org/html/rfc4101

which says:
   The purpose of a protocol model is explicitly not to provide a
   complete or alternate description of the protocol being discussed.
   Instead, it is to provide a big picture overview of the protocol so
   that readers can quickly understand the essential elements of how it
   works.

Usually, explicit statements/requirements in the text take precedent
if there is found to be some ambiguity illustrated in a Figure, and the text
is clear in this case.

hope this helps,
Al

________________________________________
From: lmap [[email-masked]] On Behalf Of 邓灵莉/Lingli Deng [[email-masked]]
Sent: Friday, June 13, 2014 10:52 PM
To: philip.eardley; lmap
Subject: [lmap] 回复： new version of framework

Hi Phil,

Lingli

----------
发自我的vivo智能手机

[email-masked]：

I just uploaded a new version
http://www.ietf.org/id/draft-ietf-lmap-framework-06.txt

Barbara, Greg, Ken and others who’ve made suggestions - Please could you do a quick check to make sure we got your points properly

Thanks
Phil

--12.6.  From -05 to -06

   o  clarified terminlogy around Measurement Methods and Tasks.  Since
      within a Method there may be several different roles (requester
      and responder, for instance)

   o  Suppression: there is now the concept of a flag (boolean) which
      indicates whether a Task is by default gets suppressed or not.
      The optional suppression message (with list of specific tasks
      /schedules to suppress) over-rides this flag.

   o  The previous bullet also means there is no need to make a
      distinction between active and passive Measurement Tasks, so this
      distinction is removed.

I now see a glitch! The final 2 bullets should be replaced by:-

   o  removed Configuration Protocol – Configuration is part of the Instruction and so uses the Control Protocol

---

From: 邓灵莉/Lingli Deng <[email-masked]>
Date: Mon, 16 Jun 2014 17:25:43 +0800

Hi Al,

Thanks for the clarification.
I am fine with the TEXT description in this case.

Lingli

> -----Original Message-----
> From: MORTON, ALFRED C (AL) [mailto:[email-masked]]
> Sent: Monday, June 16, 2014 1:26 AM
> To: 邓灵莉/Lingli Deng; philip.eardley; lmap
> Subject: RE: [lmap] 回复： new version of framework
> 
> Lingli,
> 
> There is a small issue with 5.2.2.1, where the start time, end time and on going
> suppress in a suppression message are stated as optional in the text, but are
> not marked as optional in the figure with brackets.
> 
> Lingli
> 
> ----------
> 发自我的vivo智能手机
> 
> [email-masked]：
> 
> Barbara, Greg, Ken and others who’ve made suggestions - Please could you do
> a quick check to make sure we got your points properly
> 
> Thanks
> Phil
> 
> 
> --12.6.  From -05 to -06
> 
>    o  removed Configuration Protocol – Configuration is part of the
> Instruction and so uses the Control Protocol