Subject: Re: [lmap] FW: New Version Notification for draft-deng-lmap-collaboration-00.txt

From: Charles Cook <[email-masked]>
Date: Tue, 17 Jun 2014 16:56:56 -0600

Lingli,

Some thoughts for consideration...

I understand the use cases, but I don't know that the proposed
implementation in its current state provides benefit.  Conceptually, 
the proposed implementation looks like a super Controller (the
Initiator) controlling multiple LMAP Controllers and a super Collector
(the Reporter) controlling and aggregating multiple LMAP Collectors. 
It's like we are adding another layer of management. 

It may help to provide a better distinction between messages between
Initiators and Controller and the words measurement tasks or sub-tasks. 
It was confusing to me because when the term Measurement Sub-task was
used, I thought of a sub-task of an LMAP Measurement Task and LMAP does
not have the concept of sub-tasks.  So there may need to be a change in
some of the terminology to minimize confusion.

Charles

On 5/30/2014 2:18 AM, 邓灵莉/Lingli Deng wrote:
> Hi all,
>
> We submitted a new use-case draft for collaborative measurements, and look forward to your review and comments.
>
> Thanks,
> Lingli
>
>> -----Original Message-----
>> From: [email-masked] [mailto:[email-masked]]
>> Sent: Thursday, May 29, 2014 10:21 AM
>> To: Rachel Huang; Deng Lingli; Shihui Duan; Shihui Duan; Lingli Deng; Rachel
>> Huang
>> Subject: New Version Notification for draft-deng-lmap-collaboration-00.txt
>>
>>
>> A new version of I-D, draft-deng-lmap-collaboration-00.txt
>> has been successfully submitted by Lingli Deng and posted to the
>> IETF repository.
>>
>> Name:		draft-deng-lmap-collaboration
>> Revision:	00
>> Title:		Use-cases for Collaborative LMAP
>> Document date:	2014-05-29
>> Group:		Individual Submission
>> Pages:		11
>> URL:
>> http://www.ietf.org/internet-drafts/draft-deng-lmap-collaboration-00.txt
>> Status:
>> https://datatracker.ietf.org/doc/draft-deng-lmap-collaboration/
>> Htmlized:       http://tools.ietf.org/html/draft-deng-lmap-collaboration-00
>>
>>
>> Abstract:
>>    This document discusses the motivation and use-cases for
>>    collaborative LMAP practices, where multiple autonomous measurement
>>    systems collaborate together to help with UoE enhancement by ICPs,
>>    network performance monitory to guide ISP/Regulator coordination
>>    between autonomous network domains and/or regulatory policies and
>>    cross-boundary troubleshooting for complaints from end consumers.
>>
>>
>>
>>
>>
>> Please note that it may take a couple of minutes from the time of submission
>> until the htmlized version and diff are available at tools.ietf.org.
>>
>> The IETF Secretariat
>
>
>
> _______________________________________________
> lmap mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lmap

-- 

Charles Cook 
Principal Architect
Network
5325 Zuni Street; Suite 224
Denver, CO  80221
Tel:  303.992.8952  Fax:  925.281.0662
[email-masked]

---

From: 邓灵莉/Lingli Deng <[email-masked]>
Date: Wed, 18 Jun 2014 18:43:42 +0800

Hi Charles,

Thanks for your review.
More inline.

Lingli

> From: Charles Cook [mailto:[email-masked]]
> Sent: Wednesday, June 18, 2014 6:57 AM
> To: 邓灵莉/Lingli Deng; [email-masked]
> Subject: Re: [lmap] FW: New Version Notification for
> draft-deng-lmap-collaboration-00.txt
> 
> Lingli,
> 
[邓灵莉/Lingli Deng] Thanks. The focus of the current draft is actually on the use-cases side, and the proposed architecture included as it is now only serves as a basis for more discussion.

> It's like we are adding another layer of management.
[邓灵莉/Lingli Deng] Indeed, as for the current proposal, which is on the discussion table, is a very intuitive one. The "another layer of management" is added on purpose to keep function/requirements to a LMAP MA to a minimum wherever possible.
> some of the terminology to minimize confusion.
[邓灵莉/Lingli Deng] Sorry for the confusion. By sub-task, we meant an LMAP Measurement Task (which is specific to a LMAP MA from a LMAP Controller). Shall try to keep aligned with LMAP terminology in the next revision shortly.
> >> Htmlized:
> http://tools.ietf.org/html/draft-deng-lmap-collaboration-00
> >>
> >>
> >> Abstract: