Subject: [lmap] FW: New Version Notification for draft-deng-lmap-collaboration-01.txt

From: 邓灵莉/Lingli Deng <[email-masked]>
Date: Thu, 3 Jul 2014 16:21:53 +0800

Hi all,

A revision on the collaborative cross-domain LMAP use-case draft is newly posted.
Thanks to Charles for his review and comments on this document.
Further comments and discussion would be highly appreciated.

Regards,
Lingli

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Thursday, July 03, 2014 4:18 PM
> To: Rachel Huang; Deng Lingli; Shihui Duan; Shihui Duan; Lingli Deng; Rachel
> Huang
> Subject: New Version Notification for draft-deng-lmap-collaboration-01.txt
> 
> 
> A new version of I-D, draft-deng-lmap-collaboration-01.txt
> has been successfully submitted by Lingli Deng and posted to the
> IETF repository.
> 
> Name:		draft-deng-lmap-collaboration
> Revision:	01
> Title:		Use-cases for Collaborative LMAP
> Document date:	2014-07-03
> Group:		Individual Submission
> Pages:		13
> URL:
> http://www.ietf.org/internet-drafts/draft-deng-lmap-collaboration-01.txt
> Status:
> https://datatracker.ietf.org/doc/draft-deng-lmap-collaboration/
> Htmlized:
> http://tools.ietf.org/html/draft-deng-lmap-collaboration-01
> Diff:
> http://www.ietf.org/rfcdiff?url2=draft-deng-lmap-collaboration-01
> 
> Abstract:
>    This document discusses the motivation and use-cases for
>    collaborative LMAP practices, where multiple autonomous measurement
>    systems collaborate together to help with QoE enhancement by ICPs,
>    network performance monitory to guide ISP/Regulator coordination
>    between autonomous network domains and/or regulatory policies and
>    cross-boundary troubleshooting for complaints from end consumers.
> 
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat

---

From: Jérôme Benoit <[email-masked]>
Date: Fri, 11 Jul 2014 06:13:25 +0200

On Thu, 3 Jul 2014 16:21:53 +0800 in
<000501cf9697$dad78820$90869860$@com>, 邓灵莉/Lingli Deng
<[email-masked]> wrote:

> Hi all,
> 
> A revision on the collaborative cross-domain LMAP use-case draft is
> newly posted. Thanks to Charles for his review and comments on this
> document. Further comments and discussion would be highly appreciated.

I'm not sure you're on the right track on the collaboration side ... 

The ideas I've tried to push here is that collaboration between MAs
must be topological dependent. Achieving topological dependencies is far
from being easy but it's prerequisite for some advanced tomography
measurement and is very very useful for other measurements (like
measuring the infered load on one Network Element by creating some UDP
flows at a constant rate).

Cheers.  

-- 
Jérôme Benoit aka fraggle
Piment Noir - http://piment-noir.org
OpenPGP Key ID : 9FE9161D
Key fingerprint : 9CA4 0249 AF57 A35B 34B3 AC15 FAA0 CB50 9FE9 161D

---

From: 邓灵莉/Lingli Deng <[email-masked]>
Date: Fri, 11 Jul 2014 13:51:12 +0800

Hi Jerome,

Thanks for your review. 
Glad that we share the interest of architecting collaborative measurements.

I am afraid that I am not sure I fully comprehend your meaning by "topological dependency".
It would be great to know why you believe collaboration between MAs must be topological dependent, and when.
In other words, what are "some advanced tomography measurement " in your mind that requires "topological dependency"?

Looking forward to your reply and thanks in advance,
Lingli

> From: lmap [mailto:[email-masked]] On Behalf Of Jér?me Benoit
> Sent: Friday, July 11, 2014 12:13 PM
> To: 邓灵莉/Lingli Deng
> Cc: 'Huangyihong (Rachel)'; 'duan'; 'lmap'
> Subject: Re: [lmap] FW: New Version Notification for
> draft-deng-lmap-collaboration-01.txt
> 
> The ideas I've tried to push here is that collaboration between MAs must be
> topological dependent. Achieving topological dependencies is far from being
> easy but it's prerequisite for some advanced tomography measurement and
> is very very useful for other measurements (like measuring the infered load
> on one Network Element by creating some UDP flows at a constant rate).
> 
> Cheers.
> 
> --

---

From: Jérôme Benoit <[email-masked]>
Date: Sat, 12 Jul 2014 12:30:32 +0200

> Glad that we share the interest of architecting collaborative measurements.

We're welcome.

> I am afraid that I am not sure I fully comprehend your meaning by "topological dependency".

The way ISPs do their network topology can be infered by traceroute for
the layer 3. Say I want the lauch a measurement for all MAs behind
router blah because the measurement is meant to infer the network load
on router blah. Your current work do not take into account this use
case. 

> In other words, what are "some advanced tomography measurement " in your mind that requires "topological dependency"?

Tomography measurements are active measurements of packets train
following very precise time series that go end to end (MAs are also active probe receivers that can mirror). 
If your architecture do not take into account that kind of measurements, you
will lack a key feature.

Have a look here http://wiki.grenouille.com/index.php/GSoC_2013_ideas_list

It's old by still valid and the architecture draft is here in French :

http://wiki.grenouille.com/index.php/Agent_Architecture

Code documentation of the never finished implementation : 

http://doc.grenouille.com