Subject: [lmap] IM-01: Schedule dataset questions

From: "Carey, Timothy (Timothy)" <[email-masked]>
Date: Thu, 24 Jul 2014 21:49:38 +0000

I was reviewing the draft 01 of the Information Model and I see that there exists a capability to select a set of tasks or? Input/output channels to be used. There is a filter that can be applied as well.

So after reading and rereading the document in this section I still have several questions that need clarified:

1)    The draft says tasks or channels - did really mean "OR" in the exclusive sense one (tasks only) or  the other (channels only)?

2)    I really don't understand how the filter works - it list of integers with the text
"Each filter is an array of integers specifying which Task datasets should be mapped to which output tasks and/or channels."

The filter is an attribute of the Task dataset though - so I can't figure out what the filter is referencing.

Help would be appreciated.

Thanks
Tim

---

From: <[email-masked]>
Date: Mon, 28 Jul 2014 13:21:00 +0100

I agree the inputs/outputs between tasks/channels remains the most complex and least understandable part. I will try to explain briefly here, but I will put effort into making this hopefully a lot clearer in revision 02.

Each task is expected to have a set of inputs/outputs defined presumably by the registry entry or local description. It is these 'datasets' (I struggled to find a good word since interfaces is already taken) that are referred to by the integer values. Thus for a measurement task that has two output datasets (maybe one for results and one for error reports) then [1,2] would select both of these outputs. This selection is then mapped to a list of other tasks and/or channels. Since in this example the measurement task will not know how to operate a report protocol it cannot output direct to a channel. Its output would therefore be directed to a reporting task. That reporting task in turn will have its output directed to a reporting channel.

To answer (1), no it should not be exclusive. We could imagine a reporting task that used a reporting channel but also output exceptions to a different reporting task (that reported over a different channel) responsible for exception reporting about failed reports.

Trevor.

From: lmap [mailto:[email-masked]] On Behalf Of Carey, Timothy (Timothy)
Sent: 24 July 2014 22:50
To: [email-masked]
Subject: [lmap] IM-01: Schedule dataset questions

Thanks
Tim