Subject: [lmap] Framework 07: Comment

From: "Carey, Timothy (Timothy)" <[email-masked]>
Date: Thu, 24 Jul 2014 21:59:22 +0000

During the LMAP session this morning there were a couple of presentations on protocols for LMAP.

I was wondering if we should add a some text as to the target class of device for MAs. We could use the classifications we could use the lwig terminology for classifications of devices (c0-c3) and discuss specific characteristics we feel a device should have (e.g., capable of a connection oriented transport (e.g., TCP), internet capable (HTTP)).

We did this in another body to understand what a "most" constrained device we should target - especially if we say there is a MUST protocol.

Even if we don't add text to the framework - we should have this discussion so that people submitting drafts would at least understand the device target.

Thoughts?

BR,
Tim

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 25 Jul 2014 00:31:04 +0200

> Even if we don't add text to the framework - we should have this discussion so that people submitting drafts would at least understand the device target.

In short, none of the C0-C2 constrained device classes defined in RFC
7228 is an LMAP target. As I said today during the meeting, with up to
10 KiB of memory (C0-C1), you will not execute any meaningful network
measurements since you already have a hard time to process simple IP
packets. I also believe C2 devices are not suitable. [RIPE Atlas
initially used rather limited devices (xport pro - but they are still
way bigger than C2 devices) and these devices tend to be problematic
since they are very slow and hence any time related measurements are
largely impacted by the speed (or better slowness) of the probe.]  It
seems existing systems (e.g., RIPE Atlas, Sam Knows, Caida Ark,
BISmark) run on hardware capable to run embedded Linux and the same is
obviously true for the mobile measurement apps running on smart phones.

In short, I believe any device capable to make meaningful measurements
with reasonable precision will have no problem running HTTP. (And I
have not even started to talk about security - crypto software is a
real CPU and code size burner.)

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>