Subject: [lmap] LMAP Information Model: Calendar Schedule elements evaluation

From: "Carey, Timothy (Timothy)" <[email-masked]>
Date: Sat, 9 Aug 2014 17:09:06 +0000

Team,

I am in the process of taking the LMAP Information Model in draft-01 and developing the corresponding TR-069 data model.

As I was going through the information model - I had a question on how the Calendar schedule elements are evaluated - especially when the lists are empty (we did define the behavior for days).

// Timing specialisation to run repeated Tasks at specific times and/or days
object {
[datetime ma-calendar-start;] // default: immediate
[datetime ma-calendar-end;] // default: indefinite
[int ma-calendar-months<0..*>;] // default: 1-12
[days ma-calendar-days-of-week<0..*>;] // default: all
[int ma-calendar-hours<0..*>;] // default: 0-23
[int ma-calendar-minutes<0..*>;] // default: 0-59
[int ma-calendar-seconds<0..*>;] // default: 0-59
[int ma-calendar-timezone-offset;]
// default: system timezone offset
} ma-calendar-obj;

BTW a data type for days is not defined in the draft - I didn't know if it was a string of the day (full or short) or an integer - if so does it start at 0 or 1.

We should be explicit to the domain values as we would want the same interpretation for the various data models that would use these data type.s

BR,
Tim

---

From: <[email-masked]>
Date: Mon, 11 Aug 2014 09:30:58 +0100

Good point about the format of days. Does anyone have a strong preference? E.g.:

1)      Mon, Tue, Wed

2)      1..7 with 1 being Monday, Sunday?

Personally I'd favour Strings to avoid the ambiguity of the starting day-of-week.

Not sure what the question is regarding some of the list being empty. Hopefully an example will answer it.

"ma-timing-calendar": {
            "ma-calendar-minutes": ["00"],
            "ma-calendar-seconds": ["00"]
          }

This is an example from the current draft. Since months, days, days-of-week and hours are all not defined, they all default to "all" - i.e. the action will be performed at 00m:00s of each and every hour regardless of the day of week, day of month or month of year.

I have just realised days (as in days of month) has got lost somewhere along the way, so I'll add that back in.

Trevor.

From: lmap [mailto:[email-masked]] On Behalf Of Carey, Timothy (Timothy)
Sent: 09 August 2014 18:09
To: [email-masked]
Subject: [lmap] LMAP Information Model: Calendar Schedule elements evaluation

Team,

BR,
Tim

---

From: "Carey, Timothy (Timothy)" <[email-masked]>
Date: Mon, 11 Aug 2014 12:49:55 +0000

Comments inline

From: [email-masked] [mailto:[email-masked]]
Sent: Monday, August 11, 2014 3:31 AM
To: Carey, Timothy (Timothy); [email-masked]
Subject: RE: LMAP Information Model: Calendar Schedule elements evaluation

1)      Mon, Tue, Wed

Personally I'd favour Strings to avoid the ambiguity of the starting day-of-week.
<TAC> I would prefer short code abbreviations for days as strings as well. ( "Mon", "Tue", "Wed" "Thu" "Fri" "Sat" "Sun")

"ma-timing-calendar": {

This is an example from the current draft. Since months, days, days-of-week and hours are all not defined, they all default to "all" - i.e. the action will be performed at 00m:00s of each and every hour regardless of the day of week, day of month or month of year.
<TAC> Yes that answers the question. Empty list (not defined) means all values in the domain are used.

<TAC> Ok I will as well.

Trevor.

From: lmap [mailto:[email-masked]] On Behalf Of Carey, Timothy (Timothy)
Sent: 09 August 2014 18:09
To: [email-masked]<mailto:[email-masked]>
Subject: [lmap] LMAP Information Model: Calendar Schedule elements evaluation

Team,

BR,
Tim