Subject: [lmap] I-D Action: draft-ietf-lmap-information-model-02.txt

From: [email-masked]
Date: Wed, 20 Aug 2014 03:43:38 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Large-Scale Measurement of Broadband Performance Working Group of the IETF.

        Title           : Information Model for Large-Scale Measurement Platforms (LMAP)
        Authors         : Trevor Burbridge
                          Philip Eardley
                          Marcelo Bagnulo
                          Juergen Schoenwaelder
	Filename        : draft-ietf-lmap-information-model-02.txt
	Pages           : 36
	Date            : 2014-08-20

Abstract:
   This Information Model applies to the Measurement Agent within a
   Large-Scale Measurement Platform.  As such it outlines the
   information that is (pre-)configured on the MA or exists in
   communications with a Controller or Collector within an LMAP
   framework.  The purpose of such an Information Model is to provide a
   protocol and device independent view of the MA that can be
   implemented via one or more Control and Report protocols.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-lmap-information-model/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-lmap-information-model-02

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-lmap-information-model-02

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: <[email-masked]>
Date: Wed, 20 Aug 2014 11:54:43 +0100

I have submitted version 02 of the information model following comments received before or during Toronto IETF.

The only significant revision is to task outputs assignment within the schedule. This has now changed to separate out channel assignment and output mapping to downstream tasks. This hopefully makes things clearer and allows more specific/meaningful language to be used.

I have accommodated all the suggestions from Ken Ko, Tim Carey and Michael Faath (thanks all!) except the following that remain as further discussion points:

- credentials still remains as an undefined data object
- names for task configurations, channels etc. remain as text set by the controller. There was a suggestion by Tim to have these automated to UUIDs in some manner. I think we need a discussion on how this could work.

Trevor Burbridge

>-----Original Message-----
>From: lmap [mailto:[email-masked]] On Behalf Of internet-
>[email-masked]
>Sent: 20 August 2014 11:44
>To: [email-masked]
>Cc: [email-masked]
>Subject: [lmap] I-D Action: draft-ietf-lmap-information-model-02.txt
>
>
>_______________________________________________
>lmap mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/lmap

---

From: "Liu,Shu@CATR" <[email-masked]>
Date: Wed, 20 Aug 2014 23:26:06 +0800

There are a lot of syntax errors with the json blocks, I had checked those in the previous version, I will do it again. If those errors keep the way they are now, there will be pains for those coding guys. 
First of all, please DO NOT add comment lines in json blocks, you can add such thing as  "comment": "my comment"  key/value.

Andrew

Trevor Burbridge

>Please note that it may take a couple of minutes from the time of 
>submission until the htmlized version and diff are available at tools.ietf.org.
>

---

From: <[email-masked]>
Date: Wed, 20 Aug 2014 16:32:08 +0100

I would appreciate any corrections to the JSON or any other text - however, I can't find any previous post or email from you regarding these.

Trevor.

>From: Liu,Shu@CATR [mailto:[email-masked]]
>Sent: 20 August 2014 16:26
>To: Burbridge,T,Trevor,TUB8 R; [email-masked]
>Subject: Re: [lmap] I-D Action: draft-ietf-lmap-information-model-02.txt
>
>There are a lot of syntax errors with the json blocks, I had checked those in the
>previous version, I will do it again. If those errors keep the way they are now,
>there will be pains for those coding guys.
>First of all, please DO NOT add comment lines in json blocks, you can add such
>thing as  "comment": "my comment"  key/value.
>
>Andrew
>
>
>The only significant revision is to task outputs assignment within the schedule.
>This has now changed to separate out channel assignment and output mapping to
>downstream tasks. This hopefully makes things clearer and allows more
>specific/meaningful language to be used.
>
>I have accommodated all the suggestions from Ken Ko, Tim Carey and Michael
>Faath (thanks all!) except the following that remain as further discussion points:
>
>- names for task configurations, channels etc. remain as text set by the
>controller. There was a suggestion by Tim to have these automated to UUIDs in
>some manner. I think we need a discussion on how this could work.
>
>Trevor Burbridge
>