Subject: [lmap] draft-ksubram-lmap-router-buffer-sizes-00

From: Kamala Subramaniam <[email-masked]>
Date: Mon, 10 Nov 2014 20:06:05 +0000

Dear LMAP WG,

We have submitted a draft "Router Buffer Sizes in the WAN". It will be presented this Thursday. I wanted to take this opportunity to introduce this draft, and get some feedback. This draft has received some input from the AQM WG.

The lmap-use-cases draft is what initiated the request to be presented in the LMAP WG.  Let me get more in to the details by elaborating the issue with each of the 4 subsections in this ISP use case.

Before that, maybe listing the goals would give a better idea:

*        Drive down the unit cost in $/GB by building efficient but cheaper networks. Do our networks really need the buffers we deal with today at high costs?

*        Maximize throughput in the backbone by always keeping the links busy so that the router buffers never underflow and the router does not lose throughput.

*        To take into consideration variables such as {short Vs long flows, packet sizes, queue depth/model, traffic classes, etc.} as factors while reducing the whistles, bells, and knobs to keep it simple to configure as well as manage.
Now, for the subsections:

*        Identifying, isolating and fixing problems: we observe that there are numerous issues at different layers that have an effect (directly or indirectly) on the sizing of router buffers. Could this be solved by high layer optimizations (ECN, tweaking TCP flows),  or something like just a different queuing model. Studying the nature of the traffic that exists in an ISP world today is an important way to determine this. Where really is this problem? Is it the way we design our networks for example by not taking into consideration how scavenger class really affects us?

*        Design and planning: One the problem has been identified it becomes easier to design and plan the networks. Perhaps all we need are small size buffers driving down the cost.

*        Understanding the quality experienced by customers: again a huge chunk of the study would have packet discards (WAN facing/ outgoing egress interface perhaps?). Do the new methods involved in this study work better for QoS?

*        Understanding the impact and operation of new devices and technology: let's say that the conclusion of this study is that we do not need large size buffers (we are talking 125MB per port), then can we convince the vendors (switch/router/chip) to go down that path.
There have been many studies which provide theories to what the size should be. However, most of these are theoretical in nature and do not take into account any empirical data. While we continue to mine the big data available to us to further study this, we'd also like to start a draft which would in the minimum entail a problem statement, get an idea of the amount of interest, and hopefully lead to some collaboration.

Regards,
Kamala

---

From: <[email-masked]>
Date: Thu, 13 Nov 2014 21:49:41 +0000

Hi Kamala,
I was listening in remotely.
I agree that buffer sizes are important, and especially the efforts to ensure that the queue is almost always as short as possible.

I think the draft is about requirements for a particular measurement task. To me, this sounds more like an ippm activity than lmap.

Best wishes
phil

From: lmap [mailto:[email-masked]] On Behalf Of Kamala Subramaniam
Sent: 10 November 2014 20:06
To: [email-masked]
Subject: [lmap] draft-ksubram-lmap-router-buffer-sizes-00

Dear LMAP WG,

Regards,
Kamala

---

From: Kamala Subramaniam <[email-masked]>
Date: Thu, 13 Nov 2014 22:20:57 +0000

Hi Phil,

Thank you for your feedback. The draft actually mainly points to a lack of a method to collect, compare, and analyze empirical data today more than the metrics themselves. I can understand how the metrics can be misleading.

Regards,
Kamala

From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, November 13, 2014 1:50 PM
To: Kamala Subramaniam; [email-masked]
Subject: RE: draft-ksubram-lmap-router-buffer-sizes-00

Hi Kamala,

Best wishes
phil

From: lmap [mailto:[email-masked]] On Behalf Of Kamala Subramaniam
Sent: 10 November 2014 20:06
To: [email-masked]<mailto:[email-masked]>
Subject: [lmap] draft-ksubram-lmap-router-buffer-sizes-00

Dear LMAP WG,

Regards,
Kamala