Subject: [lmap] Use of role in the LMAP information model

From: "Carey, Timothy (Timothy)" <[email-masked]>
Date: Thu, 8 Jan 2015 20:29:04 +0000

Trevor,

I was reviewing draft-ietf-lmap-information-model-03 in order to update the BBF data model.

I noticed that the concept of a role in the task and task reporting was not in the information model.
Did we not include the role concept?

BR,
Tim

---

From: <[email-masked]>
Date: Fri, 9 Jan 2015 09:14:57 +0000

There is a decision to be made in the registry area as to whether the URL is sufficient to determine both the method and role, or whether a registry URL is needed in conjunction with the role information. I have dropped role from the IM in expectation that it might be the former and the view that "less is more" until we get told that we actually need role separately from the registry URL. It will be easy to re-instantiate if needed following more work on the registry.

Trevor.

Trevor Burbridge
Network Infrastructure & Innovation | BT Research & Innovation
Tel: 01473 645115
Fax: 01473 640929

This email contains BT information, which may be privileged or confidential. It's meant only for the individual(s) or entity named above. If you're not the intended recipient, note that disclosing, copying, distributing or using this information is prohibited. If you've received this email in error, please let me know immediately on the email address above. Thank you.
We monitor our email system, and may record your emails.
British Telecommunications plc
Registered office: 81 Newgate Street London EC1A 7AJ
Registered in England no: 1800000

From: lmap [mailto:[email-masked]] On Behalf Of Carey, Timothy (Timothy)
Sent: 08 January 2015 20:29
To: [email-masked]
Subject: [lmap] Use of role in the LMAP information model

Trevor,

BR,
Tim

---

From: "Carey, Timothy (Timothy)" <[email-masked]>
Date: Fri, 9 Jan 2015 13:19:09 +0000

Trevor,

Thanks for the clarification.

BR,
Tim

From: [email-masked] [mailto:[email-masked]]
Sent: Friday, January 09, 2015 3:15 AM
To: Carey, Timothy (Timothy); [email-masked]
Subject: RE: Use of role in the LMAP information model

Trevor.

Trevor Burbridge

From: lmap [mailto:[email-masked]] On Behalf Of Carey, Timothy (Timothy)
Sent: 08 January 2015 20:29
To: [email-masked]<mailto:[email-masked]>
Subject: [lmap] Use of role in the LMAP information model

Trevor,

BR,
Tim

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Fri, 9 Jan 2015 10:47:16 -0500

Whoa Trevor, let's put it this way:

Role is an input parameter in the current registry draft, where we list the possible roles.
This doesn't match the information model, as Tim points out, but that's the current
decision from the registry area.

We have considered making similar configuration options "fixed", like the test protocol (e.g., TWAMP),
but as we discussed at the workshop this creates lots of redundant entries for the same metric
and we should avoid this artificial growth of entries. It causes a maintenance problem, among many.
If we make Role a fixed parameter, we get two almost duplicate entries for each Role
(when there are two Roles, of course). So, we understand the implications, and they 
are not attractive. 

I'd like to understand the full implications of including the role concept in the Information Model,
as Tim suggested. Then we can make an informed decision, and not be forced one way
or the other because of lack of support.

thanks,
Al
________________________________________
From: lmap [[email-masked]] On Behalf Of Carey, Timothy (Timothy) [[email-masked]]
Sent: Friday, January 09, 2015 8:19 AM
To: [email-masked]; [email-masked]
Subject: Re: [lmap] Use of role in the LMAP information model

Trevor,

BR,
Tim

There is a decision to be made in the registry area as to whether the URL is sufficient to determine both the method and role, or whether a registry URL is needed in conjunction with the role information. I have dropped role from the IM in expectation that it might be the former and the view that “less is more” until we get told that we actually need role separately from the registry URL. It will be easy to re-instantiate if needed following more work on the registry.

Trevor.

Trevor Burbridge

Trevor,

BR,
Tim