Subject: [lmap] LMAP Information Model rev3 - Communication channels

From: "Carey, Timothy (Timothy)" <[email-masked]>
Date: Tue, 13 Jan 2015 20:28:37 +0000

Trevor,

I was trying to see how the instruction would configure the communication change that would convey the results of a scheduled task to a collector.

In rev02 of the information model the was a Channel object in the Schedule Task. In fact page 6 still references the object BTW
"The references are achieved by
each object (Channel, Task Configuration, Timing)"

but the diagram and object definitions remove the Channel object.

My assumption is that the channel would be referenced in the Reporting task as described in page 7.

2. Data Transfer Tasks
A. Reporting Tasks report the results of Measurement Tasks to Collectors

And page 11.
The results
can be communicated to other Tasks or a Task may implement a
Reporting Protocol and communicate results over Report Channels.

When I look at the data model it seems we moved Channel references into tasks or scheduled tasks options field.

Oddly though the Report example doesn't show a channel name in the task options
That I think would have been
{"name": "channel", "value": "Collector A"]}

Based on the Task report.

Did I understand this correctly?

Thanks,
Tim

---

From: <[email-masked]>
Date: Wed, 14 Jan 2015 11:00:39 +0000

>each object (Channel, Task Configuration, Timing)"

Missed that one - I will correct (remove the reference to Channel).

>My assumption is that the channel would be referenced in the Reporting task as described in page 7.

Yes - true.

>When I look at the data model it seems we moved Channel references into tasks or scheduled tasks options field.

Yes that's correct.

>Based on the Task report.

I thought I'd corrected/revised the example, but I obviously forgot to put this in!

>Did I understand this correctly?

Sounds like you understand just fine! Thanks for pointing out the corrections,

Trevor.

From: lmap [mailto:[email-masked]] On Behalf Of Carey, Timothy (Timothy)
Sent: 13 January 2015 20:29
To: [email-masked]
Subject: [lmap] LMAP Information Model rev3 - Communication channels

Trevor,

2. Data Transfer Tasks

And page 11.
The results

Thanks,
Tim

---

From: "Carey, Timothy (Timothy)" <[email-masked]>
Date: Wed, 14 Jan 2015 14:56:25 +0000

Trevor,

Ok - Do we need to have a section here of "well-known" options needed in the information model - like Channel.

I can understand things like cross traffic would be method specific but a Channel is a construct of the information model; Actually I would never had made it an option but since it is; we should document the well known name option.

BR,
Tim

From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, January 14, 2015 5:01 AM
To: Carey, Timothy (Timothy); [email-masked]
Subject: RE: LMAP Information Model rev3 - Communication channels

Yes - true.

Yes that's correct.

Trevor.

From: lmap [mailto:[email-masked]] On Behalf Of Carey, Timothy (Timothy)
Sent: 13 January 2015 20:29
To: [email-masked]<mailto:[email-masked]>
Subject: [lmap] LMAP Information Model rev3 - Communication channels

Trevor,

2. Data Transfer Tasks

And page 11.
The results

Thanks,
Tim