Subject: [lmap] Reporting suppressed tasked in results

From: "Carey, Timothy (Timothy)" <[email-masked]>
Date: Fri, 9 Jan 2015 16:49:13 +0000

Trevor,

In the draft-ietf-lmap-information-model-03 I didn't see the how we record in the report that a task was suppressed therefore making the results suspect.

Is this also part of the options that a task would define?

I would suspect all these well known " task option names" (e.g., cross traffic, suppressed task) would have to be defined in the task registry for the task?

BR,
Tim

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 9 Jan 2015 21:30:12 +0100

> I would suspect all these well known " task option names" (e.g., cross traffic, suppressed task) would have to be defined in the task registry for the task?

I would assume that a suppressed task does not produce results.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1, 28759 Bremen, Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "Carey, Timothy (Timothy)" <[email-masked]>
Date: Fri, 9 Jan 2015 21:38:46 +0000

Ok - Sorry - I see suppression is only for new tasks (page 11). So existing tasks would complete and suppressed tasks wouldn't report.

BR,
Tim

-----Original Message-----
From: Juergen Schoenwaelder [mailto:[email-masked]] 
Sent: Friday, January 09, 2015 2:30 PM
To: Carey, Timothy (Timothy)
Cc: [email-masked]
Subject: Re: [lmap] Reporting suppressed tasked in results

/js

---

From: KEN KO <[email-masked]>
Date: Fri, 9 Jan 2015 21:49:43 +0000

Not always - a suppression message can request (not require) that existing tasks terminate immediately. However, even those tasks that are started and then terminated should probably not report results in most cases.

Ken

-----Original Message-----
From: lmap [mailto:[email-masked]] On Behalf Of Carey, Timothy (Timothy)
Sent: Friday, January 09, 2015 4:39 PM
To: Juergen Schoenwaelder
Cc: [email-masked]
Subject: Re: [lmap] Reporting suppressed tasked in results

BR,
Tim

-----Original Message-----
From: Juergen Schoenwaelder [mailto:[email-masked]] 
Sent: Friday, January 09, 2015 2:30 PM
To: Carey, Timothy (Timothy)
Cc: [email-masked]
Subject: Re: [lmap] Reporting suppressed tasked in results

/js

_______________________________________________
lmap mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lmap

---

From: "Carey, Timothy (Timothy)" <[email-masked]>
Date: Fri, 9 Jan 2015 21:55:28 +0000

Ken,

You are correct: Page 12
Suppression stops new Tasks from executing. In addtion, the
Suppression information also supports an additional Boolean that is
used to select whether on-going tasks are also to be terminated.

So I guess the question still stands - how to reflect the results of a suppressed on-going task. Is it as Juergen say - they simply don't report?

-----Original Message-----
From: KEN KO [mailto:[email-masked]] 
Sent: Friday, January 09, 2015 3:50 PM
To: Carey, Timothy (Timothy); Juergen Schoenwaelder
Cc: [email-masked]
Subject: RE: [lmap] Reporting suppressed tasked in results

Ken

-----Original Message-----
From: lmap [mailto:[email-masked]] On Behalf Of Carey, Timothy (Timothy)
Sent: Friday, January 09, 2015 4:39 PM
To: Juergen Schoenwaelder
Cc: [email-masked]
Subject: Re: [lmap] Reporting suppressed tasked in results

BR,
Tim

-----Original Message-----
From: Juergen Schoenwaelder [mailto:[email-masked]] 
Sent: Friday, January 09, 2015 2:30 PM
To: Carey, Timothy (Timothy)
Cc: [email-masked]
Subject: Re: [lmap] Reporting suppressed tasked in results

/js

---

From: KEN KO <[email-masked]>
Date: Fri, 9 Jan 2015 22:00:46 +0000

I think the normal case is exactly that - they don't report.

I suppose there could be specific measurement methods where it makes sense to report, even if the task is terminated by a suppression message. In that case, I think it would have to be specified in the task options.

-----Original Message-----
From: Carey, Timothy (Timothy) [mailto:[email-masked]] 
Sent: Friday, January 09, 2015 4:55 PM
To: KEN KO; Juergen Schoenwaelder
Cc: [email-masked]
Subject: RE: [lmap] Reporting suppressed tasked in results

Ken,

You are correct: Page 12
Suppression stops new Tasks from executing. In addtion, the Suppression information also supports an additional Boolean that is used to select whether on-going tasks are also to be terminated.

-----Original Message-----
From: KEN KO [mailto:[email-masked]]
Sent: Friday, January 09, 2015 3:50 PM
To: Carey, Timothy (Timothy); Juergen Schoenwaelder
Cc: [email-masked]
Subject: RE: [lmap] Reporting suppressed tasked in results

Ken

-----Original Message-----
From: lmap [mailto:[email-masked]] On Behalf Of Carey, Timothy (Timothy)
Sent: Friday, January 09, 2015 4:39 PM
To: Juergen Schoenwaelder
Cc: [email-masked]
Subject: Re: [lmap] Reporting suppressed tasked in results

BR,
Tim

-----Original Message-----
From: Juergen Schoenwaelder [mailto:[email-masked]]
Sent: Friday, January 09, 2015 2:30 PM
To: Carey, Timothy (Timothy)
Cc: [email-masked]
Subject: Re: [lmap] Reporting suppressed tasked in results

/js

---

From: "Carey, Timothy (Timothy)" <[email-masked]>
Date: Fri, 9 Jan 2015 22:18:05 +0000

Well we probably need to specify some default behavior in the draft when the options don't exist.

Are we keeping track of these "well-known" task options like cross traffic and report suspended task, etc.

BR,
Tim

-----Original Message-----
From: Carey, Timothy (Timothy) [mailto:[email-masked]] 
Sent: Friday, January 09, 2015 4:55 PM
To: KEN KO; Juergen Schoenwaelder
Cc: [email-masked]
Subject: RE: [lmap] Reporting suppressed tasked in results

Ken,

You are correct: Page 12

-----Original Message-----
From: KEN KO [mailto:[email-masked]]
Sent: Friday, January 09, 2015 3:50 PM
To: Carey, Timothy (Timothy); Juergen Schoenwaelder
Cc: [email-masked]
Subject: RE: [lmap] Reporting suppressed tasked in results

Ken

-----Original Message-----
From: lmap [mailto:[email-masked]] On Behalf Of Carey, Timothy (Timothy)
Sent: Friday, January 09, 2015 4:39 PM
To: Juergen Schoenwaelder
Cc: [email-masked]
Subject: Re: [lmap] Reporting suppressed tasked in results

BR,
Tim

-----Original Message-----
From: Juergen Schoenwaelder [mailto:[email-masked]]
Sent: Friday, January 09, 2015 2:30 PM
To: Carey, Timothy (Timothy)
Cc: [email-masked]
Subject: Re: [lmap] Reporting suppressed tasked in results

/js