Subject: [lmap] Use of options in Reports in the Information Model

From: "Carey, Timothy (Timothy)" <[email-masked]>
Date: Fri, 9 Jan 2015 14:20:34 +0000

Trevor,

I was reviewing draft-ietf-lmap-information-model-03 in order to update the BBF data model.

In section 3.6 Reporting Information:

I noticed we removed the concept of Cross traffic from the Reporting task's result row thinking that the Cross traffic option could be defined a name/value pair entry scheduled task options in the Report task object.

The text in the section is somewhat unclear as to what would be in the options field and what is in the result row in this regard.

So if I see 3000 bytes of cross traffic for a result instance. Would the result of the Cross Traffic be in the result row and the Options just specify the need to sense the Cross traffic?

I would think this would be the case - we would have a Header for Cross Traffic that would be available for each result row as defined by the options in the scheduled task and recorded in the Reporting task option to look for Cross Traffic?

BR,
Tim

---

From: <[email-masked]>
Date: Fri, 9 Jan 2015 15:54:09 +0000

>I noticed we removed the concept of Cross traffic from the Reporting task's result row thinking that the Cross traffic option
>could be defined a name/value pair entry scheduled task options in the Report task object.
>
>So if I see 3000 bytes of cross traffic for a result instance. Would the result of the Cross Traffic be in the result row and the
>Options just specify the need to sense the Cross traffic?

Yes exactly so.

>I would think this would be the case - we would have a Header for Cross Traffic that would be available for each result row as
>defined by the options in the scheduled task and recorded in the Reporting task option to look for Cross Traffic?

Yes again!