Subject: Re: [lmap] Reporting of service parameters

From: <[email-masked]>
Date: Wed, 1 Apr 2015 10:19:37 +0000

> -----Original Message-----
> From: lmap [mailto:[email-masked]] On Behalf Of Juergen
> Schoenwaelder
> Sent: 31 March 2015 16:38
> To: Eardley,PL,Philip,TUB8 R
> Cc: [email-masked]
> Subject: Re: [lmap] Reporting of service parameters
> 
> On Tue, Mar 31, 2015 at 12:49:34PM +0000, [email-masked] wrote:
> > There was some discussion during the LMAP meeting about the reporting
> of service parameters by the MA.
> > This is indeed covered by the framework
> > http://tools.ietf.org/html/draft-ietf-lmap-framework-12#section-5.4.1
> >
> > this sub-section is called "Reporting of Subscriber's service
> parameters".
> > "The Subscriber's service parameters are information about his/her
> broadband contract, line rate and so on."
> >
> > I think from the discussion that this is slightly narrow - we
> mentioned things other than Subscriber's service parameters. So I
> suggest we add a sentence on the lines:
> >
> > Similarly the MA could report service parameters about the device
> with the MA, such as its access interface or location.
> >
> > Assuming people are OK (please say if not), we can add this at the
> same time as handling the IESG comments
> >
> 
> Where do you want to add this sentence?

I was thinking, at the end of Section 5.4.1. 

> 
> /js
> 
> --
> Juergen Schoenwaelder           Jacobs University Bremen gGmbH
> Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
> Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>
> 
> _______________________________________________
> lmap mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lmap

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 1 Apr 2015 12:32:21 +0200

Sorry,

I did not even understand that this is a proposed update of the
framework document. Anyway, the proposal seems to be to add

at the end of 5.4.1. Now, it is not clear to me which proplem is
solved with this. Section 5.4.1 starts with:

   The Subscriber's service parameters are information about his/her
   broadband contract, line rate and so on.

So are we going to make a distinction between 'subscriber's service
parameters' and 'device service parameters'? Or is the issue that the
definition of subscriber's service parameters should be more detailed?
In that case, would changing the first sentence not do better?

   The Subscriber's service parameters are information about his/her
   broadband contract, line rate, access interface, location and so on.

I am actually not sure a change is needed in the framework based on
the WG meeting discussions.

/js

---

From: <[email-masked]>
Date: Thu, 2 Apr 2015 12:29:19 +0000

> I am actually not sure a change is needed in the framework based on the
> WG meeting discussions.

Ok, I won't change it. 

phil

> > > > http://tools.ietf.org/html/draft-ietf-lmap-framework-12#section-
> 5.
> > > > 4.1
> > > >

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Thu, 2 Apr 2015 13:42:00 +0000

> > the WG meeting discussions.

I think that's fine. After the F2F meeting, I thought some more about this, and think that probably what we really need are some simple holistic examples that get documented somewhere (but not framework). For some measurement method, create example registry entries (including for the "environmental / service attribute parameter" "measurement method" -- which would likely not be included in the IANA registry), tasks (including tasks for collecting environmental parameters), and schedules. I think until such an example exists it's going to continue to be hard to explain to people who keep asking about these environmental parameters. A sentence added to framework or information-model just isn't going to help.
Barbara