Subject: Re: [lmap] Last Call: <draft-mm-netconf-time-capability-05.txt> (Time Capability in NETCONF) to Experimental RFC

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 29 Jun 2015 16:49:26 +0000

(I apologize for cross-posting) but it seems justified in this case) 

I find this work useful. 

I have two questions: 
- why was not this document adopted by the NETCONF WG? Lack of time, out of focus, or are there any other (technical?) reasons? Why did it had to go on AD-sponsored and Experimental track?
- This work may potentially be useful for LMAP which has scheduling and time-stamping features in its architecture and framework. LMAP however just selected RESTCONF as their preferred protocol. What would it take to extend this work to RESTCONF)? (may be another piece of work)

Thanks and Regards,

Dan

> -----Original Message-----
> From: IETF-Announce [mailto:[email-masked]] On Behalf Of
> The IESG
> Sent: Monday, June 29, 2015 5:58 PM
> To: IETF-Announce
> Subject: Last Call: <draft-mm-netconf-time-capability-05.txt> (Time
> Capability in NETCONF) to Experimental RFC
> 
> 
> The IESG has received a request from an individual submitter to consider the
> following document:
> - 'Time Capability in NETCONF'
>   <draft-mm-netconf-time-capability-05.txt> as Experimental RFC
> 
> The IESG plans to make a decision in the next few weeks, and solicits final
> comments on this action. Please send substantive comments to the
> [email-masked] mailing lists by 2015-07-29. Exceptionally, comments may be
> sent to [email-masked] instead. In either case, please retain the beginning of
> the Subject line to allow automated sorting.
> 
> Abstract
> 
> 
>    This document defines a capability-based extension to the Network
>    Configuration Protocol (NETCONF) that allows time-triggered
>    configuration and management operations. This extension allows
>    NETCONF clients to invoke configuration updates according to
>    scheduled times, and allows NETCONF servers to attach timestamps to
>    the data they send to NETCONF clients.
> 
> 
> The Network Configuration Protocol (NETCONF) Capability URNs registry
> requires a standards action in order to populate the registry. This document
> was taken out of the ISE stream and brought forward as an AD sponsored
> individual-submission to address this consideration.
> 
> 
> The file can be obtained via
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__datatracker.ietf.org_doc_draft-2Dmm-2Dnetconf-2Dtime-
> 2Dcapability_&d=AwICAg&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNX
> CJfQzvlsiLQfucBXRucPvdrphpBsFA&m=eIbq6OXE65r_w9lwmd5WrktViMncM
> zhCDjk3tyjnVvU&s=B6e1FBSZH9H-
> OYAnRMYEgTJVYQ6SSqa2K9XpuIyx3mI&e=
> 
> IESG discussion can be tracked via
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__datatracker.ietf.org_doc_draft-2Dmm-2Dnetconf-2Dtime-
> 2Dcapability_ballot_&d=AwICAg&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR3
> 1OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=eIbq6OXE65r_w9lwmd5WrktVi
> MncMzhCDjk3tyjnVvU&s=WbISmWkVGVo43riTMHY7kzIkAREkQrB2aq-
> lyYOad-Y&e=
> 
> 
> No IPR declarations have been submitted directly on this I-D.
>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 29 Jun 2015 19:15:46 +0200

> - This work may potentially be useful for LMAP which has scheduling and time-stamping features in its architecture and framework. LMAP however just selected RESTCONF as their preferred protocol. Wh…

LMAP deals with scheduling as part of the data model. I do not think
that config changes are the way to model the start of measurements.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Mahesh Jethanandani <[email-masked]>
Date: Mon, 29 Jun 2015 10:17:13 -0700

Dan,

If you go into the archives of NETCONF and search for the draft, you will find some history on the draft.

It started by folks asking for questions and clarifications on the draft. Even after they were seemingly addressed, their was little or no support for adopting the draft into the WG both in IETF 92 and on the mailing list.

If you believe that there is a need for this work and able to get folks to review the draft and show support for it on the mailing list, the WG can relook at the draft. Making it experimental is always an option.

Cheers.

> On Jun 29, 2015, at 9:49 AM, Romascanu, Dan (Dan) <[email-masked]> wrote:
> 
> _______________________________________________
> Netconf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netconf

Mahesh Jethanandani
[email-masked]

---

From: Joe Clarke <[email-masked]>
Date: Mon, 29 Jun 2015 13:17:06 -0400

> (I apologize for cross-posting) but it seems justified in this case)

As do I.  I remember the when this was first presented in Berlin.  I 
thought it had value.

> - why was not this document adopted by the NETCONF WG? Lack of time, out of focus, or are there any other (technical?) reasons? Why did it had to go on AD-sponsored and Experimental track?

I'll speak from what I saw.  There didn't seem to be a lot of traction 
on the WG list, but I do feel this would be beneficial as a working 
group item.

Joe

---

From: "Anil Kumar S N (VRP Network BL)" <[email-masked]>
Date: Tue, 30 Jun 2015 03:33:46 +0000

I support this draft.

Thanks & Regards
Anil S N

"Be liberal in what you accept, and conservative in what you send" - Jon Postel

-----Original Message-----
From: IETF-Announce [mailto:[email-masked]] On Behalf Of The IESG
Sent: Monday, June 29, 2015 5:58 PM
To: IETF-Announce
Subject: Last Call: <draft-mm-netconf-time-capability-05.txt> (Time Capability in NETCONF) to Experimental RFC

The IESG has received a request from an individual submitter to consider the following document:
- 'Time Capability in NETCONF'
  <draft-mm-netconf-time-capability-05.txt> as Experimental RFC

The IESG plans to make a decision in the next few weeks, and solicits final comments on this action. Please send substantive comments to the [email-masked] mailing lists by 2015-07-29. Exceptionally, comments may be sent to [email-masked] instead. In either case, please retain the beginning of the Subject line to allow automated sorting.

Abstract

The Network Configuration Protocol (NETCONF) Capability URNs registry requires a standards action in order to populate the registry. This document was taken out of the ISE stream and brought forward as an AD sponsored individual-submission to address this consideration.

The file can be obtained via
https://datatracker.ietf.org/doc/draft-mm-netconf-time-capability/

IESG discussion can be tracked via
https://datatracker.ietf.org/doc/draft-mm-netconf-time-capability/ballot/