Subject: [lmap] (no) protocol decision

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 4 Jun 2015 11:10:22 +0000

Hi,

At the 5/11 virtual interim meeting we called for the participants in the WG to express on the mail list their opinions concerning the protocol submissions. This was supposed to happen for the rest of the month of May allowing the chairs to issue a proposal to be confirmed by the WG.

The relevant excerpts from the draft minutes are:

DR: Please take a look at the protocol proposals and let us know on the list if anything is missing.
DR: I would like to have a discussion and decision in about a months on the protocols.
DR: Lets discuss during the rest of May and beginning of June the chairs will try to draw conclusions.
JW: We need to have enough people participating in the discussion.
PE: I like to state that it is required to work from behind a NAT.
JW (Chair hat off) Agree and add IPv6 Firewall case as well

...

* Next Steps

- Discuss the protocol aspects and the chairs will draw conclusions beginning on June

-----

However, there were no opinions expressed or discussions on the mail list.

I suggest that all participants in the WG express their opinions about the two proposals currently on record:

-          http://datatracker.ietf.org/doc/draft-schoenw-lmap-restconf/

-          http://datatracker.ietf.org/doc/draft-liu-lmap-rest/

The protocol selection criteria are described at

-          http://datatracker.ietf.org/doc/draft-liu-lmap-rest/

Please state your position about which of the two is best suited to be used as MTI control protocol and MTI report protocol before Friday 6/12.

The chairs will state their recommendation shortly after.

Thanks and Regards,

Dan

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 4 Jun 2015 13:20:57 +0200

> -          http://datatracker.ietf.org/doc/draft-liu-lmap-rest/

I am (obviously) in favor of using RESTCONF.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Thu, 4 Jun 2015 17:48:17 +0000

Having gone through both protocol drafts and draft-schoenw-lmap-yang, I prefer draft-schoenw-lmap-restconf (and draft-schoenw-lmap-yang).

I much prefer the brevity of draft-schoenw-lmap-yang with pointers to ietf-netconf-restconf, ietf-netconf-call-home, ietf-netconf-server-model and various RFCs for implementation details (but I am curious as to the timeline for publication of the referenced drafts, since they appear to be dependencies). By leveraging the netconf drafts, the solution is more complete and does not try to re-create work that has already been done.

Because draft-liu-lmap-rest includes a YANG data model, I also looked at draft-schoenw-lmap-yang to compare data models. draft-schoenw-lmap-yang is more complete (including various enumerations and groupings, and descriptions provided for all elements).
Barbara

From: lmap [mailto:[email-masked]] On Behalf Of Romascanu, Dan (Dan)
Sent: Thursday, June 04, 2015 7:10 AM
To: [email-masked]
Subject: [lmap] (no) protocol decision

Hi,

...

* Next Steps

-----

Thanks and Regards,

Dan

---

From: <[email-masked]>
Date: Mon, 8 Jun 2015 13:09:25 +0000

This also works for me

phil

From: lmap [mailto:[email-masked]] On Behalf Of STARK, BARBARA H
Sent: 04 June 2015 18:48
To: Romascanu, Dan (Dan); [email-masked]
Subject: Re: [lmap] (no) protocol decision

From: lmap [mailto:[email-masked]] On Behalf Of Romascanu, Dan (Dan)
Sent: Thursday, June 04, 2015 7:10 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [lmap] (no) protocol decision

Hi,

...

* Next Steps

-----

Thanks and Regards,

Dan

---

From: Arne Oslebo <[email-masked]>
Date: Mon, 08 Jun 2015 16:08:43 +0200

I also prefer draft-schoenw-lmap-restconf and draft-schoenw-lmap-yang

Arne

On 04. juni 2015 19:48, STARK, BARBARA H wrote:
>
> Having gone through both protocol drafts and draft-schoenw-lmap-yang,
> I prefer draft-schoenw-lmap-restconf (and draft-schoenw-lmap-yang).
>
>  
>
> I much prefer the brevity of draft-schoenw-lmap-yang with pointers to
> ietf-netconf-restconf, ietf-netconf-call-home,
> ietf-netconf-server-model and various RFCs for implementation details
> (but I am curious as to the timeline for publication of the referenced
> drafts, since they appear to be dependencies). By leveraging the
> netconf drafts, the solution is more complete and does not try to
> re-create work that has already been done.
>
>  
>
> Because draft-liu-lmap-rest includes a YANG data model, I also looked
> at draft-schoenw-lmap-yang to compare data models.
> draft-schoenw-lmap-yang is more complete (including various
> enumerations and groupings, and descriptions provided for all elements).
>
> Barbara
>
>  
>
> *From:* lmap [mailto:[email-masked]] *On Behalf Of *Romascanu,
> Dan (Dan)
> *Sent:* Thursday, June 04, 2015 7:10 AM
> *To:* [email-masked]
> *Subject:* [lmap] (no) protocol decision
>
>  
>
> Hi,
>
>  
>
> At the 5/11 virtual interim meeting we called for the participants in
> the WG to express on the mail list their opinions concerning the
> protocol submissions. This was supposed to happen for the rest of the
> month of May allowing the chairs to issue a proposal to be confirmed
> by the WG.
>
>  
>
> …
> Please state your position about which of the two is best suited to be
> used as MTI control protocol and MTI report protocol before Friday 6/12.
>
>  
>
> _______________________________________________
> lmap mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lmap

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Tue, 9 Jun 2015 14:34:15 -0400

+1, Al

> -----Original Message-----
> From: lmap [mailto:[email-masked]] On Behalf Of Arne Oslebo
> Sent: Monday, June 08, 2015 10:09 AM
> To: [email-masked]