Subject: Re: [lmap] proposed information model / data model changes

From: Juergen Schoenwaelder <[email-masked]>
Date: Thu, 2 Jul 2015 12:45:26 +0200

Al,

[...]

> OTOH, if we can somehow combine tasks to share resources
> already, then there would likely be multiple outputs,
> and I support your proposal.

It seems you are saying that a task can implement multiple metrics
identified in the registry. The information model right now does not
allow this since an ma-task-obj only has one URI that can reference
the registry. I think it makes sense to change this such that a task
can refer to multiple registry entries. I will do this change in the
next revision of the information model unless someone speaks up
against it.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Thu, 2 Jul 2015 08:17:08 -0400

Hi Juergen,

You've understood my intent, thanks!

The last thing we want in active measurement would be 
to use two tasks and two independent streams of packets
*just* to measure two metrics (loss ratio and delay, for example).

Consolidation/computation of the metrics on a single stream 
(where that makes sense) is essential. I think this means
we can go ahead with the single metric per URI => registry entry
design.  This is one of our recent clarifications in the
TWAMP YANG model, too.

best regards,
Al

> -----Original Message-----
> From: lmap [mailto:[email-masked]] On Behalf Of Juergen
> Schoenwaelder
> Sent: Thursday, July 02, 2015 6:45 AM
> To: MORTON, ALFRED C (AL)
> Cc: [email-masked]
> Subject: Re: [lmap] proposed information model / data model changes
> 
> Al,
> 
> [...]
> 
> > OTOH, if we can somehow combine tasks to share resources already, then
> > there would likely be multiple outputs, and I support your proposal.
> 
> allow this since an ma-task-obj only has one URI that can reference the
> registry. I think it makes sense to change this such that a task can
> refer to multiple registry entries. I will do this change in the next
> revision of the information model unless someone speaks up against it.
> 
> /js
> 
> --
> _______________________________________________
> lmap mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lmap