Subject: [lmap] second virtual interim - yes or not?

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 8 Feb 2016 16:14:37 +0000

Hi,

The second virtual interim meeting between IETF 94 and IETF 95 is scheduled tentatively two weeks from now, for 2/22.

At the previous interim (on 1/12) we said that a final decision will be taken based on work progress. Right now the situation seems to be that we had a couple of important threads related to the Information Model on the mail list, but the I-D was not updated. First question is for the document editor (Juergen) whether an update is expected to be submitted in the coming days. Second question is for all WG participants - will holding the 2/22 meeting be useful? If yes, what should be on the agenda.

We need to reach a decision by the end of the week. The agenda needs to be submitted until 2/15 the latest.

Thanks and Regards,

Dan

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 9 Feb 2016 17:56:45 +0100

Dan,

I have been spending a couple of days updating our implementation in
order to align it with the current definitions. I have just posted a
proposal to simplify and streamline how we use tags.

The main question really is whether you want me to have a separate
email thread for every issue that comes up or whether you want me to
produce a proposal in the form of a revised IDs that we then discuss.
The thing is that I now have three documents to keep consistent, the
information model, the YANG data model, and our C code. The more drain
there is between the three, the more complicated my editing job gets.

/js

PS: I just sent a question to the yang-doctors concerning the usage of
    boolean vs. empty leafs, which is triggered by lmap but a more
    general 'how to do things in YANG question' I think. The question
    is whether to use

        <lmapc:stop-running>true</lmapc:stop-running>

    or

        <lmapc:stop-running/>

    and it was not clear to me whether there are any hidden gotchas.

> _______________________________________________
> lmap mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lmap

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 9 Feb 2016 17:39:46 +0000

Hi Juergen,

My take is that the information model drives the other items and this is where we should focus. 

Thus my personal preference is for submitting a revised ID, and discussing it on the mail list, and then at the virtual interim. That's only a contributor opinion, however, and I invite other WG participants to express their preferences. 

Thanks for all the great work. 

Regards,

Dan

> -----Original Message-----
> From: lmap [mailto:[email-masked]] On Behalf Of Juergen
> Schoenwaelder
> Sent: Tuesday, February 09, 2016 6:57 PM
> To: Romascanu, Dan (Dan)
> Cc: [email-masked]
> Subject: Re: [lmap] second virtual interim - yes or not?
> 
> Dan,
> 
> I have been spending a couple of days updating our implementation in order
> to align it with the current definitions. I have just posted a proposal to
> simplify and streamline how we use tags.
> 
> The main question really is whether you want me to have a separate email
> thread for every issue that comes up or whether you want me to produce a
> proposal in the form of a revised IDs that we then discuss.
> > The second virtual interim meeting between IETF 94 and IETF 95 is
> scheduled tentatively two weeks from now, for 2/22.
> >
> > At the previous interim (on 1/12) we said that a final decision will be taken
> based on work progress. Right now the situation seems to be that we had a
> couple of important threads related to the Information Model on the mail
> list, but the I-D was not updated. First question is for the document editor
> (Juergen) whether an update is expected to be submitted in the coming
> days. Second question is for all WG participants - will holding the 2/22
> meeting be useful? If yes, what should be on the agenda.
> >
> > https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mail
> >
> man_listinfo_lmap&d=BQICAg&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31
> OcNXCJf
> > QzvlsiLQfucBXRucPvdrphpBsFA&m=4Z7KQTkSKOI832ZN4b6bO6G-nufG-
> MIMprSYF9Y-
> > dGA&s=AxutEEpLbkYM3N6zi_WxFvEBE1k6QU16ZzYIPnzTBXA&e=
> 
> 
> --
> Fax:   +49 421 200 3103
> <https://urldefense.proofpoint.com/v2/url?u=http-3A__www.jacobs-
> 2Duniversity.de_&d=BQICAg&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31O
> cNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=4Z7KQTkSKOI832ZN4b6bO6G-
> nufG-MIMprSYF9Y-dGA&s=anMVV2gbSQNljlkBIMIH5IqeJ-
> UA6sPOp2Yj1LSgy_Q&e= >
> 
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mailman_listinfo_lmap&d=BQICAg&c=BFpWQw8bsuKpl1
> SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=4Z7KQTk
> SKOI832ZN4b6bO6G-nufG-MIMprSYF9Y-
> dGA&s=AxutEEpLbkYM3N6zi_WxFvEBE1k6QU16ZzYIPnzTBXA&e=

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 15 Feb 2016 14:50:22 +0100

Dan,

I am working on our implementation based on the YANG data model and
things in reality go backwards (from implementation experience to data
model changes to information model changes). Top down works on paper
but the truth is you only know you got an information model right once
there are corresponding data models and implementations of those data
models.

/js